Glimpse.Core Namespace

Glimpse.Core Namespace Glimpse API Documentation

[Missing <summary> documentation for "N:Glimpse.Core"]

Classes
 | Class | Description
Public class | TraceListener |

Send Feedback on this topic to Glimpse Developers List.


TraceListener Class

TraceListener Class Glimpse API Documentation

[Missing <summary> documentation for "T:Glimpse.Core.TraceListener"]

Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.Diagnostics TraceListener
Glimpse.Core TraceListener

Namespace: Glimpse.Core
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TraceListener : TraceListener
public class TraceListener : TraceListener
See Also
TraceListener Members
Glimpse.Core Namespace


TraceListener Members

TraceListener Members Glimpse API Documentation

The TraceListener type exposes the following members.
Constructors
 | Name | Description
Public method | TraceListener | Initializes a new instance of the TraceListener class
Public method | TraceListener(String) | Initializes a new instance of the TraceListener class
Public method | TraceListener(IMessageBroker, Func IExecutionTimer ) | Initializes a new instance of the TraceListener class
Back to Top
Methods
 | Name | Description
Public method | Online Close | When overridden in a derived class, closes the output stream so it no longer receives tracing or debugging output. (Inherited from Online TraceListener.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online Dispose | Releases all resources used by the Online TraceListener. (Inherited from Online TraceListener.)
Protected method | Online Dispose(Boolean) | Releases the unmanaged resources used by the Online TraceListener and optionally releases the managed resources. (Inherited from Online TraceListener.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Fail(String) | (Overrides Online TraceListener Fail(String).)
Public method | Fail(String, String) | (Overrides Online TraceListener Fail(String, String).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Flush | When overridden in a derived class, flushes the output buffer. (Inherited from Online TraceListener.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online GetSupportedAttributes | Gets the custom attributes supported by the trace listener. (Inherited from Online TraceListener.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TraceData(TraceEventCache, String, TraceEventType, Int32, Object) | (Overrides Online TraceListener TraceData(TraceEventCache, String, TraceEventType, Int32, Object).)
Public method | TraceData(TraceEventCache, String, TraceEventType, Int32, Object ) | (Overrides Online TraceListener TraceData(TraceEventCache, String, TraceEventType, Int32, Object ).)
Public method | Online TraceEvent(TraceEventCache, String, TraceEventType, Int32) | Writes trace and event information to the listener specific output. (Inherited from Online TraceListener.)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32, String) | (Overrides Online TraceListener TraceEvent(TraceEventCache, String, TraceEventType, Int32, String).)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32, String, Object ) | (Overrides Online TraceListener TraceEvent(TraceEventCache, String, TraceEventType, Int32, String, Object ).)
Public method | Online TraceTransfer | Writes trace information, a message, a related activity identity and event information to the listener specific output. (Inherited from Online TraceListener.)
Public method | Write(Object) | (Overrides Online TraceListener Write(Object).)
Public method | Write(String) | (Overrides Online TraceListener Write(String).)
Public method | Write(Object, String) | (Overrides Online TraceListener Write(Object, String).)
Public method | Write(String, String) | (Overrides Online TraceListener Write(String, String).)
Protected method | Online WriteIndent | Writes the indent to the listener you create when you implement this class, and resets the Online NeedIndent property to false. (Inherited from Online TraceListener.)
Public method | WriteLine(Object) | (Overrides Online TraceListener WriteLine(Object).)
Public method | WriteLine(String) | (Overrides Online TraceListener WriteLine(String).)
Public method | WriteLine(Object, String) | (Overrides Online TraceListener WriteLine(Object, String).)
Public method | WriteLine(String, String) | (Overrides Online TraceListener WriteLine(String, String).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Attributes | Gets the custom trace listener attributes defined in the application configuration file. (Inherited from Online TraceListener.)
Public property | Online Filter | Gets and sets the trace filter for the trace listener. (Inherited from Online TraceListener.)
Public property | Online IndentLevel | Gets or sets the indent level. (Inherited from Online TraceListener.)
Public property | Online IndentSize | Gets or sets the number of spaces in an indent. (Inherited from Online TraceListener.)
Public property | Online IsThreadSafe | Gets a value indicating whether the trace listener is thread safe. (Inherited from Online TraceListener.)
Public property | Online Name | Gets or sets a name for this Online TraceListener. (Inherited from Online TraceListener.)
Protected property | Online NeedIndent | Gets or sets a value indicating whether to indent the output. (Inherited from Online TraceListener.)
Public property | Online TraceOutputOptions | Gets or sets the trace output options. (Inherited from Online TraceListener.)
Back to Top
See Also
TraceListener Class
Glimpse.Core Namespace


TraceListener Constructor

TraceListener Constructor Glimpse API Documentation
Overload List
 | Name | Description
Public method | TraceListener | Initializes a new instance of the TraceListener class
Public method | TraceListener(String) | Initializes a new instance of the TraceListener class
Public method | TraceListener(IMessageBroker, Func IExecutionTimer ) | Initializes a new instance of the TraceListener class
Back to Top
See Also
TraceListener Class
TraceListener Members
Glimpse.Core Namespace


TraceListener Constructor

TraceListener Constructor Glimpse API Documentation
Initializes a new instance of the TraceListener class

Namespace: Glimpse.Core
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TraceListener()
public TraceListener()
See Also
TraceListener Class
TraceListener Members
TraceListener Overload
Glimpse.Core Namespace


TraceListener Constructor (String)

TraceListener Constructor (String) Glimpse API Documentation
Initializes a new instance of the TraceListener class

Namespace: Glimpse.Core
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TraceListener(
    string initializeData
)
public TraceListener(
    string initializeData
)
Parameters
initializeData
Type:   Online System String
[Missing <param name="initializeData"/> documentation for "M:Glimpse.Core.TraceListener.#ctor(System.String)"]
See Also
TraceListener Class
TraceListener Members
TraceListener Overload
Glimpse.Core Namespace


TraceListener Constructor (IMessageBroker, Func(IExecutionTimer))

TraceListener Constructor (IMessageBroker, Func IExecutionTimer ) Glimpse API Documentation
Initializes a new instance of the TraceListener class

Namespace: Glimpse.Core
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TraceListener(
    IMessageBroker messageBroker,
    Func<IExecutionTimer> timerStrategy
)
public TraceListener(
    IMessageBroker messageBroker,
    Func<IExecutionTimer> timerStrategy
)
Parameters
messageBroker
Type: Glimpse.Core.Extensibility IMessageBroker
[Missing <param name="messageBroker"/> documentation for "M:Glimpse.Core.TraceListener.#ctor(Glimpse.Core.Extensibility.IMessageBroker,System.Func{Glimpse.Core.Extensibility.IExecutionTimer})"]
timerStrategy
Type:   Online System Func  IExecutionTimer
[Missing <param name="timerStrategy"/> documentation for "M:Glimpse.Core.TraceListener.#ctor(Glimpse.Core.Extensibility.IMessageBroker,System.Func{Glimpse.Core.Extensibility.IExecutionTimer})"]
See Also
TraceListener Class
TraceListener Members
TraceListener Overload
Glimpse.Core Namespace


TraceListener Methods

TraceListener Methods Glimpse API Documentation
The TraceListener type exposes the following members.
Methods
 | Name | Description
Public method | Online Close | When overridden in a derived class, closes the output stream so it no longer receives tracing or debugging output. (Inherited from Online TraceListener.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online Dispose | Releases all resources used by the Online TraceListener. (Inherited from Online TraceListener.)
Protected method | Online Dispose(Boolean) | Releases the unmanaged resources used by the Online TraceListener and optionally releases the managed resources. (Inherited from Online TraceListener.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Fail(String) | (Overrides Online TraceListener Fail(String).)
Public method | Fail(String, String) | (Overrides Online TraceListener Fail(String, String).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Flush | When overridden in a derived class, flushes the output buffer. (Inherited from Online TraceListener.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online GetSupportedAttributes | Gets the custom attributes supported by the trace listener. (Inherited from Online TraceListener.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TraceData(TraceEventCache, String, TraceEventType, Int32, Object) | (Overrides Online TraceListener TraceData(TraceEventCache, String, TraceEventType, Int32, Object).)
Public method | TraceData(TraceEventCache, String, TraceEventType, Int32, Object ) | (Overrides Online TraceListener TraceData(TraceEventCache, String, TraceEventType, Int32, Object ).)
Public method | Online TraceEvent(TraceEventCache, String, TraceEventType, Int32) | Writes trace and event information to the listener specific output. (Inherited from Online TraceListener.)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32, String) | (Overrides Online TraceListener TraceEvent(TraceEventCache, String, TraceEventType, Int32, String).)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32, String, Object ) | (Overrides Online TraceListener TraceEvent(TraceEventCache, String, TraceEventType, Int32, String, Object ).)
Public method | Online TraceTransfer | Writes trace information, a message, a related activity identity and event information to the listener specific output. (Inherited from Online TraceListener.)
Public method | Write(Object) | (Overrides Online TraceListener Write(Object).)
Public method | Write(String) | (Overrides Online TraceListener Write(String).)
Public method | Write(Object, String) | (Overrides Online TraceListener Write(Object, String).)
Public method | Write(String, String) | (Overrides Online TraceListener Write(String, String).)
Protected method | Online WriteIndent | Writes the indent to the listener you create when you implement this class, and resets the Online NeedIndent property to false. (Inherited from Online TraceListener.)
Public method | WriteLine(Object) | (Overrides Online TraceListener WriteLine(Object).)
Public method | WriteLine(String) | (Overrides Online TraceListener WriteLine(String).)
Public method | WriteLine(Object, String) | (Overrides Online TraceListener WriteLine(Object, String).)
Public method | WriteLine(String, String) | (Overrides Online TraceListener WriteLine(String, String).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TraceListener Class
Glimpse.Core Namespace


Fail Method

TraceListener Fail Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Fail(String) | (Overrides Online TraceListener Fail(String).)
Public method | Fail(String, String) | (Overrides Online TraceListener Fail(String, String).)
Back to Top
See Also
TraceListener Class
TraceListener Members
Glimpse.Core Namespace


Fail Method (String)

TraceListener Fail Method (String) Glimpse API Documentation

[Missing <summary> documentation for "M:Glimpse.Core.TraceListener.Fail(System.String)"]

Namespace: Glimpse.Core
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Fail(
    string message
)
public override void Fail(
    string message
)
Parameters
message
Type:   Online System String
[Missing <param name="message"/> documentation for "M:Glimpse.Core.TraceListener.Fail(System.String)"]
See Also
TraceListener Class
TraceListener Members
Fail Overload
Glimpse.Core Namespace


Fail Method (String, String)

TraceListener Fail Method (String, String) Glimpse API Documentation

[Missing <summary> documentation for "M:Glimpse.Core.TraceListener.Fail(System.String,System.String)"]

Namespace: Glimpse.Core
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Fail(
    string message,
    string detailMessage
)
public override void Fail(
    string message,
    string detailMessage
)
Parameters
message
Type:   Online System String
[Missing <param name="message"/> documentation for "M:Glimpse.Core.TraceListener.Fail(System.String,System.String)"]
detailMessage
Type:   Online System String
[Missing <param name="detailMessage"/> documentation for "M:Glimpse.Core.TraceListener.Fail(System.String,System.String)"]
See Also
TraceListener Class
TraceListener Members
Fail Overload
Glimpse.Core Namespace


TraceData Method

TraceListener TraceData Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | TraceData(TraceEventCache, String, TraceEventType, Int32, Object) | (Overrides Online TraceListener TraceData(TraceEventCache, String, TraceEventType, Int32, Object).)
Public method | TraceData(TraceEventCache, String, TraceEventType, Int32, Object ) | (Overrides Online TraceListener TraceData(TraceEventCache, String, TraceEventType, Int32, Object ).)
Back to Top
See Also
TraceListener Class
TraceListener Members
Glimpse.Core Namespace


TraceData Method (TraceEventCache, String, TraceEventType, Int32, Object)

TraceListener TraceData Method (TraceEventCache, String, TraceEventType, Int32, Object) Glimpse API Documentation

[Missing <summary> documentation for "M:Glimpse.Core.TraceListener.TraceData(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.Object)"]

Namespace: Glimpse.Core
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void TraceData(
    TraceEventCache eventCache,
    string source,
    TraceEventType eventType,
    int id,
    Object data
)
public override void TraceData(
    TraceEventCache eventCache,
    string source,
    TraceEventType eventType,
    int id,
    Object data
)
Parameters
eventCache
Type:   Online System.Diagnostics TraceEventCache
[Missing <param name="eventCache"/> documentation for "M:Glimpse.Core.TraceListener.TraceData(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.Object)"]
source
Type:   Online System String
[Missing <param name="source"/> documentation for "M:Glimpse.Core.TraceListener.TraceData(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.Object)"]
eventType
Type:   Online System.Diagnostics TraceEventType
[Missing <param name="eventType"/> documentation for "M:Glimpse.Core.TraceListener.TraceData(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.Object)"]
id
Type:   Online System Int32
[Missing <param name="id"/> documentation for "M:Glimpse.Core.TraceListener.TraceData(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.Object)"]
data
Type:   Online System Object
[Missing <param name="data"/> documentation for "M:Glimpse.Core.TraceListener.TraceData(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.Object)"]
See Also
TraceListener Class
TraceListener Members
TraceData Overload
Glimpse.Core Namespace


TraceData Method (TraceEventCache, String, TraceEventType, Int32, Object[])

TraceListener TraceData Method (TraceEventCache, String, TraceEventType, Int32, Object ) Glimpse API Documentation

[Missing <summary> documentation for "M:Glimpse.Core.TraceListener.TraceData(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.Object[])"]

Namespace: Glimpse.Core
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void TraceData(
    TraceEventCache eventCache,
    string source,
    TraceEventType eventType,
    int id,
    params Object[] data
)
public override void TraceData(
    TraceEventCache eventCache,
    string source,
    TraceEventType eventType,
    int id,
    params Object[] data
)
Parameters
eventCache
Type:   Online System.Diagnostics TraceEventCache
[Missing <param name="eventCache"/> documentation for "M:Glimpse.Core.TraceListener.TraceData(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.Object[])"]
source
Type:   Online System String
[Missing <param name="source"/> documentation for "M:Glimpse.Core.TraceListener.TraceData(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.Object[])"]
eventType
Type:   Online System.Diagnostics TraceEventType
[Missing <param name="eventType"/> documentation for "M:Glimpse.Core.TraceListener.TraceData(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.Object[])"]
id
Type:   Online System Int32
[Missing <param name="id"/> documentation for "M:Glimpse.Core.TraceListener.TraceData(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.Object[])"]
data
Type:    Online System Object
[Missing <param name="data"/> documentation for "M:Glimpse.Core.TraceListener.TraceData(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.Object[])"]
See Also
TraceListener Class
TraceListener Members
TraceData Overload
Glimpse.Core Namespace


TraceEvent Method

TraceListener TraceEvent Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Online TraceEvent(TraceEventCache, String, TraceEventType, Int32) | Writes trace and event information to the listener specific output. (Inherited from Online TraceListener.)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32, String) | (Overrides Online TraceListener TraceEvent(TraceEventCache, String, TraceEventType, Int32, String).)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32, String, Object ) | (Overrides Online TraceListener TraceEvent(TraceEventCache, String, TraceEventType, Int32, String, Object ).)
Back to Top
See Also
TraceListener Class
TraceListener Members
Glimpse.Core Namespace


TraceEvent Method (TraceEventCache, String, TraceEventType, Int32, String)

TraceListener TraceEvent Method (TraceEventCache, String, TraceEventType, Int32, String) Glimpse API Documentation

[Missing <summary> documentation for "M:Glimpse.Core.TraceListener.TraceEvent(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.String)"]

Namespace: Glimpse.Core
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void TraceEvent(
    TraceEventCache eventCache,
    string source,
    TraceEventType eventType,
    int id,
    string data
)
public override void TraceEvent(
    TraceEventCache eventCache,
    string source,
    TraceEventType eventType,
    int id,
    string data
)
Parameters
eventCache
Type:   Online System.Diagnostics TraceEventCache
[Missing <param name="eventCache"/> documentation for "M:Glimpse.Core.TraceListener.TraceEvent(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.String)"]
source
Type:   Online System String
[Missing <param name="source"/> documentation for "M:Glimpse.Core.TraceListener.TraceEvent(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.String)"]
eventType
Type:   Online System.Diagnostics TraceEventType
[Missing <param name="eventType"/> documentation for "M:Glimpse.Core.TraceListener.TraceEvent(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.String)"]
id
Type:   Online System Int32
[Missing <param name="id"/> documentation for "M:Glimpse.Core.TraceListener.TraceEvent(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.String)"]
data
Type:   Online System String
[Missing <param name="data"/> documentation for "M:Glimpse.Core.TraceListener.TraceEvent(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.String)"]
See Also
TraceListener Class
TraceListener Members
TraceEvent Overload
Glimpse.Core Namespace


TraceEvent Method (TraceEventCache, String, TraceEventType, Int32, String, Object[])

TraceListener TraceEvent Method (TraceEventCache, String, TraceEventType, Int32, String, Object ) Glimpse API Documentation

[Missing <summary> documentation for "M:Glimpse.Core.TraceListener.TraceEvent(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.String,System.Object[])"]

Namespace: Glimpse.Core
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void TraceEvent(
    TraceEventCache eventCache,
    string source,
    TraceEventType eventType,
    int id,
    string format,
    params Object[] args
)
public override void TraceEvent(
    TraceEventCache eventCache,
    string source,
    TraceEventType eventType,
    int id,
    string format,
    params Object[] args
)
Parameters
eventCache
Type:   Online System.Diagnostics TraceEventCache
[Missing <param name="eventCache"/> documentation for "M:Glimpse.Core.TraceListener.TraceEvent(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.String,System.Object[])"]
source
Type:   Online System String
[Missing <param name="source"/> documentation for "M:Glimpse.Core.TraceListener.TraceEvent(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.String,System.Object[])"]
eventType
Type:   Online System.Diagnostics TraceEventType
[Missing <param name="eventType"/> documentation for "M:Glimpse.Core.TraceListener.TraceEvent(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.String,System.Object[])"]
id
Type:   Online System Int32
[Missing <param name="id"/> documentation for "M:Glimpse.Core.TraceListener.TraceEvent(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.String,System.Object[])"]
format
Type:   Online System String
[Missing <param name="format"/> documentation for "M:Glimpse.Core.TraceListener.TraceEvent(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.String,System.Object[])"]
args
Type:    Online System Object
[Missing <param name="args"/> documentation for "M:Glimpse.Core.TraceListener.TraceEvent(System.Diagnostics.TraceEventCache,System.String,System.Diagnostics.TraceEventType,System.Int32,System.String,System.Object[])"]
See Also
TraceListener Class
TraceListener Members
TraceEvent Overload
Glimpse.Core Namespace


Write Method

TraceListener Write Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Write(Object) | (Overrides Online TraceListener Write(Object).)
Public method | Write(String) | (Overrides Online TraceListener Write(String).)
Public method | Write(Object, String) | (Overrides Online TraceListener Write(Object, String).)
Public method | Write(String, String) | (Overrides Online TraceListener Write(String, String).)
Back to Top
See Also
TraceListener Class
TraceListener Members
Glimpse.Core Namespace


Write Method (Object)

TraceListener Write Method (Object) Glimpse API Documentation

[Missing <summary> documentation for "M:Glimpse.Core.TraceListener.Write(System.Object)"]

Namespace: Glimpse.Core
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Object o
)
public override void Write(
    Object o
)
Parameters
o
Type:   Online System Object
[Missing <param name="o"/> documentation for "M:Glimpse.Core.TraceListener.Write(System.Object)"]
See Also
TraceListener Class
TraceListener Members
Write Overload
Glimpse.Core Namespace


Write Method (String)

TraceListener Write Method (String) Glimpse API Documentation

[Missing <summary> documentation for "M:Glimpse.Core.TraceListener.Write(System.String)"]

Namespace: Glimpse.Core
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    string message
)
public override void Write(
    string message
)
Parameters
message
Type:   Online System String
[Missing <param name="message"/> documentation for "M:Glimpse.Core.TraceListener.Write(System.String)"]
See Also
TraceListener Class
TraceListener Members
Write Overload
Glimpse.Core Namespace


Write Method (Object, String)

TraceListener Write Method (Object, String) Glimpse API Documentation

[Missing <summary> documentation for "M:Glimpse.Core.TraceListener.Write(System.Object,System.String)"]

Namespace: Glimpse.Core
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Object o,
    string category
)
public override void Write(
    Object o,
    string category
)
Parameters
o
Type:   Online System Object
[Missing <param name="o"/> documentation for "M:Glimpse.Core.TraceListener.Write(System.Object,System.String)"]
category
Type:   Online System String
[Missing <param name="category"/> documentation for "M:Glimpse.Core.TraceListener.Write(System.Object,System.String)"]
See Also
TraceListener Class
TraceListener Members
Write Overload
Glimpse.Core Namespace


Write Method (String, String)

TraceListener Write Method (String, String) Glimpse API Documentation

[Missing <summary> documentation for "M:Glimpse.Core.TraceListener.Write(System.String,System.String)"]

Namespace: Glimpse.Core
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    string message,
    string category
)
public override void Write(
    string message,
    string category
)
Parameters
message
Type:   Online System String
[Missing <param name="message"/> documentation for "M:Glimpse.Core.TraceListener.Write(System.String,System.String)"]
category
Type:   Online System String
[Missing <param name="category"/> documentation for "M:Glimpse.Core.TraceListener.Write(System.String,System.String)"]
See Also
TraceListener Class
TraceListener Members
Write Overload
Glimpse.Core Namespace


WriteLine Method

TraceListener WriteLine Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | WriteLine(Object) | (Overrides Online TraceListener WriteLine(Object).)
Public method | WriteLine(String) | (Overrides Online TraceListener WriteLine(String).)
Public method | WriteLine(Object, String) | (Overrides Online TraceListener WriteLine(Object, String).)
Public method | WriteLine(String, String) | (Overrides Online TraceListener WriteLine(String, String).)
Back to Top
See Also
TraceListener Class
TraceListener Members
Glimpse.Core Namespace


WriteLine Method (Object)

TraceListener WriteLine Method (Object) Glimpse API Documentation

[Missing <summary> documentation for "M:Glimpse.Core.TraceListener.WriteLine(System.Object)"]

Namespace: Glimpse.Core
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void WriteLine(
    Object o
)
public override void WriteLine(
    Object o
)
Parameters
o
Type:   Online System Object
[Missing <param name="o"/> documentation for "M:Glimpse.Core.TraceListener.WriteLine(System.Object)"]
See Also
TraceListener Class
TraceListener Members
WriteLine Overload
Glimpse.Core Namespace


WriteLine Method (String)

TraceListener WriteLine Method (String) Glimpse API Documentation

[Missing <summary> documentation for "M:Glimpse.Core.TraceListener.WriteLine(System.String)"]

Namespace: Glimpse.Core
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void WriteLine(
    string message
)
public override void WriteLine(
    string message
)
Parameters
message
Type:   Online System String
[Missing <param name="message"/> documentation for "M:Glimpse.Core.TraceListener.WriteLine(System.String)"]
See Also
TraceListener Class
TraceListener Members
WriteLine Overload
Glimpse.Core Namespace


WriteLine Method (Object, String)

TraceListener WriteLine Method (Object, String) Glimpse API Documentation

[Missing <summary> documentation for "M:Glimpse.Core.TraceListener.WriteLine(System.Object,System.String)"]

Namespace: Glimpse.Core
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void WriteLine(
    Object o,
    string category
)
public override void WriteLine(
    Object o,
    string category
)
Parameters
o
Type:   Online System Object
[Missing <param name="o"/> documentation for "M:Glimpse.Core.TraceListener.WriteLine(System.Object,System.String)"]
category
Type:   Online System String
[Missing <param name="category"/> documentation for "M:Glimpse.Core.TraceListener.WriteLine(System.Object,System.String)"]
See Also
TraceListener Class
TraceListener Members
WriteLine Overload
Glimpse.Core Namespace


WriteLine Method (String, String)

TraceListener WriteLine Method (String, String) Glimpse API Documentation

[Missing <summary> documentation for "M:Glimpse.Core.TraceListener.WriteLine(System.String,System.String)"]

Namespace: Glimpse.Core
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void WriteLine(
    string message,
    string category
)
public override void WriteLine(
    string message,
    string category
)
Parameters
message
Type:   Online System String
[Missing <param name="message"/> documentation for "M:Glimpse.Core.TraceListener.WriteLine(System.String,System.String)"]
category
Type:   Online System String
[Missing <param name="category"/> documentation for "M:Glimpse.Core.TraceListener.WriteLine(System.String,System.String)"]
See Also
TraceListener Class
TraceListener Members
WriteLine Overload
Glimpse.Core Namespace


TraceListener Properties

TraceListener Properties Glimpse API Documentation
The TraceListener type exposes the following members.
Properties
 | Name | Description
Public property | Online Attributes | Gets the custom trace listener attributes defined in the application configuration file. (Inherited from Online TraceListener.)
Public property | Online Filter | Gets and sets the trace filter for the trace listener. (Inherited from Online TraceListener.)
Public property | Online IndentLevel | Gets or sets the indent level. (Inherited from Online TraceListener.)
Public property | Online IndentSize | Gets or sets the number of spaces in an indent. (Inherited from Online TraceListener.)
Public property | Online IsThreadSafe | Gets a value indicating whether the trace listener is thread safe. (Inherited from Online TraceListener.)
Public property | Online Name | Gets or sets a name for this Online TraceListener. (Inherited from Online TraceListener.)
Protected property | Online NeedIndent | Gets or sets a value indicating whether to indent the output. (Inherited from Online TraceListener.)
Public property | Online TraceOutputOptions | Gets or sets the trace output options. (Inherited from Online TraceListener.)
Back to Top
See Also
TraceListener Class
Glimpse.Core Namespace


Glimpse.Core.ClientScript Namespace

Glimpse.Core.ClientScript Namespace Glimpse API Documentation
All types which result in Glimpse injecting <script> tags into a page response are defined within this namespace.
Classes
 | Class | Description
Public class | Client | The IDynamicClientScript implementation responsible for adding the Glimpse JavaScript client <script> tag to a page response.
Public class | Data | The IDynamicClientScript implementation responsible for adding the Http request metadata <script> tag to a page response.
Public class | Metadata | The IDynamicClientScript implementation responsible for adding the Glimpse server configuration metadata <script> tag to a page response.


Client Class

Client Class Glimpse API Documentation
The IDynamicClientScript implementation responsible for adding the Glimpse JavaScript client <script> tag to a page response.
Inheritance Hierarchy
Online System Object
Glimpse.Core.ClientScript Client

Namespace: Glimpse.Core.ClientScript
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Client : IDynamicClientScript,
    IClientScript
public sealed class Client : IDynamicClientScript,
    IClientScript
See Also
Client Members
Glimpse.Core.ClientScript Namespace


Client Members

Client Members Glimpse API Documentation

The Client type exposes the following members.
Constructors
 | Name | Description
Public method | Client | Initializes a new instance of the Client class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetResourceName | Gets the name of the IResource to dynamically generate a Uri for.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Order | Gets the sorting order in which a <script> tag will be injected a page response, relative to other implementations of IClientScript.
Back to Top
See Also
Client Class
Glimpse.Core.ClientScript Namespace


Client Constructor

Client Constructor Glimpse API Documentation
Initializes a new instance of the Client class

Namespace: Glimpse.Core.ClientScript
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Client()
public Client()
See Also
Client Class
Client Members
Glimpse.Core.ClientScript Namespace


Client Methods

Client Methods Glimpse API Documentation
The Client type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetResourceName | Gets the name of the IResource to dynamically generate a Uri for.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
Client Class
Glimpse.Core.ClientScript Namespace


GetResourceName Method

Client GetResourceName Method Glimpse API Documentation
Gets the name of the IResource to dynamically generate a Uri for.

Namespace: Glimpse.Core.ClientScript
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetResourceName()
public string GetResourceName()
Return Value

            Name of the IResource to link to.

Implements
IDynamicClientScript GetResourceName
Remarks
IResource Uri generation is handled by implementations of ResourceEndpointConfiguration.

See Also
Client Class
Client Members
Glimpse.Core.ClientScript Namespace


Client Properties

Client Properties Glimpse API Documentation
The Client type exposes the following members.
Properties
 | Name | Description
Public property | Order | Gets the sorting order in which a <script> tag will be injected a page response, relative to other implementations of IClientScript.
Back to Top
See Also
Client Class
Glimpse.Core.ClientScript Namespace


Order Property

Client Order Property Glimpse API Documentation
Gets the sorting order in which a <script> tag will be injected a page response, relative to other implementations of IClientScript.

Namespace: Glimpse.Core.ClientScript
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ScriptOrder Order { get; }
public ScriptOrder Order { get; }
Field Value

            Any value from the ScriptOrder enumeration.

Implements
IClientScript Order
Remarks

            Multiple IClientScript's with the same ScriptOrder will be sorted in an indeterminate order.

See Also
Client Class
Client Members
Glimpse.Core.ClientScript Namespace


Data Class

Data Class Glimpse API Documentation
The IDynamicClientScript implementation responsible for adding the Http request metadata <script> tag to a page response.
Inheritance Hierarchy
Online System Object
Glimpse.Core.ClientScript Data

Namespace: Glimpse.Core.ClientScript
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Data : IDynamicClientScript, IClientScript,
    IParameterValueProvider
public sealed class Data : IDynamicClientScript, IClientScript,
    IParameterValueProvider
See Also
Data Members
Glimpse.Core.ClientScript Namespace


Data Members

Data Members Glimpse API Documentation

The Data type exposes the following members.
Constructors
 | Name | Description
Public method | Data | Initializes a new instance of the Data class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetResourceName | Gets the name of the IResource to dynamically generate a Uri for.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OverrideParameterValues | Used to override or append Uri template parameter values to the values required for the IDynamicClientScript.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Order | Gets the sorting order in which a <script> tag will be injected a page response, relative to other implementations of IClientScript.
Back to Top
See Also
Data Class
Glimpse.Core.ClientScript Namespace


Data Constructor

Data Constructor Glimpse API Documentation
Initializes a new instance of the Data class

Namespace: Glimpse.Core.ClientScript
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Data()
public Data()
See Also
Data Class
Data Members
Glimpse.Core.ClientScript Namespace


Data Methods

Data Methods Glimpse API Documentation
The Data type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetResourceName | Gets the name of the IResource to dynamically generate a Uri for.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OverrideParameterValues | Used to override or append Uri template parameter values to the values required for the IDynamicClientScript.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
Data Class
Glimpse.Core.ClientScript Namespace


GetResourceName Method

Data GetResourceName Method Glimpse API Documentation
Gets the name of the IResource to dynamically generate a Uri for.

Namespace: Glimpse.Core.ClientScript
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetResourceName()
public string GetResourceName()
Return Value

            Name of the IResource to link to.

Implements
IDynamicClientScript GetResourceName
Remarks
IResource Uri generation is handled by implementations of ResourceEndpointConfiguration.

See Also
Data Class
Data Members
Glimpse.Core.ClientScript Namespace


OverrideParameterValues Method

Data OverrideParameterValues Method Glimpse API Documentation
Used to override or append Uri template parameter values to the values required for the IDynamicClientScript.

Namespace: Glimpse.Core.ClientScript
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void OverrideParameterValues(
    IDictionary<string, string> defaults
)
public void OverrideParameterValues(
    IDictionary<string, string> defaults
)
Parameters
defaults
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
The default Uri template parameter values as defined by the Glimpse server.
Implements
IParameterValueProvider OverrideParameterValues(IDictionary String, String )
See Also
Data Class
Data Members
Glimpse.Core.ClientScript Namespace


Data Properties

Data Properties Glimpse API Documentation
The Data type exposes the following members.
Properties
 | Name | Description
Public property | Order | Gets the sorting order in which a <script> tag will be injected a page response, relative to other implementations of IClientScript.
Back to Top
See Also
Data Class
Glimpse.Core.ClientScript Namespace


Order Property

Data Order Property Glimpse API Documentation
Gets the sorting order in which a <script> tag will be injected a page response, relative to other implementations of IClientScript.

Namespace: Glimpse.Core.ClientScript
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ScriptOrder Order { get; }
public ScriptOrder Order { get; }
Field Value

            Any value from the ScriptOrder enumeration.

Implements
IClientScript Order
Remarks

            Multiple IClientScript's with the same ScriptOrder will be sorted in an indeterminate order.

See Also
Data Class
Data Members
Glimpse.Core.ClientScript Namespace


Metadata Class

Metadata Class Glimpse API Documentation
The IDynamicClientScript implementation responsible for adding the Glimpse server configuration metadata <script> tag to a page response.
Inheritance Hierarchy
Online System Object
Glimpse.Core.ClientScript Metadata

Namespace: Glimpse.Core.ClientScript
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Metadata : IDynamicClientScript,
    IClientScript, IParameterValueProvider
public sealed class Metadata : IDynamicClientScript,
    IClientScript, IParameterValueProvider
See Also
Metadata Members
Glimpse.Core.ClientScript Namespace


Metadata Members

Metadata Members Glimpse API Documentation

The Metadata type exposes the following members.
Constructors
 | Name | Description
Public method | Metadata | Initializes a new instance of the Metadata class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetResourceName | Gets the name of the IResource to dynamically generate a Uri for.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OverrideParameterValues | Used to override or append Uri template parameter values to the values required for the IDynamicClientScript.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Order | Gets the sorting order in which a <script> tag will be injected a page response, relative to other implementations of IClientScript.
Back to Top
See Also
Metadata Class
Glimpse.Core.ClientScript Namespace


Metadata Constructor

Metadata Constructor Glimpse API Documentation
Initializes a new instance of the Metadata class

Namespace: Glimpse.Core.ClientScript
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Metadata()
public Metadata()
See Also
Metadata Class
Metadata Members
Glimpse.Core.ClientScript Namespace


Metadata Methods

Metadata Methods Glimpse API Documentation
The Metadata type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetResourceName | Gets the name of the IResource to dynamically generate a Uri for.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OverrideParameterValues | Used to override or append Uri template parameter values to the values required for the IDynamicClientScript.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
Metadata Class
Glimpse.Core.ClientScript Namespace


GetResourceName Method

Metadata GetResourceName Method Glimpse API Documentation
Gets the name of the IResource to dynamically generate a Uri for.

Namespace: Glimpse.Core.ClientScript
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetResourceName()
public string GetResourceName()
Return Value

            Name of the IResource to link to.

Implements
IDynamicClientScript GetResourceName
Remarks
IResource Uri generation is handled by implementations of ResourceEndpointConfiguration.

See Also
Metadata Class
Metadata Members
Glimpse.Core.ClientScript Namespace


OverrideParameterValues Method

Metadata OverrideParameterValues Method Glimpse API Documentation
Used to override or append Uri template parameter values to the values required for the IDynamicClientScript.

Namespace: Glimpse.Core.ClientScript
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void OverrideParameterValues(
    IDictionary<string, string> defaults
)
public void OverrideParameterValues(
    IDictionary<string, string> defaults
)
Parameters
defaults
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
The default Uri template parameter values as defined by the Glimpse server.
Implements
IParameterValueProvider OverrideParameterValues(IDictionary String, String )
See Also
Metadata Class
Metadata Members
Glimpse.Core.ClientScript Namespace


Metadata Properties

Metadata Properties Glimpse API Documentation
The Metadata type exposes the following members.
Properties
 | Name | Description
Public property | Order | Gets the sorting order in which a <script> tag will be injected a page response, relative to other implementations of IClientScript.
Back to Top
See Also
Metadata Class
Glimpse.Core.ClientScript Namespace


Order Property

Metadata Order Property Glimpse API Documentation
Gets the sorting order in which a <script> tag will be injected a page response, relative to other implementations of IClientScript.

Namespace: Glimpse.Core.ClientScript
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ScriptOrder Order { get; }
public ScriptOrder Order { get; }
Field Value

            Any value from the ScriptOrder enumeration.

Implements
IClientScript Order
Remarks

            Multiple IClientScript's with the same ScriptOrder will be sorted in an indeterminate order.

See Also
Metadata Class
Metadata Members
Glimpse.Core.ClientScript Namespace


Glimpse.Core.Configuration Namespace

Glimpse.Core.Configuration Namespace Glimpse API Documentation
All types having to do with Glimpse configuration and the Glimpse specific XML nodes within web.config are defined within this namespace.
Classes
 | Class | Description
Public class | ContentTypeElement | The Glimpse configuration node for representing a content type.
Public class | ContentTypeElementCollection | The Glimpse configuration node for collecting a list of content types.
Public class | DiscoverableCollectionElement | The Glimpse configuration node that configures the instance of IDiscoverableCollection T that Glimpse uses to automatically find and load types at runtime.
Public class | LoggingElement | The Glimpse configuration node for logging settings in Glimpse.
Public class | PolicyDiscoverableCollectionElement | The Glimpse configuration node is a specialized DiscoverableCollectionElement used by IRuntimePolicys and IConfigurables to allow for end user configuration of runtime policies.
Public class | RegexElement | The Glimpse configuration node representing a regular expression.
Public class | RegexElementCollection | The Glimpse configuration node for collecting a list of regular expressions.
Public class | Section | The root Glimpse configuration node, that provides Glimpse configuration options in a site's web.config.
Public class | StatusCodeElement | The Glimpse configuration node representing an Http status code.
Public class | StatusCodeElementCollection | The Glimpse configuration node for collecting a list of status codes.
Public class | TypeElement | The Glimpse configuration node representing a .NET Framework type.
Public class | TypeElementCollection | The Glimpse configuration node for creating a collection of types.
Enumerations
 | Enumeration | Description
Public enumeration | LoggingLevel | LoggingLevel defines the level of output detail to be written to the Glimpse log.


ContentTypeElement Class

ContentTypeElement Class Glimpse API Documentation
The Glimpse configuration node for representing a content type.
Inheritance Hierarchy
Online System Object
Online System.Configuration ConfigurationElement
Glimpse.Core.Configuration ContentTypeElement

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ContentTypeElement : ConfigurationElement
public class ContentTypeElement : ConfigurationElement
See Also
ContentTypeElement Members
Glimpse.Core.Configuration Namespace


ContentTypeElement Members

ContentTypeElement Members Glimpse API Documentation

The ContentTypeElement type exposes the following members.
Constructors
 | Name | Description
Public method | ContentTypeElement | Initializes a new instance of the ContentTypeElement class
Back to Top
Methods
 | Name | Description
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the current Online ConfigurationElement instance to the specified object. (Inherited from Online ConfigurationElement.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Gets a unique value representing the current Online ConfigurationElement instance. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElement object is read-only. (Inherited from Online ConfigurationElement.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the internal state of the Online ConfigurationElement object, including the locks and the properties collections. (Inherited from Online ConfigurationElement.)
Protected method | Online ResetModified | Resets the value of the Online IsModified method to false when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElement object and all subelements. (Inherited from Online ConfigurationElement.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Modifies the Online ConfigurationElement object to remove all values that should not be saved. (Inherited from Online ConfigurationElement.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ContentType | Gets or sets the content type.
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Back to Top
See Also
ContentTypeElement Class
Glimpse.Core.Configuration Namespace


ContentTypeElement Constructor

ContentTypeElement Constructor Glimpse API Documentation
Initializes a new instance of the ContentTypeElement class

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ContentTypeElement()
public ContentTypeElement()
See Also
ContentTypeElement Class
ContentTypeElement Members
Glimpse.Core.Configuration Namespace


ContentTypeElement Methods

ContentTypeElement Methods Glimpse API Documentation
The ContentTypeElement type exposes the following members.
Methods
 | Name | Description
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the current Online ConfigurationElement instance to the specified object. (Inherited from Online ConfigurationElement.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Gets a unique value representing the current Online ConfigurationElement instance. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElement object is read-only. (Inherited from Online ConfigurationElement.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the internal state of the Online ConfigurationElement object, including the locks and the properties collections. (Inherited from Online ConfigurationElement.)
Protected method | Online ResetModified | Resets the value of the Online IsModified method to false when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElement object and all subelements. (Inherited from Online ConfigurationElement.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Modifies the Online ConfigurationElement object to remove all values that should not be saved. (Inherited from Online ConfigurationElement.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ContentTypeElement Class
Glimpse.Core.Configuration Namespace


ContentTypeElement Properties

ContentTypeElement Properties Glimpse API Documentation
The ContentTypeElement type exposes the following members.
Properties
 | Name | Description
Public property | ContentType | Gets or sets the content type.
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Back to Top
See Also
ContentTypeElement Class
Glimpse.Core.Configuration Namespace


ContentType Property

ContentTypeElement ContentType Property Glimpse API Documentation
Gets or sets the content type.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ContentType { get; set; }
public string ContentType { get; set; }
Field Value

            Valid content type syntax is defined in   Online RFC 2046. A   Online list of commonly used content types is available from IANA.

See Also
ContentTypeElement Class
ContentTypeElement Members
Glimpse.Core.Configuration Namespace
  Online Multipurpose Internet Mail Extensions(MIME) Part Two: Media Types
  Online IANA MIME Media Types


ContentTypeElementCollection Class

ContentTypeElementCollection Class Glimpse API Documentation
The Glimpse configuration node for collecting a list of content types.
Inheritance Hierarchy
Online System Object
Online System.Configuration ConfigurationElement
Online System.Configuration ConfigurationElementCollection
Glimpse.Core.Configuration ContentTypeElementCollection

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ContentTypeElementCollection : ConfigurationElementCollection
public sealed class ContentTypeElementCollection : ConfigurationElementCollection
Remarks

            By default, ContentTypeElementCollections contain two elements: text/html and application/json.

See Also
ContentTypeElementCollection Members
Glimpse.Core.Configuration Namespace


ContentTypeElementCollection Members

ContentTypeElementCollection Members Glimpse API Documentation

The ContentTypeElementCollection type exposes the following members.
Constructors
 | Name | Description
Public method | ContentTypeElementCollection | Initializes a new instance of the ContentTypeElementCollection class with text/html and application/json added to the collection.
Back to Top
Methods
 | Name | Description
Protected method | Online BaseAdd(ConfigurationElement) | Adds a configuration element to the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseClear | Removes all configuration element objects from the collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGetKey | Gets the key for the Online ConfigurationElement at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseIndexOf | The index of the specified Online ConfigurationElement. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseIsRemoved | Gets a value indicating whether the Online ConfigurationElement with the specified key has been removed from the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseRemove | Removes a Online ConfigurationElement from the collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseRemoveAt | Removes the Online ConfigurationElement at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Public method | Online CopyTo | Copies the contents of the Online ConfigurationElementCollection to an array. (Inherited from Online ConfigurationElementCollection.)
Protected method | CreateNewElement | When overridden in a derived class, creates a new Online ConfigurationElement. (Overrides Online ConfigurationElementCollection CreateNewElement .)
Protected method | Online CreateNewElement(String) | Creates a new Online ConfigurationElement when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the Online ConfigurationElementCollection to the specified object. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetElementKey | Gets the element key for a specified configuration element when overridden in a derived class. (Overrides Online ConfigurationElementCollection GetElementKey(ConfigurationElement).)
Public method | Online GetEnumerator | Gets an Online IEnumerator which is used to iterate through the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Public method | Online GetHashCode | Gets a unique value representing the Online ConfigurationElementCollection instance. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsElementName | Indicates whether the specified Online ConfigurationElement exists in the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online IsElementRemovable | Gets a value indicating whether the specified Online ConfigurationElement can be removed from the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online IsModified | Indicates whether this Online ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElementCollection object is read only. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the Online ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online ResetModified | Resets the value of the Online IsModified property to false when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElementCollection object and for all sub-elements. (Inherited from Online ConfigurationElementCollection.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from Online ConfigurationElementCollection.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Protected property | Online AddElementName | Gets or sets the name of the Online ConfigurationElement to associate with the add operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ClearElementName | Gets or sets the name for the Online ConfigurationElement to associate with the clear operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public property | Online CollectionType | Gets the type of the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Public property | Online Count | Gets the number of elements in the collection. (Inherited from Online ConfigurationElementCollection.)
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Public property | Online EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Public property | Online IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from Online ConfigurationElementCollection.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Protected property | Online RemoveElementName | Gets or sets the name of the Online ConfigurationElement to associate with the remove operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public property | Online SyncRoot | Gets an object used to synchronize access to the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate Online ConfigurationElement to the Online ConfigurationElementCollection will cause an exception to be thrown. (Inherited from Online ConfigurationElementCollection.)
Back to Top
See Also
ContentTypeElementCollection Class
Glimpse.Core.Configuration Namespace


ContentTypeElementCollection Constructor

ContentTypeElementCollection Constructor Glimpse API Documentation
Initializes a new instance of the ContentTypeElementCollection class with text/html and application/json added to the collection.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ContentTypeElementCollection()
public ContentTypeElementCollection()
See Also
ContentTypeElementCollection Class
ContentTypeElementCollection Members
Glimpse.Core.Configuration Namespace


ContentTypeElementCollection Methods

ContentTypeElementCollection Methods Glimpse API Documentation
The ContentTypeElementCollection type exposes the following members.
Methods
 | Name | Description
Protected method | Online BaseAdd(ConfigurationElement) | Adds a configuration element to the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseClear | Removes all configuration element objects from the collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGetKey | Gets the key for the Online ConfigurationElement at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseIndexOf | The index of the specified Online ConfigurationElement. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseIsRemoved | Gets a value indicating whether the Online ConfigurationElement with the specified key has been removed from the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseRemove | Removes a Online ConfigurationElement from the collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseRemoveAt | Removes the Online ConfigurationElement at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Public method | Online CopyTo | Copies the contents of the Online ConfigurationElementCollection to an array. (Inherited from Online ConfigurationElementCollection.)
Protected method | CreateNewElement | When overridden in a derived class, creates a new Online ConfigurationElement. (Overrides Online ConfigurationElementCollection CreateNewElement .)
Protected method | Online CreateNewElement(String) | Creates a new Online ConfigurationElement when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the Online ConfigurationElementCollection to the specified object. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetElementKey | Gets the element key for a specified configuration element when overridden in a derived class. (Overrides Online ConfigurationElementCollection GetElementKey(ConfigurationElement).)
Public method | Online GetEnumerator | Gets an Online IEnumerator which is used to iterate through the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Public method | Online GetHashCode | Gets a unique value representing the Online ConfigurationElementCollection instance. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsElementName | Indicates whether the specified Online ConfigurationElement exists in the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online IsElementRemovable | Gets a value indicating whether the specified Online ConfigurationElement can be removed from the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online IsModified | Indicates whether this Online ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElementCollection object is read only. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the Online ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online ResetModified | Resets the value of the Online IsModified property to false when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElementCollection object and for all sub-elements. (Inherited from Online ConfigurationElementCollection.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from Online ConfigurationElementCollection.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ContentTypeElementCollection Class
Glimpse.Core.Configuration Namespace


CreateNewElement Method

ContentTypeElementCollection CreateNewElement Method Glimpse API Documentation
Overload List
 | Name | Description
Protected method | CreateNewElement | When overridden in a derived class, creates a new Online ConfigurationElement. (Overrides Online ConfigurationElementCollection CreateNewElement .)
Protected method | Online CreateNewElement(String) | Creates a new Online ConfigurationElement when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Back to Top
See Also
ContentTypeElementCollection Class
ContentTypeElementCollection Members
Glimpse.Core.Configuration Namespace


CreateNewElement Method

ContentTypeElementCollection CreateNewElement Method Glimpse API Documentation
When overridden in a derived class, creates a new Online ConfigurationElement.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override ConfigurationElement CreateNewElement()
protected override ConfigurationElement CreateNewElement()
Return Value

            A new   Online ConfigurationElement.

See Also
ContentTypeElementCollection Class
ContentTypeElementCollection Members
CreateNewElement Overload
Glimpse.Core.Configuration Namespace


GetElementKey Method

ContentTypeElementCollection GetElementKey Method Glimpse API Documentation
Gets the element key for a specified configuration element when overridden in a derived class.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Object GetElementKey(
    ConfigurationElement element
)
protected override Object GetElementKey(
    ConfigurationElement element
)
Parameters
element
Type:   Online System.Configuration ConfigurationElement
The   Online ConfigurationElement to return the key for.
Return Value

            An   Online Object that acts as the key for the specified   Online ConfigurationElement.

See Also
ContentTypeElementCollection Class
ContentTypeElementCollection Members
Glimpse.Core.Configuration Namespace


ContentTypeElementCollection Properties

ContentTypeElementCollection Properties Glimpse API Documentation
The ContentTypeElementCollection type exposes the following members.
Properties
 | Name | Description
Protected property | Online AddElementName | Gets or sets the name of the Online ConfigurationElement to associate with the add operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ClearElementName | Gets or sets the name for the Online ConfigurationElement to associate with the clear operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public property | Online CollectionType | Gets the type of the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Public property | Online Count | Gets the number of elements in the collection. (Inherited from Online ConfigurationElementCollection.)
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Public property | Online EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Public property | Online IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from Online ConfigurationElementCollection.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Protected property | Online RemoveElementName | Gets or sets the name of the Online ConfigurationElement to associate with the remove operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public property | Online SyncRoot | Gets an object used to synchronize access to the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate Online ConfigurationElement to the Online ConfigurationElementCollection will cause an exception to be thrown. (Inherited from Online ConfigurationElementCollection.)
Back to Top
See Also
ContentTypeElementCollection Class
Glimpse.Core.Configuration Namespace


DiscoverableCollectionElement Class

DiscoverableCollectionElement Class Glimpse API Documentation
The Glimpse configuration node that configures the instance of IDiscoverableCollection T that Glimpse uses to automatically find and load types at runtime.
Inheritance Hierarchy
Online System Object
Online System.Configuration ConfigurationElement
Glimpse.Core.Configuration DiscoverableCollectionElement
Glimpse.Core.Configuration PolicyDiscoverableCollectionElement

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class DiscoverableCollectionElement : ConfigurationElement
public class DiscoverableCollectionElement : ConfigurationElement
Remarks
DiscoverableCollectionElement is used to configure many types, including: IClientScript, IInspector, ISerializationConverter and ITab. IRuntimePolicy's use a specialized version of DiscoverableCollectionElement called PolicyDiscoverableCollectionElement.

See Also
DiscoverableCollectionElement Members
Glimpse.Core.Configuration Namespace


DiscoverableCollectionElement Members

DiscoverableCollectionElement Members Glimpse API Documentation

The DiscoverableCollectionElement type exposes the following members.
Constructors
 | Name | Description
Public method | DiscoverableCollectionElement | Initializes a new instance of the DiscoverableCollectionElement class
Back to Top
Methods
 | Name | Description
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the current Online ConfigurationElement instance to the specified object. (Inherited from Online ConfigurationElement.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Gets a unique value representing the current Online ConfigurationElement instance. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElement object is read-only. (Inherited from Online ConfigurationElement.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the internal state of the Online ConfigurationElement object, including the locks and the properties collections. (Inherited from Online ConfigurationElement.)
Protected method | Online ResetModified | Resets the value of the Online IsModified method to false when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElement object and all subelements. (Inherited from Online ConfigurationElement.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Modifies the Online ConfigurationElement object to remove all values that should not be saved. (Inherited from Online ConfigurationElement.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AutoDiscover | Gets or sets a value indicating whether Glimpse should automatically discover types at runtime.
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | DiscoveryLocation | Gets or sets the file path to the automatic discovery location or a particular Glimpse type. This property overrides the globally configured DiscoveryLocation in Section.
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Public property | IgnoredTypes | Gets or sets the list of types for Glimpse to ignore when they are automatically discovered.
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Back to Top
See Also
DiscoverableCollectionElement Class
Glimpse.Core.Configuration Namespace


DiscoverableCollectionElement Constructor

DiscoverableCollectionElement Constructor Glimpse API Documentation
Initializes a new instance of the DiscoverableCollectionElement class

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DiscoverableCollectionElement()
public DiscoverableCollectionElement()
See Also
DiscoverableCollectionElement Class
DiscoverableCollectionElement Members
Glimpse.Core.Configuration Namespace


DiscoverableCollectionElement Methods

DiscoverableCollectionElement Methods Glimpse API Documentation
The DiscoverableCollectionElement type exposes the following members.
Methods
 | Name | Description
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the current Online ConfigurationElement instance to the specified object. (Inherited from Online ConfigurationElement.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Gets a unique value representing the current Online ConfigurationElement instance. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElement object is read-only. (Inherited from Online ConfigurationElement.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the internal state of the Online ConfigurationElement object, including the locks and the properties collections. (Inherited from Online ConfigurationElement.)
Protected method | Online ResetModified | Resets the value of the Online IsModified method to false when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElement object and all subelements. (Inherited from Online ConfigurationElement.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Modifies the Online ConfigurationElement object to remove all values that should not be saved. (Inherited from Online ConfigurationElement.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
DiscoverableCollectionElement Class
Glimpse.Core.Configuration Namespace


DiscoverableCollectionElement Properties

DiscoverableCollectionElement Properties Glimpse API Documentation
The DiscoverableCollectionElement type exposes the following members.
Properties
 | Name | Description
Public property | AutoDiscover | Gets or sets a value indicating whether Glimpse should automatically discover types at runtime.
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | DiscoveryLocation | Gets or sets the file path to the automatic discovery location or a particular Glimpse type. This property overrides the globally configured DiscoveryLocation in Section.
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Public property | IgnoredTypes | Gets or sets the list of types for Glimpse to ignore when they are automatically discovered.
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Back to Top
See Also
DiscoverableCollectionElement Class
Glimpse.Core.Configuration Namespace


AutoDiscover Property

DiscoverableCollectionElement AutoDiscover Property Glimpse API Documentation
Gets or sets a value indicating whether Glimpse should automatically discover types at runtime.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AutoDiscover { get; set; }
public bool AutoDiscover { get; set; }
Field Value
true to automatically discover (default); otherwise, false.

See Also
DiscoverableCollectionElement Class
DiscoverableCollectionElement Members
Glimpse.Core.Configuration Namespace


DiscoveryLocation Property

DiscoverableCollectionElement DiscoveryLocation Property Glimpse API Documentation
Gets or sets the file path to the automatic discovery location or a particular Glimpse type. This property overrides the globally configured DiscoveryLocation in Section.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DiscoveryLocation { get; set; }
public string DiscoveryLocation { get; set; }
Field Value

            The absolute or relative file path to the automatic discovery location.
            Relative paths are rooted from AppDomain.CurrentDomain.BaseDirectory, or the equivalent shadow copy directory when appropriate.

See Also
DiscoverableCollectionElement Class
DiscoverableCollectionElement Members
Glimpse.Core.Configuration Namespace


IgnoredTypes Property

DiscoverableCollectionElement IgnoredTypes Property Glimpse API Documentation
Gets or sets the list of types for Glimpse to ignore when they are automatically discovered.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeElementCollection IgnoredTypes { get; set; }
public TypeElementCollection IgnoredTypes { get; set; }
See Also
DiscoverableCollectionElement Class
DiscoverableCollectionElement Members
Glimpse.Core.Configuration Namespace


LoggingElement Class

LoggingElement Class Glimpse API Documentation
The Glimpse configuration node for logging settings in Glimpse.
Inheritance Hierarchy
Online System Object
Online System.Configuration ConfigurationElement
Glimpse.Core.Configuration LoggingElement

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LoggingElement : ConfigurationElement
public class LoggingElement : ConfigurationElement
Remarks

            Glimpse logging is mostly used to diagnose problems with Glimpse itself. Logging is off by default, but can be configured to output log statements at various levels.

Examples
View Colorized Copy to Clipboard Print
<logging level="Trace" />
<logging level="Trace" />
See Also
LoggingElement Members
Glimpse.Core.Configuration Namespace


LoggingElement Members

LoggingElement Members Glimpse API Documentation

The LoggingElement type exposes the following members.
Constructors
 | Name | Description
Public method | LoggingElement | Initializes a new instance of the LoggingElement class
Back to Top
Methods
 | Name | Description
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the current Online ConfigurationElement instance to the specified object. (Inherited from Online ConfigurationElement.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Gets a unique value representing the current Online ConfigurationElement instance. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElement object is read-only. (Inherited from Online ConfigurationElement.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the internal state of the Online ConfigurationElement object, including the locks and the properties collections. (Inherited from Online ConfigurationElement.)
Protected method | Online ResetModified | Resets the value of the Online IsModified method to false when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElement object and all subelements. (Inherited from Online ConfigurationElement.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Modifies the Online ConfigurationElement object to remove all values that should not be saved. (Inherited from Online ConfigurationElement.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Level | Gets or sets the logging level used by Glimpse.
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Public property | LogLocation | Gets or sets the file path to the Glimpse log file.
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Back to Top
See Also
LoggingElement Class
Glimpse.Core.Configuration Namespace


LoggingElement Constructor

LoggingElement Constructor Glimpse API Documentation
Initializes a new instance of the LoggingElement class

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggingElement()
public LoggingElement()
See Also
LoggingElement Class
LoggingElement Members
Glimpse.Core.Configuration Namespace


LoggingElement Methods

LoggingElement Methods Glimpse API Documentation
The LoggingElement type exposes the following members.
Methods
 | Name | Description
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the current Online ConfigurationElement instance to the specified object. (Inherited from Online ConfigurationElement.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Gets a unique value representing the current Online ConfigurationElement instance. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElement object is read-only. (Inherited from Online ConfigurationElement.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the internal state of the Online ConfigurationElement object, including the locks and the properties collections. (Inherited from Online ConfigurationElement.)
Protected method | Online ResetModified | Resets the value of the Online IsModified method to false when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElement object and all subelements. (Inherited from Online ConfigurationElement.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Modifies the Online ConfigurationElement object to remove all values that should not be saved. (Inherited from Online ConfigurationElement.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
LoggingElement Class
Glimpse.Core.Configuration Namespace


LoggingElement Properties

LoggingElement Properties Glimpse API Documentation
The LoggingElement type exposes the following members.
Properties
 | Name | Description
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Level | Gets or sets the logging level used by Glimpse.
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Public property | LogLocation | Gets or sets the file path to the Glimpse log file.
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Back to Top
See Also
LoggingElement Class
Glimpse.Core.Configuration Namespace


Level Property

LoggingElement Level Property Glimpse API Documentation
Gets or sets the logging level used by Glimpse.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggingLevel Level { get; set; }
public LoggingLevel Level { get; set; }
Field Value

            The string representation of any valid LoggingLevel.

See Also
LoggingElement Class
LoggingElement Members
Glimpse.Core.Configuration Namespace


LogLocation Property

LoggingElement LogLocation Property Glimpse API Documentation
Gets or sets the file path to the Glimpse log file.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LogLocation { get; set; }
public string LogLocation { get; set; }
Field Value

            The absolute or relative file path to the log file.
            Relative paths are rooted from AppDomain.CurrentDomain.BaseDirectory.
            The default value is Glimpse.log.

Remarks
LogLocation is only written to if Level is not set to Off.

See Also
LoggingElement Class
LoggingElement Members
Glimpse.Core.Configuration Namespace


LoggingLevel Enumeration

LoggingLevel Enumeration Glimpse API Documentation
LoggingLevel defines the level of output detail to be written to the Glimpse log.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum LoggingLevel
public enum LoggingLevel
Members
Member name | Value | Description
Trace | 0 | The Trace level is the most detailed level of output in Glimpse.
Debug | 1 | The Debug level contains debugging information, and is less detailed than trace.
Info | 2 | The Info level contains common information messages.
Warn | 3 | The Warn level contains warning messages, typically for non-critical issues, which can be recovered or which are temporary failures.
Error | 4 | The Error level contains error messages that Glimpse was able to recover from.
Fatal | 5 | The Fatal level contains error messages that Glimpse was unable to recover from.
Off | 6 | The Off level contains no messages. When the logging level is Off, Glimpse will not even create a log file.
See Also
Glimpse.Core.Configuration Namespace


PolicyDiscoverableCollectionElement Class

PolicyDiscoverableCollectionElement Class Glimpse API Documentation
The Glimpse configuration node is a specialized DiscoverableCollectionElement used by IRuntimePolicys and IConfigurables to allow for end user configuration of runtime policies.
Inheritance Hierarchy
Online System Object
Online System.Configuration ConfigurationElement
Glimpse.Core.Configuration DiscoverableCollectionElement
Glimpse.Core.Configuration PolicyDiscoverableCollectionElement

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PolicyDiscoverableCollectionElement : DiscoverableCollectionElement
public class PolicyDiscoverableCollectionElement : DiscoverableCollectionElement
See Also
PolicyDiscoverableCollectionElement Members
Glimpse.Core.Configuration Namespace


PolicyDiscoverableCollectionElement Members

PolicyDiscoverableCollectionElement Members Glimpse API Documentation

The PolicyDiscoverableCollectionElement type exposes the following members.
Constructors
 | Name | Description
Public method | PolicyDiscoverableCollectionElement | Initializes a new instance of the PolicyDiscoverableCollectionElement class
Back to Top
Methods
 | Name | Description
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the current Online ConfigurationElement instance to the specified object. (Inherited from Online ConfigurationElement.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Gets a unique value representing the current Online ConfigurationElement instance. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElement object is read-only. (Inherited from Online ConfigurationElement.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the internal state of the Online ConfigurationElement object, including the locks and the properties collections. (Inherited from Online ConfigurationElement.)
Protected method | Online ResetModified | Resets the value of the Online IsModified method to false when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElement object and all subelements. (Inherited from Online ConfigurationElement.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Modifies the Online ConfigurationElement object to remove all values that should not be saved. (Inherited from Online ConfigurationElement.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AutoDiscover | Gets or sets a value indicating whether Glimpse should automatically discover types at runtime. (Inherited from DiscoverableCollectionElement.)
Public property | ContentTypes | Gets or sets a list of content types (aka media types or mime types).
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | DiscoveryLocation | Gets or sets the file path to the automatic discovery location or a particular Glimpse type. This property overrides the globally configured DiscoveryLocation in Section. (Inherited from DiscoverableCollectionElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Public property | IgnoredTypes | Gets or sets the list of types for Glimpse to ignore when they are automatically discovered. (Inherited from DiscoverableCollectionElement.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Public property | StatusCodes | Gets or sets a list of Http status codes.
Public property | Uris | Gets or sets a list of Uris.
Back to Top
See Also
PolicyDiscoverableCollectionElement Class
Glimpse.Core.Configuration Namespace


PolicyDiscoverableCollectionElement Constructor

PolicyDiscoverableCollectionElement Constructor Glimpse API Documentation
Initializes a new instance of the PolicyDiscoverableCollectionElement class

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PolicyDiscoverableCollectionElement()
public PolicyDiscoverableCollectionElement()
See Also
PolicyDiscoverableCollectionElement Class
PolicyDiscoverableCollectionElement Members
Glimpse.Core.Configuration Namespace


PolicyDiscoverableCollectionElement Methods

PolicyDiscoverableCollectionElement Methods Glimpse API Documentation
The PolicyDiscoverableCollectionElement type exposes the following members.
Methods
 | Name | Description
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the current Online ConfigurationElement instance to the specified object. (Inherited from Online ConfigurationElement.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Gets a unique value representing the current Online ConfigurationElement instance. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElement object is read-only. (Inherited from Online ConfigurationElement.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the internal state of the Online ConfigurationElement object, including the locks and the properties collections. (Inherited from Online ConfigurationElement.)
Protected method | Online ResetModified | Resets the value of the Online IsModified method to false when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElement object and all subelements. (Inherited from Online ConfigurationElement.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Modifies the Online ConfigurationElement object to remove all values that should not be saved. (Inherited from Online ConfigurationElement.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
PolicyDiscoverableCollectionElement Class
Glimpse.Core.Configuration Namespace


PolicyDiscoverableCollectionElement Properties

PolicyDiscoverableCollectionElement Properties Glimpse API Documentation
The PolicyDiscoverableCollectionElement type exposes the following members.
Properties
 | Name | Description
Public property | AutoDiscover | Gets or sets a value indicating whether Glimpse should automatically discover types at runtime. (Inherited from DiscoverableCollectionElement.)
Public property | ContentTypes | Gets or sets a list of content types (aka media types or mime types).
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | DiscoveryLocation | Gets or sets the file path to the automatic discovery location or a particular Glimpse type. This property overrides the globally configured DiscoveryLocation in Section. (Inherited from DiscoverableCollectionElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Public property | IgnoredTypes | Gets or sets the list of types for Glimpse to ignore when they are automatically discovered. (Inherited from DiscoverableCollectionElement.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Public property | StatusCodes | Gets or sets a list of Http status codes.
Public property | Uris | Gets or sets a list of Uris.
Back to Top
See Also
PolicyDiscoverableCollectionElement Class
Glimpse.Core.Configuration Namespace


ContentTypes Property

PolicyDiscoverableCollectionElement ContentTypes Property Glimpse API Documentation
Gets or sets a list of content types (aka media types or mime types).

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ContentTypeElementCollection ContentTypes { get; set; }
public ContentTypeElementCollection ContentTypes { get; set; }
Field Value

            The ContentTypes list is used by ContentTypePolicy to filter invalid Glimpse responses.

Remarks

            Valid content type syntax is defined in   Online RFC 2046. A   Online list of commonly used content types is available from IANA.

See Also
PolicyDiscoverableCollectionElement Class
PolicyDiscoverableCollectionElement Members
Glimpse.Core.Configuration Namespace


StatusCodes Property

PolicyDiscoverableCollectionElement StatusCodes Property Glimpse API Documentation
Gets or sets a list of Http status codes.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StatusCodeElementCollection StatusCodes { get; set; }
public StatusCodeElementCollection StatusCodes { get; set; }
Field Value

            The StatusCodes list is used by StatusCodePolicy to filter invalid Glimpse responses.

Remarks

            A list of ratified Http status codes is available in   Online Section 10 of RFC 2616, the Http version 1.1 specification.

See Also
PolicyDiscoverableCollectionElement Class
PolicyDiscoverableCollectionElement Members
Glimpse.Core.Configuration Namespace


Uris Property

PolicyDiscoverableCollectionElement Uris Property Glimpse API Documentation
Gets or sets a list of Uris.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RegexElementCollection Uris { get; set; }
public RegexElementCollection Uris { get; set; }
Field Value

            The Uris list is used by UriPolicy to filter invalid Glimpse responses.

Remarks

            Each Uri in the Uris list must be a valid Uniform Resource Identifier, as defined by   Online RFC 3986.
            In addition, "wildcard" Uris are supported via .NET regular expression syntax.

See Also
PolicyDiscoverableCollectionElement Class
PolicyDiscoverableCollectionElement Members
Glimpse.Core.Configuration Namespace


RegexElement Class

RegexElement Class Glimpse API Documentation
The Glimpse configuration node representing a regular expression.
Inheritance Hierarchy
Online System Object
Online System.Configuration ConfigurationElement
Glimpse.Core.Configuration RegexElement

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RegexElement : ConfigurationElement
public class RegexElement : ConfigurationElement
See Also
RegexElement Members
Glimpse.Core.Configuration Namespace


RegexElement Members

RegexElement Members Glimpse API Documentation

The RegexElement type exposes the following members.
Constructors
 | Name | Description
Public method | RegexElement | Initializes a new instance of the RegexElement class
Back to Top
Methods
 | Name | Description
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the current Online ConfigurationElement instance to the specified object. (Inherited from Online ConfigurationElement.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Gets a unique value representing the current Online ConfigurationElement instance. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElement object is read-only. (Inherited from Online ConfigurationElement.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the internal state of the Online ConfigurationElement object, including the locks and the properties collections. (Inherited from Online ConfigurationElement.)
Protected method | Online ResetModified | Resets the value of the Online IsModified method to false when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElement object and all subelements. (Inherited from Online ConfigurationElement.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Modifies the Online ConfigurationElement object to remove all values that should not be saved. (Inherited from Online ConfigurationElement.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Public property | Regex | Gets or sets the regular expression.
Back to Top
See Also
RegexElement Class
Glimpse.Core.Configuration Namespace


RegexElement Constructor

RegexElement Constructor Glimpse API Documentation
Initializes a new instance of the RegexElement class

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RegexElement()
public RegexElement()
See Also
RegexElement Class
RegexElement Members
Glimpse.Core.Configuration Namespace


RegexElement Methods

RegexElement Methods Glimpse API Documentation
The RegexElement type exposes the following members.
Methods
 | Name | Description
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the current Online ConfigurationElement instance to the specified object. (Inherited from Online ConfigurationElement.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Gets a unique value representing the current Online ConfigurationElement instance. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElement object is read-only. (Inherited from Online ConfigurationElement.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the internal state of the Online ConfigurationElement object, including the locks and the properties collections. (Inherited from Online ConfigurationElement.)
Protected method | Online ResetModified | Resets the value of the Online IsModified method to false when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElement object and all subelements. (Inherited from Online ConfigurationElement.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Modifies the Online ConfigurationElement object to remove all values that should not be saved. (Inherited from Online ConfigurationElement.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
RegexElement Class
Glimpse.Core.Configuration Namespace


RegexElement Properties

RegexElement Properties Glimpse API Documentation
The RegexElement type exposes the following members.
Properties
 | Name | Description
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Public property | Regex | Gets or sets the regular expression.
Back to Top
See Also
RegexElement Class
Glimpse.Core.Configuration Namespace


Regex Property

RegexElement Regex Property Glimpse API Documentation
Gets or sets the regular expression.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Regex Regex { get; set; }
public Regex Regex { get; set; }
Field Value

            Any valid   Online .NET Framework regular expression. is supported.

See Also
RegexElement Class
RegexElement Members
Glimpse.Core.Configuration Namespace


RegexElementCollection Class

RegexElementCollection Class Glimpse API Documentation
The Glimpse configuration node for collecting a list of regular expressions.
Inheritance Hierarchy
Online System Object
Online System.Configuration ConfigurationElement
Online System.Configuration ConfigurationElementCollection
Glimpse.Core.Configuration RegexElementCollection

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RegexElementCollection : ConfigurationElementCollection
public class RegexElementCollection : ConfigurationElementCollection
See Also
RegexElementCollection Members
Glimpse.Core.Configuration Namespace


RegexElementCollection Members

RegexElementCollection Members Glimpse API Documentation

The RegexElementCollection type exposes the following members.
Constructors
 | Name | Description
Public method | RegexElementCollection | Initializes a new instance of the RegexElementCollection class
Back to Top
Methods
 | Name | Description
Protected method | Online BaseAdd(ConfigurationElement) | Adds a configuration element to the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseClear | Removes all configuration element objects from the collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGetKey | Gets the key for the Online ConfigurationElement at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseIndexOf | The index of the specified Online ConfigurationElement. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseIsRemoved | Gets a value indicating whether the Online ConfigurationElement with the specified key has been removed from the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseRemove | Removes a Online ConfigurationElement from the collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseRemoveAt | Removes the Online ConfigurationElement at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Public method | Online CopyTo | Copies the contents of the Online ConfigurationElementCollection to an array. (Inherited from Online ConfigurationElementCollection.)
Protected method | CreateNewElement | When overridden in a derived class, creates a new Online ConfigurationElement. (Overrides Online ConfigurationElementCollection CreateNewElement .)
Protected method | Online CreateNewElement(String) | Creates a new Online ConfigurationElement when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the Online ConfigurationElementCollection to the specified object. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetElementKey | Gets the element key for a specified configuration element when overridden in a derived class. (Overrides Online ConfigurationElementCollection GetElementKey(ConfigurationElement).)
Public method | Online GetEnumerator | Gets an Online IEnumerator which is used to iterate through the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Public method | Online GetHashCode | Gets a unique value representing the Online ConfigurationElementCollection instance. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsElementName | Indicates whether the specified Online ConfigurationElement exists in the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online IsElementRemovable | Gets a value indicating whether the specified Online ConfigurationElement can be removed from the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online IsModified | Indicates whether this Online ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElementCollection object is read only. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the Online ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online ResetModified | Resets the value of the Online IsModified property to false when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElementCollection object and for all sub-elements. (Inherited from Online ConfigurationElementCollection.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from Online ConfigurationElementCollection.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Protected property | Online AddElementName | Gets or sets the name of the Online ConfigurationElement to associate with the add operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ClearElementName | Gets or sets the name for the Online ConfigurationElement to associate with the clear operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public property | Online CollectionType | Gets the type of the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Public property | Online Count | Gets the number of elements in the collection. (Inherited from Online ConfigurationElementCollection.)
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Public property | Online EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Public property | Online IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from Online ConfigurationElementCollection.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Protected property | Online RemoveElementName | Gets or sets the name of the Online ConfigurationElement to associate with the remove operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public property | Online SyncRoot | Gets an object used to synchronize access to the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate Online ConfigurationElement to the Online ConfigurationElementCollection will cause an exception to be thrown. (Inherited from Online ConfigurationElementCollection.)
Back to Top
See Also
RegexElementCollection Class
Glimpse.Core.Configuration Namespace


RegexElementCollection Constructor

RegexElementCollection Constructor Glimpse API Documentation
Initializes a new instance of the RegexElementCollection class

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RegexElementCollection()
public RegexElementCollection()
See Also
RegexElementCollection Class
RegexElementCollection Members
Glimpse.Core.Configuration Namespace


RegexElementCollection Methods

RegexElementCollection Methods Glimpse API Documentation
The RegexElementCollection type exposes the following members.
Methods
 | Name | Description
Protected method | Online BaseAdd(ConfigurationElement) | Adds a configuration element to the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseClear | Removes all configuration element objects from the collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGetKey | Gets the key for the Online ConfigurationElement at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseIndexOf | The index of the specified Online ConfigurationElement. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseIsRemoved | Gets a value indicating whether the Online ConfigurationElement with the specified key has been removed from the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseRemove | Removes a Online ConfigurationElement from the collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseRemoveAt | Removes the Online ConfigurationElement at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Public method | Online CopyTo | Copies the contents of the Online ConfigurationElementCollection to an array. (Inherited from Online ConfigurationElementCollection.)
Protected method | CreateNewElement | When overridden in a derived class, creates a new Online ConfigurationElement. (Overrides Online ConfigurationElementCollection CreateNewElement .)
Protected method | Online CreateNewElement(String) | Creates a new Online ConfigurationElement when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the Online ConfigurationElementCollection to the specified object. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetElementKey | Gets the element key for a specified configuration element when overridden in a derived class. (Overrides Online ConfigurationElementCollection GetElementKey(ConfigurationElement).)
Public method | Online GetEnumerator | Gets an Online IEnumerator which is used to iterate through the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Public method | Online GetHashCode | Gets a unique value representing the Online ConfigurationElementCollection instance. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsElementName | Indicates whether the specified Online ConfigurationElement exists in the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online IsElementRemovable | Gets a value indicating whether the specified Online ConfigurationElement can be removed from the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online IsModified | Indicates whether this Online ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElementCollection object is read only. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the Online ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online ResetModified | Resets the value of the Online IsModified property to false when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElementCollection object and for all sub-elements. (Inherited from Online ConfigurationElementCollection.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from Online ConfigurationElementCollection.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
RegexElementCollection Class
Glimpse.Core.Configuration Namespace


CreateNewElement Method

RegexElementCollection CreateNewElement Method Glimpse API Documentation
Overload List
 | Name | Description
Protected method | CreateNewElement | When overridden in a derived class, creates a new Online ConfigurationElement. (Overrides Online ConfigurationElementCollection CreateNewElement .)
Protected method | Online CreateNewElement(String) | Creates a new Online ConfigurationElement when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Back to Top
See Also
RegexElementCollection Class
RegexElementCollection Members
Glimpse.Core.Configuration Namespace


CreateNewElement Method

RegexElementCollection CreateNewElement Method Glimpse API Documentation
When overridden in a derived class, creates a new Online ConfigurationElement.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override ConfigurationElement CreateNewElement()
protected override ConfigurationElement CreateNewElement()
Return Value

            A new   Online ConfigurationElement.

See Also
RegexElementCollection Class
RegexElementCollection Members
CreateNewElement Overload
Glimpse.Core.Configuration Namespace


GetElementKey Method

RegexElementCollection GetElementKey Method Glimpse API Documentation
Gets the element key for a specified configuration element when overridden in a derived class.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Object GetElementKey(
    ConfigurationElement element
)
protected override Object GetElementKey(
    ConfigurationElement element
)
Parameters
element
Type:   Online System.Configuration ConfigurationElement
The   Online ConfigurationElement to return the key for.
Return Value

            An   Online Object that acts as the key for the specified   Online ConfigurationElement.

See Also
RegexElementCollection Class
RegexElementCollection Members
Glimpse.Core.Configuration Namespace


RegexElementCollection Properties

RegexElementCollection Properties Glimpse API Documentation
The RegexElementCollection type exposes the following members.
Properties
 | Name | Description
Protected property | Online AddElementName | Gets or sets the name of the Online ConfigurationElement to associate with the add operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ClearElementName | Gets or sets the name for the Online ConfigurationElement to associate with the clear operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public property | Online CollectionType | Gets the type of the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Public property | Online Count | Gets the number of elements in the collection. (Inherited from Online ConfigurationElementCollection.)
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Public property | Online EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Public property | Online IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from Online ConfigurationElementCollection.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Protected property | Online RemoveElementName | Gets or sets the name of the Online ConfigurationElement to associate with the remove operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public property | Online SyncRoot | Gets an object used to synchronize access to the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate Online ConfigurationElement to the Online ConfigurationElementCollection will cause an exception to be thrown. (Inherited from Online ConfigurationElementCollection.)
Back to Top
See Also
RegexElementCollection Class
Glimpse.Core.Configuration Namespace


Section Class

Section Class Glimpse API Documentation
The root Glimpse configuration node, that provides Glimpse configuration options in a site's web.config.
Inheritance Hierarchy
Online System Object
Online System.Configuration ConfigurationElement
Online System.Configuration ConfigurationSection
Glimpse.Core.Configuration Section

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Section : ConfigurationSection
public class Section : ConfigurationSection
Remarks

            Before using, the Section class must be added to the configSections section of web.config, as shown in the examples. However, usually a NuGet package will make the necessary web.config changes automatically.

Examples
View Colorized Copy to Clipboard Print
<configuration>
    <configSections>
        <section name="glimpse" type="Glimpse.Core.Configuration.Section, Glimpse.Core" />
        <!-- Additional section registrations -->
    </configSections>
    <!-- Additional configuration nodes -->
</configuration>
<configuration>
    <configSections>
        <section name="glimpse" type="Glimpse.Core.Configuration.Section, Glimpse.Core" />
        <!-- Additional section registrations -->
    </configSections>
    <!-- Additional configuration nodes -->
</configuration>
See Also
Section Members
Glimpse.Core.Configuration Namespace


Section Members

Section Members Glimpse API Documentation

The Section type exposes the following members.
Constructors
 | Name | Description
Public method | Section | Initializes a new instance of the Section class
Back to Top
Methods
 | Name | Description
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Protected method | Online DeserializeSection | Reads XML from the configuration file. (Inherited from Online ConfigurationSection.)
Public method | Online Equals | Compares the current Online ConfigurationElement instance to the specified object. (Inherited from Online ConfigurationElement.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Gets a unique value representing the current Online ConfigurationElement instance. (Inherited from Online ConfigurationElement.)
Protected method | Online GetRuntimeObject | Returns a custom object when overridden in a derived class. (Inherited from Online ConfigurationSection.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded when implemented in a derived class. (Inherited from Online ConfigurationSection.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElement object is read-only. (Inherited from Online ConfigurationElement.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the internal state of the Online ConfigurationElement object, including the locks and the properties collections. (Inherited from Online ConfigurationElement.)
Protected method | Online ResetModified | Resets the value of the Online IsModified method to false when implemented in a derived class. (Inherited from Online ConfigurationSection.)
Protected method | Online SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeSection | Creates an XML string containing an unmerged view of the Online ConfigurationSection object as a single section to write to a file. (Inherited from Online ConfigurationSection.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElement object and all subelements. (Inherited from Online ConfigurationElement.)
Protected method | Online ShouldSerializeElementInTargetVersion | Indicates whether the specified element should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from Online ConfigurationSection.)
Protected method | Online ShouldSerializePropertyInTargetVersion | Indicates whether the specified property should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from Online ConfigurationSection.)
Protected method | Online ShouldSerializeSectionInTargetVersion | Indicates whether the current Online ConfigurationSection instance should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from Online ConfigurationSection.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Modifies the Online ConfigurationElement object to remove all values that should not be saved. (Inherited from Online ConfigurationElement.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ClientScripts | Gets or sets the collection of IClientScripts that are injected into a page response by Glimpse.
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | DefaultRuntimePolicy | Gets or sets the default runtime policy. Glimpse will never be allowed to do more with a Http response than is specified in DefaultRuntimePolicy.
Public property | DiscoveryLocation | Gets or sets the path Glimpse will use to auto discover all types.
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Public property | EndpointBaseUri | Gets or sets the base Uri endpoint for accessing all resources. The EndpointBaseUri is leveraged by an instance of ResourceEndpointConfiguration in order to generate dynamic resource Uris.
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Public property | Inspectors | Gets or sets the collection of IInspectors that used to gather information about a site during Http requests.
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Public property | Logging | Gets or sets the logging settings used by Glimpse.
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Public property | Resources | Gets or sets the collection of IResources that provide endpoints to access server side data.
Public property | RuntimePolicies | Gets or sets the collection of IRuntimePolicys that Glimpse will use to determine how it can manipulate any given Http response.
Public property | Online SectionInformation | Gets a Online SectionInformation object that contains the non-customizable information and functionality of the Online ConfigurationSection object. (Inherited from Online ConfigurationSection.)
Public property | SerializationConverters | Gets or sets the collection of ISerializationConverters that Glimpse will use alter the default serialization output of any given type.
Public property | ServiceLocatorType | Gets or sets an IServiceLocator Glimpse will use to override default type resolution.
Public property | Tabs | Gets or sets the collection of ITabs that Glimpse will render in the client.
Back to Top
See Also
Section Class
Glimpse.Core.Configuration Namespace


Section Constructor

Section Constructor Glimpse API Documentation
Initializes a new instance of the Section class

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Section()
public Section()
See Also
Section Class
Section Members
Glimpse.Core.Configuration Namespace


Section Methods

Section Methods Glimpse API Documentation
The Section type exposes the following members.
Methods
 | Name | Description
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Protected method | Online DeserializeSection | Reads XML from the configuration file. (Inherited from Online ConfigurationSection.)
Public method | Online Equals | Compares the current Online ConfigurationElement instance to the specified object. (Inherited from Online ConfigurationElement.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Gets a unique value representing the current Online ConfigurationElement instance. (Inherited from Online ConfigurationElement.)
Protected method | Online GetRuntimeObject | Returns a custom object when overridden in a derived class. (Inherited from Online ConfigurationSection.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded when implemented in a derived class. (Inherited from Online ConfigurationSection.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElement object is read-only. (Inherited from Online ConfigurationElement.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the internal state of the Online ConfigurationElement object, including the locks and the properties collections. (Inherited from Online ConfigurationElement.)
Protected method | Online ResetModified | Resets the value of the Online IsModified method to false when implemented in a derived class. (Inherited from Online ConfigurationSection.)
Protected method | Online SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeSection | Creates an XML string containing an unmerged view of the Online ConfigurationSection object as a single section to write to a file. (Inherited from Online ConfigurationSection.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElement object and all subelements. (Inherited from Online ConfigurationElement.)
Protected method | Online ShouldSerializeElementInTargetVersion | Indicates whether the specified element should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from Online ConfigurationSection.)
Protected method | Online ShouldSerializePropertyInTargetVersion | Indicates whether the specified property should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from Online ConfigurationSection.)
Protected method | Online ShouldSerializeSectionInTargetVersion | Indicates whether the current Online ConfigurationSection instance should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from Online ConfigurationSection.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Modifies the Online ConfigurationElement object to remove all values that should not be saved. (Inherited from Online ConfigurationElement.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
Section Class
Glimpse.Core.Configuration Namespace


Section Properties

Section Properties Glimpse API Documentation
The Section type exposes the following members.
Properties
 | Name | Description
Public property | ClientScripts | Gets or sets the collection of IClientScripts that are injected into a page response by Glimpse.
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | DefaultRuntimePolicy | Gets or sets the default runtime policy. Glimpse will never be allowed to do more with a Http response than is specified in DefaultRuntimePolicy.
Public property | DiscoveryLocation | Gets or sets the path Glimpse will use to auto discover all types.
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Public property | EndpointBaseUri | Gets or sets the base Uri endpoint for accessing all resources. The EndpointBaseUri is leveraged by an instance of ResourceEndpointConfiguration in order to generate dynamic resource Uris.
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Public property | Inspectors | Gets or sets the collection of IInspectors that used to gather information about a site during Http requests.
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Public property | Logging | Gets or sets the logging settings used by Glimpse.
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Public property | Resources | Gets or sets the collection of IResources that provide endpoints to access server side data.
Public property | RuntimePolicies | Gets or sets the collection of IRuntimePolicys that Glimpse will use to determine how it can manipulate any given Http response.
Public property | Online SectionInformation | Gets a Online SectionInformation object that contains the non-customizable information and functionality of the Online ConfigurationSection object. (Inherited from Online ConfigurationSection.)
Public property | SerializationConverters | Gets or sets the collection of ISerializationConverters that Glimpse will use alter the default serialization output of any given type.
Public property | ServiceLocatorType | Gets or sets an IServiceLocator Glimpse will use to override default type resolution.
Public property | Tabs | Gets or sets the collection of ITabs that Glimpse will render in the client.
Back to Top
See Also
Section Class
Glimpse.Core.Configuration Namespace


ClientScripts Property

Section ClientScripts Property Glimpse API Documentation
Gets or sets the collection of IClientScripts that are injected into a page response by Glimpse.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DiscoverableCollectionElement ClientScripts { get; set; }
public DiscoverableCollectionElement ClientScripts { get; set; }
Remarks

            By default, client scripts are discovered at runtime but that behavior, plus the location of where they are found, and which ones should be ignored is configurable.

Examples
View Colorized Copy to Clipboard Print
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <clientScripts autoDiscover="true" discoveryLocation="bin\debug">
        <ignoredTypes>
            <add type="{Namespace.Type, AssemblyName}"/>
        </ignoredTypes>
    </clientScripts>
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <clientScripts autoDiscover="true" discoveryLocation="bin\debug">
        <ignoredTypes>
            <add type="{Namespace.Type, AssemblyName}"/>
        </ignoredTypes>
    </clientScripts>
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
See Also
Section Class
Section Members
Glimpse.Core.Configuration Namespace


DefaultRuntimePolicy Property

Section DefaultRuntimePolicy Property Glimpse API Documentation
Gets or sets the default runtime policy. Glimpse will never be allowed to do more with a Http response than is specified in DefaultRuntimePolicy.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RuntimePolicy DefaultRuntimePolicy { get; set; }
public RuntimePolicy DefaultRuntimePolicy { get; set; }
Remarks

            By default, the default runtime policy of Glimpse is Off. Setting the base policy to On will allow Glimpse to fully function.

Examples
View Colorized Copy to Clipboard Print
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
See Also
Section Class
Section Members
Glimpse.Core.Configuration Namespace


DiscoveryLocation Property

Section DiscoveryLocation Property Glimpse API Documentation
Gets or sets the path Glimpse will use to auto discover all types.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DiscoveryLocation { get; set; }
public string DiscoveryLocation { get; set; }
Remarks

            The DiscoveryLocation defaults to AppDomain.CurrentDomain.BaseDirectory. Discovery locations for each type can be overwritten at the type level in web.config.

Examples
View Colorized Copy to Clipboard Print
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd" discoveryLocation="bin\debug">
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd" discoveryLocation="bin\debug">
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
See Also
Section Class
Section Members
Glimpse.Core.Configuration Namespace


EndpointBaseUri Property

Section EndpointBaseUri Property Glimpse API Documentation
Gets or sets the base Uri endpoint for accessing all resources. The EndpointBaseUri is leveraged by an instance of ResourceEndpointConfiguration in order to generate dynamic resource Uris.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string EndpointBaseUri { get; set; }
public string EndpointBaseUri { get; set; }
Remarks

            The EndpointBaseUri is required.

Examples
View Colorized Copy to Clipboard Print
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
See Also
Section Class
Section Members
Glimpse.Core.Configuration Namespace


Inspectors Property

Section Inspectors Property Glimpse API Documentation
Gets or sets the collection of IInspectors that used to gather information about a site during Http requests.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DiscoverableCollectionElement Inspectors { get; set; }
public DiscoverableCollectionElement Inspectors { get; set; }
Remarks

            By default, inspectors are discovered at runtime but that behavior, plus the location of where they are found, and which ones should be ignored is configurable.

Examples
View Colorized Copy to Clipboard Print
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <inspectors autoDiscover="true" discoveryLocation="bin\debug">
        <ignoredTypes>
            <add type="{Namespace.Type, AssemblyName}"/>
        </ignoredTypes>
    </inspectors>
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <inspectors autoDiscover="true" discoveryLocation="bin\debug">
        <ignoredTypes>
            <add type="{Namespace.Type, AssemblyName}"/>
        </ignoredTypes>
    </inspectors>
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
See Also
Section Class
Section Members
Glimpse.Core.Configuration Namespace


Logging Property

Section Logging Property Glimpse API Documentation
Gets or sets the logging settings used by Glimpse.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LoggingElement Logging { get; set; }
public LoggingElement Logging { get; set; }
Remarks

            Glimpse logging is mostly used to diagnose problems with Glimpse itself. Logging is off by default.

Examples
View Colorized Copy to Clipboard Print
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <logging level="Trace" />
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <logging level="Trace" />
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
See Also
Section Class
Section Members
Glimpse.Core.Configuration Namespace


Resources Property

Section Resources Property Glimpse API Documentation
Gets or sets the collection of IResources that provide endpoints to access server side data.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DiscoverableCollectionElement Resources { get; set; }
public DiscoverableCollectionElement Resources { get; set; }
Remarks

            By default, resources are discovered at runtime but that behavior, plus the location of where they are found, and which ones should be ignored is configurable.

Examples
View Colorized Copy to Clipboard Print
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <resources autoDiscover="true" discoveryLocation="bin\debug">
        <ignoredTypes>
            <add type="{Namespace.Type, AssemblyName}"/>
        </ignoredTypes>
    </resources>
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <resources autoDiscover="true" discoveryLocation="bin\debug">
        <ignoredTypes>
            <add type="{Namespace.Type, AssemblyName}"/>
        </ignoredTypes>
    </resources>
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
See Also
Section Class
Section Members
Glimpse.Core.Configuration Namespace


RuntimePolicies Property

Section RuntimePolicies Property Glimpse API Documentation
Gets or sets the collection of IRuntimePolicys that Glimpse will use to determine how it can manipulate any given Http response.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PolicyDiscoverableCollectionElement RuntimePolicies { get; set; }
public PolicyDiscoverableCollectionElement RuntimePolicies { get; set; }
Remarks

            By default, runtime policies are discovered at runtime but that behavior, plus the location of where they are found, and which ones should be ignored is configurable.

Examples
View Colorized Copy to Clipboard Print
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <runtimePolicies autoDiscover="true" discoveryLocation="bin\debug">
        <ignoredTypes>
            <add type="{Namespace.Type, AssemblyName}"/>
        </ignoredTypes>
    </runtimePolicies>
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <runtimePolicies autoDiscover="true" discoveryLocation="bin\debug">
        <ignoredTypes>
            <add type="{Namespace.Type, AssemblyName}"/>
        </ignoredTypes>
    </runtimePolicies>
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
See Also
Section Class
Section Members
Glimpse.Core.Configuration Namespace


SerializationConverters Property

Section SerializationConverters Property Glimpse API Documentation
Gets or sets the collection of ISerializationConverters that Glimpse will use alter the default serialization output of any given type.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DiscoverableCollectionElement SerializationConverters { get; set; }
public DiscoverableCollectionElement SerializationConverters { get; set; }
Remarks

            By default, serialization converters are discovered at runtime but that behavior, plus the location of where they are found, and which ones should be ignored is configurable.

Examples
View Colorized Copy to Clipboard Print
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <serializationConverters autoDiscover="true" discoveryLocation="bin\debug">
        <ignoredTypes>
            <add type="{Namespace.Type, AssemblyName}"/>
        </ignoredTypes>
    </serializationConverters>
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <serializationConverters autoDiscover="true" discoveryLocation="bin\debug">
        <ignoredTypes>
            <add type="{Namespace.Type, AssemblyName}"/>
        </ignoredTypes>
    </serializationConverters>
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
See Also
Section Class
Section Members
Glimpse.Core.Configuration Namespace


ServiceLocatorType Property

Section ServiceLocatorType Property Glimpse API Documentation
Gets or sets an IServiceLocator Glimpse will use to override default type resolution.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type ServiceLocatorType { get; set; }
public Type ServiceLocatorType { get; set; }
Examples
View Colorized Copy to Clipboard Print
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd" serviceLocatorType="{Namespace.Type, AssemblyName}">
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd" serviceLocatorType="{Namespace.Type, AssemblyName}">
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
See Also
Section Class
Section Members
Glimpse.Core.Configuration Namespace


Tabs Property

Section Tabs Property Glimpse API Documentation
Gets or sets the collection of ITabs that Glimpse will render in the client.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DiscoverableCollectionElement Tabs { get; set; }
public DiscoverableCollectionElement Tabs { get; set; }
Remarks

            By default, tabs are discovered at runtime but that behavior, plus the location of where they are found, and which ones should be ignored is configurable.

Examples
View Colorized Copy to Clipboard Print
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <tabs autoDiscover="true" discoveryLocation="bin\debug">
        <ignoredTypes>
            <add type="{Namespace.Type, AssemblyName}"/>
        </ignoredTypes>
    </tabs>
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <tabs autoDiscover="true" discoveryLocation="bin\debug">
        <ignoredTypes>
            <add type="{Namespace.Type, AssemblyName}"/>
        </ignoredTypes>
    </tabs>
    <!-- Additional Glimpse configuration nodes -->
</glimpse>
See Also
Section Class
Section Members
Glimpse.Core.Configuration Namespace


StatusCodeElement Class

StatusCodeElement Class Glimpse API Documentation
The Glimpse configuration node representing an Http status code.
Inheritance Hierarchy
Online System Object
Online System.Configuration ConfigurationElement
Glimpse.Core.Configuration StatusCodeElement

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class StatusCodeElement : ConfigurationElement
public class StatusCodeElement : ConfigurationElement
See Also
StatusCodeElement Members
Glimpse.Core.Configuration Namespace


StatusCodeElement Members

StatusCodeElement Members Glimpse API Documentation

The StatusCodeElement type exposes the following members.
Constructors
 | Name | Description
Public method | StatusCodeElement | Initializes a new instance of the StatusCodeElement class
Back to Top
Methods
 | Name | Description
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the current Online ConfigurationElement instance to the specified object. (Inherited from Online ConfigurationElement.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Gets a unique value representing the current Online ConfigurationElement instance. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElement object is read-only. (Inherited from Online ConfigurationElement.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the internal state of the Online ConfigurationElement object, including the locks and the properties collections. (Inherited from Online ConfigurationElement.)
Protected method | Online ResetModified | Resets the value of the Online IsModified method to false when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElement object and all subelements. (Inherited from Online ConfigurationElement.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Modifies the Online ConfigurationElement object to remove all values that should not be saved. (Inherited from Online ConfigurationElement.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Public property | StatusCode | Gets or sets the status code.
Back to Top
See Also
StatusCodeElement Class
Glimpse.Core.Configuration Namespace


StatusCodeElement Constructor

StatusCodeElement Constructor Glimpse API Documentation
Initializes a new instance of the StatusCodeElement class

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StatusCodeElement()
public StatusCodeElement()
See Also
StatusCodeElement Class
StatusCodeElement Members
Glimpse.Core.Configuration Namespace


StatusCodeElement Methods

StatusCodeElement Methods Glimpse API Documentation
The StatusCodeElement type exposes the following members.
Methods
 | Name | Description
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the current Online ConfigurationElement instance to the specified object. (Inherited from Online ConfigurationElement.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Gets a unique value representing the current Online ConfigurationElement instance. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElement object is read-only. (Inherited from Online ConfigurationElement.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the internal state of the Online ConfigurationElement object, including the locks and the properties collections. (Inherited from Online ConfigurationElement.)
Protected method | Online ResetModified | Resets the value of the Online IsModified method to false when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElement object and all subelements. (Inherited from Online ConfigurationElement.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Modifies the Online ConfigurationElement object to remove all values that should not be saved. (Inherited from Online ConfigurationElement.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
StatusCodeElement Class
Glimpse.Core.Configuration Namespace


StatusCodeElement Properties

StatusCodeElement Properties Glimpse API Documentation
The StatusCodeElement type exposes the following members.
Properties
 | Name | Description
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Public property | StatusCode | Gets or sets the status code.
Back to Top
See Also
StatusCodeElement Class
Glimpse.Core.Configuration Namespace


StatusCode Property

StatusCodeElement StatusCode Property Glimpse API Documentation
Gets or sets the status code.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int StatusCode { get; set; }
public int StatusCode { get; set; }
Field Value

            A list of ratified Http status codes in available in   Online Section 10 of RFC 2616, the Http version 1.1 specification.

See Also
StatusCodeElement Class
StatusCodeElement Members
Glimpse.Core.Configuration Namespace
  Online Http 1.1 Specification


StatusCodeElementCollection Class

StatusCodeElementCollection Class Glimpse API Documentation
The Glimpse configuration node for collecting a list of status codes.
Inheritance Hierarchy
Online System Object
Online System.Configuration ConfigurationElement
Online System.Configuration ConfigurationElementCollection
Glimpse.Core.Configuration StatusCodeElementCollection

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class StatusCodeElementCollection : ConfigurationElementCollection
public class StatusCodeElementCollection : ConfigurationElementCollection
Remarks

            By default, StatusCodeElementCollections contain three elements: 200, 301 and 302.

See Also
StatusCodeElementCollection Members
Glimpse.Core.Configuration Namespace


StatusCodeElementCollection Members

StatusCodeElementCollection Members Glimpse API Documentation

The StatusCodeElementCollection type exposes the following members.
Constructors
 | Name | Description
Public method | StatusCodeElementCollection | Initializes a new instance of the StatusCodeElementCollection class with 200, 301 and 302 added to the collection.
Back to Top
Methods
 | Name | Description
Protected method | Online BaseAdd(ConfigurationElement) | Adds a configuration element to the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseClear | Removes all configuration element objects from the collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGetKey | Gets the key for the Online ConfigurationElement at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseIndexOf | The index of the specified Online ConfigurationElement. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseIsRemoved | Gets a value indicating whether the Online ConfigurationElement with the specified key has been removed from the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseRemove | Removes a Online ConfigurationElement from the collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseRemoveAt | Removes the Online ConfigurationElement at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Public method | Online CopyTo | Copies the contents of the Online ConfigurationElementCollection to an array. (Inherited from Online ConfigurationElementCollection.)
Protected method | CreateNewElement | When overridden in a derived class, creates a new Online ConfigurationElement. (Overrides Online ConfigurationElementCollection CreateNewElement .)
Protected method | Online CreateNewElement(String) | Creates a new Online ConfigurationElement when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the Online ConfigurationElementCollection to the specified object. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetElementKey | Gets the element key for a specified configuration element when overridden in a derived class. (Overrides Online ConfigurationElementCollection GetElementKey(ConfigurationElement).)
Public method | Online GetEnumerator | Gets an Online IEnumerator which is used to iterate through the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Public method | Online GetHashCode | Gets a unique value representing the Online ConfigurationElementCollection instance. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsElementName | Indicates whether the specified Online ConfigurationElement exists in the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online IsElementRemovable | Gets a value indicating whether the specified Online ConfigurationElement can be removed from the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online IsModified | Indicates whether this Online ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElementCollection object is read only. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the Online ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online ResetModified | Resets the value of the Online IsModified property to false when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElementCollection object and for all sub-elements. (Inherited from Online ConfigurationElementCollection.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from Online ConfigurationElementCollection.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Protected property | Online AddElementName | Gets or sets the name of the Online ConfigurationElement to associate with the add operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ClearElementName | Gets or sets the name for the Online ConfigurationElement to associate with the clear operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public property | Online CollectionType | Gets the type of the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Public property | Online Count | Gets the number of elements in the collection. (Inherited from Online ConfigurationElementCollection.)
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Public property | Online EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Public property | Online IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from Online ConfigurationElementCollection.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Protected property | Online RemoveElementName | Gets or sets the name of the Online ConfigurationElement to associate with the remove operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public property | Online SyncRoot | Gets an object used to synchronize access to the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate Online ConfigurationElement to the Online ConfigurationElementCollection will cause an exception to be thrown. (Inherited from Online ConfigurationElementCollection.)
Back to Top
See Also
StatusCodeElementCollection Class
Glimpse.Core.Configuration Namespace


StatusCodeElementCollection Constructor

StatusCodeElementCollection Constructor Glimpse API Documentation
Initializes a new instance of the StatusCodeElementCollection class with 200, 301 and 302 added to the collection.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StatusCodeElementCollection()
public StatusCodeElementCollection()
See Also
StatusCodeElementCollection Class
StatusCodeElementCollection Members
Glimpse.Core.Configuration Namespace


StatusCodeElementCollection Methods

StatusCodeElementCollection Methods Glimpse API Documentation
The StatusCodeElementCollection type exposes the following members.
Methods
 | Name | Description
Protected method | Online BaseAdd(ConfigurationElement) | Adds a configuration element to the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseClear | Removes all configuration element objects from the collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGetKey | Gets the key for the Online ConfigurationElement at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseIndexOf | The index of the specified Online ConfigurationElement. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseIsRemoved | Gets a value indicating whether the Online ConfigurationElement with the specified key has been removed from the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseRemove | Removes a Online ConfigurationElement from the collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseRemoveAt | Removes the Online ConfigurationElement at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Public method | Online CopyTo | Copies the contents of the Online ConfigurationElementCollection to an array. (Inherited from Online ConfigurationElementCollection.)
Protected method | CreateNewElement | When overridden in a derived class, creates a new Online ConfigurationElement. (Overrides Online ConfigurationElementCollection CreateNewElement .)
Protected method | Online CreateNewElement(String) | Creates a new Online ConfigurationElement when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the Online ConfigurationElementCollection to the specified object. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetElementKey | Gets the element key for a specified configuration element when overridden in a derived class. (Overrides Online ConfigurationElementCollection GetElementKey(ConfigurationElement).)
Public method | Online GetEnumerator | Gets an Online IEnumerator which is used to iterate through the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Public method | Online GetHashCode | Gets a unique value representing the Online ConfigurationElementCollection instance. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsElementName | Indicates whether the specified Online ConfigurationElement exists in the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online IsElementRemovable | Gets a value indicating whether the specified Online ConfigurationElement can be removed from the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online IsModified | Indicates whether this Online ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElementCollection object is read only. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the Online ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online ResetModified | Resets the value of the Online IsModified property to false when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElementCollection object and for all sub-elements. (Inherited from Online ConfigurationElementCollection.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from Online ConfigurationElementCollection.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
StatusCodeElementCollection Class
Glimpse.Core.Configuration Namespace


CreateNewElement Method

StatusCodeElementCollection CreateNewElement Method Glimpse API Documentation
Overload List
 | Name | Description
Protected method | CreateNewElement | When overridden in a derived class, creates a new Online ConfigurationElement. (Overrides Online ConfigurationElementCollection CreateNewElement .)
Protected method | Online CreateNewElement(String) | Creates a new Online ConfigurationElement when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Back to Top
See Also
StatusCodeElementCollection Class
StatusCodeElementCollection Members
Glimpse.Core.Configuration Namespace


CreateNewElement Method

StatusCodeElementCollection CreateNewElement Method Glimpse API Documentation
When overridden in a derived class, creates a new Online ConfigurationElement.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override ConfigurationElement CreateNewElement()
protected override ConfigurationElement CreateNewElement()
Return Value

            A new   Online ConfigurationElement.

See Also
StatusCodeElementCollection Class
StatusCodeElementCollection Members
CreateNewElement Overload
Glimpse.Core.Configuration Namespace


GetElementKey Method

StatusCodeElementCollection GetElementKey Method Glimpse API Documentation
Gets the element key for a specified configuration element when overridden in a derived class.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Object GetElementKey(
    ConfigurationElement element
)
protected override Object GetElementKey(
    ConfigurationElement element
)
Parameters
element
Type:   Online System.Configuration ConfigurationElement
The   Online ConfigurationElement to return the key for.
Return Value

            An   Online Object that acts as the key for the specified   Online ConfigurationElement.

See Also
StatusCodeElementCollection Class
StatusCodeElementCollection Members
Glimpse.Core.Configuration Namespace


StatusCodeElementCollection Properties

StatusCodeElementCollection Properties Glimpse API Documentation
The StatusCodeElementCollection type exposes the following members.
Properties
 | Name | Description
Protected property | Online AddElementName | Gets or sets the name of the Online ConfigurationElement to associate with the add operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ClearElementName | Gets or sets the name for the Online ConfigurationElement to associate with the clear operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public property | Online CollectionType | Gets the type of the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Public property | Online Count | Gets the number of elements in the collection. (Inherited from Online ConfigurationElementCollection.)
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Public property | Online EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Public property | Online IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from Online ConfigurationElementCollection.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Protected property | Online RemoveElementName | Gets or sets the name of the Online ConfigurationElement to associate with the remove operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public property | Online SyncRoot | Gets an object used to synchronize access to the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate Online ConfigurationElement to the Online ConfigurationElementCollection will cause an exception to be thrown. (Inherited from Online ConfigurationElementCollection.)
Back to Top
See Also
StatusCodeElementCollection Class
Glimpse.Core.Configuration Namespace


TypeElement Class

TypeElement Class Glimpse API Documentation
The Glimpse configuration node representing a .NET Framework type.
Inheritance Hierarchy
Online System Object
Online System.Configuration ConfigurationElement
Glimpse.Core.Configuration TypeElement

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TypeElement : ConfigurationElement
public class TypeElement : ConfigurationElement
See Also
TypeElement Members
Glimpse.Core.Configuration Namespace


TypeElement Members

TypeElement Members Glimpse API Documentation

The TypeElement type exposes the following members.
Constructors
 | Name | Description
Public method | TypeElement | Initializes a new instance of the TypeElement class
Back to Top
Methods
 | Name | Description
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the current Online ConfigurationElement instance to the specified object. (Inherited from Online ConfigurationElement.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Gets a unique value representing the current Online ConfigurationElement instance. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElement object is read-only. (Inherited from Online ConfigurationElement.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the internal state of the Online ConfigurationElement object, including the locks and the properties collections. (Inherited from Online ConfigurationElement.)
Protected method | Online ResetModified | Resets the value of the Online IsModified method to false when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElement object and all subelements. (Inherited from Online ConfigurationElement.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Modifies the Online ConfigurationElement object to remove all values that should not be saved. (Inherited from Online ConfigurationElement.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Public property | Type | Gets or sets the type based on an assembly qualified name string.
Back to Top
See Also
TypeElement Class
Glimpse.Core.Configuration Namespace


TypeElement Constructor

TypeElement Constructor Glimpse API Documentation
Initializes a new instance of the TypeElement class

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeElement()
public TypeElement()
See Also
TypeElement Class
TypeElement Members
Glimpse.Core.Configuration Namespace


TypeElement Methods

TypeElement Methods Glimpse API Documentation
The TypeElement type exposes the following members.
Methods
 | Name | Description
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the current Online ConfigurationElement instance to the specified object. (Inherited from Online ConfigurationElement.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Gets a unique value representing the current Online ConfigurationElement instance. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElement object is read-only. (Inherited from Online ConfigurationElement.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the internal state of the Online ConfigurationElement object, including the locks and the properties collections. (Inherited from Online ConfigurationElement.)
Protected method | Online ResetModified | Resets the value of the Online IsModified method to false when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElement object and all subelements. (Inherited from Online ConfigurationElement.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Modifies the Online ConfigurationElement object to remove all values that should not be saved. (Inherited from Online ConfigurationElement.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TypeElement Class
Glimpse.Core.Configuration Namespace


TypeElement Properties

TypeElement Properties Glimpse API Documentation
The TypeElement type exposes the following members.
Properties
 | Name | Description
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Public property | Type | Gets or sets the type based on an assembly qualified name string.
Back to Top
See Also
TypeElement Class
Glimpse.Core.Configuration Namespace


Type Property

TypeElement Type Property Glimpse API Documentation
Gets or sets the type based on an assembly qualified name string.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type Type { get; set; }
public Type Type { get; set; }
See Also
TypeElement Class
TypeElement Members
Glimpse.Core.Configuration Namespace


TypeElementCollection Class

TypeElementCollection Class Glimpse API Documentation
The Glimpse configuration node for creating a collection of types.
Inheritance Hierarchy
Online System Object
Online System.Configuration ConfigurationElement
Online System.Configuration ConfigurationElementCollection
Glimpse.Core.Configuration TypeElementCollection

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TypeElementCollection : ConfigurationElementCollection
public class TypeElementCollection : ConfigurationElementCollection
See Also
TypeElementCollection Members
Glimpse.Core.Configuration Namespace


TypeElementCollection Members

TypeElementCollection Members Glimpse API Documentation

The TypeElementCollection type exposes the following members.
Constructors
 | Name | Description
Public method | TypeElementCollection | Initializes a new instance of the TypeElementCollection class
Back to Top
Methods
 | Name | Description
Protected method | Online BaseAdd(ConfigurationElement) | Adds a configuration element to the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseClear | Removes all configuration element objects from the collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGetKey | Gets the key for the Online ConfigurationElement at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseIndexOf | The index of the specified Online ConfigurationElement. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseIsRemoved | Gets a value indicating whether the Online ConfigurationElement with the specified key has been removed from the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseRemove | Removes a Online ConfigurationElement from the collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseRemoveAt | Removes the Online ConfigurationElement at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Public method | Online CopyTo | Copies the contents of the Online ConfigurationElementCollection to an array. (Inherited from Online ConfigurationElementCollection.)
Protected method | CreateNewElement | When overridden in a derived class, creates a new Online ConfigurationElement. (Overrides Online ConfigurationElementCollection CreateNewElement .)
Protected method | Online CreateNewElement(String) | Creates a new Online ConfigurationElement when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the Online ConfigurationElementCollection to the specified object. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetElementKey | Gets the element key for a specified configuration element when overridden in a derived class. (Overrides Online ConfigurationElementCollection GetElementKey(ConfigurationElement).)
Public method | Online GetEnumerator | Gets an Online IEnumerator which is used to iterate through the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Public method | Online GetHashCode | Gets a unique value representing the Online ConfigurationElementCollection instance. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsElementName | Indicates whether the specified Online ConfigurationElement exists in the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online IsElementRemovable | Gets a value indicating whether the specified Online ConfigurationElement can be removed from the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online IsModified | Indicates whether this Online ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElementCollection object is read only. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the Online ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online ResetModified | Resets the value of the Online IsModified property to false when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElementCollection object and for all sub-elements. (Inherited from Online ConfigurationElementCollection.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from Online ConfigurationElementCollection.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Protected property | Online AddElementName | Gets or sets the name of the Online ConfigurationElement to associate with the add operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ClearElementName | Gets or sets the name for the Online ConfigurationElement to associate with the clear operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public property | Online CollectionType | Gets the type of the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Public property | Online Count | Gets the number of elements in the collection. (Inherited from Online ConfigurationElementCollection.)
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Public property | Online EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Public property | Online IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from Online ConfigurationElementCollection.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Protected property | Online RemoveElementName | Gets or sets the name of the Online ConfigurationElement to associate with the remove operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public property | Online SyncRoot | Gets an object used to synchronize access to the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate Online ConfigurationElement to the Online ConfigurationElementCollection will cause an exception to be thrown. (Inherited from Online ConfigurationElementCollection.)
Back to Top
See Also
TypeElementCollection Class
Glimpse.Core.Configuration Namespace


TypeElementCollection Constructor

TypeElementCollection Constructor Glimpse API Documentation
Initializes a new instance of the TypeElementCollection class

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeElementCollection()
public TypeElementCollection()
See Also
TypeElementCollection Class
TypeElementCollection Members
Glimpse.Core.Configuration Namespace


TypeElementCollection Methods

TypeElementCollection Methods Glimpse API Documentation
The TypeElementCollection type exposes the following members.
Methods
 | Name | Description
Protected method | Online BaseAdd(ConfigurationElement) | Adds a configuration element to the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseClear | Removes all configuration element objects from the collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseGetKey | Gets the key for the Online ConfigurationElement at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseIndexOf | The index of the specified Online ConfigurationElement. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseIsRemoved | Gets a value indicating whether the Online ConfigurationElement with the specified key has been removed from the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseRemove | Removes a Online ConfigurationElement from the collection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online BaseRemoveAt | Removes the Online ConfigurationElement at the specified index location. (Inherited from Online ConfigurationElementCollection.)
Public method | Online CopyTo | Copies the contents of the Online ConfigurationElementCollection to an array. (Inherited from Online ConfigurationElementCollection.)
Protected method | CreateNewElement | When overridden in a derived class, creates a new Online ConfigurationElement. (Overrides Online ConfigurationElementCollection CreateNewElement .)
Protected method | Online CreateNewElement(String) | Creates a new Online ConfigurationElement when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online DeserializeElement | Reads XML from the configuration file. (Inherited from Online ConfigurationElement.)
Public method | Online Equals | Compares the Online ConfigurationElementCollection to the specified object. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetElementKey | Gets the element key for a specified configuration element when overridden in a derived class. (Overrides Online ConfigurationElementCollection GetElementKey(ConfigurationElement).)
Public method | Online GetEnumerator | Gets an Online IEnumerator which is used to iterate through the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Public method | Online GetHashCode | Gets a unique value representing the Online ConfigurationElementCollection instance. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from Online ConfigurationElement.)
Protected method | Online GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from Online ConfigurationElement.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online Init | Sets the Online ConfigurationElement object to its initial state. (Inherited from Online ConfigurationElement.)
Protected method | Online InitializeDefault | Used to initialize a default set of values for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected method | Online IsElementName | Indicates whether the specified Online ConfigurationElement exists in the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online IsElementRemovable | Gets a value indicating whether the specified Online ConfigurationElement can be removed from the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online IsModified | Indicates whether this Online ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public method | Online IsReadOnly | Gets a value indicating whether the Online ConfigurationElementCollection object is read only. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online ListErrors | Adds the invalid-property errors in this Online ConfigurationElement object, and in all subelements, to the passed list. (Inherited from Online ConfigurationElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from Online ConfigurationElement.)
Protected method | Online PostDeserialize | Called after deserialization. (Inherited from Online ConfigurationElement.)
Protected method | Online PreSerialize | Called before serialization. (Inherited from Online ConfigurationElement.)
Protected method | Online Reset | Resets the Online ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online ResetModified | Resets the value of the Online IsModified property to false when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected method | Online SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from Online ConfigurationElement.)
Protected method | Online SetPropertyValue | Sets a property to the specified value. (Inherited from Online ConfigurationElement.)
Protected method | Online SetReadOnly | Sets the Online IsReadOnly property for the Online ConfigurationElementCollection object and for all sub-elements. (Inherited from Online ConfigurationElementCollection.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Online Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from Online ConfigurationElementCollection.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TypeElementCollection Class
Glimpse.Core.Configuration Namespace


CreateNewElement Method

TypeElementCollection CreateNewElement Method Glimpse API Documentation
Overload List
 | Name | Description
Protected method | CreateNewElement | When overridden in a derived class, creates a new Online ConfigurationElement. (Overrides Online ConfigurationElementCollection CreateNewElement .)
Protected method | Online CreateNewElement(String) | Creates a new Online ConfigurationElement when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Back to Top
See Also
TypeElementCollection Class
TypeElementCollection Members
Glimpse.Core.Configuration Namespace


CreateNewElement Method

TypeElementCollection CreateNewElement Method Glimpse API Documentation
When overridden in a derived class, creates a new Online ConfigurationElement.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override ConfigurationElement CreateNewElement()
protected override ConfigurationElement CreateNewElement()
Return Value

            A new   Online ConfigurationElement.

See Also
TypeElementCollection Class
TypeElementCollection Members
CreateNewElement Overload
Glimpse.Core.Configuration Namespace


GetElementKey Method

TypeElementCollection GetElementKey Method Glimpse API Documentation
Gets the element key for a specified configuration element when overridden in a derived class.

Namespace: Glimpse.Core.Configuration
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Object GetElementKey(
    ConfigurationElement element
)
protected override Object GetElementKey(
    ConfigurationElement element
)
Parameters
element
Type:   Online System.Configuration ConfigurationElement
The   Online ConfigurationElement to return the key for.
Return Value

            An   Online Object that acts as the key for the specified   Online ConfigurationElement.

See Also
TypeElementCollection Class
TypeElementCollection Members
Glimpse.Core.Configuration Namespace


TypeElementCollection Properties

TypeElementCollection Properties Glimpse API Documentation
The TypeElementCollection type exposes the following members.
Properties
 | Name | Description
Protected property | Online AddElementName | Gets or sets the name of the Online ConfigurationElement to associate with the add operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ClearElementName | Gets or sets the name for the Online ConfigurationElement to associate with the clear operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public property | Online CollectionType | Gets the type of the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Public property | Online Count | Gets the number of elements in the collection. (Inherited from Online ConfigurationElementCollection.)
Public property | Online CurrentConfiguration | Gets a reference to the top-level Online Configuration instance that represents the configuration hierarchy that the current Online ConfigurationElement instance belongs to. (Inherited from Online ConfigurationElement.)
Public property | Online ElementInformation | Gets an Online ElementInformation object that contains the non-customizable information and functionality of the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Protected property | Online ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ElementProperty | Gets the Online ConfigurationElementProperty object that represents the Online ConfigurationElement object itself. (Inherited from Online ConfigurationElement.)
Public property | Online EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online EvaluationContext | Gets the Online ContextInformation object for the Online ConfigurationElement object. (Inherited from Online ConfigurationElement.)
Public property | Online IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from Online ConfigurationElementCollection.)
Protected property | Online Item ConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from Online ConfigurationElement.)
Protected property | Online Item String | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from Online ConfigurationElement.)
Public property | Online LockAllElementsExcept | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockAttributes | Gets the collection of locked attributes (Inherited from Online ConfigurationElement.)
Public property | Online LockElements | Gets the collection of locked elements. (Inherited from Online ConfigurationElement.)
Public property | Online LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from Online ConfigurationElement.)
Protected property | Online Properties | Gets the collection of properties. (Inherited from Online ConfigurationElement.)
Protected property | Online RemoveElementName | Gets or sets the name of the Online ConfigurationElement to associate with the remove operation in the Online ConfigurationElementCollection when overridden in a derived class. (Inherited from Online ConfigurationElementCollection.)
Public property | Online SyncRoot | Gets an object used to synchronize access to the Online ConfigurationElementCollection. (Inherited from Online ConfigurationElementCollection.)
Protected property | Online ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate Online ConfigurationElement to the Online ConfigurationElementCollection will cause an exception to be thrown. (Inherited from Online ConfigurationElementCollection.)
Back to Top
See Also
TypeElementCollection Class
Glimpse.Core.Configuration Namespace


Glimpse.Core.Extensibility Namespace

Glimpse.Core.Extensibility Namespace Glimpse API Documentation
Most interfaces and abstract types for extending Glimpse are defined within this namespace.
Classes
 | Class | Description
Public class | AlternateMethod | An abstract IAlternateMethod implementation which handles checking Glimpse policies and timing original implementations.
Public class | AlternateType T | An abstract IAlternateType T implementation that handles the most common TryCreate scenarios.
Public class | AlternateTypeGenerationHook T | An implementation of Castle DynamicProxy's IProxyGenerationHook for Glimpse.
Public class | AlternateTypeSelector | An implementation of Castle DynamicProxy's IInterceptorSelector for Glimpse.
Public class | AlternateTypeToCastleInterceptorAdapter | An adapter between Glimpse's IAlternateType T and Castle DynamicProxy's IInterceptor.
Public class | AntiXssEncoder | The default IHtmlEncoder implementation of Glimpse, which leverages Microsoft's Web Protection Library.
Public class | CastleInvocationToAlternateMethodContextAdapter | An adapter between Castle DynamicProxy's IInvocation and Glimpse's IAlternateMethodContext.
Public class | DictionaryDataStoreAdapter | An adapter between an Online IDictionary and IDataStore.
Public class | ExecutionTimer | An implementation of IExecutionTimer.
Public class | InspectorContext | The context passed into the Setup method of IInspector.
Public class | JsonNetConverterDictionaryKeysAreNotPropertyNames | A JsonConverter that overrides the way Json.Net handles dictionaries.
Public class | JsonNetSerializationConverterAdapter | An adapter which converts Glimpse's ISerializationConverter to Json.Net JsonConverter.
Public class | JsonNetSerializer | An implementation of ISerializer which leverages Json.Net.
Public class | LoggerBase | An abstract base class which provides ILogger implementations with message formatting abilities.
Public class | MessageBroker | The default implementation of IMessageBroker which supports subscribing to messages based on types, base types and interfaces.
Public class | NLogLogger | An implementation of ILogger based on NLog.
Public class | NuGetPackageAttribute | An attribute used to identify the corresponding NuGet package and Id for an assembly.
Public class | NullLogger | An ILogger implementation of the Null Object pattern for use when Glimpse if configured to not use logging.
Public class | ResourceContext | The implementation of IResourceContext, used in the Execute method of IResource.
Public class | ResourceParameter | A collection of commonly used ResourceParameterMetadata objects.
Public class | ResourceParameterMetadata | ResourceParameterMetadata describes the parameters for an IResource.
Public class | ResourceResultContext | The implementation of IResourceResultContext used in the Execute method of IResourceResult.
Public class | ResourceResultDecorator | An IResourceResult abstraction for adding additional functionality to IResourceResult via the common Online decorator pattern.
Public class | RuntimePolicyContext | The implementation of IRuntimePolicyContext used in the Execute method of IRuntimePolicy.
Public class | SerializationConverter T | The ISerializationConverter abstraction which makes creating converters that deal with one type easier.
Public class | TabBase | Base implementation that allows simplified the implementation of a tab. NOTE, this implementation is intended for by tabs that can execute on any provider (i.e. aren't bound to HttpContextBase in the case of the ASP.NET provider). Most tabs wont be tied to a specific provider.
Public class | TabBase T | Base implementation that allows simplified the implementation of a tab. NOTE, this implementation is intended for by tabs that can only be executed by a specific provider (i.e. ones bound to HttpContextBase in the case of the ASP.NET provider).
Public class | TabContext | The ITabContext implementation used by the GetData method of ITab.
Public class | TabSetupContext | The implementation of ITabSetupContext used by the Setup method of ITabSetup.
Public class | TimerResult | The result of a Time method call on a IExecutionTimer.
Public class | TimerResult T | A subtype of TimerResult which includes the result of non-void method calls.
Interfaces
Interface Description
Public interface IAlternateMethod
Definition for an alternate method which allows classes to be proxied.
Public interface IAlternateMethodContext
Definition for the context used by IAlternateMethod
Public interface IAlternateType T
Definition for an alternate that should replace a given Type
Public interface IClientScript
IClientScript injects <script> tags into page responses.
Public interface IConfigurable
IConfigurable allows types to participate in their own configuration.
Public interface IContext
Definition for the base context that is used by various concepts in the system. Typically uses in place of passing multiple arguments to a method.
Public interface IDataStore
Definition for a data store that can be implemented as a storage strategy. This could be used to store request data in memory, to disk or any other source.
Public interface IDocumentation
Allows a ITab to define what URI it should use if the Tab has supporting documentation.
Public interface IDynamicClientScript
IDynamicClientScript's are a special type of IClientScript that sets the <script> tag's src attribute to the dynamically generated Uri for the IResource of a given name.
Public interface IExecutionTimer
Definition for an execution timer which will track how long given executions take.
Public interface IHtmlEncoder
Definition for a html encoder.
Public interface IInspector
Definition of an inspector that runs during startup. This provides the means by which a Tab can setup any listeners, proxies, etc that are needed to gather the data needed the corresponding ITab.
Public interface IInspectorContext
Definition of a context that is used by the IInspector.
Public interface IKey
IKey provides implementers a means to override the automatically generated key for an object.
Public interface ILogger
Definition of the internal logger that will used by the system.
Public interface IMessageBroker
Definition of the Message Broker that will used by the system.
Public interface IParameterValueProvider
IParameterValueProvider provides a mechanism to override or append Uri template parameter values when generating an IDynamicClientScript's corresponding IResource Uri.
Public interface IProxyFactory

Definition of a factory that can create proxies of given objects/types. Factory supports wrapping a interfaces, wrapping a class or extending a class.

Wrapping takes a target instance, generates a new type that extends the input types and injects the target object within the new instance. Extends takes a type and generates a new type that extends it.

Public interface IResource

IResource provides Glimpse clients with data and assets for rendering to the end user.

When implemented, a resource will be discovered and added to the collection of resources.

Public interface IResourceContext
IResourceContext provides implementations of IResource access to their parameters and the IReadOnlyPersistenceStore.
Public interface IResourceResult
IResourceResult provides Glimpse a Online command object for returning the results of an IResource.
Public interface IResourceResultContext
IResourceResultContext provides implementations of IResourceResult access to the IFrameworkProvider, ISerializer and IHtmlEncoder.
Public interface IRuntimePolicy

IRuntimePolicy controls the operations Glimpse is allowed to do an Http request.

When implemented, a policy will be discovered and added to the collection of policies. Together, all policies determine what Glimpse is allowed to do during an Http request.

Public interface IRuntimePolicyContext
Definition for the context that is used when a runtime policy is being executed.
Public interface ISerializationConverter

Definition for a converter that will provide a custom object representation to serialize for the supported types.

When implemented, a serialization converter will be discovered and added to the collection of serialization converters.

Public interface ISerializer
Definition for a provider that can serialize complex objects to JSON.
Public interface IStaticClientScript
IStaticClientScript's are a special type of IClientScript that sets the <script> tag's src attribute to a given uri.
Public interface ITab

Definition for an object which will be represented in the UI as a Tab. To operate you simply need to implement this interface and return an object graph that you would like to view.

When returning data, you can either return the object which represents the Glimpse protocol or return a typed view model. It is recommended that you use typed view models, as it is this object that will be stored in by the Data Store. If this is done, it means that these typed objects can be queried at a latter stage. That said, if you are after simplicity, you can return objects in the shape the Glimpse Protocol requires.

If you do decide to work with a typed view model you can convert this into an objects in the shape the Glimpse Protocol by implementing ISerializationConverter targeting the type of the view model.

Alternatively, if you after simplicity and return an object which represents the Glimpse protocol, you can use TabObject and TabSection as helpers.

Additional functionality can be injected into via additionally implementing the following interfaces: - : Key that will be used to identify the tab within the client. - : URI that will describe where the documentation for the tab can be found. - : Control how the layout of the content should look. - : Allows tab to inject any hooks it needs within the system. - : Allow complex objects to be converted into the Glimpse protocol.

Public interface ITabContext
Definition for the context which tabs use when generating the content will be returned.
Public interface ITabLayout
Definition for how the layout of a given object can be controlled. When implementing a layout, TabLayout can be used to make creating the required objects easier.
Public interface ITabSetup
Definition which allows a tab to inject any hooks it needs within the system.
Public interface ITabSetupContext
Definition for the context which is used during tab setup.
Public interface IWrapper T
IWrapper<T> provides a common way to leverage the Online decorator pattern.
Enumerations
 | Enumeration | Description
Public enumeration | RuntimeEvent | Used to describe when a given IRuntimePolicy should be executed.
Public enumeration | RuntimePolicy | Used to describe what operations Glimpse is allowed to perform during a Http request/response.
Public enumeration | ScriptOrder | The ScriptOrder enumeration specifies the sorting order placement of <script> tags generated by IClientScript's within a page response.


AlternateMethod Class

AlternateMethod Class Glimpse API Documentation
An abstract IAlternateMethod implementation which handles checking Glimpse policies and timing original implementations.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility AlternateMethod

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class AlternateMethod : IAlternateMethod
public abstract class AlternateMethod : IAlternateMethod
See Also
AlternateMethod Members
Glimpse.Core.Extensibility Namespace


AlternateMethod Members

AlternateMethod Members Glimpse API Documentation

The AlternateMethod type exposes the following members.
Constructors
 | Name | Description
Protected method | AlternateMethod(MethodInfo) | Initializes a new instance of the AlternateMethod class.
Protected method | AlternateMethod(Type, String) | Initializes a new instance of the AlternateMethod class.
Protected method | AlternateMethod(Type, String, BindingFlags) | Initializes a new instance of the AlternateMethod class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NewImplementation | New implementation that is called in-place of the the original method.
Public method | PostImplementation | Additional code to be executed after the original implementation has been run.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | MethodToImplement | Gets the method to implement.
Back to Top
See Also
AlternateMethod Class
Glimpse.Core.Extensibility Namespace


AlternateMethod Constructor

AlternateMethod Constructor Glimpse API Documentation
Overload List
 | Name | Description
Protected method | AlternateMethod(MethodInfo) | Initializes a new instance of the AlternateMethod class.
Protected method | AlternateMethod(Type, String) | Initializes a new instance of the AlternateMethod class.
Protected method | AlternateMethod(Type, String, BindingFlags) | Initializes a new instance of the AlternateMethod class.
Back to Top
See Also
AlternateMethod Class
AlternateMethod Members
Glimpse.Core.Extensibility Namespace


AlternateMethod Constructor (MethodInfo)

AlternateMethod Constructor (MethodInfo) Glimpse API Documentation
Initializes a new instance of the AlternateMethod class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected AlternateMethod(
    MethodInfo methodToImplement
)
protected AlternateMethod(
    MethodInfo methodToImplement
)
Parameters
methodToImplement
Type:   Online System.Reflection MethodInfo
The method to implement.
Exceptions
Exception | Condition
Online System ArgumentNullException | Throws an exception if methodToImplement is null.
See Also
AlternateMethod Class
AlternateMethod Members
AlternateMethod Overload
Glimpse.Core.Extensibility Namespace


AlternateMethod Constructor (Type, String)

AlternateMethod Constructor (Type, String) Glimpse API Documentation
Initializes a new instance of the AlternateMethod class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected AlternateMethod(
    Type type,
    string methodName
)
protected AlternateMethod(
    Type type,
    string methodName
)
Parameters
type
Type:   Online System Type
The type.
methodName
Type:   Online System String
Name of the method.
See Also
AlternateMethod Class
AlternateMethod Members
AlternateMethod Overload
Glimpse.Core.Extensibility Namespace


AlternateMethod Constructor (Type, String, BindingFlags)

AlternateMethod Constructor (Type, String, BindingFlags) Glimpse API Documentation
Initializes a new instance of the AlternateMethod class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected AlternateMethod(
    Type type,
    string methodName,
    BindingFlags bindingFlags
)
protected AlternateMethod(
    Type type,
    string methodName,
    BindingFlags bindingFlags
)
Parameters
type
Type:   Online System Type
The type.
methodName
Type:   Online System String
Name of the method.
bindingFlags
Type:   Online System.Reflection BindingFlags
The binding flags.
See Also
AlternateMethod Class
AlternateMethod Members
AlternateMethod Overload
Glimpse.Core.Extensibility Namespace


AlternateMethod Methods

AlternateMethod Methods Glimpse API Documentation
The AlternateMethod type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NewImplementation | New implementation that is called in-place of the the original method.
Public method | PostImplementation | Additional code to be executed after the original implementation has been run.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
AlternateMethod Class
Glimpse.Core.Extensibility Namespace


NewImplementation Method

AlternateMethod NewImplementation Method Glimpse API Documentation
New implementation that is called in-place of the the original method.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void NewImplementation(
    IAlternateMethodContext context
)
public void NewImplementation(
    IAlternateMethodContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IAlternateMethodContext
The context.
Implements
IAlternateMethod NewImplementation(IAlternateMethodContext)
Remarks

            It is up to this method to call the underlying target method.

See Also
AlternateMethod Class
AlternateMethod Members
Glimpse.Core.Extensibility Namespace


PostImplementation Method

AlternateMethod PostImplementation Method Glimpse API Documentation
Additional code to be executed after the original implementation has been run.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void PostImplementation(
    IAlternateMethodContext context,
    TimerResult timerResult
)
public abstract void PostImplementation(
    IAlternateMethodContext context,
    TimerResult timerResult
)
Parameters
context
Type: Glimpse.Core.Extensibility IAlternateMethodContext
The context.
timerResult
Type: Glimpse.Core.Extensibility TimerResult
The timer result.
See Also
AlternateMethod Class
AlternateMethod Members
Glimpse.Core.Extensibility Namespace


AlternateMethod Properties

AlternateMethod Properties Glimpse API Documentation
The AlternateMethod type exposes the following members.
Properties
 | Name | Description
Public property | MethodToImplement | Gets the method to implement.
Back to Top
See Also
AlternateMethod Class
Glimpse.Core.Extensibility Namespace


MethodToImplement Property

AlternateMethod MethodToImplement Property Glimpse API Documentation
Gets the method to implement.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MethodInfo MethodToImplement { get; private set; }
public MethodInfo MethodToImplement { get; private set; }
Field Value

            The method to implement.

Implements
IAlternateMethod MethodToImplement
Remarks

            The info of the method that this alternate is for.

See Also
AlternateMethod Class
AlternateMethod Members
Glimpse.Core.Extensibility Namespace


AlternateType(T) Class

AlternateType T Class Glimpse API Documentation
An abstract IAlternateType T implementation that handles the most common TryCreate scenarios.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility AlternateType T

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class AlternateType<T> : IAlternateType<T>
where T : class
public abstract class AlternateType<T> : IAlternateType<T>
where T : class
Type Parameters
T
The type to retrieve and alternate for.
See Also
AlternateType T  Members
Glimpse.Core.Extensibility Namespace


AlternateType(T) Members

AlternateType T Members Glimpse API Documentation

The AlternateType T type exposes the following members.
Constructors
 | Name | Description
Protected method | AlternateType T | Initializes a new instance of the AlternateType T class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryCreate(T, T ) | Tries to create an alternate type.
Public method | TryCreate(T, T , IEnumerable Object ) | Tries to create an alternate type with mixins.
Public method | TryCreate(T, T , IEnumerable Object , Object ) | Tries to create an alternate type with mixins and constructor arguments.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AllMethods | Gets all methods for the proxy to override.
Public property | ProxyFactory | Gets or sets the proxy factory.
Back to Top
See Also
AlternateType T Class
Glimpse.Core.Extensibility Namespace


AlternateType(T) Constructor

AlternateType T Constructor Glimpse API Documentation
Initializes a new instance of the AlternateType T class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected AlternateType(
    IProxyFactory proxyFactory
)
protected AlternateType(
    IProxyFactory proxyFactory
)
Parameters
proxyFactory
Type: Glimpse.Core.Extensibility IProxyFactory
The proxy factory.
Exceptions
Exception | Condition
Online System ArgumentNullException | Throws and exception if proxyFactory is null.
See Also
AlternateType T  Class
AlternateType T  Members
Glimpse.Core.Extensibility Namespace


AlternateType(T) Methods

AlternateType T Methods Glimpse API Documentation
The AlternateType T type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryCreate(T, T ) | Tries to create an alternate type.
Public method | TryCreate(T, T , IEnumerable Object ) | Tries to create an alternate type with mixins.
Public method | TryCreate(T, T , IEnumerable Object , Object ) | Tries to create an alternate type with mixins and constructor arguments.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
AlternateType T Class
Glimpse.Core.Extensibility Namespace


TryCreate Method

AlternateType T TryCreate Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | TryCreate(T, T ) | Tries to create an alternate type.
Public method | TryCreate(T, T , IEnumerable Object ) | Tries to create an alternate type with mixins.
Public method | TryCreate(T, T , IEnumerable Object , Object ) | Tries to create an alternate type with mixins and constructor arguments.
Back to Top
See Also
AlternateType T Class
AlternateType T Members
Glimpse.Core.Extensibility Namespace


TryCreate Method (T, T)

AlternateType T TryCreate Method (T, T ) Glimpse API Documentation
Tries to create an alternate type.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryCreate(
    T originalObj,
    out T newObj
)
public bool TryCreate(
    T originalObj,
    out T newObj
)
Parameters
originalObj
Type: T
The original object.
newObj
Type: T
The new object.
Return Value
A proxied implementation of the originalObj.
Implements
IAlternateType T  TryCreate(T, T )
See Also
AlternateType T  Class
AlternateType T  Members
TryCreate Overload
Glimpse.Core.Extensibility Namespace


TryCreate Method (T, T, IEnumerable(Object))

AlternateType T TryCreate Method (T, T , IEnumerable Object ) Glimpse API Documentation
Tries to create an alternate type with mixins.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryCreate(
    T originalObj,
    out T newObj,
    IEnumerable<Object> mixins
)
public bool TryCreate(
    T originalObj,
    out T newObj,
    IEnumerable<Object> mixins
)
Parameters
originalObj
Type: T
The original object.
newObj
Type: T
The new object.
mixins
Type:   Online System.Collections.Generic IEnumerable    Online Object
The mixins.
Return Value

            A proxied implementation of the originalObj.

See Also
AlternateType T  Class
AlternateType T  Members
TryCreate Overload
Glimpse.Core.Extensibility Namespace


TryCreate Method (T, T, IEnumerable(Object), Object[])

AlternateType T TryCreate Method (T, T , IEnumerable Object , Object ) Glimpse API Documentation
Tries to create an alternate type with mixins and constructor arguments.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool TryCreate(
    T originalObj,
    out T newObj,
    IEnumerable<Object> mixins,
    Object[] constructorArguments
)
public virtual bool TryCreate(
    T originalObj,
    out T newObj,
    IEnumerable<Object> mixins,
    Object[] constructorArguments
)
Parameters
originalObj
Type: T
The original object.
newObj
Type: T
The new object.
mixins
Type:   Online System.Collections.Generic IEnumerable    Online Object
The mixins.
constructorArguments
Type:    Online System Object
The constructor arguments.
Return Value

            A proxied implementation of the originalObj.

See Also
AlternateType T  Class
AlternateType T  Members
TryCreate Overload
Glimpse.Core.Extensibility Namespace


AlternateType(T) Properties

AlternateType T Properties Glimpse API Documentation
The AlternateType T type exposes the following members.
Properties
 | Name | Description
Public property | AllMethods | Gets all methods for the proxy to override.
Public property | ProxyFactory | Gets or sets the proxy factory.
Back to Top
See Also
AlternateType T Class
Glimpse.Core.Extensibility Namespace


AllMethods Property

AlternateType T AllMethods Property Glimpse API Documentation
Gets all methods for the proxy to override.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract IEnumerable<IAlternateMethod> AllMethods { get; }
public abstract IEnumerable<IAlternateMethod> AllMethods { get; }
Field Value

            All methods.

See Also
AlternateType T  Class
AlternateType T  Members
Glimpse.Core.Extensibility Namespace


ProxyFactory Property

AlternateType T ProxyFactory Property Glimpse API Documentation
Gets or sets the proxy factory.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IProxyFactory ProxyFactory { get; set; }
public IProxyFactory ProxyFactory { get; set; }
Field Value

            The proxy factory.

See Also
AlternateType T  Class
AlternateType T  Members
Glimpse.Core.Extensibility Namespace


AlternateTypeGenerationHook(T) Class

AlternateTypeGenerationHook T Class Glimpse API Documentation
An implementation of Castle DynamicProxy's IProxyGenerationHook for Glimpse.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility AlternateTypeGenerationHook T

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AlternateTypeGenerationHook<T> : IProxyGenerationHook
public class AlternateTypeGenerationHook<T> : IProxyGenerationHook
Type Parameters
T
The type being proxied.
See Also
AlternateTypeGenerationHook T  Members
Glimpse.Core.Extensibility Namespace


AlternateTypeGenerationHook(T) Members

AlternateTypeGenerationHook T Members Glimpse API Documentation

The AlternateTypeGenerationHook T type exposes the following members.
Constructors
 | Name | Description
Public method | AlternateTypeGenerationHook T | Initializes a new instance of the AlternateTypeGenerationHook T class.
Back to Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Online Object is equal to this instance. (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MethodsInspected | Invoked by the generation process to notify that the whole process has completed.
Public method | NonProxyableMemberNotification | Invoked by the generation process to notify that a member was not marked as virtual.
Public method | ShouldInterceptMethod | Invoked by the generation process to determine if the specified method should be proxied.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
AlternateTypeGenerationHook T Class
Glimpse.Core.Extensibility Namespace


AlternateTypeGenerationHook(T) Constructor

AlternateTypeGenerationHook T Constructor Glimpse API Documentation
Initializes a new instance of the AlternateTypeGenerationHook T class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AlternateTypeGenerationHook(
    IEnumerable<IAlternateMethod> methodImplementations,
    ILogger logger
)
public AlternateTypeGenerationHook(
    IEnumerable<IAlternateMethod> methodImplementations,
    ILogger logger
)
Parameters
methodImplementations
Type:   Online System.Collections.Generic IEnumerable  IAlternateMethod
The method implementations.
logger
Type: Glimpse.Core.Extensibility ILogger
The logger.
Exceptions
Exception | Condition
Online System ArgumentNullException | Throws an exception if either methodImplementations or logger are null.
See Also
AlternateTypeGenerationHook T  Class
AlternateTypeGenerationHook T  Members
Glimpse.Core.Extensibility Namespace


AlternateTypeGenerationHook(T) Methods

AlternateTypeGenerationHook T Methods Glimpse API Documentation
The AlternateTypeGenerationHook T type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Online Object is equal to this instance. (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MethodsInspected | Invoked by the generation process to notify that the whole process has completed.
Public method | NonProxyableMemberNotification | Invoked by the generation process to notify that a member was not marked as virtual.
Public method | ShouldInterceptMethod | Invoked by the generation process to determine if the specified method should be proxied.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
AlternateTypeGenerationHook T Class
Glimpse.Core.Extensibility Namespace


Equals Method

AlternateTypeGenerationHook T Equals Method Glimpse API Documentation
Determines whether the specified Online Object is equal to this instance.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Parameters
obj
Type:   Online System Object
The   Online Object to compare with this instance.
Return Value
true if the specified   Online Object is equal to this instance; otherwise, false.

See Also
AlternateTypeGenerationHook T  Class
AlternateTypeGenerationHook T  Members
Glimpse.Core.Extensibility Namespace


GetHashCode Method

AlternateTypeGenerationHook T GetHashCode Method Glimpse API Documentation
Returns a hash code for this instance.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Return Value

            A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

See Also
AlternateTypeGenerationHook T  Class
AlternateTypeGenerationHook T  Members
Glimpse.Core.Extensibility Namespace


MethodsInspected Method

AlternateTypeGenerationHook T MethodsInspected Method Glimpse API Documentation
Invoked by the generation process to notify that the whole process has completed.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void MethodsInspected()
public void MethodsInspected()
Implements
IProxyGenerationHookMethodsInspected
See Also
AlternateTypeGenerationHook T  Class
AlternateTypeGenerationHook T  Members
Glimpse.Core.Extensibility Namespace


NonProxyableMemberNotification Method

AlternateTypeGenerationHook T NonProxyableMemberNotification Method Glimpse API Documentation
Invoked by the generation process to notify that a member was not marked as virtual.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void NonProxyableMemberNotification(
    Type type,
    MemberInfo memberInfo
)
public void NonProxyableMemberNotification(
    Type type,
    MemberInfo memberInfo
)
Parameters
type
Type:   Online System Type
The type which declares the non-virtual member.
memberInfo
Type:   Online System.Reflection MemberInfo
The non-virtual member.
Implements
IProxyGenerationHookNonProxyableMemberNotification(Type, MemberInfo)
Remarks

            This method gives an opportunity to inspect any member which is not proxyable of a type that has
            been requested to be proxied, and if appropriate - throw an exception to notify the caller.

See Also
AlternateTypeGenerationHook T  Class
AlternateTypeGenerationHook T  Members
Glimpse.Core.Extensibility Namespace


ShouldInterceptMethod Method

AlternateTypeGenerationHook T ShouldInterceptMethod Method Glimpse API Documentation
Invoked by the generation process to determine if the specified method should be proxied.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ShouldInterceptMethod(
    Type type,
    MethodInfo methodInfo
)
public bool ShouldInterceptMethod(
    Type type,
    MethodInfo methodInfo
)
Parameters
type
Type:   Online System Type
The type which declares the given method.
methodInfo
Type:   Online System.Reflection MethodInfo
The method to inspect.
Return Value

            True if the given method should be proxied; false otherwise.

Implements
IProxyGenerationHookShouldInterceptMethod(Type, MethodInfo)
See Also
AlternateTypeGenerationHook T  Class
AlternateTypeGenerationHook T  Members
Glimpse.Core.Extensibility Namespace


AlternateTypeSelector Class

AlternateTypeSelector Class Glimpse API Documentation
An implementation of Castle DynamicProxy's IInterceptorSelector for Glimpse.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility AlternateTypeSelector

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AlternateTypeSelector : IInterceptorSelector
public class AlternateTypeSelector : IInterceptorSelector
See Also
AlternateTypeSelector Members
Glimpse.Core.Extensibility Namespace


AlternateTypeSelector Members

AlternateTypeSelector Members Glimpse API Documentation

The AlternateTypeSelector type exposes the following members.
Constructors
 | Name | Description
Public method | AlternateTypeSelector | Initializes a new instance of the AlternateTypeSelector class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SelectInterceptors | Selects the interceptors that should intercept calls to the given method.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
AlternateTypeSelector Class
Glimpse.Core.Extensibility Namespace


AlternateTypeSelector Constructor

AlternateTypeSelector Constructor Glimpse API Documentation
Initializes a new instance of the AlternateTypeSelector class

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AlternateTypeSelector()
public AlternateTypeSelector()
See Also
AlternateTypeSelector Class
AlternateTypeSelector Members
Glimpse.Core.Extensibility Namespace


AlternateTypeSelector Methods

AlternateTypeSelector Methods Glimpse API Documentation
The AlternateTypeSelector type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SelectInterceptors | Selects the interceptors that should intercept calls to the given method.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
AlternateTypeSelector Class
Glimpse.Core.Extensibility Namespace


SelectInterceptors Method

AlternateTypeSelector SelectInterceptors Method Glimpse API Documentation
Selects the interceptors that should intercept calls to the given method.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IInterceptor[] SelectInterceptors(
    Type type,
    MethodInfo method,
    IInterceptor[] interceptors
)
public IInterceptor[] SelectInterceptors(
    Type type,
    MethodInfo method,
    IInterceptor[] interceptors
)
Parameters
type
Type:   Online System Type
The type declaring the method to intercept.
method
Type:   Online System.Reflection MethodInfo
The method that will be intercepted.
interceptors
Type:  IInterceptor
All interceptors registered with the proxy.
Return Value

            An array of interceptors to invoke upon calling the method.

Implements
IInterceptorSelectorSelectInterceptors(Type, MethodInfo,  IInterceptor )
Remarks

            This method is called only once per proxy instance, upon the first call to the
            method. Either an empty array or null are valid return values to indicate
            that no interceptor should intercept calls to the method. Although it is not advised, it is
            legal to return other IInterceptor implementations than these provided in
            interceptors.

See Also
AlternateTypeSelector Class
AlternateTypeSelector Members
Glimpse.Core.Extensibility Namespace


AlternateTypeToCastleInterceptorAdapter Class

AlternateTypeToCastleInterceptorAdapter Class Glimpse API Documentation
An adapter between Glimpse's IAlternateType T and Castle DynamicProxy's IInterceptor.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility AlternateTypeToCastleInterceptorAdapter

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AlternateTypeToCastleInterceptorAdapter : IInterceptor
public class AlternateTypeToCastleInterceptorAdapter : IInterceptor
See Also
AlternateTypeToCastleInterceptorAdapter Members
Glimpse.Core.Extensibility Namespace


AlternateTypeToCastleInterceptorAdapter Members

AlternateTypeToCastleInterceptorAdapter Members Glimpse API Documentation

The AlternateTypeToCastleInterceptorAdapter type exposes the following members.
Constructors
 | Name | Description
Public method | AlternateTypeToCastleInterceptorAdapter | Initializes a new instance of the AlternateTypeToCastleInterceptorAdapter class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Intercept | Intercepts the specified invocation.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Implementation | Gets or sets the implementation.
Public property | Logger | Gets or sets the logger.
Public property | MessageBroker | Gets or sets the message broker.
Public property | MethodToImplement | Gets the method to implement.
Public property | ProxyFactory | Gets or sets the proxy factory.
Public property | RuntimePolicyStrategy | Gets or sets the runtime policy strategy.
Public property | TimerStrategy | Gets or sets the timer strategy.
Back to Top
See Also
AlternateTypeToCastleInterceptorAdapter Class
Glimpse.Core.Extensibility Namespace


AlternateTypeToCastleInterceptorAdapter Constructor

AlternateTypeToCastleInterceptorAdapter Constructor Glimpse API Documentation
Initializes a new instance of the AlternateTypeToCastleInterceptorAdapter class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AlternateTypeToCastleInterceptorAdapter(
    IAlternateMethod implementation,
    ILogger logger,
    IMessageBroker messageBroker,
    IProxyFactory proxyFactory,
    Func<IExecutionTimer> timerStrategy,
    Func<RuntimePolicy> runtimePolicyStrategy
)
public AlternateTypeToCastleInterceptorAdapter(
    IAlternateMethod implementation,
    ILogger logger,
    IMessageBroker messageBroker,
    IProxyFactory proxyFactory,
    Func<IExecutionTimer> timerStrategy,
    Func<RuntimePolicy> runtimePolicyStrategy
)
Parameters
implementation
Type: Glimpse.Core.Extensibility IAlternateMethod
The implementation.
logger
Type: Glimpse.Core.Extensibility ILogger
The logger.
messageBroker
Type: Glimpse.Core.Extensibility IMessageBroker
The message broker.
proxyFactory
Type: Glimpse.Core.Extensibility IProxyFactory
The proxy factory.
timerStrategy
Type:   Online System Func  IExecutionTimer
The timer strategy.
runtimePolicyStrategy
Type:   Online System Func  RuntimePolicy
The runtime policy strategy.
Exceptions
Exception | Condition
Online System ArgumentNullException | Throws an exception if either implementation or logger are null.
See Also
AlternateTypeToCastleInterceptorAdapter Class
AlternateTypeToCastleInterceptorAdapter Members
Glimpse.Core.Extensibility Namespace


AlternateTypeToCastleInterceptorAdapter Methods

AlternateTypeToCastleInterceptorAdapter Methods Glimpse API Documentation
The AlternateTypeToCastleInterceptorAdapter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Intercept | Intercepts the specified invocation.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
AlternateTypeToCastleInterceptorAdapter Class
Glimpse.Core.Extensibility Namespace


Intercept Method

AlternateTypeToCastleInterceptorAdapter Intercept Method Glimpse API Documentation
Intercepts the specified invocation.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Intercept(
    IInvocation invocation
)
public void Intercept(
    IInvocation invocation
)
Parameters
invocation
Type: IInvocation
The invocation.
Implements
IInterceptorIntercept(IInvocation)
See Also
AlternateTypeToCastleInterceptorAdapter Class
AlternateTypeToCastleInterceptorAdapter Members
Glimpse.Core.Extensibility Namespace


AlternateTypeToCastleInterceptorAdapter Properties

AlternateTypeToCastleInterceptorAdapter Properties Glimpse API Documentation
The AlternateTypeToCastleInterceptorAdapter type exposes the following members.
Properties
 | Name | Description
Public property | Implementation | Gets or sets the implementation.
Public property | Logger | Gets or sets the logger.
Public property | MessageBroker | Gets or sets the message broker.
Public property | MethodToImplement | Gets the method to implement.
Public property | ProxyFactory | Gets or sets the proxy factory.
Public property | RuntimePolicyStrategy | Gets or sets the runtime policy strategy.
Public property | TimerStrategy | Gets or sets the timer strategy.
Back to Top
See Also
AlternateTypeToCastleInterceptorAdapter Class
Glimpse.Core.Extensibility Namespace


Implementation Property

AlternateTypeToCastleInterceptorAdapter Implementation Property Glimpse API Documentation
Gets or sets the implementation.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IAlternateMethod Implementation { get; set; }
public IAlternateMethod Implementation { get; set; }
Field Value

            The implementation.

See Also
AlternateTypeToCastleInterceptorAdapter Class
AlternateTypeToCastleInterceptorAdapter Members
Glimpse.Core.Extensibility Namespace


Logger Property

AlternateTypeToCastleInterceptorAdapter Logger Property Glimpse API Documentation
Gets or sets the logger.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILogger Logger { get; set; }
public ILogger Logger { get; set; }
Field Value

            The logger.

See Also
AlternateTypeToCastleInterceptorAdapter Class
AlternateTypeToCastleInterceptorAdapter Members
Glimpse.Core.Extensibility Namespace


MessageBroker Property

AlternateTypeToCastleInterceptorAdapter MessageBroker Property Glimpse API Documentation
Gets or sets the message broker.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IMessageBroker MessageBroker { get; set; }
public IMessageBroker MessageBroker { get; set; }
Field Value

            The message broker.

See Also
AlternateTypeToCastleInterceptorAdapter Class
AlternateTypeToCastleInterceptorAdapter Members
Glimpse.Core.Extensibility Namespace


MethodToImplement Property

AlternateTypeToCastleInterceptorAdapter MethodToImplement Property Glimpse API Documentation
Gets the method to implement.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MethodInfo MethodToImplement { get; }
public MethodInfo MethodToImplement { get; }
Field Value

            The method to implement.

See Also
AlternateTypeToCastleInterceptorAdapter Class
AlternateTypeToCastleInterceptorAdapter Members
Glimpse.Core.Extensibility Namespace


ProxyFactory Property

AlternateTypeToCastleInterceptorAdapter ProxyFactory Property Glimpse API Documentation
Gets or sets the proxy factory.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IProxyFactory ProxyFactory { get; set; }
public IProxyFactory ProxyFactory { get; set; }
Field Value

            The proxy factory.

See Also
AlternateTypeToCastleInterceptorAdapter Class
AlternateTypeToCastleInterceptorAdapter Members
Glimpse.Core.Extensibility Namespace


RuntimePolicyStrategy Property

AlternateTypeToCastleInterceptorAdapter RuntimePolicyStrategy Property Glimpse API Documentation
Gets or sets the runtime policy strategy.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Func<RuntimePolicy> RuntimePolicyStrategy { get; set; }
public Func<RuntimePolicy> RuntimePolicyStrategy { get; set; }
Field Value

            The runtime policy strategy.

See Also
AlternateTypeToCastleInterceptorAdapter Class
AlternateTypeToCastleInterceptorAdapter Members
Glimpse.Core.Extensibility Namespace


TimerStrategy Property

AlternateTypeToCastleInterceptorAdapter TimerStrategy Property Glimpse API Documentation
Gets or sets the timer strategy.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Func<IExecutionTimer> TimerStrategy { get; set; }
public Func<IExecutionTimer> TimerStrategy { get; set; }
Field Value

            The timer strategy.

See Also
AlternateTypeToCastleInterceptorAdapter Class
AlternateTypeToCastleInterceptorAdapter Members
Glimpse.Core.Extensibility Namespace


AntiXssEncoder Class

AntiXssEncoder Class Glimpse API Documentation
The default IHtmlEncoder implementation of Glimpse, which leverages Microsoft's Web Protection Library.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility AntiXssEncoder

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AntiXssEncoder : IHtmlEncoder
public class AntiXssEncoder : IHtmlEncoder
See Also
AntiXssEncoder Members
Glimpse.Core.Extensibility Namespace


AntiXssEncoder Members

AntiXssEncoder Members Glimpse API Documentation

The AntiXssEncoder type exposes the following members.
Constructors
 | Name | Description
Public method | AntiXssEncoder | Initializes a new instance of the AntiXssEncoder class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HtmlAttributeEncode | Encode a given value for use as in an Html attribute.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
AntiXssEncoder Class
Glimpse.Core.Extensibility Namespace


AntiXssEncoder Constructor

AntiXssEncoder Constructor Glimpse API Documentation
Initializes a new instance of the AntiXssEncoder class

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AntiXssEncoder()
public AntiXssEncoder()
See Also
AntiXssEncoder Class
AntiXssEncoder Members
Glimpse.Core.Extensibility Namespace


AntiXssEncoder Methods

AntiXssEncoder Methods Glimpse API Documentation
The AntiXssEncoder type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HtmlAttributeEncode | Encode a given value for use as in an Html attribute.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
AntiXssEncoder Class
Glimpse.Core.Extensibility Namespace


HtmlAttributeEncode Method

AntiXssEncoder HtmlAttributeEncode Method Glimpse API Documentation
Encode a given value for use as in an Html attribute.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string HtmlAttributeEncode(
    string input
)
public string HtmlAttributeEncode(
    string input
)
Parameters
input
Type:   Online System String
The input.
Return Value

            Encoded result.

Implements
IHtmlEncoder HtmlAttributeEncode(String)
See Also
AntiXssEncoder Class
AntiXssEncoder Members
Glimpse.Core.Extensibility Namespace


CastleInvocationToAlternateMethodContextAdapter Class

CastleInvocationToAlternateMethodContextAdapter Class Glimpse API Documentation
An adapter between Castle DynamicProxy's IInvocation and Glimpse's IAlternateMethodContext.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility CastleInvocationToAlternateMethodContextAdapter

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CastleInvocationToAlternateMethodContextAdapter : IAlternateMethodContext,
    IContext
public class CastleInvocationToAlternateMethodContextAdapter : IAlternateMethodContext,
    IContext
See Also
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


CastleInvocationToAlternateMethodContextAdapter Members

CastleInvocationToAlternateMethodContextAdapter Members Glimpse API Documentation

The CastleInvocationToAlternateMethodContextAdapter type exposes the following members.
Constructors
 | Name | Description
Public method | CastleInvocationToAlternateMethodContextAdapter | Initializes a new instance of the CastleInvocationToAlternateMethodContextAdapter class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetArgumentValue | Gets the value of the argument at the specified index.
Public method | GetConcreteMethod | Gets the concrete method.
Public method | GetConcreteMethodInvocationTarget | Gets the concrete method invocation target.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Proceed | Proceeds the call to the next implementation in line, and ultimately to the target method.
Public method | SetArgumentValue | Overrides the value of an argument at the given index with the new value provided.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | TryProceedWithTimer | Calls Proceed on the original implementation, if the current RuntimePolicy is not Off, and provides a corresponding TimerResult. (Defined by AlternateMethodContextExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments that IAlternateMethod has been invoked with.
Public property | GenericArguments | Gets the generic arguments.
Public property | Invocation | Gets or sets the invocation.
Public property | InvocationTarget | Gets the object on which the invocation is performed. This is different from proxy object because most of the time this will be the proxy target object.
Public property | Logger | Gets or sets the logger.
Public property | MessageBroker | Gets the message broker.
Public property | Method | Gets the method representing the method being invoked on the proxy.
Public property | MethodInvocationTarget | Gets the method info on the target class.
Public property | Proxy | Gets the proxy object on which the alternate implementation is invoked.
Public property | ProxyFactory | Gets the proxy factory.
Public property | ReturnValue | Gets or sets the return value of the method.
Public property | RuntimePolicyStrategy | Gets the runtime policy strategy.
Public property | TargetType | Gets the type of the target object for the intercepted method.
Public property | TimerStrategy | Gets the timer strategy.
Back to Top
See Also
CastleInvocationToAlternateMethodContextAdapter Class
Glimpse.Core.Extensibility Namespace


CastleInvocationToAlternateMethodContextAdapter Constructor

CastleInvocationToAlternateMethodContextAdapter Constructor Glimpse API Documentation
Initializes a new instance of the CastleInvocationToAlternateMethodContextAdapter class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CastleInvocationToAlternateMethodContextAdapter(
    IInvocation invocation,
    ILogger logger,
    IMessageBroker messageBroker,
    IProxyFactory proxyFactory,
    Func<IExecutionTimer> timerStrategy,
    Func<RuntimePolicy> runtimePolicyStrategy
)
public CastleInvocationToAlternateMethodContextAdapter(
    IInvocation invocation,
    ILogger logger,
    IMessageBroker messageBroker,
    IProxyFactory proxyFactory,
    Func<IExecutionTimer> timerStrategy,
    Func<RuntimePolicy> runtimePolicyStrategy
)
Parameters
invocation
Type: IInvocation
The invocation.
logger
Type: Glimpse.Core.Extensibility ILogger
The logger.
messageBroker
Type: Glimpse.Core.Extensibility IMessageBroker
The message broker.
proxyFactory
Type: Glimpse.Core.Extensibility IProxyFactory
The proxy factory.
timerStrategy
Type:   Online System Func  IExecutionTimer
The timer strategy.
runtimePolicyStrategy
Type:   Online System Func  RuntimePolicy
The runtime policy strategy.
Exceptions
Exception | Condition
Online System ArgumentNullException | Throws an exception if any parameter is null.
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


CastleInvocationToAlternateMethodContextAdapter Methods

CastleInvocationToAlternateMethodContextAdapter Methods Glimpse API Documentation
The CastleInvocationToAlternateMethodContextAdapter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetArgumentValue | Gets the value of the argument at the specified index.
Public method | GetConcreteMethod | Gets the concrete method.
Public method | GetConcreteMethodInvocationTarget | Gets the concrete method invocation target.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Proceed | Proceeds the call to the next implementation in line, and ultimately to the target method.
Public method | SetArgumentValue | Overrides the value of an argument at the given index with the new value provided.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | TryProceedWithTimer | Calls Proceed on the original implementation, if the current RuntimePolicy is not Off, and provides a corresponding TimerResult. (Defined by AlternateMethodContextExtensions.)
Back to Top
See Also
CastleInvocationToAlternateMethodContextAdapter Class
Glimpse.Core.Extensibility Namespace


GetArgumentValue Method

CastleInvocationToAlternateMethodContextAdapter GetArgumentValue Method Glimpse API Documentation
Gets the value of the argument at the specified index.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object GetArgumentValue(
    int index
)
public Object GetArgumentValue(
    int index
)
Parameters
index
Type:   Online System Int32
The index.
Return Value

            Value of the argument.

Implements
IAlternateMethodContext GetArgumentValue(Int32)
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


GetConcreteMethod Method

CastleInvocationToAlternateMethodContextAdapter GetConcreteMethod Method Glimpse API Documentation
Gets the concrete method.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MethodInfo GetConcreteMethod()
public MethodInfo GetConcreteMethod()
Return Value

            The method info of the method that is the proxy that is the alternative implementation.

Implements
IAlternateMethodContext GetConcreteMethod
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


GetConcreteMethodInvocationTarget Method

CastleInvocationToAlternateMethodContextAdapter GetConcreteMethodInvocationTarget Method Glimpse API Documentation
Gets the concrete method invocation target.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MethodInfo GetConcreteMethodInvocationTarget()
public MethodInfo GetConcreteMethodInvocationTarget()
Return Value

            The method info of the method that is the target of the alternative implementation.

Implements
IAlternateMethodContext GetConcreteMethodInvocationTarget
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


Proceed Method

CastleInvocationToAlternateMethodContextAdapter Proceed Method Glimpse API Documentation
Proceeds the call to the next implementation in line, and ultimately to the target method.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Proceed()
public void Proceed()
Implements
IAlternateMethodContext Proceed
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


SetArgumentValue Method

CastleInvocationToAlternateMethodContextAdapter SetArgumentValue Method Glimpse API Documentation
Overrides the value of an argument at the given index with the new value provided.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetArgumentValue(
    int index,
    Object value
)
public void SetArgumentValue(
    int index,
    Object value
)
Parameters
index
Type:   Online System Int32
The index.
value
Type:   Online System Object
The value.
Implements
IAlternateMethodContext SetArgumentValue(Int32, Object)
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


CastleInvocationToAlternateMethodContextAdapter Properties

CastleInvocationToAlternateMethodContextAdapter Properties Glimpse API Documentation
The CastleInvocationToAlternateMethodContextAdapter type exposes the following members.
Properties
 | Name | Description
Public property | Arguments | Gets the arguments that IAlternateMethod has been invoked with.
Public property | GenericArguments | Gets the generic arguments.
Public property | Invocation | Gets or sets the invocation.
Public property | InvocationTarget | Gets the object on which the invocation is performed. This is different from proxy object because most of the time this will be the proxy target object.
Public property | Logger | Gets or sets the logger.
Public property | MessageBroker | Gets the message broker.
Public property | Method | Gets the method representing the method being invoked on the proxy.
Public property | MethodInvocationTarget | Gets the method info on the target class.
Public property | Proxy | Gets the proxy object on which the alternate implementation is invoked.
Public property | ProxyFactory | Gets the proxy factory.
Public property | ReturnValue | Gets or sets the return value of the method.
Public property | RuntimePolicyStrategy | Gets the runtime policy strategy.
Public property | TargetType | Gets the type of the target object for the intercepted method.
Public property | TimerStrategy | Gets the timer strategy.
Back to Top
See Also
CastleInvocationToAlternateMethodContextAdapter Class
Glimpse.Core.Extensibility Namespace


Arguments Property

CastleInvocationToAlternateMethodContextAdapter Arguments Property Glimpse API Documentation
Gets the arguments that IAlternateMethod has been invoked with.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object[] Arguments { get; }
public Object[] Arguments { get; }
Field Value

            The arguments.

Implements
IAlternateMethodContext Arguments
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


GenericArguments Property

CastleInvocationToAlternateMethodContextAdapter GenericArguments Property Glimpse API Documentation
Gets the generic arguments.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type[] GenericArguments { get; }
public Type[] GenericArguments { get; }
Field Value

            The generic arguments.

Implements
IAlternateMethodContext GenericArguments
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


Invocation Property

CastleInvocationToAlternateMethodContextAdapter Invocation Property Glimpse API Documentation
Gets or sets the invocation.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IInvocation Invocation { get; set; }
public IInvocation Invocation { get; set; }
Field Value

            The invocation.

See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


InvocationTarget Property

CastleInvocationToAlternateMethodContextAdapter InvocationTarget Property Glimpse API Documentation
Gets the object on which the invocation is performed. This is different from proxy object because most of the time this will be the proxy target object.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object InvocationTarget { get; }
public Object InvocationTarget { get; }
Field Value

            The invocation target.

Implements
IAlternateMethodContext InvocationTarget
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


Logger Property

CastleInvocationToAlternateMethodContextAdapter Logger Property Glimpse API Documentation
Gets or sets the logger.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILogger Logger { get; set; }
public ILogger Logger { get; set; }
Field Value

            The logger.

Implements
IContext Logger
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


MessageBroker Property

CastleInvocationToAlternateMethodContextAdapter MessageBroker Property Glimpse API Documentation
Gets the message broker.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IMessageBroker MessageBroker { get; private set; }
public IMessageBroker MessageBroker { get; private set; }
Field Value

            The message broker.

Implements
IAlternateMethodContext MessageBroker
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


Method Property

CastleInvocationToAlternateMethodContextAdapter Method Property Glimpse API Documentation
Gets the method representing the method being invoked on the proxy.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MethodInfo Method { get; }
public MethodInfo Method { get; }
Field Value

            The method.

Implements
IAlternateMethodContext Method
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


MethodInvocationTarget Property

CastleInvocationToAlternateMethodContextAdapter MethodInvocationTarget Property Glimpse API Documentation
Gets the method info on the target class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MethodInfo MethodInvocationTarget { get; }
public MethodInfo MethodInvocationTarget { get; }
Field Value

            The method invocation target.

Implements
IAlternateMethodContext MethodInvocationTarget
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


Proxy Property

CastleInvocationToAlternateMethodContextAdapter Proxy Property Glimpse API Documentation
Gets the proxy object on which the alternate implementation is invoked.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Proxy { get; }
public Object Proxy { get; }
Field Value

            The proxy.

Implements
IAlternateMethodContext Proxy
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


ProxyFactory Property

CastleInvocationToAlternateMethodContextAdapter ProxyFactory Property Glimpse API Documentation
Gets the proxy factory.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IProxyFactory ProxyFactory { get; private set; }
public IProxyFactory ProxyFactory { get; private set; }
Field Value

            The proxy factory.

Implements
IAlternateMethodContext ProxyFactory
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


ReturnValue Property

CastleInvocationToAlternateMethodContextAdapter ReturnValue Property Glimpse API Documentation
Gets or sets the return value of the method.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ReturnValue { get; set; }
public Object ReturnValue { get; set; }
Field Value

            The return value.

Implements
IAlternateMethodContext ReturnValue
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


RuntimePolicyStrategy Property

CastleInvocationToAlternateMethodContextAdapter RuntimePolicyStrategy Property Glimpse API Documentation
Gets the runtime policy strategy.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Func<RuntimePolicy> RuntimePolicyStrategy { get; private set; }
public Func<RuntimePolicy> RuntimePolicyStrategy { get; private set; }
Field Value

            The runtime policy strategy.

Implements
IAlternateMethodContext RuntimePolicyStrategy
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


TargetType Property

CastleInvocationToAlternateMethodContextAdapter TargetType Property Glimpse API Documentation
Gets the type of the target object for the intercepted method.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type TargetType { get; }
public Type TargetType { get; }
Field Value

            The type of the target.

Implements
IAlternateMethodContext TargetType
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


TimerStrategy Property

CastleInvocationToAlternateMethodContextAdapter TimerStrategy Property Glimpse API Documentation
Gets the timer strategy.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Func<IExecutionTimer> TimerStrategy { get; private set; }
public Func<IExecutionTimer> TimerStrategy { get; private set; }
Field Value

            The timer strategy.

Implements
IAlternateMethodContext TimerStrategy
See Also
CastleInvocationToAlternateMethodContextAdapter Class
CastleInvocationToAlternateMethodContextAdapter Members
Glimpse.Core.Extensibility Namespace


DictionaryDataStoreAdapter Class

DictionaryDataStoreAdapter Class Glimpse API Documentation
An adapter between an Online IDictionary and IDataStore.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility DictionaryDataStoreAdapter

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class DictionaryDataStoreAdapter : IDataStore
public class DictionaryDataStoreAdapter : IDataStore
See Also
DictionaryDataStoreAdapter Members
Glimpse.Core.Extensibility Namespace


DictionaryDataStoreAdapter Members

DictionaryDataStoreAdapter Members Glimpse API Documentation

The DictionaryDataStoreAdapter type exposes the following members.
Constructors
 | Name | Description
Public method | DictionaryDataStoreAdapter | Initializes a new instance of the DictionaryDataStoreAdapter class.
Back to Top
Methods
 | Name | Description
Public method | Contains | Determines whether the data store contains a definition for the specified key.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get | Gets the item with the specified key.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Set | Sets the item with the specified key.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | Contains T | Determines whether store contains and item with a key of T. (Defined by DataStoreExtensions.)
Public Extension Method | Get T | Overloaded. Gets an item from store using <T> as a key. This method should be used in combination with Set<T>. (Defined by DataStoreExtensions.)
Public Extension Method | Get T (String) | Overloaded. Gets an item from store using the key and casts to <T>. (Defined by DataStoreExtensions.)
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | Set T | Sets an item in store using <T> as a key. This method should be used in combination with Get<T>. (Defined by DataStoreExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
DictionaryDataStoreAdapter Class
Glimpse.Core.Extensibility Namespace


DictionaryDataStoreAdapter Constructor

DictionaryDataStoreAdapter Constructor Glimpse API Documentation
Initializes a new instance of the DictionaryDataStoreAdapter class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DictionaryDataStoreAdapter(
    IDictionary dictionary
)
public DictionaryDataStoreAdapter(
    IDictionary dictionary
)
Parameters
dictionary
Type:   Online System.Collections IDictionary
The dictionary.
Exceptions
Exception | Condition
Online System ArgumentException | Throws an exception if a generic dictionary does not have a value of type Online Object and a key of either Online String or Online Object.
See Also
DictionaryDataStoreAdapter Class
DictionaryDataStoreAdapter Members
Glimpse.Core.Extensibility Namespace


DictionaryDataStoreAdapter Methods

DictionaryDataStoreAdapter Methods Glimpse API Documentation
The DictionaryDataStoreAdapter type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Determines whether the data store contains a definition for the specified key.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get | Gets the item with the specified key.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Set | Sets the item with the specified key.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | Contains T | Determines whether store contains and item with a key of T. (Defined by DataStoreExtensions.)
Public Extension Method | Get T | Overloaded. Gets an item from store using <T> as a key. This method should be used in combination with Set<T>. (Defined by DataStoreExtensions.)
Public Extension Method | Get T (String) | Overloaded. Gets an item from store using the key and casts to <T>. (Defined by DataStoreExtensions.)
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | Set T | Sets an item in store using <T> as a key. This method should be used in combination with Get<T>. (Defined by DataStoreExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
DictionaryDataStoreAdapter Class
Glimpse.Core.Extensibility Namespace


Contains Method

DictionaryDataStoreAdapter Contains Method Glimpse API Documentation
Determines whether the data store contains a definition for the specified key.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Contains(
    string key
)
public bool Contains(
    string key
)
Parameters
key
Type:   Online System String
The key.
Return Value
true if it contains the specified key; otherwise, false.

Implements
IDataStore Contains(String)
See Also
DictionaryDataStoreAdapter Class
DictionaryDataStoreAdapter Members
Glimpse.Core.Extensibility Namespace


Get Method

DictionaryDataStoreAdapter Get Method Glimpse API Documentation
Gets the item with the specified key.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Get(
    string key
)
public Object Get(
    string key
)
Parameters
key
Type:   Online System String
The key.
Return Value

            The value stored at given key.

Implements
IDataStore Get(String)
See Also
DictionaryDataStoreAdapter Class
DictionaryDataStoreAdapter Members
Glimpse.Core.Extensibility Namespace


Set Method

DictionaryDataStoreAdapter Set Method Glimpse API Documentation
Sets the item with the specified key.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Set(
    string key,
    Object value
)
public void Set(
    string key,
    Object value
)
Parameters
key
Type:   Online System String
The key.
value
Type:   Online System Object
The value.
Implements
IDataStore Set(String, Object)
See Also
DictionaryDataStoreAdapter Class
DictionaryDataStoreAdapter Members
Glimpse.Core.Extensibility Namespace


ExecutionTimer Class

ExecutionTimer Class Glimpse API Documentation
An implementation of IExecutionTimer.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility ExecutionTimer

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ExecutionTimer : IExecutionTimer
public class ExecutionTimer : IExecutionTimer
See Also
ExecutionTimer Members
Glimpse.Core.Extensibility Namespace


ExecutionTimer Members

ExecutionTimer Members Glimpse API Documentation

The ExecutionTimer type exposes the following members.
Constructors
 | Name | Description
Public method | ExecutionTimer | Initializes a new instance of the ExecutionTimer class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Point | Returns a special TimerResult which represents a single point in time.
Public method | Start | Starts the timer instance.
Public method | Stop | Stops the timer instance.
Public method | Time(Action) | Times the specified action. This will start and stop the timer either side of the action that is executed.
Public method | Time T (Func T ) | Times the specified function. This will start and stop the timer either side of the function that is executed.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | RequestStart | Gets the request start date and time.
Back to Top
See Also
ExecutionTimer Class
Glimpse.Core.Extensibility Namespace


ExecutionTimer Constructor

ExecutionTimer Constructor Glimpse API Documentation
Initializes a new instance of the ExecutionTimer class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ExecutionTimer(
    Stopwatch stopwatch
)
public ExecutionTimer(
    Stopwatch stopwatch
)
Parameters
stopwatch
Type:   Online System.Diagnostics Stopwatch
The stopwatch.
See Also
ExecutionTimer Class
ExecutionTimer Members
Glimpse.Core.Extensibility Namespace


ExecutionTimer Methods

ExecutionTimer Methods Glimpse API Documentation
The ExecutionTimer type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Point | Returns a special TimerResult which represents a single point in time.
Public method | Start | Starts the timer instance.
Public method | Stop | Stops the timer instance.
Public method | Time(Action) | Times the specified action. This will start and stop the timer either side of the action that is executed.
Public method | Time T (Func T ) | Times the specified function. This will start and stop the timer either side of the function that is executed.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ExecutionTimer Class
Glimpse.Core.Extensibility Namespace


Point Method

ExecutionTimer Point Method Glimpse API Documentation
Returns a special TimerResult which represents a single point in time.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimerResult Point()
public TimerResult Point()
Return Value

            A TimerResult of a single point in time.

Implements
IExecutionTimer Point
See Also
ExecutionTimer Class
ExecutionTimer Members
Glimpse.Core.Extensibility Namespace


Start Method

ExecutionTimer Start Method Glimpse API Documentation
Starts the timer instance.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan Start()
public TimeSpan Start()
Return Value

            TimeSpan that represents this timing instance.

Implements
IExecutionTimer Start
Remarks

            If this method is used, it is up to the developer to manually stop the
            timer by calling Stop().

See Also
ExecutionTimer Class
ExecutionTimer Members
Glimpse.Core.Extensibility Namespace


Stop Method

ExecutionTimer Stop Method Glimpse API Documentation
Stops the timer instance.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimerResult Stop(
    TimeSpan offset
)
public TimerResult Stop(
    TimeSpan offset
)
Parameters
offset
Type:   Online System TimeSpan
The offset.
Return Value

            Timing info that is collected as a result of the execution.

Implements
IExecutionTimer Stop(TimeSpan)
Remarks

            Inconsistent results may be experienced if you do not call Start() before
            calling Stop().

See Also
ExecutionTimer Class
ExecutionTimer Members
Glimpse.Core.Extensibility Namespace


Time Method

ExecutionTimer Time Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Time(Action) | Times the specified action. This will start and stop the timer either side of the action that is executed.
Public method | Time T (Func T ) | Times the specified function. This will start and stop the timer either side of the function that is executed.
Back to Top
See Also
ExecutionTimer Class
ExecutionTimer Members
Glimpse.Core.Extensibility Namespace


Time Method (Action)

ExecutionTimer Time Method (Action) Glimpse API Documentation
Times the specified action. This will start and stop the timer either side of the action that is executed.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimerResult Time(
    Action action
)
public TimerResult Time(
    Action action
)
Parameters
action
Type:   Online System Action
The action that should be executed.
Return Value

            Timing info that is collected as a result of the execution.

Implements
IExecutionTimer Time(Action)
See Also
ExecutionTimer Class
ExecutionTimer Members
Time Overload
Glimpse.Core.Extensibility Namespace


Time(T) Method (Func(T))

ExecutionTimer Time T Method (Func T ) Glimpse API Documentation
Times the specified function. This will start and stop the timer either side of the function that is executed.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimerResult<T> Time<T>(
    Func<T> function
)
public TimerResult<T> Time<T>(
    Func<T> function
)
Parameters
function
Type:   Online System Func  T
The function that should be executed.
Type Parameters
T
Type of result that is expected
Return Value

            Timing info that is collected as a result of the execution.

Implements
IExecutionTimer Time T (Func T )
See Also
ExecutionTimer Class
ExecutionTimer Members
Time Overload
Glimpse.Core.Extensibility Namespace


ExecutionTimer Properties

ExecutionTimer Properties Glimpse API Documentation
The ExecutionTimer type exposes the following members.
Properties
 | Name | Description
Public property | RequestStart | Gets the request start date and time.
Back to Top
See Also
ExecutionTimer Class
Glimpse.Core.Extensibility Namespace


RequestStart Property

ExecutionTimer RequestStart Property Glimpse API Documentation
Gets the request start date and time.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime RequestStart { get; private set; }
public DateTime RequestStart { get; private set; }
Field Value

            The request start.

Implements
IExecutionTimer RequestStart
See Also
ExecutionTimer Class
ExecutionTimer Members
Glimpse.Core.Extensibility Namespace


IAlternateMethod Interface

IAlternateMethod Interface Glimpse API Documentation
Definition for an alternate method which allows classes to be proxied.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IAlternateMethod
public interface IAlternateMethod
See Also
IAlternateMethod Members
Glimpse.Core.Extensibility Namespace


IAlternateMethod Members

IAlternateMethod Members Glimpse API Documentation

The IAlternateMethod type exposes the following members.
Methods
 | Name | Description
Public method | NewImplementation | New implementation that is called in-place of the the original method.
Back to Top
Properties
 | Name | Description
Public property | MethodToImplement | Gets the method to implement.
Back to Top
See Also
IAlternateMethod Interface
Glimpse.Core.Extensibility Namespace


IAlternateMethod Methods

IAlternateMethod Methods Glimpse API Documentation
The IAlternateMethod type exposes the following members.
Methods
 | Name | Description
Public method | NewImplementation | New implementation that is called in-place of the the original method.
Back to Top
See Also
IAlternateMethod Interface
Glimpse.Core.Extensibility Namespace


NewImplementation Method

IAlternateMethod NewImplementation Method Glimpse API Documentation
New implementation that is called in-place of the the original method.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void NewImplementation(
    IAlternateMethodContext context
)
void NewImplementation(
    IAlternateMethodContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IAlternateMethodContext
The context.
Remarks

            It is up to this method to call the underlying target method.

See Also
IAlternateMethod Interface
IAlternateMethod Members
Glimpse.Core.Extensibility Namespace


IAlternateMethod Properties

IAlternateMethod Properties Glimpse API Documentation
The IAlternateMethod type exposes the following members.
Properties
 | Name | Description
Public property | MethodToImplement | Gets the method to implement.
Back to Top
See Also
IAlternateMethod Interface
Glimpse.Core.Extensibility Namespace


MethodToImplement Property

IAlternateMethod MethodToImplement Property Glimpse API Documentation
Gets the method to implement.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
MethodInfo MethodToImplement { get; }
MethodInfo MethodToImplement { get; }
Field Value
The method to implement.
Remarks

            The info of the method that this alternate is for.

See Also
IAlternateMethod Interface
IAlternateMethod Members
Glimpse.Core.Extensibility Namespace


IAlternateMethodContext Interface

IAlternateMethodContext Interface Glimpse API Documentation
Definition for the context used by IAlternateMethod

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IAlternateMethodContext : IContext
public interface IAlternateMethodContext : IContext
See Also
IAlternateMethodContext Members
Glimpse.Core.Extensibility Namespace


IAlternateMethodContext Members

IAlternateMethodContext Members Glimpse API Documentation

The IAlternateMethodContext type exposes the following members.
Methods
 | Name | Description
Public method | GetArgumentValue | Gets the value of the argument at the specified index.
Public method | GetConcreteMethod | Gets the concrete method.
Public method | GetConcreteMethodInvocationTarget | Gets the concrete method invocation target.
Public method | Proceed | Proceeds the call to the next implementation in line, and ultimately to the target method.
Public method | SetArgumentValue | Overrides the value of an argument at the given index with the new value provided.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | TryProceedWithTimer | Calls Proceed on the original implementation, if the current RuntimePolicy is not Off, and provides a corresponding TimerResult. (Defined by AlternateMethodContextExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments that IAlternateMethod has been invoked with.
Public property | GenericArguments | Gets the generic arguments.
Public property | InvocationTarget | Gets the object on which the invocation is performed. This is different from proxy object because most of the time this will be the proxy target object.
Public property | Logger | Gets the logger. (Inherited from IContext.)
Public property | MessageBroker | Gets the message broker.
Public property | Method | Gets the method representing the method being invoked on the proxy.
Public property | MethodInvocationTarget | Gets the method info on the target class.
Public property | Proxy | Gets the proxy object on which the alternate implementation is invoked.
Public property | ProxyFactory | Gets the proxy factory.
Public property | ReturnValue | Gets or sets the return value of the method.
Public property | RuntimePolicyStrategy | Gets the runtime policy strategy.
Public property | TargetType | Gets the type of the target object for the intercepted method.
Public property | TimerStrategy | Gets the timer strategy.
Back to Top
See Also
IAlternateMethodContext Interface
Glimpse.Core.Extensibility Namespace


IAlternateMethodContext Methods

IAlternateMethodContext Methods Glimpse API Documentation
The IAlternateMethodContext type exposes the following members.
Methods
 | Name | Description
Public method | GetArgumentValue | Gets the value of the argument at the specified index.
Public method | GetConcreteMethod | Gets the concrete method.
Public method | GetConcreteMethodInvocationTarget | Gets the concrete method invocation target.
Public method | Proceed | Proceeds the call to the next implementation in line, and ultimately to the target method.
Public method | SetArgumentValue | Overrides the value of an argument at the given index with the new value provided.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | TryProceedWithTimer | Calls Proceed on the original implementation, if the current RuntimePolicy is not Off, and provides a corresponding TimerResult. (Defined by AlternateMethodContextExtensions.)
Back to Top
See Also
IAlternateMethodContext Interface
Glimpse.Core.Extensibility Namespace


GetArgumentValue Method

IAlternateMethodContext GetArgumentValue Method Glimpse API Documentation
Gets the value of the argument at the specified index.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object GetArgumentValue(
    int index
)
Object GetArgumentValue(
    int index
)
Parameters
index
Type:   Online System Int32
The index.
Return Value
Value of the argument.
See Also
IAlternateMethodContext Interface
IAlternateMethodContext Members
Glimpse.Core.Extensibility Namespace


GetConcreteMethod Method

IAlternateMethodContext GetConcreteMethod Method Glimpse API Documentation
Gets the concrete method.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
MethodInfo GetConcreteMethod()
MethodInfo GetConcreteMethod()
Return Value
The method info of the method that is the proxy that is the alternative implementation.
See Also
IAlternateMethodContext Interface
IAlternateMethodContext Members
Glimpse.Core.Extensibility Namespace


GetConcreteMethodInvocationTarget Method

IAlternateMethodContext GetConcreteMethodInvocationTarget Method Glimpse API Documentation
Gets the concrete method invocation target.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
MethodInfo GetConcreteMethodInvocationTarget()
MethodInfo GetConcreteMethodInvocationTarget()
Return Value
The method info of the method that is the target of the alternative implementation.
See Also
IAlternateMethodContext Interface
IAlternateMethodContext Members
Glimpse.Core.Extensibility Namespace


Proceed Method

IAlternateMethodContext Proceed Method Glimpse API Documentation
Proceeds the call to the next implementation in line, and ultimately to the target method.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Proceed()
void Proceed()
See Also
IAlternateMethodContext Interface
IAlternateMethodContext Members
Glimpse.Core.Extensibility Namespace


SetArgumentValue Method

IAlternateMethodContext SetArgumentValue Method Glimpse API Documentation
Overrides the value of an argument at the given index with the new value provided.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void SetArgumentValue(
    int index,
    Object value
)
void SetArgumentValue(
    int index,
    Object value
)
Parameters
index
Type:   Online System Int32
The index.
value
Type:   Online System Object
The value.
See Also
IAlternateMethodContext Interface
IAlternateMethodContext Members
Glimpse.Core.Extensibility Namespace


IAlternateMethodContext Properties

IAlternateMethodContext Properties Glimpse API Documentation
The IAlternateMethodContext type exposes the following members.
Properties
 | Name | Description
Public property | Arguments | Gets the arguments that IAlternateMethod has been invoked with.
Public property | GenericArguments | Gets the generic arguments.
Public property | InvocationTarget | Gets the object on which the invocation is performed. This is different from proxy object because most of the time this will be the proxy target object.
Public property | Logger | Gets the logger. (Inherited from IContext.)
Public property | MessageBroker | Gets the message broker.
Public property | Method | Gets the method representing the method being invoked on the proxy.
Public property | MethodInvocationTarget | Gets the method info on the target class.
Public property | Proxy | Gets the proxy object on which the alternate implementation is invoked.
Public property | ProxyFactory | Gets the proxy factory.
Public property | ReturnValue | Gets or sets the return value of the method.
Public property | RuntimePolicyStrategy | Gets the runtime policy strategy.
Public property | TargetType | Gets the type of the target object for the intercepted method.
Public property | TimerStrategy | Gets the timer strategy.
Back to Top
See Also
IAlternateMethodContext Interface
Glimpse.Core.Extensibility Namespace


Arguments Property

IAlternateMethodContext Arguments Property Glimpse API Documentation
Gets the arguments that IAlternateMethod has been invoked with.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object[] Arguments { get; }
Object[] Arguments { get; }
Field Value
The arguments.
See Also
IAlternateMethodContext Interface
IAlternateMethodContext Members
Glimpse.Core.Extensibility Namespace


GenericArguments Property

IAlternateMethodContext GenericArguments Property Glimpse API Documentation
Gets the generic arguments.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Type[] GenericArguments { get; }
Type[] GenericArguments { get; }
Field Value
The generic arguments.
See Also
IAlternateMethodContext Interface
IAlternateMethodContext Members
Glimpse.Core.Extensibility Namespace


InvocationTarget Property

IAlternateMethodContext InvocationTarget Property Glimpse API Documentation
Gets the object on which the invocation is performed. This is different from proxy object because most of the time this will be the proxy target object.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object InvocationTarget { get; }
Object InvocationTarget { get; }
Field Value
The invocation target.
See Also
IAlternateMethodContext Interface
IAlternateMethodContext Members
Glimpse.Core.Extensibility Namespace


MessageBroker Property

IAlternateMethodContext MessageBroker Property Glimpse API Documentation
Gets the message broker.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IMessageBroker MessageBroker { get; }
IMessageBroker MessageBroker { get; }
Field Value
The message broker.
See Also
IAlternateMethodContext Interface
IAlternateMethodContext Members
Glimpse.Core.Extensibility Namespace


Method Property

IAlternateMethodContext Method Property Glimpse API Documentation
Gets the method representing the method being invoked on the proxy.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
MethodInfo Method { get; }
MethodInfo Method { get; }
Field Value
The method.
See Also
IAlternateMethodContext Interface
IAlternateMethodContext Members
Glimpse.Core.Extensibility Namespace


MethodInvocationTarget Property

IAlternateMethodContext MethodInvocationTarget Property Glimpse API Documentation
Gets the method info on the target class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
MethodInfo MethodInvocationTarget { get; }
MethodInfo MethodInvocationTarget { get; }
Field Value
The method invocation target.
See Also
IAlternateMethodContext Interface
IAlternateMethodContext Members
Glimpse.Core.Extensibility Namespace


Proxy Property

IAlternateMethodContext Proxy Property Glimpse API Documentation
Gets the proxy object on which the alternate implementation is invoked.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object Proxy { get; }
Object Proxy { get; }
Field Value
The proxy.
See Also
IAlternateMethodContext Interface
IAlternateMethodContext Members
Glimpse.Core.Extensibility Namespace


ProxyFactory Property

IAlternateMethodContext ProxyFactory Property Glimpse API Documentation
Gets the proxy factory.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IProxyFactory ProxyFactory { get; }
IProxyFactory ProxyFactory { get; }
Field Value
The proxy factory.
See Also
IAlternateMethodContext Interface
IAlternateMethodContext Members
Glimpse.Core.Extensibility Namespace


ReturnValue Property

IAlternateMethodContext ReturnValue Property Glimpse API Documentation
Gets or sets the return value of the method.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ReturnValue { get; set; }
Object ReturnValue { get; set; }
Field Value
The return value.
See Also
IAlternateMethodContext Interface
IAlternateMethodContext Members
Glimpse.Core.Extensibility Namespace


RuntimePolicyStrategy Property

IAlternateMethodContext RuntimePolicyStrategy Property Glimpse API Documentation
Gets the runtime policy strategy.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Func<RuntimePolicy> RuntimePolicyStrategy { get; }
Func<RuntimePolicy> RuntimePolicyStrategy { get; }
Field Value
The runtime policy strategy.
See Also
IAlternateMethodContext Interface
IAlternateMethodContext Members
Glimpse.Core.Extensibility Namespace


TargetType Property

IAlternateMethodContext TargetType Property Glimpse API Documentation
Gets the type of the target object for the intercepted method.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Type TargetType { get; }
Type TargetType { get; }
Field Value
The type of the target.
See Also
IAlternateMethodContext Interface
IAlternateMethodContext Members
Glimpse.Core.Extensibility Namespace


TimerStrategy Property

IAlternateMethodContext TimerStrategy Property Glimpse API Documentation
Gets the timer strategy.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Func<IExecutionTimer> TimerStrategy { get; }
Func<IExecutionTimer> TimerStrategy { get; }
Field Value
The timer strategy.
See Also
IAlternateMethodContext Interface
IAlternateMethodContext Members
Glimpse.Core.Extensibility Namespace


IAlternateType(T) Interface

IAlternateType T Interface Glimpse API Documentation
Definition for an alternate that should replace a given Type

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IAlternateType<T>
public interface IAlternateType<T>
Type Parameters
T
The type to retrieve and alternate for.
See Also
IAlternateType T  Members
Glimpse.Core.Extensibility Namespace


IAlternateType(T) Members

IAlternateType T Members Glimpse API Documentation

The IAlternateType T type exposes the following members.
Methods
 | Name | Description
Public method | TryCreate | Tries to create an alternate for the given target.
Back to Top
See Also
IAlternateType T Interface
Glimpse.Core.Extensibility Namespace


IAlternateType(T) Methods

IAlternateType T Methods Glimpse API Documentation
The IAlternateType T type exposes the following members.
Methods
 | Name | Description
Public method | TryCreate | Tries to create an alternate for the given target.
Back to Top
See Also
IAlternateType T Interface
Glimpse.Core.Extensibility Namespace


TryCreate Method

IAlternateType T TryCreate Method Glimpse API Documentation
Tries to create an alternate for the given target.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool TryCreate(
    T originalObj,
    out T newObj
)
bool TryCreate(
    T originalObj,
    out T newObj
)
Parameters
originalObj
Type: T
The original object.
newObj
Type: T
The new object.
Return Value
true if the create was successful, false otherwise
See Also
IAlternateType T  Interface
IAlternateType T  Members
Glimpse.Core.Extensibility Namespace


IClientScript Interface

IClientScript Interface Glimpse API Documentation
IClientScript injects <script> tags into page responses.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IClientScript
public interface IClientScript
Remarks

            There are three sub-types of IClientScript:

  1. IStaticClientScript
    IStaticClientScript's create <script> tag's with a src attribute pointing to a specific Uri.
  2. IDynamicClientScript
    IDynamicClientScript's create <script> tag's with a src attribute pointing to the Uri of a specific type of IResource.
See Also
IClientScript Members
Glimpse.Core.Extensibility Namespace


IClientScript Members

IClientScript Members Glimpse API Documentation

The IClientScript type exposes the following members.
Properties
 | Name | Description
Public property | Order | Gets the sorting order in which a <script> tag will be injected a page response, relative to other implementations of IClientScript.
Back to Top
See Also
IClientScript Interface
Glimpse.Core.Extensibility Namespace


IClientScript Properties

IClientScript Properties Glimpse API Documentation
The IClientScript type exposes the following members.
Properties
 | Name | Description
Public property | Order | Gets the sorting order in which a <script> tag will be injected a page response, relative to other implementations of IClientScript.
Back to Top
See Also
IClientScript Interface
Glimpse.Core.Extensibility Namespace


Order Property

IClientScript Order Property Glimpse API Documentation
Gets the sorting order in which a <script> tag will be injected a page response, relative to other implementations of IClientScript.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ScriptOrder Order { get; }
ScriptOrder Order { get; }
Field Value
Any value from the ScriptOrder enumeration.
Remarks

            Multiple IClientScript's with the same ScriptOrder will be sorted in an indeterminate order.

See Also
IClientScript Interface
IClientScript Members
Glimpse.Core.Extensibility Namespace


IConfigurable Interface

IConfigurable Interface Glimpse API Documentation
IConfigurable allows types to participate in their own configuration.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IConfigurable
public interface IConfigurable
Remarks

            Several IRuntimePolicy implementations leverage IConfigurable to allow for configuration via web.config.

See Also
IConfigurable Members
Glimpse.Core.Extensibility Namespace


IConfigurable Members

IConfigurable Members Glimpse API Documentation

The IConfigurable type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Provides implementations an instance of Section to self populate any end user configuration options.
Back to Top
See Also
IConfigurable Interface
Glimpse.Core.Extensibility Namespace


IConfigurable Methods

IConfigurable Methods Glimpse API Documentation
The IConfigurable type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Provides implementations an instance of Section to self populate any end user configuration options.
Back to Top
See Also
IConfigurable Interface
Glimpse.Core.Extensibility Namespace


Configure Method

IConfigurable Configure Method Glimpse API Documentation
Provides implementations an instance of Section to self populate any end user configuration options.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Configure(
    Section section
)
void Configure(
    Section section
)
Parameters
section
Type: Glimpse.Core.Configuration Section
The configuration section, <glimpse> from web.config.
See Also
IConfigurable Interface
IConfigurable Members
Glimpse.Core.Extensibility Namespace


IContext Interface

IContext Interface Glimpse API Documentation
Definition for the base context that is used by various concepts in the system. Typically uses in place of passing multiple arguments to a method.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IContext
public interface IContext
See Also
IContext Members
Glimpse.Core.Extensibility Namespace


IContext Members

IContext Members Glimpse API Documentation

The IContext type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Gets the logger.
Back to Top
See Also
IContext Interface
Glimpse.Core.Extensibility Namespace


IContext Properties

IContext Properties Glimpse API Documentation
The IContext type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Gets the logger.
Back to Top
See Also
IContext Interface
Glimpse.Core.Extensibility Namespace


Logger Property

IContext Logger Property Glimpse API Documentation
Gets the logger.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ILogger Logger { get; }
ILogger Logger { get; }
Field Value
The logger.
See Also
IContext Interface
IContext Members
Glimpse.Core.Extensibility Namespace


IDataStore Interface

IDataStore Interface Glimpse API Documentation
Definition for a data store that can be implemented as a storage strategy. This could be used to store request data in memory, to disk or any other source.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IDataStore
public interface IDataStore
Remarks

            In the case of storing requests to disk, it would mean that the system
            would still work in a multi server environment (i.e. a web farm).

See Also
IDataStore Members
Glimpse.Core.Extensibility Namespace


IDataStore Members

IDataStore Members Glimpse API Documentation

The IDataStore type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Determines whether the data store contains a definition for the specified key.
Public method | Get | Gets the specified key.
Public method | Set | Sets the specified key.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | Contains T | Determines whether store contains and item with a key of T. (Defined by DataStoreExtensions.)
Public Extension Method | Get T | Overloaded. Gets an item from store using <T> as a key. This method should be used in combination with Set<T>. (Defined by DataStoreExtensions.)
Public Extension Method | Get T (String) | Overloaded. Gets an item from store using the key and casts to <T>. (Defined by DataStoreExtensions.)
Public Extension Method | Set T | Sets an item in store using <T> as a key. This method should be used in combination with Get<T>. (Defined by DataStoreExtensions.)
Back to Top
See Also
IDataStore Interface
Glimpse.Core.Extensibility Namespace


IDataStore Methods

IDataStore Methods Glimpse API Documentation
The IDataStore type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Determines whether the data store contains a definition for the specified key.
Public method | Get | Gets the specified key.
Public method | Set | Sets the specified key.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | Contains T | Determines whether store contains and item with a key of T. (Defined by DataStoreExtensions.)
Public Extension Method | Get T | Overloaded. Gets an item from store using <T> as a key. This method should be used in combination with Set<T>. (Defined by DataStoreExtensions.)
Public Extension Method | Get T (String) | Overloaded. Gets an item from store using the key and casts to <T>. (Defined by DataStoreExtensions.)
Public Extension Method | Set T | Sets an item in store using <T> as a key. This method should be used in combination with Get<T>. (Defined by DataStoreExtensions.)
Back to Top
See Also
IDataStore Interface
Glimpse.Core.Extensibility Namespace


Contains Method

IDataStore Contains Method Glimpse API Documentation
Determines whether the data store contains a definition for the specified key.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Contains(
    string key
)
bool Contains(
    string key
)
Parameters
key
Type:   Online System String
The key.
Return Value
true if it contains the specified key; otherwise, false.
See Also
IDataStore Interface
IDataStore Members
Glimpse.Core.Extensibility Namespace


Get Method

IDataStore Get Method Glimpse API Documentation
Gets the specified key.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object Get(
    string key
)
Object Get(
    string key
)
Parameters
key
Type:   Online System String
The key.
Return Value
The value stored at given key.
See Also
IDataStore Interface
IDataStore Members
Glimpse.Core.Extensibility Namespace


Set Method

IDataStore Set Method Glimpse API Documentation
Sets the specified key.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Set(
    string key,
    Object value
)
void Set(
    string key,
    Object value
)
Parameters
key
Type:   Online System String
The key.
value
Type:   Online System Object
The value.
See Also
IDataStore Interface
IDataStore Members
Glimpse.Core.Extensibility Namespace


IDocumentation Interface

IDocumentation Interface Glimpse API Documentation
Allows a ITab to define what URI it should use if the Tab has supporting documentation.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IDocumentation
public interface IDocumentation
Remarks

            If this interface isn't implemented on a ITab no documentation will be
            provided.

See Also
IDocumentation Members
Glimpse.Core.Extensibility Namespace


IDocumentation Members

IDocumentation Members Glimpse API Documentation

The IDocumentation type exposes the following members.
Properties
 | Name | Description
Public property | DocumentationUri | Gets the documentation URI.
Back to Top
See Also
IDocumentation Interface
Glimpse.Core.Extensibility Namespace


IDocumentation Properties

IDocumentation Properties Glimpse API Documentation
The IDocumentation type exposes the following members.
Properties
 | Name | Description
Public property | DocumentationUri | Gets the documentation URI.
Back to Top
See Also
IDocumentation Interface
Glimpse.Core.Extensibility Namespace


DocumentationUri Property

IDocumentation DocumentationUri Property Glimpse API Documentation
Gets the documentation URI.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string DocumentationUri { get; }
string DocumentationUri { get; }
Field Value
The documentation URI.
See Also
IDocumentation Interface
IDocumentation Members
Glimpse.Core.Extensibility Namespace


IDynamicClientScript Interface

IDynamicClientScript Interface Glimpse API Documentation
IDynamicClientScript's are a special type of IClientScript that sets the <script> tag's src attribute to the dynamically generated Uri for the IResource of a given name.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IDynamicClientScript : IClientScript
public interface IDynamicClientScript : IClientScript
See Also
IDynamicClientScript Members
Glimpse.Core.Extensibility Namespace


IDynamicClientScript Members

IDynamicClientScript Members Glimpse API Documentation

The IDynamicClientScript type exposes the following members.
Methods
 | Name | Description
Public method | GetResourceName | Gets the name of the IResource to dynamically generate a Uri for.
Back to Top
Properties
 | Name | Description
Public property | Order | Gets the sorting order in which a <script> tag will be injected a page response, relative to other implementations of IClientScript. (Inherited from IClientScript.)
Back to Top
See Also
IDynamicClientScript Interface
Glimpse.Core.Extensibility Namespace


IDynamicClientScript Methods

IDynamicClientScript Methods Glimpse API Documentation
The IDynamicClientScript type exposes the following members.
Methods
 | Name | Description
Public method | GetResourceName | Gets the name of the IResource to dynamically generate a Uri for.
Back to Top
See Also
IDynamicClientScript Interface
Glimpse.Core.Extensibility Namespace


GetResourceName Method

IDynamicClientScript GetResourceName Method Glimpse API Documentation
Gets the name of the IResource to dynamically generate a Uri for.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string GetResourceName()
string GetResourceName()
Return Value
Name of the IResource to link to.
Remarks
IResource Uri generation is handled by implementations of ResourceEndpointConfiguration.

See Also
IDynamicClientScript Interface
IDynamicClientScript Members
Glimpse.Core.Extensibility Namespace


IDynamicClientScript Properties

IDynamicClientScript Properties Glimpse API Documentation
The IDynamicClientScript type exposes the following members.
Properties
 | Name | Description
Public property | Order | Gets the sorting order in which a <script> tag will be injected a page response, relative to other implementations of IClientScript. (Inherited from IClientScript.)
Back to Top
See Also
IDynamicClientScript Interface
Glimpse.Core.Extensibility Namespace


IExecutionTimer Interface

IExecutionTimer Interface Glimpse API Documentation
Definition for an execution timer which will track how long given executions take.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IExecutionTimer
public interface IExecutionTimer
See Also
IExecutionTimer Members
Glimpse.Core.Extensibility Namespace


IExecutionTimer Members

IExecutionTimer Members Glimpse API Documentation

The IExecutionTimer type exposes the following members.
Methods
 | Name | Description
Public method | Point | Points this instance.
Public method | Start | Starts the timer instance.
Public method | Stop | Stops the timer instance.
Public method | Time(Action) | Times the specified action. This will start and stop the timer either side of the action that is executed.
Public method | Time T (Func T ) | Times the specified function. This will start and stop the timer either side of the function that is executed.
Back to Top
Properties
 | Name | Description
Public property | RequestStart | Gets the request start date and time.
Back to Top
See Also
IExecutionTimer Interface
Glimpse.Core.Extensibility Namespace


IExecutionTimer Methods

IExecutionTimer Methods Glimpse API Documentation
The IExecutionTimer type exposes the following members.
Methods
 | Name | Description
Public method | Point | Points this instance.
Public method | Start | Starts the timer instance.
Public method | Stop | Stops the timer instance.
Public method | Time(Action) | Times the specified action. This will start and stop the timer either side of the action that is executed.
Public method | Time T (Func T ) | Times the specified function. This will start and stop the timer either side of the function that is executed.
Back to Top
See Also
IExecutionTimer Interface
Glimpse.Core.Extensibility Namespace


Point Method

IExecutionTimer Point Method Glimpse API Documentation
Points this instance.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TimerResult Point()
TimerResult Point()
Return Value
A TimerResult which represents a single point in time.
See Also
IExecutionTimer Interface
IExecutionTimer Members
Glimpse.Core.Extensibility Namespace


Start Method

IExecutionTimer Start Method Glimpse API Documentation
Starts the timer instance.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TimeSpan Start()
TimeSpan Start()
Return Value
TimeSpan that represents this timing instance.
Remarks

            If this method is used, it is up to the developer to manually stop the
            timer by calling Stop().

See Also
IExecutionTimer Interface
IExecutionTimer Members
Glimpse.Core.Extensibility Namespace


Stop Method

IExecutionTimer Stop Method Glimpse API Documentation
Stops the timer instance.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TimerResult Stop(
    TimeSpan offset
)
TimerResult Stop(
    TimeSpan offset
)
Parameters
offset
Type:   Online System TimeSpan
The offset.
Return Value
Timing info that is collected as a result of the execution.
Remarks

            Inconsistent results may be experienced if you do not call Start() before
            calling Stop().

See Also
IExecutionTimer Interface
IExecutionTimer Members
Glimpse.Core.Extensibility Namespace


Time Method

IExecutionTimer Time Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Time(Action) | Times the specified action. This will start and stop the timer either side of the action that is executed.
Public method | Time T (Func T ) | Times the specified function. This will start and stop the timer either side of the function that is executed.
Back to Top
See Also
IExecutionTimer Interface
IExecutionTimer Members
Glimpse.Core.Extensibility Namespace


Time Method (Action)

IExecutionTimer Time Method (Action) Glimpse API Documentation
Times the specified action. This will start and stop the timer either side of the action that is executed.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TimerResult Time(
    Action action
)
TimerResult Time(
    Action action
)
Parameters
action
Type:   Online System Action
The action that should be executed.
Return Value
Timing info that is collected as a result of the execution.
See Also
IExecutionTimer Interface
IExecutionTimer Members
Time Overload
Glimpse.Core.Extensibility Namespace


Time(T) Method (Func(T))

IExecutionTimer Time T Method (Func T ) Glimpse API Documentation
Times the specified function. This will start and stop the timer either side of the function that is executed.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TimerResult<T> Time<T>(
    Func<T> function
)
TimerResult<T> Time<T>(
    Func<T> function
)
Parameters
function
Type:   Online System Func  T
The function that should be executed.
Type Parameters
T
Type of result that is expected
Return Value
Timing info that is collected as a result of the execution.
See Also
IExecutionTimer Interface
IExecutionTimer Members
Time Overload
Glimpse.Core.Extensibility Namespace


IExecutionTimer Properties

IExecutionTimer Properties Glimpse API Documentation
The IExecutionTimer type exposes the following members.
Properties
 | Name | Description
Public property | RequestStart | Gets the request start date and time.
Back to Top
See Also
IExecutionTimer Interface
Glimpse.Core.Extensibility Namespace


RequestStart Property

IExecutionTimer RequestStart Property Glimpse API Documentation
Gets the request start date and time.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
DateTime RequestStart { get; }
DateTime RequestStart { get; }
Field Value

            The request start.

See Also
IExecutionTimer Interface
IExecutionTimer Members
Glimpse.Core.Extensibility Namespace


IHtmlEncoder Interface

IHtmlEncoder Interface Glimpse API Documentation
Definition for a html encoder.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IHtmlEncoder
public interface IHtmlEncoder
See Also
IHtmlEncoder Members
Glimpse.Core.Extensibility Namespace


IHtmlEncoder Members

IHtmlEncoder Members Glimpse API Documentation

The IHtmlEncoder type exposes the following members.
Methods
 | Name | Description
Public method | HtmlAttributeEncode | Encode a given value for use as an Html attribute.
Back to Top
See Also
IHtmlEncoder Interface
Glimpse.Core.Extensibility Namespace


IHtmlEncoder Methods

IHtmlEncoder Methods Glimpse API Documentation
The IHtmlEncoder type exposes the following members.
Methods
 | Name | Description
Public method | HtmlAttributeEncode | Encode a given value for use as an Html attribute.
Back to Top
See Also
IHtmlEncoder Interface
Glimpse.Core.Extensibility Namespace


HtmlAttributeEncode Method

IHtmlEncoder HtmlAttributeEncode Method Glimpse API Documentation
Encode a given value for use as an Html attribute.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string HtmlAttributeEncode(
    string input
)
string HtmlAttributeEncode(
    string input
)
Parameters
input
Type:   Online System String
The input.
Return Value
Encoded result.
See Also
IHtmlEncoder Interface
IHtmlEncoder Members
Glimpse.Core.Extensibility Namespace


IInspector Interface

IInspector Interface Glimpse API Documentation
Definition of an inspector that runs during startup. This provides the means by which a Tab can setup any listeners, proxies, etc that are needed to gather the data needed the corresponding ITab.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IInspector
public interface IInspector
Remarks

            This interface can be implemented on the same class as the ITab, but
            typically it would be implemented on a different class for separation of concerns.

See Also
IInspector Members
Glimpse.Core.Extensibility Namespace


IInspector Members

IInspector Members Glimpse API Documentation

The IInspector type exposes the following members.
Methods
 | Name | Description
Public method | Setup | Setups the specified context.
Back to Top
See Also
IInspector Interface
Glimpse.Core.Extensibility Namespace


IInspector Methods

IInspector Methods Glimpse API Documentation
The IInspector type exposes the following members.
Methods
 | Name | Description
Public method | Setup | Setups the specified context.
Back to Top
See Also
IInspector Interface
Glimpse.Core.Extensibility Namespace


Setup Method

IInspector Setup Method Glimpse API Documentation
Setups the specified context.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Setup(
    IInspectorContext context
)
void Setup(
    IInspectorContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IInspectorContext
The context.
Remarks

            Executed during the Initialize  phase of
            system startup. Specifically, with the ASP.NET provider, this is wired to/implemented by the
            System.Web.IHttpModule.Init method.

See Also
IInspector Interface
IInspector Members
Glimpse.Core.Extensibility Namespace


IInspectorContext Interface

IInspectorContext Interface Glimpse API Documentation
Definition of a context that is used by the IInspector.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IInspectorContext : IContext
public interface IInspectorContext : IContext
See Also
IInspectorContext Members
Glimpse.Core.Extensibility Namespace


IInspectorContext Members

IInspectorContext Members Glimpse API Documentation

The IInspectorContext type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Gets the logger. (Inherited from IContext.)
Public property | MessageBroker | Gets the message broker.
Public property | ProxyFactory | Gets the proxy factory.
Public property | RuntimePolicyStrategy | Gets the runtime policy strategy.
Public property | TimerStrategy | Gets the timer strategy.
Back to Top
See Also
IInspectorContext Interface
Glimpse.Core.Extensibility Namespace


IInspectorContext Properties

IInspectorContext Properties Glimpse API Documentation
The IInspectorContext type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Gets the logger. (Inherited from IContext.)
Public property | MessageBroker | Gets the message broker.
Public property | ProxyFactory | Gets the proxy factory.
Public property | RuntimePolicyStrategy | Gets the runtime policy strategy.
Public property | TimerStrategy | Gets the timer strategy.
Back to Top
See Also
IInspectorContext Interface
Glimpse.Core.Extensibility Namespace


MessageBroker Property

IInspectorContext MessageBroker Property Glimpse API Documentation
Gets the message broker.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IMessageBroker MessageBroker { get; }
IMessageBroker MessageBroker { get; }
Field Value
The message broker.
See Also
IInspectorContext Interface
IInspectorContext Members
Glimpse.Core.Extensibility Namespace


ProxyFactory Property

IInspectorContext ProxyFactory Property Glimpse API Documentation
Gets the proxy factory.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IProxyFactory ProxyFactory { get; }
IProxyFactory ProxyFactory { get; }
Field Value
The proxy factory.
See Also
IInspectorContext Interface
IInspectorContext Members
Glimpse.Core.Extensibility Namespace


RuntimePolicyStrategy Property

IInspectorContext RuntimePolicyStrategy Property Glimpse API Documentation
Gets the runtime policy strategy.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Func<RuntimePolicy> RuntimePolicyStrategy { get; }
Func<RuntimePolicy> RuntimePolicyStrategy { get; }
Field Value
The runtime policy strategy.
See Also
IInspectorContext Interface
IInspectorContext Members
Glimpse.Core.Extensibility Namespace


TimerStrategy Property

IInspectorContext TimerStrategy Property Glimpse API Documentation
Gets the timer strategy.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Func<IExecutionTimer> TimerStrategy { get; }
Func<IExecutionTimer> TimerStrategy { get; }
Field Value
The timer strategy.
See Also
IInspectorContext Interface
IInspectorContext Members
Glimpse.Core.Extensibility Namespace


IKey Interface

IKey Interface Glimpse API Documentation
IKey provides implementers a means to override the automatically generated key for an object.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IKey
public interface IKey
Remarks
IKey is used by ITab and IResource implementations that need consistent and predictable
            key names for client side interaction.

            All keys, rather dynamically generated or specified with IKey have spaces (' ') and periods ('.') removed,
            and are converted to lower case for consistency and simplification of JavaScript access.

See Also
IKey Members
Glimpse.Core.Extensibility Namespace


IKey Members

IKey Members Glimpse API Documentation

The IKey type exposes the following members.
Properties
 | Name | Description
Public property | Key | Gets the key.
Back to Top
See Also
IKey Interface
Glimpse.Core.Extensibility Namespace


IKey Properties

IKey Properties Glimpse API Documentation
The IKey type exposes the following members.
Properties
 | Name | Description
Public property | Key | Gets the key.
Back to Top
See Also
IKey Interface
Glimpse.Core.Extensibility Namespace


Key Property

IKey Key Property Glimpse API Documentation
Gets the key.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Key { get; }
string Key { get; }
Field Value
The key. Only valid JavaScript identifiers should be used for future compatibility.
See Also
IKey Interface
IKey Members
Glimpse.Core.Extensibility Namespace


ILogger Interface

ILogger Interface Glimpse API Documentation
Definition of the internal logger that will used by the system.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ILogger
public interface ILogger
See Also
ILogger Members
Glimpse.Core.Extensibility Namespace


ILogger Members

ILogger Members Glimpse API Documentation

Methods
 | Name | Description
Public method | Debug(String) | Log message at Debug level.
Public method | Debug(String, Exception) | Log message at Debug level.
Public method | Debug(String, Object ) | Log message at Debug level.
Public method | Debug(String, Exception, Object ) | Log message at Debug level.
Public method | Error(String) | Log message at Error level.
Public method | Error(String, Exception) | Log message at Error level.
Public method | Error(String, Object ) | Log message at Error level.
Public method | Error(String, Exception, Object ) | Log message at Error level.
Public method | Fatal(String) | Log message at Fatal level.
Public method | Fatal(String, Exception) | Log message at Fatal level.
Public method | Fatal(String, Object ) | Log message at Fatal level.
Public method | Fatal(String, Exception, Object ) | Log message at Fatal level.
Public method | Info(String) | Log message at Info level.
Public method | Info(String, Exception) | Log message at Info level.
Public method | Info(String, Object ) | Log message at Info level.
Public method | Info(String, Exception, Object ) | Log message at Info level.
Public method | Trace(String) | Log message at Trace level.
Public method | Trace(String, Exception) | Log message at Trace level.
Public method | Trace(String, Object ) | Log message at Trace level.
Public method | Trace(String, Exception, Object ) | Log message at Trace level.
Public method | Warn(String) | Log message at Warn level.
Public method | Warn(String, Exception) | Log message at Warn level.
Public method | Warn(String, Object ) | Log message at Warn level.
Public method | Warn(String, Exception, Object ) | Log message at Warn level.
Back to Top
See Also
ILogger Interface
Glimpse.Core.Extensibility Namespace


ILogger Methods

ILogger Methods Glimpse API Documentation
Methods
 | Name | Description
Public method | Debug(String) | Log message at Debug level.
Public method | Debug(String, Exception) | Log message at Debug level.
Public method | Debug(String, Object ) | Log message at Debug level.
Public method | Debug(String, Exception, Object ) | Log message at Debug level.
Public method | Error(String) | Log message at Error level.
Public method | Error(String, Exception) | Log message at Error level.
Public method | Error(String, Object ) | Log message at Error level.
Public method | Error(String, Exception, Object ) | Log message at Error level.
Public method | Fatal(String) | Log message at Fatal level.
Public method | Fatal(String, Exception) | Log message at Fatal level.
Public method | Fatal(String, Object ) | Log message at Fatal level.
Public method | Fatal(String, Exception, Object ) | Log message at Fatal level.
Public method | Info(String) | Log message at Info level.
Public method | Info(String, Exception) | Log message at Info level.
Public method | Info(String, Object ) | Log message at Info level.
Public method | Info(String, Exception, Object ) | Log message at Info level.
Public method | Trace(String) | Log message at Trace level.
Public method | Trace(String, Exception) | Log message at Trace level.
Public method | Trace(String, Object ) | Log message at Trace level.
Public method | Trace(String, Exception, Object ) | Log message at Trace level.
Public method | Warn(String) | Log message at Warn level.
Public method | Warn(String, Exception) | Log message at Warn level.
Public method | Warn(String, Object ) | Log message at Warn level.
Public method | Warn(String, Exception, Object ) | Log message at Warn level.
Back to Top
See Also
ILogger Interface
Glimpse.Core.Extensibility Namespace


Debug Method

ILogger Debug Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Debug(String) | Log message at Debug level.
Public method | Debug(String, Exception) | Log message at Debug level.
Public method | Debug(String, Object ) | Log message at Debug level.
Public method | Debug(String, Exception, Object ) | Log message at Debug level.
Back to Top
See Also
ILogger Interface
ILogger Members
Glimpse.Core.Extensibility Namespace


Debug Method (String)

ILogger Debug Method (String) Glimpse API Documentation
Log message at Debug level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Debug(
    string message
)
void Debug(
    string message
)
Parameters
message
Type:   Online System String
The message.
See Also
ILogger Interface
ILogger Members
Debug Overload
Glimpse.Core.Extensibility Namespace


Debug Method (String, Exception)

ILogger Debug Method (String, Exception) Glimpse API Documentation
Log message at Debug level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Debug(
    string message,
    Exception exception
)
void Debug(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
See Also
ILogger Interface
ILogger Members
Debug Overload
Glimpse.Core.Extensibility Namespace


Debug Method (String, Object[])

ILogger Debug Method (String, Object ) Glimpse API Documentation
Log message at Debug level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Debug(
    string messageFormat,
    params Object[] args
)
void Debug(
    string messageFormat,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
args
Type:    Online System Object
The args.
See Also
ILogger Interface
ILogger Members
Debug Overload
Glimpse.Core.Extensibility Namespace


Debug Method (String, Exception, Object[])

ILogger Debug Method (String, Exception, Object ) Glimpse API Documentation
Log message at Debug level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Debug(
    string messageFormat,
    Exception exception,
    params Object[] args
)
void Debug(
    string messageFormat,
    Exception exception,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
exception
Type:   Online System Exception
The exception.
args
Type:    Online System Object
The args.
See Also
ILogger Interface
ILogger Members
Debug Overload
Glimpse.Core.Extensibility Namespace


Error Method

ILogger Error Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Error(String) | Log message at Error level.
Public method | Error(String, Exception) | Log message at Error level.
Public method | Error(String, Object ) | Log message at Error level.
Public method | Error(String, Exception, Object ) | Log message at Error level.
Back to Top
See Also
ILogger Interface
ILogger Members
Glimpse.Core.Extensibility Namespace


Error Method (String)

ILogger Error Method (String) Glimpse API Documentation
Log message at Error level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Error(
    string message
)
void Error(
    string message
)
Parameters
message
Type:   Online System String
The message.
See Also
ILogger Interface
ILogger Members
Error Overload
Glimpse.Core.Extensibility Namespace


Error Method (String, Exception)

ILogger Error Method (String, Exception) Glimpse API Documentation
Log message at Error level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Error(
    string message,
    Exception exception
)
void Error(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
See Also
ILogger Interface
ILogger Members
Error Overload
Glimpse.Core.Extensibility Namespace


Error Method (String, Object[])

ILogger Error Method (String, Object ) Glimpse API Documentation
Log message at Error level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Error(
    string messageFormat,
    params Object[] args
)
void Error(
    string messageFormat,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
args
Type:    Online System Object
The args.
See Also
ILogger Interface
ILogger Members
Error Overload
Glimpse.Core.Extensibility Namespace


Error Method (String, Exception, Object[])

ILogger Error Method (String, Exception, Object ) Glimpse API Documentation
Log message at Error level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Error(
    string messageFormat,
    Exception exception,
    params Object[] args
)
void Error(
    string messageFormat,
    Exception exception,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
exception
Type:   Online System Exception
The exception.
args
Type:    Online System Object
The args.
See Also
ILogger Interface
ILogger Members
Error Overload
Glimpse.Core.Extensibility Namespace


Fatal Method

ILogger Fatal Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Fatal(String) | Log message at Fatal level.
Public method | Fatal(String, Exception) | Log message at Fatal level.
Public method | Fatal(String, Object ) | Log message at Fatal level.
Public method | Fatal(String, Exception, Object ) | Log message at Fatal level.
Back to Top
See Also
ILogger Interface
ILogger Members
Glimpse.Core.Extensibility Namespace


Fatal Method (String)

ILogger Fatal Method (String) Glimpse API Documentation
Log message at Fatal level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Fatal(
    string message
)
void Fatal(
    string message
)
Parameters
message
Type:   Online System String
The message.
See Also
ILogger Interface
ILogger Members
Fatal Overload
Glimpse.Core.Extensibility Namespace


Fatal Method (String, Exception)

ILogger Fatal Method (String, Exception) Glimpse API Documentation
Log message at Fatal level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Fatal(
    string message,
    Exception exception
)
void Fatal(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
See Also
ILogger Interface
ILogger Members
Fatal Overload
Glimpse.Core.Extensibility Namespace


Fatal Method (String, Object[])

ILogger Fatal Method (String, Object ) Glimpse API Documentation
Log message at Fatal level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Fatal(
    string messageFormat,
    params Object[] args
)
void Fatal(
    string messageFormat,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
args
Type:    Online System Object
The args.
See Also
ILogger Interface
ILogger Members
Fatal Overload
Glimpse.Core.Extensibility Namespace


Fatal Method (String, Exception, Object[])

ILogger Fatal Method (String, Exception, Object ) Glimpse API Documentation
Log message at Fatal level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Fatal(
    string messageFormat,
    Exception exception,
    params Object[] args
)
void Fatal(
    string messageFormat,
    Exception exception,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
exception
Type:   Online System Exception
The exception.
args
Type:    Online System Object
The args.
See Also
ILogger Interface
ILogger Members
Fatal Overload
Glimpse.Core.Extensibility Namespace


Info Method

ILogger Info Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Info(String) | Log message at Info level.
Public method | Info(String, Exception) | Log message at Info level.
Public method | Info(String, Object ) | Log message at Info level.
Public method | Info(String, Exception, Object ) | Log message at Info level.
Back to Top
See Also
ILogger Interface
ILogger Members
Glimpse.Core.Extensibility Namespace


Info Method (String)

ILogger Info Method (String) Glimpse API Documentation
Log message at Info level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Info(
    string message
)
void Info(
    string message
)
Parameters
message
Type:   Online System String
The message.
See Also
ILogger Interface
ILogger Members
Info Overload
Glimpse.Core.Extensibility Namespace


Info Method (String, Exception)

ILogger Info Method (String, Exception) Glimpse API Documentation
Log message at Info level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Info(
    string message,
    Exception exception
)
void Info(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
See Also
ILogger Interface
ILogger Members
Info Overload
Glimpse.Core.Extensibility Namespace


Info Method (String, Object[])

ILogger Info Method (String, Object ) Glimpse API Documentation
Log message at Info level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Info(
    string messageFormat,
    params Object[] args
)
void Info(
    string messageFormat,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
args
Type:    Online System Object
The args.
See Also
ILogger Interface
ILogger Members
Info Overload
Glimpse.Core.Extensibility Namespace


Info Method (String, Exception, Object[])

ILogger Info Method (String, Exception, Object ) Glimpse API Documentation
Log message at Info level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Info(
    string messageFormat,
    Exception exception,
    params Object[] args
)
void Info(
    string messageFormat,
    Exception exception,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
exception
Type:   Online System Exception
The exception.
args
Type:    Online System Object
The args.
See Also
ILogger Interface
ILogger Members
Info Overload
Glimpse.Core.Extensibility Namespace


Trace Method

ILogger Trace Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Trace(String) | Log message at Trace level.
Public method | Trace(String, Exception) | Log message at Trace level.
Public method | Trace(String, Object ) | Log message at Trace level.
Public method | Trace(String, Exception, Object ) | Log message at Trace level.
Back to Top
See Also
ILogger Interface
ILogger Members
Glimpse.Core.Extensibility Namespace


Trace Method (String)

ILogger Trace Method (String) Glimpse API Documentation
Log message at Trace level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Trace(
    string message
)
void Trace(
    string message
)
Parameters
message
Type:   Online System String
The message.
See Also
ILogger Interface
ILogger Members
Trace Overload
Glimpse.Core.Extensibility Namespace


Trace Method (String, Exception)

ILogger Trace Method (String, Exception) Glimpse API Documentation
Log message at Trace level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Trace(
    string message,
    Exception exception
)
void Trace(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
See Also
ILogger Interface
ILogger Members
Trace Overload
Glimpse.Core.Extensibility Namespace


Trace Method (String, Object[])

ILogger Trace Method (String, Object ) Glimpse API Documentation
Log message at Trace level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Trace(
    string messageFormat,
    params Object[] args
)
void Trace(
    string messageFormat,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
args
Type:    Online System Object
The args.
See Also
ILogger Interface
ILogger Members
Trace Overload
Glimpse.Core.Extensibility Namespace


Trace Method (String, Exception, Object[])

ILogger Trace Method (String, Exception, Object ) Glimpse API Documentation
Log message at Trace level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Trace(
    string messageFormat,
    Exception exception,
    params Object[] args
)
void Trace(
    string messageFormat,
    Exception exception,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
exception
Type:   Online System Exception
The exception.
args
Type:    Online System Object
The args.
See Also
ILogger Interface
ILogger Members
Trace Overload
Glimpse.Core.Extensibility Namespace


Warn Method

ILogger Warn Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Warn(String) | Log message at Warn level.
Public method | Warn(String, Exception) | Log message at Warn level.
Public method | Warn(String, Object ) | Log message at Warn level.
Public method | Warn(String, Exception, Object ) | Log message at Warn level.
Back to Top
See Also
ILogger Interface
ILogger Members
Glimpse.Core.Extensibility Namespace


Warn Method (String)

ILogger Warn Method (String) Glimpse API Documentation
Log message at Warn level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Warn(
    string message
)
void Warn(
    string message
)
Parameters
message
Type:   Online System String
The message.
See Also
ILogger Interface
ILogger Members
Warn Overload
Glimpse.Core.Extensibility Namespace


Warn Method (String, Exception)

ILogger Warn Method (String, Exception) Glimpse API Documentation
Log message at Warn level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Warn(
    string message,
    Exception exception
)
void Warn(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
See Also
ILogger Interface
ILogger Members
Warn Overload
Glimpse.Core.Extensibility Namespace


Warn Method (String, Object[])

ILogger Warn Method (String, Object ) Glimpse API Documentation
Log message at Warn level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Warn(
    string messageFormat,
    params Object[] args
)
void Warn(
    string messageFormat,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
args
Type:    Online System Object
The args.
See Also
ILogger Interface
ILogger Members
Warn Overload
Glimpse.Core.Extensibility Namespace


Warn Method (String, Exception, Object[])

ILogger Warn Method (String, Exception, Object ) Glimpse API Documentation
Log message at Warn level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Warn(
    string messageFormat,
    Exception exception,
    params Object[] args
)
void Warn(
    string messageFormat,
    Exception exception,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
exception
Type:   Online System Exception
The exception.
args
Type:    Online System Object
The args.
See Also
ILogger Interface
ILogger Members
Warn Overload
Glimpse.Core.Extensibility Namespace


IMessageBroker Interface

IMessageBroker Interface Glimpse API Documentation
Definition of the Message Broker that will used by the system.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IMessageBroker
public interface IMessageBroker
See Also
IMessageBroker Members
Glimpse.Core.Extensibility Namespace


IMessageBroker Members

IMessageBroker Members Glimpse API Documentation

The IMessageBroker type exposes the following members.
Methods
 | Name | Description
Public method | Publish T | Publishes the specified message using the type as the topic.
Public method | Subscribe T | Subscribes the specified action to the Type specified.
Public method | Unsubscribe T | Unsubscribes the listener from the specified subscription id.
Back to Top
See Also
IMessageBroker Interface
Glimpse.Core.Extensibility Namespace


IMessageBroker Methods

IMessageBroker Methods Glimpse API Documentation
The IMessageBroker type exposes the following members.
Methods
 | Name | Description
Public method | Publish T | Publishes the specified message using the type as the topic.
Public method | Subscribe T | Subscribes the specified action to the Type specified.
Public method | Unsubscribe T | Unsubscribes the listener from the specified subscription id.
Back to Top
See Also
IMessageBroker Interface
Glimpse.Core.Extensibility Namespace


Publish(T) Method

IMessageBroker Publish T Method Glimpse API Documentation
Publishes the specified message using the type as the topic.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Publish<T>(
    T message
)
void Publish<T>(
    T message
)
Parameters
message
Type: T
The message.
Type Parameters
T
Type of the message
See Also
IMessageBroker Interface
IMessageBroker Members
Glimpse.Core.Extensibility Namespace


Subscribe(T) Method

IMessageBroker Subscribe T Method Glimpse API Documentation
Subscribes the specified action to the Type specified.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Guid Subscribe<T>(
    Action<T> action
)
Guid Subscribe<T>(
    Action<T> action
)
Parameters
action
Type:   Online System Action  T
The action.
Type Parameters
T
Type of the message
Return Value
A subscription Id, which should be retained in order to unsubscribe.
See Also
IMessageBroker Interface
IMessageBroker Members
Glimpse.Core.Extensibility Namespace


Unsubscribe(T) Method

IMessageBroker Unsubscribe T Method Glimpse API Documentation
Unsubscribes the listener from the specified subscription id.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Unsubscribe<T>(
    Guid subscriptionId
)
void Unsubscribe<T>(
    Guid subscriptionId
)
Parameters
subscriptionId
Type:   Online System Guid
The subscription id.
Type Parameters
T
Type of the message
See Also
IMessageBroker Interface
IMessageBroker Members
Glimpse.Core.Extensibility Namespace


InspectorContext Class

InspectorContext Class Glimpse API Documentation
The context passed into the Setup method of IInspector.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility InspectorContext

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class InspectorContext : IInspectorContext,
    IContext
public class InspectorContext : IInspectorContext,
    IContext
See Also
InspectorContext Members
Glimpse.Core.Extensibility Namespace


InspectorContext Members

InspectorContext Members Glimpse API Documentation

The InspectorContext type exposes the following members.
Constructors
 | Name | Description
Public method | InspectorContext | Initializes a new instance of the InspectorContext class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Logger | Gets or sets the logger.
Public property | MessageBroker | Gets or sets the message broker.
Public property | ProxyFactory | Gets or sets the proxy factory.
Public property | RuntimePolicyStrategy | Gets or sets the runtime policy strategy.
Public property | TimerStrategy | Gets or sets the timer strategy.
Back to Top
See Also
InspectorContext Class
Glimpse.Core.Extensibility Namespace


InspectorContext Constructor

InspectorContext Constructor Glimpse API Documentation
Initializes a new instance of the InspectorContext class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InspectorContext(
    ILogger logger,
    IProxyFactory proxyFactory,
    IMessageBroker messageBroker,
    Func<IExecutionTimer> timerStrategy,
    Func<RuntimePolicy> runtimePolicyStrategy
)
public InspectorContext(
    ILogger logger,
    IProxyFactory proxyFactory,
    IMessageBroker messageBroker,
    Func<IExecutionTimer> timerStrategy,
    Func<RuntimePolicy> runtimePolicyStrategy
)
Parameters
logger
Type: Glimpse.Core.Extensibility ILogger
The logger.
proxyFactory
Type: Glimpse.Core.Extensibility IProxyFactory
The proxy factory.
messageBroker
Type: Glimpse.Core.Extensibility IMessageBroker
The message broker.
timerStrategy
Type:   Online System Func  IExecutionTimer
The timer strategy.
runtimePolicyStrategy
Type:   Online System Func  RuntimePolicy
The runtime policy strategy.
Exceptions
Exception | Condition
Online System ArgumentNullException | Throws an exception if any parameter if null.
See Also
InspectorContext Class
InspectorContext Members
Glimpse.Core.Extensibility Namespace


InspectorContext Methods

InspectorContext Methods Glimpse API Documentation
The InspectorContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
InspectorContext Class
Glimpse.Core.Extensibility Namespace


InspectorContext Properties

InspectorContext Properties Glimpse API Documentation
The InspectorContext type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Gets or sets the logger.
Public property | MessageBroker | Gets or sets the message broker.
Public property | ProxyFactory | Gets or sets the proxy factory.
Public property | RuntimePolicyStrategy | Gets or sets the runtime policy strategy.
Public property | TimerStrategy | Gets or sets the timer strategy.
Back to Top
See Also
InspectorContext Class
Glimpse.Core.Extensibility Namespace


Logger Property

InspectorContext Logger Property Glimpse API Documentation
Gets or sets the logger.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILogger Logger { get; set; }
public ILogger Logger { get; set; }
Field Value

            The logger.

Implements
IContext Logger
See Also
InspectorContext Class
InspectorContext Members
Glimpse.Core.Extensibility Namespace


MessageBroker Property

InspectorContext MessageBroker Property Glimpse API Documentation
Gets or sets the message broker.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IMessageBroker MessageBroker { get; set; }
public IMessageBroker MessageBroker { get; set; }
Field Value

            The message broker.

Implements
IInspectorContext MessageBroker
See Also
InspectorContext Class
InspectorContext Members
Glimpse.Core.Extensibility Namespace


ProxyFactory Property

InspectorContext ProxyFactory Property Glimpse API Documentation
Gets or sets the proxy factory.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IProxyFactory ProxyFactory { get; set; }
public IProxyFactory ProxyFactory { get; set; }
Field Value

            The proxy factory.

Implements
IInspectorContext ProxyFactory
See Also
InspectorContext Class
InspectorContext Members
Glimpse.Core.Extensibility Namespace


RuntimePolicyStrategy Property

InspectorContext RuntimePolicyStrategy Property Glimpse API Documentation
Gets or sets the runtime policy strategy.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Func<RuntimePolicy> RuntimePolicyStrategy { get; set; }
public Func<RuntimePolicy> RuntimePolicyStrategy { get; set; }
Field Value

            The runtime policy strategy.

Implements
IInspectorContext RuntimePolicyStrategy
See Also
InspectorContext Class
InspectorContext Members
Glimpse.Core.Extensibility Namespace


TimerStrategy Property

InspectorContext TimerStrategy Property Glimpse API Documentation
Gets or sets the timer strategy.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Func<IExecutionTimer> TimerStrategy { get; set; }
public Func<IExecutionTimer> TimerStrategy { get; set; }
Field Value

            The timer strategy.

Implements
IInspectorContext TimerStrategy
See Also
InspectorContext Class
InspectorContext Members
Glimpse.Core.Extensibility Namespace


IParameterValueProvider Interface

IParameterValueProvider Interface Glimpse API Documentation
IParameterValueProvider provides a mechanism to override or append Uri template parameter values when generating an IDynamicClientScript's corresponding IResource Uri.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IParameterValueProvider
public interface IParameterValueProvider
See Also
IParameterValueProvider Members
Glimpse.Core.Extensibility Namespace


IParameterValueProvider Members

IParameterValueProvider Members Glimpse API Documentation

The IParameterValueProvider type exposes the following members.
Methods
 | Name | Description
Public method | OverrideParameterValues | Used to override or append Uri template parameter values to the values required for the IDynamicClientScript.
Back to Top
See Also
IParameterValueProvider Interface
Glimpse.Core.Extensibility Namespace


IParameterValueProvider Methods

IParameterValueProvider Methods Glimpse API Documentation
The IParameterValueProvider type exposes the following members.
Methods
 | Name | Description
Public method | OverrideParameterValues | Used to override or append Uri template parameter values to the values required for the IDynamicClientScript.
Back to Top
See Also
IParameterValueProvider Interface
Glimpse.Core.Extensibility Namespace


OverrideParameterValues Method

IParameterValueProvider OverrideParameterValues Method Glimpse API Documentation
Used to override or append Uri template parameter values to the values required for the IDynamicClientScript.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void OverrideParameterValues(
    IDictionary<string, string> defaults
)
void OverrideParameterValues(
    IDictionary<string, string> defaults
)
Parameters
defaults
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
The default Uri template parameter values as defined by the Glimpse server.
See Also
IParameterValueProvider Interface
IParameterValueProvider Members
Glimpse.Core.Extensibility Namespace


IProxyFactory Interface

IProxyFactory Interface Glimpse API Documentation

Definition of a factory that can create proxies of given objects/types. Factory supports wrapping a interfaces, wrapping a class or extending a class.

Wrapping takes a target instance, generates a new type that extends the input types and injects the target object within the new instance. Extends takes a type and generates a new type that extends it.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IProxyFactory
public interface IProxyFactory
Remarks

            When selecting a class to wrap or extend, it is important to know what constructors
            you have and whether a default constructor is available.

            When a method is called on a wrapped target, it is important to note that once the
            targets version of that method is called, no other method on the proxy will be called.
            This can become important if you are try to wrap multiple methods where one calls the
            other.

            When a method is called on a extended class, it is important to note that the new
            class will behave differently to that of a wrapped classes. Meaning that if you have
            multiple methods that you are providing alternates for, if one calls the other, the
            alternate will be called on both methods.

See Also
IProxyFactory Members
Glimpse.Core.Extensibility Namespace


IProxyFactory Members

IProxyFactory Members Glimpse API Documentation

The IProxyFactory type exposes the following members.
Methods
 | Name | Description
Public method | ExtendClass T (IEnumerable IAlternateMethod ) | Extends the class.
Public method | ExtendClass T (IEnumerable IAlternateMethod , IEnumerable Object ) | Extends the class.
Public method | ExtendClass T (IEnumerable IAlternateMethod , IEnumerable Object , IEnumerable Object ) | Extends the class.
Public method | IsExtendClassEligible | Determines whether the specified type is extend class eligible.
Public method | IsWrapClassEligible | Determines whether the specified type is wrap class eligible.
Public method | IsWrapInterfaceEligible TToWrap | Determines whether the specified type is wrap interface eligible.
Public method | WrapClass T (T, IEnumerable IAlternateMethod ) | Wraps the class.
Public method | WrapClass T (T, IEnumerable IAlternateMethod , IEnumerable Object ) | Wraps the class.
Public method | WrapClass T (T, IEnumerable IAlternateMethod , IEnumerable Object , IEnumerable Object ) | Wraps the class.
Public method | WrapInterface T (T, IEnumerable IAlternateMethod ) | Wraps the interface.
Public method | WrapInterface T (T, IEnumerable IAlternateMethod , IEnumerable Object ) | Wraps the interface.
Back to Top
See Also
IProxyFactory Interface
Glimpse.Core.Extensibility Namespace


IProxyFactory Methods

IProxyFactory Methods Glimpse API Documentation
The IProxyFactory type exposes the following members.
Methods
 | Name | Description
Public method | ExtendClass T (IEnumerable IAlternateMethod ) | Extends the class.
Public method | ExtendClass T (IEnumerable IAlternateMethod , IEnumerable Object ) | Extends the class.
Public method | ExtendClass T (IEnumerable IAlternateMethod , IEnumerable Object , IEnumerable Object ) | Extends the class.
Public method | IsExtendClassEligible | Determines whether the specified type is extend class eligible.
Public method | IsWrapClassEligible | Determines whether the specified type is wrap class eligible.
Public method | IsWrapInterfaceEligible TToWrap | Determines whether the specified type is wrap interface eligible.
Public method | WrapClass T (T, IEnumerable IAlternateMethod ) | Wraps the class.
Public method | WrapClass T (T, IEnumerable IAlternateMethod , IEnumerable Object ) | Wraps the class.
Public method | WrapClass T (T, IEnumerable IAlternateMethod , IEnumerable Object , IEnumerable Object ) | Wraps the class.
Public method | WrapInterface T (T, IEnumerable IAlternateMethod ) | Wraps the interface.
Public method | WrapInterface T (T, IEnumerable IAlternateMethod , IEnumerable Object ) | Wraps the interface.
Back to Top
See Also
IProxyFactory Interface
Glimpse.Core.Extensibility Namespace


ExtendClass Method

IProxyFactory ExtendClass Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | ExtendClass T (IEnumerable IAlternateMethod ) | Extends the class.
Public method | ExtendClass T (IEnumerable IAlternateMethod , IEnumerable Object ) | Extends the class.
Public method | ExtendClass T (IEnumerable IAlternateMethod , IEnumerable Object , IEnumerable Object ) | Extends the class.
Back to Top
See Also
IProxyFactory Interface
IProxyFactory Members
Glimpse.Core.Extensibility Namespace


ExtendClass(T) Method (IEnumerable(IAlternateMethod))

IProxyFactory ExtendClass T Method (IEnumerable IAlternateMethod ) Glimpse API Documentation
Extends the class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T ExtendClass<T>(
    IEnumerable<IAlternateMethod> methodImplementations
)
where T : class
T ExtendClass<T>(
    IEnumerable<IAlternateMethod> methodImplementations
)
where T : class
Parameters
methodImplementations
Type:   Online System.Collections.Generic IEnumerable  IAlternateMethod
The method implementations.
Type Parameters
T
Instance type
Return Value
Extended instance.
See Also
IProxyFactory Interface
IProxyFactory Members
ExtendClass Overload
Glimpse.Core.Extensibility Namespace


ExtendClass(T) Method (IEnumerable(IAlternateMethod), IEnumerable(Object))

IProxyFactory ExtendClass T Method (IEnumerable IAlternateMethod , IEnumerable Object ) Glimpse API Documentation
Extends the class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T ExtendClass<T>(
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins
)
where T : class
T ExtendClass<T>(
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins
)
where T : class
Parameters
methodImplementations
Type:   Online System.Collections.Generic IEnumerable  IAlternateMethod
The method implementations.
mixins
Type:   Online System.Collections.Generic IEnumerable    Online Object
The mixins.
Type Parameters
T
Instance type
Return Value
Extended instance.
See Also
IProxyFactory Interface
IProxyFactory Members
ExtendClass Overload
Glimpse.Core.Extensibility Namespace


ExtendClass(T) Method (IEnumerable(IAlternateMethod), IEnumerable(Object), IEnumerable(Object))

IProxyFactory ExtendClass T Method (IEnumerable IAlternateMethod , IEnumerable Object , IEnumerable Object ) Glimpse API Documentation
Extends the class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T ExtendClass<T>(
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins,
    IEnumerable<Object> constructorArguments
)
where T : class
T ExtendClass<T>(
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins,
    IEnumerable<Object> constructorArguments
)
where T : class
Parameters
methodImplementations
Type:   Online System.Collections.Generic IEnumerable  IAlternateMethod
The method implementations.
mixins
Type:   Online System.Collections.Generic IEnumerable    Online Object
The mixins.
constructorArguments
Type:   Online System.Collections.Generic IEnumerable    Online Object
The constructor arguments.
Type Parameters
T
Instance type
Return Value
Extended instance.
See Also
IProxyFactory Interface
IProxyFactory Members
ExtendClass Overload
Glimpse.Core.Extensibility Namespace


IsExtendClassEligible Method

IProxyFactory IsExtendClassEligible Method Glimpse API Documentation
Determines whether the specified type is extend class eligible.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsExtendClassEligible(
    Type type
)
bool IsExtendClassEligible(
    Type type
)
Parameters
type
Type:   Online System Type
The type.
Return Value
true if [is extend class eligible] [the specified type]; otherwise, false.
See Also
IProxyFactory Interface
IProxyFactory Members
Glimpse.Core.Extensibility Namespace


IsWrapClassEligible Method

IProxyFactory IsWrapClassEligible Method Glimpse API Documentation
Determines whether the specified type is wrap class eligible.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsWrapClassEligible(
    Type type
)
bool IsWrapClassEligible(
    Type type
)
Parameters
type
Type:   Online System Type
The type.
Return Value
true if [is wrap class eligible] [the specified type]; otherwise, false.
Remarks

            Wrapping takes a target instance, generates a new type that extends
            the input types and injects the target object within the new instance.

See Also
IProxyFactory Interface
IProxyFactory Members
Glimpse.Core.Extensibility Namespace


IsWrapInterfaceEligible(TToWrap) Method

IProxyFactory IsWrapInterfaceEligible TToWrap Method Glimpse API Documentation
Determines whether the specified type is wrap interface eligible.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsWrapInterfaceEligible<TToWrap>(
    Type type
)
bool IsWrapInterfaceEligible<TToWrap>(
    Type type
)
Parameters
type
Type:   Online System Type
The type.
Type Parameters
TToWrap
The type of the T to wrap.
Return Value
true if [is wrap interface eligible] [the specified type]; otherwise, false.
Remarks

            Wrapping takes a target instance, generates a new type that extends
            the input types and injects the target object within the new instance.

See Also
IProxyFactory Interface
IProxyFactory Members
Glimpse.Core.Extensibility Namespace


WrapClass Method

IProxyFactory WrapClass Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | WrapClass T (T, IEnumerable IAlternateMethod ) | Wraps the class.
Public method | WrapClass T (T, IEnumerable IAlternateMethod , IEnumerable Object ) | Wraps the class.
Public method | WrapClass T (T, IEnumerable IAlternateMethod , IEnumerable Object , IEnumerable Object ) | Wraps the class.
Back to Top
See Also
IProxyFactory Interface
IProxyFactory Members
Glimpse.Core.Extensibility Namespace


WrapClass(T) Method (T, IEnumerable(IAlternateMethod))

IProxyFactory WrapClass T Method (T, IEnumerable IAlternateMethod ) Glimpse API Documentation
Wraps the class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T WrapClass<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations
)
where T : class
T WrapClass<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations
)
where T : class
Parameters
instance
Type: T
The instance.
methodImplementations
Type:   Online System.Collections.Generic IEnumerable  IAlternateMethod
The method implementations.
Type Parameters
T
Instance type
Return Value
Wrapped instance.
Remarks

            Wrapping takes a target instance, generates a new type that extends
            the input types and injects the target object within the new instance.

See Also
IProxyFactory Interface
IProxyFactory Members
WrapClass Overload
Glimpse.Core.Extensibility Namespace


WrapClass(T) Method (T, IEnumerable(IAlternateMethod), IEnumerable(Object))

IProxyFactory WrapClass T Method (T, IEnumerable IAlternateMethod , IEnumerable Object ) Glimpse API Documentation
Wraps the class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T WrapClass<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins
)
where T : class
T WrapClass<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins
)
where T : class
Parameters
instance
Type: T
The instance.
methodImplementations
Type:   Online System.Collections.Generic IEnumerable  IAlternateMethod
The method implementations.
mixins
Type:   Online System.Collections.Generic IEnumerable    Online Object
The mixins.
Type Parameters
T
Instance type
Return Value
Wrapped instance.
Remarks

            Wrapping takes a target instance, generates a new type that extends
            the input types and injects the target object within the new instance.

See Also
IProxyFactory Interface
IProxyFactory Members
WrapClass Overload
Glimpse.Core.Extensibility Namespace


WrapClass(T) Method (T, IEnumerable(IAlternateMethod), IEnumerable(Object), IEnumerable(Object))

IProxyFactory WrapClass T Method (T, IEnumerable IAlternateMethod , IEnumerable Object , IEnumerable Object ) Glimpse API Documentation
Wraps the class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T WrapClass<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins,
    IEnumerable<Object> constructorArguments
)
where T : class
T WrapClass<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins,
    IEnumerable<Object> constructorArguments
)
where T : class
Parameters
instance
Type: T
The instance.
methodImplementations
Type:   Online System.Collections.Generic IEnumerable  IAlternateMethod
The method implementations.
mixins
Type:   Online System.Collections.Generic IEnumerable    Online Object
The mixins.
constructorArguments
Type:   Online System.Collections.Generic IEnumerable    Online Object
The constructor arguments.
Type Parameters
T
Instance type
Return Value
Wrapped instance.
Remarks

            Wrapping takes a target instance, generates a new type that extends
            the input types and injects the target object within the new instance.

See Also
IProxyFactory Interface
IProxyFactory Members
WrapClass Overload
Glimpse.Core.Extensibility Namespace


WrapInterface Method

IProxyFactory WrapInterface Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | WrapInterface T (T, IEnumerable IAlternateMethod ) | Wraps the interface.
Public method | WrapInterface T (T, IEnumerable IAlternateMethod , IEnumerable Object ) | Wraps the interface.
Back to Top
See Also
IProxyFactory Interface
IProxyFactory Members
Glimpse.Core.Extensibility Namespace


WrapInterface(T) Method (T, IEnumerable(IAlternateMethod))

IProxyFactory WrapInterface T Method (T, IEnumerable IAlternateMethod ) Glimpse API Documentation
Wraps the interface.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T WrapInterface<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations
)
where T : class
T WrapInterface<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations
)
where T : class
Parameters
instance
Type: T
The instance.
methodImplementations
Type:   Online System.Collections.Generic IEnumerable  IAlternateMethod
The method implementations.
Type Parameters
T
Instance type
Return Value
Wrapped instance.
Remarks

            Wrapping takes a target instance, generates a new type that extends
            the input types and injects the target object within the new instance.

See Also
IProxyFactory Interface
IProxyFactory Members
WrapInterface Overload
Glimpse.Core.Extensibility Namespace


WrapInterface(T) Method (T, IEnumerable(IAlternateMethod), IEnumerable(Object))

IProxyFactory WrapInterface T Method (T, IEnumerable IAlternateMethod , IEnumerable Object ) Glimpse API Documentation
Wraps the interface.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T WrapInterface<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins
)
where T : class
T WrapInterface<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins
)
where T : class
Parameters
instance
Type: T
The instance.
methodImplementations
Type:   Online System.Collections.Generic IEnumerable  IAlternateMethod
The method implementations.
mixins
Type:   Online System.Collections.Generic IEnumerable    Online Object
The mixins.
Type Parameters
T
Instance type
Return Value
Wrapped instance.
Remarks

            Wrapping takes a target instance, generates a new type that extends
            the input types and injects the target object within the new instance.

See Also
IProxyFactory Interface
IProxyFactory Members
WrapInterface Overload
Glimpse.Core.Extensibility Namespace


IResource Interface

IResource Interface Glimpse API Documentation

IResource provides Glimpse clients with data and assets for rendering to the end user.

When implemented, a resource will be discovered and added to the collection of resources.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IResource
public interface IResource
See Also
IResource Members
Glimpse.Core.Extensibility Namespace


IResource Members

IResource Members Glimpse API Documentation

The IResource type exposes the following members.
Methods
 | Name | Description
Public method | Execute | Executes the specified resource with the specific context.
Back to Top
Properties
 | Name | Description
Public property | Name | Gets the name of the resource.
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input.
Back to Top
See Also
IResource Interface
Glimpse.Core.Extensibility Namespace


IResource Methods

IResource Methods Glimpse API Documentation
The IResource type exposes the following members.
Methods
 | Name | Description
Public method | Execute | Executes the specified resource with the specific context.
Back to Top
See Also
IResource Interface
Glimpse.Core.Extensibility Namespace


Execute Method

IResource Execute Method Glimpse API Documentation
Executes the specified resource with the specific context.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IResourceResult Execute(
    IResourceContext context
)
IResourceResult Execute(
    IResourceContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceContext
The context.
Return Value
IResourceResult that can be executed when the Http response is ready to be returned.
See Also
IResource Interface
IResource Members
Glimpse.Core.Extensibility Namespace


IResource Properties

IResource Properties Glimpse API Documentation
The IResource type exposes the following members.
Properties
 | Name | Description
Public property | Name | Gets the name of the resource.
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input.
Back to Top
See Also
IResource Interface
Glimpse.Core.Extensibility Namespace


Name Property

IResource Name Property Glimpse API Documentation
Gets the name of the resource.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Name { get; }
string Name { get; }
Field Value
The name.
Remarks
Resource name's should be unique across a given web application. If multiple IResource implementations contain the same name, Glimpse may throw an exception resulting in an Http 500 Server Error.
See Also
IResource Interface
IResource Members
Glimpse.Core.Extensibility Namespace


Parameters Property

IResource Parameters Property Glimpse API Documentation
Gets the required or optional parameters that a resource needs as processing input.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<ResourceParameterMetadata> Parameters { get; }
IEnumerable<ResourceParameterMetadata> Parameters { get; }
Field Value
The parameters.
See Also
IResource Interface
IResource Members
Glimpse.Core.Extensibility Namespace


IResourceContext Interface

IResourceContext Interface Glimpse API Documentation
IResourceContext provides implementations of IResource access to their parameters and the IReadOnlyPersistenceStore.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IResourceContext : IContext
public interface IResourceContext : IContext
See Also
IResourceContext Members
Glimpse.Core.Extensibility Namespace


IResourceContext Members

IResourceContext Members Glimpse API Documentation

The IResourceContext type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Gets the logger. (Inherited from IContext.)
Public property | Parameters | Gets the parameters that the resource has declared.
Public property | PersistenceStore | Gets the read only persistence store so that historical requests can be accessed.
Back to Top
See Also
IResourceContext Interface
Glimpse.Core.Extensibility Namespace


IResourceContext Properties

IResourceContext Properties Glimpse API Documentation
The IResourceContext type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Gets the logger. (Inherited from IContext.)
Public property | Parameters | Gets the parameters that the resource has declared.
Public property | PersistenceStore | Gets the read only persistence store so that historical requests can be accessed.
Back to Top
See Also
IResourceContext Interface
Glimpse.Core.Extensibility Namespace


Parameters Property

IResourceContext Parameters Property Glimpse API Documentation
Gets the parameters that the resource has declared.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IDictionary<string, string> Parameters { get; }
IDictionary<string, string> Parameters { get; }
Field Value
The parameters.
See Also
IResourceContext Interface
IResourceContext Members
Glimpse.Core.Extensibility Namespace


PersistenceStore Property

IResourceContext PersistenceStore Property Glimpse API Documentation
Gets the read only persistence store so that historical requests can be accessed.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IReadOnlyPersistenceStore PersistenceStore { get; }
IReadOnlyPersistenceStore PersistenceStore { get; }
Field Value
The persistence store.
See Also
IResourceContext Interface
IResourceContext Members
Glimpse.Core.Extensibility Namespace


IResourceResult Interface

IResourceResult Interface Glimpse API Documentation
IResourceResult provides Glimpse a Online command object for returning the results of an IResource.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IResourceResult
public interface IResourceResult
See Also
IResourceResult Members
Glimpse.Core.Extensibility Namespace


IResourceResult Members

IResourceResult Members Glimpse API Documentation

The IResourceResult type exposes the following members.
Methods
 | Name | Description
Public method | Execute | Executes the resource result with the specified context.
Back to Top
See Also
IResourceResult Interface
Glimpse.Core.Extensibility Namespace


IResourceResult Methods

IResourceResult Methods Glimpse API Documentation
The IResourceResult type exposes the following members.
Methods
 | Name | Description
Public method | Execute | Executes the resource result with the specified context.
Back to Top
See Also
IResourceResult Interface
Glimpse.Core.Extensibility Namespace


Execute Method

IResourceResult Execute Method Glimpse API Documentation
Executes the resource result with the specified context.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Execute(
    IResourceResultContext context
)
void Execute(
    IResourceResultContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceResultContext
The context.
See Also
IResourceResult Interface
IResourceResult Members
Glimpse.Core.Extensibility Namespace


IResourceResultContext Interface

IResourceResultContext Interface Glimpse API Documentation
IResourceResultContext provides implementations of IResourceResult access to the IFrameworkProvider, ISerializer and IHtmlEncoder.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IResourceResultContext : IContext
public interface IResourceResultContext : IContext
See Also
IResourceResultContext Members
Glimpse.Core.Extensibility Namespace


IResourceResultContext Members

IResourceResultContext Members Glimpse API Documentation

The IResourceResultContext type exposes the following members.
Properties
 | Name | Description
Public property | FrameworkProvider | Gets the framework provider.
Public property | HtmlEncoder | Gets the HTML encoder.
Public property | Logger | Gets the logger. (Inherited from IContext.)
Public property | Serializer | Gets the serializer.
Back to Top
See Also
IResourceResultContext Interface
Glimpse.Core.Extensibility Namespace


IResourceResultContext Properties

IResourceResultContext Properties Glimpse API Documentation
The IResourceResultContext type exposes the following members.
Properties
 | Name | Description
Public property | FrameworkProvider | Gets the framework provider.
Public property | HtmlEncoder | Gets the HTML encoder.
Public property | Logger | Gets the logger. (Inherited from IContext.)
Public property | Serializer | Gets the serializer.
Back to Top
See Also
IResourceResultContext Interface
Glimpse.Core.Extensibility Namespace


FrameworkProvider Property

IResourceResultContext FrameworkProvider Property Glimpse API Documentation
Gets the framework provider.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IFrameworkProvider FrameworkProvider { get; }
IFrameworkProvider FrameworkProvider { get; }
Field Value
The framework provider.
See Also
IResourceResultContext Interface
IResourceResultContext Members
Glimpse.Core.Extensibility Namespace


HtmlEncoder Property

IResourceResultContext HtmlEncoder Property Glimpse API Documentation
Gets the HTML encoder.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IHtmlEncoder HtmlEncoder { get; }
IHtmlEncoder HtmlEncoder { get; }
Field Value
The HTML encoder.
See Also
IResourceResultContext Interface
IResourceResultContext Members
Glimpse.Core.Extensibility Namespace


Serializer Property

IResourceResultContext Serializer Property Glimpse API Documentation
Gets the serializer.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ISerializer Serializer { get; }
ISerializer Serializer { get; }
Field Value
The serializer.
See Also
IResourceResultContext Interface
IResourceResultContext Members
Glimpse.Core.Extensibility Namespace


IRuntimePolicy Interface

IRuntimePolicy Interface Glimpse API Documentation

IRuntimePolicy controls the operations Glimpse is allowed to do an Http request.

When implemented, a policy will be discovered and added to the collection of policies. Together, all policies determine what Glimpse is allowed to do during an Http request.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IRuntimePolicy
public interface IRuntimePolicy
See Also
IRuntimePolicy Members
Glimpse.Core.Extensibility Namespace


IRuntimePolicy Members

IRuntimePolicy Members Glimpse API Documentation

The IRuntimePolicy type exposes the following members.
Methods
 | Name | Description
Public method | Execute | Executes the specified policy with the given context.
Back to Top
Properties
 | Name | Description
Public property | ExecuteOn | Gets the point in an Http request lifecycle that a policy should execute.
Back to Top
See Also
IRuntimePolicy Interface
Glimpse.Core.Extensibility Namespace


IRuntimePolicy Methods

IRuntimePolicy Methods Glimpse API Documentation
The IRuntimePolicy type exposes the following members.
Methods
 | Name | Description
Public method | Execute | Executes the specified policy with the given context.
Back to Top
See Also
IRuntimePolicy Interface
Glimpse.Core.Extensibility Namespace


Execute Method

IRuntimePolicy Execute Method Glimpse API Documentation
Executes the specified policy with the given context.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
RuntimePolicy Execute(
    IRuntimePolicyContext policyContext
)
RuntimePolicy Execute(
    IRuntimePolicyContext policyContext
)
Parameters
policyContext
Type: Glimpse.Core.Extensibility IRuntimePolicyContext
The policy context.
Return Value
A value describing what Glimpse is allowed to do during the request.
See Also
IRuntimePolicy Interface
IRuntimePolicy Members
Glimpse.Core.Extensibility Namespace


IRuntimePolicy Properties

IRuntimePolicy Properties Glimpse API Documentation
The IRuntimePolicy type exposes the following members.
Properties
 | Name | Description
Public property | ExecuteOn | Gets the point in an Http request lifecycle that a policy should execute.
Back to Top
See Also
IRuntimePolicy Interface
Glimpse.Core.Extensibility Namespace


ExecuteOn Property

IRuntimePolicy ExecuteOn Property Glimpse API Documentation
Gets the point in an Http request lifecycle that a policy should execute.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
RuntimeEvent ExecuteOn { get; }
RuntimeEvent ExecuteOn { get; }
Field Value
The moment to execute.
See Also
IRuntimePolicy Interface
IRuntimePolicy Members
Glimpse.Core.Extensibility Namespace


IRuntimePolicyContext Interface

IRuntimePolicyContext Interface Glimpse API Documentation
Definition for the context that is used when a runtime policy is being executed.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IRuntimePolicyContext : IContext
public interface IRuntimePolicyContext : IContext
See Also
IRuntimePolicyContext Members
Glimpse.Core.Extensibility Namespace


IRuntimePolicyContext Members

IRuntimePolicyContext Members Glimpse API Documentation

The IRuntimePolicyContext type exposes the following members.
Methods
 | Name | Description
Public method | GetRequestContext T | Gets the request context.
Back to Top
Properties
 | Name | Description
Public property | Logger | Gets the logger. (Inherited from IContext.)
Public property | RequestMetadata | Gets the request metadata.
Back to Top
See Also
IRuntimePolicyContext Interface
Glimpse.Core.Extensibility Namespace


IRuntimePolicyContext Methods

IRuntimePolicyContext Methods Glimpse API Documentation
The IRuntimePolicyContext type exposes the following members.
Methods
 | Name | Description
Public method | GetRequestContext T | Gets the request context.
Back to Top
See Also
IRuntimePolicyContext Interface
Glimpse.Core.Extensibility Namespace


GetRequestContext(T) Method

IRuntimePolicyContext GetRequestContext T Method Glimpse API Documentation
Gets the request context.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T GetRequestContext<T>()
where T : class
T GetRequestContext<T>()
where T : class
Type Parameters
T
Type of result that is expected.
Return Value
The request context that is being used.
See Also
IRuntimePolicyContext Interface
IRuntimePolicyContext Members
Glimpse.Core.Extensibility Namespace


IRuntimePolicyContext Properties

IRuntimePolicyContext Properties Glimpse API Documentation
The IRuntimePolicyContext type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Gets the logger. (Inherited from IContext.)
Public property | RequestMetadata | Gets the request metadata.
Back to Top
See Also
IRuntimePolicyContext Interface
Glimpse.Core.Extensibility Namespace


RequestMetadata Property

IRuntimePolicyContext RequestMetadata Property Glimpse API Documentation
Gets the request metadata.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IRequestMetadata RequestMetadata { get; }
IRequestMetadata RequestMetadata { get; }
Field Value
The request metadata.
See Also
IRuntimePolicyContext Interface
IRuntimePolicyContext Members
Glimpse.Core.Extensibility Namespace


ISerializationConverter Interface

ISerializationConverter Interface Glimpse API Documentation

Definition for a converter that will provide a custom object representation to serialize for the supported types.

When implemented, a serialization converter will be discovered and added to the collection of serialization converters.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ISerializationConverter
public interface ISerializationConverter
See Also
ISerializationConverter Members
Glimpse.Core.Extensibility Namespace


ISerializationConverter Members

ISerializationConverter Members Glimpse API Documentation

The ISerializationConverter type exposes the following members.
Methods
 | Name | Description
Public method | Convert | Converts the specified object into a representation suitable for serialization.
Back to Top
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for.
Back to Top
See Also
ISerializationConverter Interface
Glimpse.Core.Extensibility Namespace


ISerializationConverter Methods

ISerializationConverter Methods Glimpse API Documentation
The ISerializationConverter type exposes the following members.
Methods
 | Name | Description
Public method | Convert | Converts the specified object into a representation suitable for serialization.
Back to Top
See Also
ISerializationConverter Interface
Glimpse.Core.Extensibility Namespace


Convert Method

ISerializationConverter Convert Method Glimpse API Documentation
Converts the specified object into a representation suitable for serialization.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object Convert(
    Object target
)
Object Convert(
    Object target
)
Parameters
target
Type:   Online System Object
The object to be converted.
Return Value
The new object representation.
See Also
ISerializationConverter Interface
ISerializationConverter Members
Glimpse.Core.Extensibility Namespace


ISerializationConverter Properties

ISerializationConverter Properties Glimpse API Documentation
The ISerializationConverter type exposes the following members.
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for.
Back to Top
See Also
ISerializationConverter Interface
Glimpse.Core.Extensibility Namespace


SupportedTypes Property

ISerializationConverter SupportedTypes Property Glimpse API Documentation
Gets the supported types the converter will be invoked for.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Type> SupportedTypes { get; }
IEnumerable<Type> SupportedTypes { get; }
Field Value
The supported types.
See Also
ISerializationConverter Interface
ISerializationConverter Members
Glimpse.Core.Extensibility Namespace


ISerializer Interface

ISerializer Interface Glimpse API Documentation
Definition for a provider that can serialize complex objects to JSON.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ISerializer
public interface ISerializer
See Also
ISerializer Members
Glimpse.Core.Extensibility Namespace


ISerializer Members

ISerializer Members Glimpse API Documentation

The ISerializer type exposes the following members.
Methods
 | Name | Description
Public method | RegisterSerializationConverters | Registers a collection of serialization converters which can conduct custom transformations on given types when processed.
Public method | Serialize | Serializes the specified object to JSON.
Back to Top
See Also
ISerializer Interface
Glimpse.Core.Extensibility Namespace


ISerializer Methods

ISerializer Methods Glimpse API Documentation
The ISerializer type exposes the following members.
Methods
 | Name | Description
Public method | RegisterSerializationConverters | Registers a collection of serialization converters which can conduct custom transformations on given types when processed.
Public method | Serialize | Serializes the specified object to JSON.
Back to Top
See Also
ISerializer Interface
Glimpse.Core.Extensibility Namespace


RegisterSerializationConverters Method

ISerializer RegisterSerializationConverters Method Glimpse API Documentation
Registers a collection of serialization converters which can conduct custom transformations on given types when processed.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void RegisterSerializationConverters(
    IEnumerable<ISerializationConverter> converters
)
void RegisterSerializationConverters(
    IEnumerable<ISerializationConverter> converters
)
Parameters
converters
Type:   Online System.Collections.Generic IEnumerable  ISerializationConverter
The converters.
See Also
ISerializer Interface
ISerializer Members
Glimpse.Core.Extensibility Namespace


Serialize Method

ISerializer Serialize Method Glimpse API Documentation
Serializes the specified object to JSON.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Serialize(
    Object target
)
string Serialize(
    Object target
)
Parameters
target
Type:   Online System Object
The target to be Serialized.
Return Value
Serialized object.
See Also
ISerializer Interface
ISerializer Members
Glimpse.Core.Extensibility Namespace


IStaticClientScript Interface

IStaticClientScript Interface Glimpse API Documentation
IStaticClientScript's are a special type of IClientScript that sets the <script> tag's src attribute to a given uri.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IStaticClientScript : IClientScript
public interface IStaticClientScript : IClientScript
Remarks

            It is up to the implementer of IStaticClientScript to host a given resource.

See Also
IStaticClientScript Members
Glimpse.Core.Extensibility Namespace


IStaticClientScript Members

IStaticClientScript Members Glimpse API Documentation

The IStaticClientScript type exposes the following members.
Methods
 | Name | Description
Public method | GetUri | Gets the Uri to set as the value for the src attribute.
Back to Top
Properties
 | Name | Description
Public property | Order | Gets the sorting order in which a <script> tag will be injected a page response, relative to other implementations of IClientScript. (Inherited from IClientScript.)
Back to Top
See Also
IStaticClientScript Interface
Glimpse.Core.Extensibility Namespace


IStaticClientScript Methods

IStaticClientScript Methods Glimpse API Documentation
The IStaticClientScript type exposes the following members.
Methods
 | Name | Description
Public method | GetUri | Gets the Uri to set as the value for the src attribute.
Back to Top
See Also
IStaticClientScript Interface
Glimpse.Core.Extensibility Namespace


GetUri Method

IStaticClientScript GetUri Method Glimpse API Documentation
Gets the Uri to set as the value for the src attribute.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string GetUri(
    string version
)
string GetUri(
    string version
)
Parameters
version
Type:   Online System String

            A unique string that should be combined with the Uri to allow for Http cache invalidation.

Examples

            In this example, the version parameter is appended to a query string argument.

View Colorized Copy to Clipboard Print
public string GetUri(string version)
{
    return "//localhost/scripts/myScript.js?v=" + version;
}
public string GetUri(string version)
{
    return "//localhost/scripts/myScript.js?v=" + version;
}
Return Value
A string Uri pointing to a JavaScript asset.
Remarks

            The returned Uri should only point to JavaScript files since the <script> tag will be rendered with a type='text/javascript' attribute.

See Also
IStaticClientScript Interface
IStaticClientScript Members
Glimpse.Core.Extensibility Namespace


IStaticClientScript Properties

IStaticClientScript Properties Glimpse API Documentation
The IStaticClientScript type exposes the following members.
Properties
 | Name | Description
Public property | Order | Gets the sorting order in which a <script> tag will be injected a page response, relative to other implementations of IClientScript. (Inherited from IClientScript.)
Back to Top
See Also
IStaticClientScript Interface
Glimpse.Core.Extensibility Namespace


ITab Interface

ITab Interface Glimpse API Documentation

Definition for an object which will be represented in the UI as a Tab. To operate you simply need to implement this interface and return an object graph that you would like to view.

When returning data, you can either return the object which represents the Glimpse protocol or return a typed view model. It is recommended that you use typed view models, as it is this object that will be stored in by the Data Store. If this is done, it means that these typed objects can be queried at a latter stage. That said, if you are after simplicity, you can return objects in the shape the Glimpse Protocol requires.

If you do decide to work with a typed view model you can convert this into an objects in the shape the Glimpse Protocol by implementing ISerializationConverter targeting the type of the view model.

Alternatively, if you after simplicity and return an object which represents the Glimpse protocol, you can use TabObject and TabSection as helpers.

Additional functionality can be injected into via additionally implementing the following interfaces: - : Key that will be used to identify the tab within the client. - : URI that will describe where the documentation for the tab can be found. - : Control how the layout of the content should look. - : Allows tab to inject any hooks it needs within the system. - : Allow complex objects to be converted into the Glimpse protocol.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITab
public interface ITab
See Also
ITab Members
Glimpse.Core.Extensibility Namespace
Glimpse.Core.Extensibility IKey
Glimpse.Core.Extensibility IDocumentation
Glimpse.Core.Extensibility ITabLayout
Glimpse.Core.Extensibility ITabSetup
Glimpse.Core.Extensibility ISerializationConverter


ITab Members

ITab Members Glimpse API Documentation

The ITab type exposes the following members.
Methods
 | Name | Description
Public method | GetData | Gets the data that should be shown in the UI.
Back to Top
Properties
 | Name | Description
Public property | ExecuteOn | Gets when the GetData(ITabContext) method should run.
Public property | Name | Gets the name that will show in the tab.
Public property | RequestContextType | Gets the type of the request context that the Tab relies on. If returns null, the tab can be used in any context.
Back to Top
See Also
ITab Interface
Glimpse.Core.Extensibility Namespace


ITab Methods

ITab Methods Glimpse API Documentation
The ITab type exposes the following members.
Methods
 | Name | Description
Public method | GetData | Gets the data that should be shown in the UI.
Back to Top
See Also
ITab Interface
Glimpse.Core.Extensibility Namespace


GetData Method

ITab GetData Method Glimpse API Documentation
Gets the data that should be shown in the UI.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object GetData(
    ITabContext context
)
Object GetData(
    ITabContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility ITabContext
The context.
Return Value
Object that will be shown.
See Also
ITab Interface
ITab Members
Glimpse.Core.Extensibility Namespace


ITab Properties

ITab Properties Glimpse API Documentation
The ITab type exposes the following members.
Properties
 | Name | Description
Public property | ExecuteOn | Gets when the GetData(ITabContext) method should run.
Public property | Name | Gets the name that will show in the tab.
Public property | RequestContextType | Gets the type of the request context that the Tab relies on. If returns null, the tab can be used in any context.
Back to Top
See Also
ITab Interface
Glimpse.Core.Extensibility Namespace


ExecuteOn Property

ITab ExecuteOn Property Glimpse API Documentation
Gets when the GetData(ITabContext) method should run.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
RuntimeEvent ExecuteOn { get; }
RuntimeEvent ExecuteOn { get; }
Field Value
The execute on.
See Also
ITab Interface
ITab Members
Glimpse.Core.Extensibility Namespace


Name Property

ITab Name Property Glimpse API Documentation
Gets the name that will show in the tab.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Name { get; }
string Name { get; }
Field Value
The name.
See Also
ITab Interface
ITab Members
Glimpse.Core.Extensibility Namespace


RequestContextType Property

ITab RequestContextType Property Glimpse API Documentation
Gets the type of the request context that the Tab relies on. If returns null, the tab can be used in any context.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Type RequestContextType { get; }
Type RequestContextType { get; }
Field Value
The type of the request context.
See Also
ITab Interface
ITab Members
Glimpse.Core.Extensibility Namespace


ITabContext Interface

ITabContext Interface Glimpse API Documentation
Definition for the context which tabs use when generating the content will be returned.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITabContext : IContext
public interface ITabContext : IContext
See Also
ITabContext Members
Glimpse.Core.Extensibility Namespace


ITabContext Members

ITabContext Members Glimpse API Documentation

The ITabContext type exposes the following members.
Methods
 | Name | Description
Public method | GetRequestContext T | Gets the request context.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetMessages T | Gets all messages of type T that have been persisted with PersistMessage<T>. (Defined by TabContextExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Logger | Gets the logger. (Inherited from IContext.)
Public property | MessageBroker | Gets access to the message broker. This broker can be used to access messages that are published over various topics during a given request.
Public property | TabStore | Gets access to the tab store. This is where content can be stored within the context of each request.
Back to Top
See Also
ITabContext Interface
Glimpse.Core.Extensibility Namespace


ITabContext Methods

ITabContext Methods Glimpse API Documentation
The ITabContext type exposes the following members.
Methods
 | Name | Description
Public method | GetRequestContext T | Gets the request context.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetMessages T | Gets all messages of type T that have been persisted with PersistMessage<T>. (Defined by TabContextExtensions.)
Back to Top
See Also
ITabContext Interface
Glimpse.Core.Extensibility Namespace


GetRequestContext(T) Method

ITabContext GetRequestContext T Method Glimpse API Documentation
Gets the request context.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T GetRequestContext<T>()
where T : class
T GetRequestContext<T>()
where T : class
Type Parameters
T
Type of result that is expected.
Return Value
The request context that is being used.
See Also
ITabContext Interface
ITabContext Members
Glimpse.Core.Extensibility Namespace


ITabContext Properties

ITabContext Properties Glimpse API Documentation
The ITabContext type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Gets the logger. (Inherited from IContext.)
Public property | MessageBroker | Gets access to the message broker. This broker can be used to access messages that are published over various topics during a given request.
Public property | TabStore | Gets access to the tab store. This is where content can be stored within the context of each request.
Back to Top
See Also
ITabContext Interface
Glimpse.Core.Extensibility Namespace


MessageBroker Property

ITabContext MessageBroker Property Glimpse API Documentation
Gets access to the message broker. This broker can be used to access messages that are published over various topics during a given request.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IMessageBroker MessageBroker { get; }
IMessageBroker MessageBroker { get; }
Field Value
The message broker.
See Also
ITabContext Interface
ITabContext Members
Glimpse.Core.Extensibility Namespace


TabStore Property

ITabContext TabStore Property Glimpse API Documentation
Gets access to the tab store. This is where content can be stored within the context of each request.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IDataStore TabStore { get; }
IDataStore TabStore { get; }
Field Value
The tab store.
See Also
ITabContext Interface
ITabContext Members
Glimpse.Core.Extensibility Namespace


ITabLayout Interface

ITabLayout Interface Glimpse API Documentation
Definition for how the layout of a given object can be controlled. When implementing a layout, TabLayout can be used to make creating the required objects easier.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITabLayout
public interface ITabLayout
See Also
ITabLayout Members
Glimpse.Core.Extensibility Namespace


ITabLayout Members

ITabLayout Members Glimpse API Documentation

The ITabLayout type exposes the following members.
Methods
 | Name | Description
Public method | GetLayout | Gets the layout which controls the layout.
Back to Top
See Also
ITabLayout Interface
Glimpse.Core.Extensibility Namespace


ITabLayout Methods

ITabLayout Methods Glimpse API Documentation
The ITabLayout type exposes the following members.
Methods
 | Name | Description
Public method | GetLayout | Gets the layout which controls the layout.
Back to Top
See Also
ITabLayout Interface
Glimpse.Core.Extensibility Namespace


GetLayout Method

ITabLayout GetLayout Method Glimpse API Documentation
Gets the layout which controls the layout.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object GetLayout()
Object GetLayout()
Return Value
Object that dictates the layout.
See Also
ITabLayout Interface
ITabLayout Members
Glimpse.Core.Extensibility Namespace


ITabSetup Interface

ITabSetup Interface Glimpse API Documentation
Definition which allows a tab to inject any hooks it needs within the system.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITabSetup
public interface ITabSetup
Remarks

            If this interface isn't implemented on a ITab no documentation
            will be provided.

See Also
ITabSetup Members
Glimpse.Core.Extensibility Namespace


ITabSetup Members

ITabSetup Members Glimpse API Documentation

The ITabSetup type exposes the following members.
Methods
 | Name | Description
Public method | Setup | Setups the targeted tab using the specified context.
Back to Top
See Also
ITabSetup Interface
Glimpse.Core.Extensibility Namespace


ITabSetup Methods

ITabSetup Methods Glimpse API Documentation
The ITabSetup type exposes the following members.
Methods
 | Name | Description
Public method | Setup | Setups the targeted tab using the specified context.
Back to Top
See Also
ITabSetup Interface
Glimpse.Core.Extensibility Namespace


Setup Method

ITabSetup Setup Method Glimpse API Documentation
Setups the targeted tab using the specified context.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Setup(
    ITabSetupContext context
)
void Setup(
    ITabSetupContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility ITabSetupContext
The context which should be used.
See Also
ITabSetup Interface
ITabSetup Members
Glimpse.Core.Extensibility Namespace


ITabSetupContext Interface

ITabSetupContext Interface Glimpse API Documentation
Definition for the context which is used during tab setup.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITabSetupContext : IContext
public interface ITabSetupContext : IContext
See Also
ITabSetupContext Members
Glimpse.Core.Extensibility Namespace


ITabSetupContext Members

ITabSetupContext Members Glimpse API Documentation

The ITabSetupContext type exposes the following members.
Methods
 | Name | Description
Public method | GetTabStore | Gets the tab store.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | PersistMessages T | Persists all messages of type T to a thread safe store. Persisted messages can be retrieved with GetMessages<T>. (Defined by TabContextExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Logger | Gets the logger. (Inherited from IContext.)
Public property | MessageBroker | Gets the message broker.
Back to Top
See Also
ITabSetupContext Interface
Glimpse.Core.Extensibility Namespace


ITabSetupContext Methods

ITabSetupContext Methods Glimpse API Documentation
The ITabSetupContext type exposes the following members.
Methods
 | Name | Description
Public method | GetTabStore | Gets the tab store.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | PersistMessages T | Persists all messages of type T to a thread safe store. Persisted messages can be retrieved with GetMessages<T>. (Defined by TabContextExtensions.)
Back to Top
See Also
ITabSetupContext Interface
Glimpse.Core.Extensibility Namespace


GetTabStore Method

ITabSetupContext GetTabStore Method Glimpse API Documentation
Gets the tab store.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IDataStore GetTabStore()
IDataStore GetTabStore()
Return Value
Data store that can be used.
See Also
ITabSetupContext Interface
ITabSetupContext Members
Glimpse.Core.Extensibility Namespace


ITabSetupContext Properties

ITabSetupContext Properties Glimpse API Documentation
The ITabSetupContext type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Gets the logger. (Inherited from IContext.)
Public property | MessageBroker | Gets the message broker.
Back to Top
See Also
ITabSetupContext Interface
Glimpse.Core.Extensibility Namespace


MessageBroker Property

ITabSetupContext MessageBroker Property Glimpse API Documentation
Gets the message broker.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IMessageBroker MessageBroker { get; }
IMessageBroker MessageBroker { get; }
Field Value
The message broker.
See Also
ITabSetupContext Interface
ITabSetupContext Members
Glimpse.Core.Extensibility Namespace


IWrapper(T) Interface

IWrapper T Interface Glimpse API Documentation
IWrapper<T> provides a common way to leverage the Online decorator pattern.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IWrapper<T>
public interface IWrapper<T>
Type Parameters
T
Type of target object.
See Also
IWrapper T  Members
Glimpse.Core.Extensibility Namespace


IWrapper(T) Members

IWrapper T Members Glimpse API Documentation

The IWrapper T type exposes the following members.
Methods
 | Name | Description
Public method | GetWrappedObject | Gets the wrapped target object.
Back to Top
See Also
IWrapper T Interface
Glimpse.Core.Extensibility Namespace


IWrapper(T) Methods

IWrapper T Methods Glimpse API Documentation
The IWrapper T type exposes the following members.
Methods
 | Name | Description
Public method | GetWrappedObject | Gets the wrapped target object.
Back to Top
See Also
IWrapper T Interface
Glimpse.Core.Extensibility Namespace


GetWrappedObject Method

IWrapper T GetWrappedObject Method Glimpse API Documentation
Gets the wrapped target object.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T GetWrappedObject()
T GetWrappedObject()
Return Value
The underlying target object.
See Also
IWrapper T  Interface
IWrapper T  Members
Glimpse.Core.Extensibility Namespace


JsonNetConverterDictionaryKeysAreNotPropertyNames Class

JsonNetConverterDictionaryKeysAreNotPropertyNames Class Glimpse API Documentation
A JsonConverter that overrides the way Json.Net handles dictionaries.
Inheritance Hierarchy
Online System Object
JsonConverter
Glimpse.Core.Extensibility JsonNetConverterDictionaryKeysAreNotPropertyNames

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class JsonNetConverterDictionaryKeysAreNotPropertyNames : JsonConverter
public class JsonNetConverterDictionaryKeysAreNotPropertyNames : JsonConverter
See Also
JsonNetConverterDictionaryKeysAreNotPropertyNames Members
Glimpse.Core.Extensibility Namespace


JsonNetConverterDictionaryKeysAreNotPropertyNames Members

JsonNetConverterDictionaryKeysAreNotPropertyNames Members Glimpse API Documentation

The JsonNetConverterDictionaryKeysAreNotPropertyNames type exposes the following members.
Constructors
 | Name | Description
Public method | JsonNetConverterDictionaryKeysAreNotPropertyNames | Initializes a new instance of the JsonNetConverterDictionaryKeysAreNotPropertyNames class
Back to Top
Methods
 | Name | Description
Public method | CanConvert | Determines whether this instance can convert the specified object type. (Overrides JsonConverterCanConvert(Type).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetSchema | (Inherited from JsonConverter.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadJson | Reads the JSON representation of the object. (Overrides JsonConverterReadJson(JsonReader, Type, Object, JsonSerializer).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | WriteJson | Writes the JSON representation of the object. (Overrides JsonConverterWriteJson(JsonWriter, Object, JsonSerializer).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether this JsonConverter can read JSON. (Overrides JsonConverterCanRead.)
Public property | CanWrite | (Inherited from JsonConverter.)
Back to Top
See Also
JsonNetConverterDictionaryKeysAreNotPropertyNames Class
Glimpse.Core.Extensibility Namespace


JsonNetConverterDictionaryKeysAreNotPropertyNames Constructor

JsonNetConverterDictionaryKeysAreNotPropertyNames Constructor Glimpse API Documentation
Initializes a new instance of the JsonNetConverterDictionaryKeysAreNotPropertyNames class

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JsonNetConverterDictionaryKeysAreNotPropertyNames()
public JsonNetConverterDictionaryKeysAreNotPropertyNames()
See Also
JsonNetConverterDictionaryKeysAreNotPropertyNames Class
JsonNetConverterDictionaryKeysAreNotPropertyNames Members
Glimpse.Core.Extensibility Namespace


JsonNetConverterDictionaryKeysAreNotPropertyNames Methods

JsonNetConverterDictionaryKeysAreNotPropertyNames Methods Glimpse API Documentation
The JsonNetConverterDictionaryKeysAreNotPropertyNames type exposes the following members.
Methods
 | Name | Description
Public method | CanConvert | Determines whether this instance can convert the specified object type. (Overrides JsonConverterCanConvert(Type).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetSchema | (Inherited from JsonConverter.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadJson | Reads the JSON representation of the object. (Overrides JsonConverterReadJson(JsonReader, Type, Object, JsonSerializer).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | WriteJson | Writes the JSON representation of the object. (Overrides JsonConverterWriteJson(JsonWriter, Object, JsonSerializer).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
JsonNetConverterDictionaryKeysAreNotPropertyNames Class
Glimpse.Core.Extensibility Namespace


CanConvert Method

JsonNetConverterDictionaryKeysAreNotPropertyNames CanConvert Method Glimpse API Documentation
Determines whether this instance can convert the specified object type.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanConvert(
    Type objectType
)
public override bool CanConvert(
    Type objectType
)
Parameters
objectType
Type:   Online System Type
Type of the object.
Return Value
true if this instance can convert the specified object type; otherwise, false.

See Also
JsonNetConverterDictionaryKeysAreNotPropertyNames Class
JsonNetConverterDictionaryKeysAreNotPropertyNames Members
Glimpse.Core.Extensibility Namespace


ReadJson Method

JsonNetConverterDictionaryKeysAreNotPropertyNames ReadJson Method Glimpse API Documentation
Reads the JSON representation of the object.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object ReadJson(
    JsonReader reader,
    Type objectType,
    Object existingValue,
    JsonSerializer serializer
)
public override Object ReadJson(
    JsonReader reader,
    Type objectType,
    Object existingValue,
    JsonSerializer serializer
)
Parameters
reader
Type: JsonReader
The JsonReader to read from.
objectType
Type:   Online System Type
Type of the object.
existingValue
Type:   Online System Object
The existing value of object being read.
serializer
Type: JsonSerializer
The calling serializer.
Return Value

            The object value.

Exceptions
Exception | Condition
Online System NotSupportedException | Throws an exception if called.
See Also
JsonNetConverterDictionaryKeysAreNotPropertyNames Class
JsonNetConverterDictionaryKeysAreNotPropertyNames Members
Glimpse.Core.Extensibility Namespace


WriteJson Method

JsonNetConverterDictionaryKeysAreNotPropertyNames WriteJson Method Glimpse API Documentation
Writes the JSON representation of the object.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void WriteJson(
    JsonWriter writer,
    Object value,
    JsonSerializer serializer
)
public override void WriteJson(
    JsonWriter writer,
    Object value,
    JsonSerializer serializer
)
Parameters
writer
Type: JsonWriter
The JsonWriter to write to.
value
Type:   Online System Object
The value.
serializer
Type: JsonSerializer
The calling serializer.
See Also
JsonNetConverterDictionaryKeysAreNotPropertyNames Class
JsonNetConverterDictionaryKeysAreNotPropertyNames Members
Glimpse.Core.Extensibility Namespace


JsonNetConverterDictionaryKeysAreNotPropertyNames Properties

JsonNetConverterDictionaryKeysAreNotPropertyNames Properties Glimpse API Documentation
The JsonNetConverterDictionaryKeysAreNotPropertyNames type exposes the following members.
Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether this JsonConverter can read JSON. (Overrides JsonConverterCanRead.)
Public property | CanWrite | (Inherited from JsonConverter.)
Back to Top
See Also
JsonNetConverterDictionaryKeysAreNotPropertyNames Class
Glimpse.Core.Extensibility Namespace


CanRead Property

JsonNetConverterDictionaryKeysAreNotPropertyNames CanRead Property Glimpse API Documentation
Gets a value indicating whether this JsonConverter can read JSON.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanRead { get; }
public override bool CanRead { get; }
Field Value
true if this JsonConverter can read JSON; otherwise, false.

See Also
JsonNetConverterDictionaryKeysAreNotPropertyNames Class
JsonNetConverterDictionaryKeysAreNotPropertyNames Members
Glimpse.Core.Extensibility Namespace


JsonNetSerializationConverterAdapter Class

JsonNetSerializationConverterAdapter Class Glimpse API Documentation
An adapter which converts Glimpse's ISerializationConverter to Json.Net JsonConverter.
Inheritance Hierarchy
Online System Object
JsonConverter
Glimpse.Core.Extensibility JsonNetSerializationConverterAdapter

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class JsonNetSerializationConverterAdapter : JsonConverter
public class JsonNetSerializationConverterAdapter : JsonConverter
See Also
JsonNetSerializationConverterAdapter Members
Glimpse.Core.Extensibility Namespace


JsonNetSerializationConverterAdapter Members

JsonNetSerializationConverterAdapter Members Glimpse API Documentation

The JsonNetSerializationConverterAdapter type exposes the following members.
Constructors
 | Name | Description
Public method | JsonNetSerializationConverterAdapter | Initializes a new instance of the JsonNetSerializationConverterAdapter class.
Back to Top
Methods
 | Name | Description
Public method | CanConvert | Determines whether this instance can convert the specified object type. (Overrides JsonConverterCanConvert(Type).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetSchema | (Inherited from JsonConverter.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadJson | Reads the JSON representation of the object. (Overrides JsonConverterReadJson(JsonReader, Type, Object, JsonSerializer).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | WriteJson | Writes the JSON representation of the object. (Overrides JsonConverterWriteJson(JsonWriter, Object, JsonSerializer).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CanRead | (Inherited from JsonConverter.)
Public property | CanWrite | (Inherited from JsonConverter.)
Back to Top
See Also
JsonNetSerializationConverterAdapter Class
Glimpse.Core.Extensibility Namespace


JsonNetSerializationConverterAdapter Constructor

JsonNetSerializationConverterAdapter Constructor Glimpse API Documentation
Initializes a new instance of the JsonNetSerializationConverterAdapter class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JsonNetSerializationConverterAdapter(
    ISerializationConverter converter
)
public JsonNetSerializationConverterAdapter(
    ISerializationConverter converter
)
Parameters
converter
Type: Glimpse.Core.Extensibility ISerializationConverter
The converter.
See Also
JsonNetSerializationConverterAdapter Class
JsonNetSerializationConverterAdapter Members
Glimpse.Core.Extensibility Namespace


JsonNetSerializationConverterAdapter Methods

JsonNetSerializationConverterAdapter Methods Glimpse API Documentation
The JsonNetSerializationConverterAdapter type exposes the following members.
Methods
 | Name | Description
Public method | CanConvert | Determines whether this instance can convert the specified object type. (Overrides JsonConverterCanConvert(Type).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetSchema | (Inherited from JsonConverter.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadJson | Reads the JSON representation of the object. (Overrides JsonConverterReadJson(JsonReader, Type, Object, JsonSerializer).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | WriteJson | Writes the JSON representation of the object. (Overrides JsonConverterWriteJson(JsonWriter, Object, JsonSerializer).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
JsonNetSerializationConverterAdapter Class
Glimpse.Core.Extensibility Namespace


CanConvert Method

JsonNetSerializationConverterAdapter CanConvert Method Glimpse API Documentation
Determines whether this instance can convert the specified object type.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanConvert(
    Type objectType
)
public override bool CanConvert(
    Type objectType
)
Parameters
objectType
Type:   Online System Type
Type of the object.
Return Value
true if this instance can convert the specified object type; otherwise, false.

See Also
JsonNetSerializationConverterAdapter Class
JsonNetSerializationConverterAdapter Members
Glimpse.Core.Extensibility Namespace


ReadJson Method

JsonNetSerializationConverterAdapter ReadJson Method Glimpse API Documentation
Reads the JSON representation of the object.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object ReadJson(
    JsonReader reader,
    Type objectType,
    Object existingValue,
    JsonSerializer serializer
)
public override Object ReadJson(
    JsonReader reader,
    Type objectType,
    Object existingValue,
    JsonSerializer serializer
)
Parameters
reader
Type: JsonReader
The JsonReader to read from.
objectType
Type:   Online System Type
Type of the object.
existingValue
Type:   Online System Object
The existing value of object being read.
serializer
Type: JsonSerializer
The calling serializer.
Return Value

            The object value.

Exceptions
Exception | Condition
Online System NotSupportedException | An exception is thrown if this method is called because it it not supported by Glimpse.
See Also
JsonNetSerializationConverterAdapter Class
JsonNetSerializationConverterAdapter Members
Glimpse.Core.Extensibility Namespace


WriteJson Method

JsonNetSerializationConverterAdapter WriteJson Method Glimpse API Documentation
Writes the JSON representation of the object.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void WriteJson(
    JsonWriter writer,
    Object value,
    JsonSerializer serializer
)
public override void WriteJson(
    JsonWriter writer,
    Object value,
    JsonSerializer serializer
)
Parameters
writer
Type: JsonWriter
The JsonWriter to write to.
value
Type:   Online System Object
The value.
serializer
Type: JsonSerializer
The calling serializer.
See Also
JsonNetSerializationConverterAdapter Class
JsonNetSerializationConverterAdapter Members
Glimpse.Core.Extensibility Namespace


JsonNetSerializationConverterAdapter Properties

JsonNetSerializationConverterAdapter Properties Glimpse API Documentation
The JsonNetSerializationConverterAdapter type exposes the following members.
Properties
 | Name | Description
Public property | CanRead | (Inherited from JsonConverter.)
Public property | CanWrite | (Inherited from JsonConverter.)
Back to Top
See Also
JsonNetSerializationConverterAdapter Class
Glimpse.Core.Extensibility Namespace


JsonNetSerializer Class

JsonNetSerializer Class Glimpse API Documentation
An implementation of ISerializer which leverages Json.Net.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility JsonNetSerializer

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class JsonNetSerializer : ISerializer
public class JsonNetSerializer : ISerializer
See Also
JsonNetSerializer Members
Glimpse.Core.Extensibility Namespace


JsonNetSerializer Members

JsonNetSerializer Members Glimpse API Documentation

The JsonNetSerializer type exposes the following members.
Constructors
 | Name | Description
Public method | JsonNetSerializer | Initializes a new instance of the JsonNetSerializer class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterSerializationConverters | Registers a collection of serialization converters which can conduct custom transformations on given types when processed.
Public method | Serialize | Serializes the specified object to JSON.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
JsonNetSerializer Class
Glimpse.Core.Extensibility Namespace


JsonNetSerializer Constructor

JsonNetSerializer Constructor Glimpse API Documentation
Initializes a new instance of the JsonNetSerializer class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JsonNetSerializer(
    ILogger logger
)
public JsonNetSerializer(
    ILogger logger
)
Parameters
logger
Type: Glimpse.Core.Extensibility ILogger
The logger.
See Also
JsonNetSerializer Class
JsonNetSerializer Members
Glimpse.Core.Extensibility Namespace


JsonNetSerializer Methods

JsonNetSerializer Methods Glimpse API Documentation
The JsonNetSerializer type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterSerializationConverters | Registers a collection of serialization converters which can conduct custom transformations on given types when processed.
Public method | Serialize | Serializes the specified object to JSON.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
JsonNetSerializer Class
Glimpse.Core.Extensibility Namespace


RegisterSerializationConverters Method

JsonNetSerializer RegisterSerializationConverters Method Glimpse API Documentation
Registers a collection of serialization converters which can conduct custom transformations on given types when processed.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RegisterSerializationConverters(
    IEnumerable<ISerializationConverter> converters
)
public void RegisterSerializationConverters(
    IEnumerable<ISerializationConverter> converters
)
Parameters
converters
Type:   Online System.Collections.Generic IEnumerable  ISerializationConverter
The converters.
Implements
ISerializer RegisterSerializationConverters(IEnumerable ISerializationConverter )
Exceptions
Exception | Condition
Online System ArgumentNullException | Throws an exception if converters is null.
See Also
JsonNetSerializer Class
JsonNetSerializer Members
Glimpse.Core.Extensibility Namespace


Serialize Method

JsonNetSerializer Serialize Method Glimpse API Documentation
Serializes the specified object to JSON.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Serialize(
    Object target
)
public string Serialize(
    Object target
)
Parameters
target
Type:   Online System Object
The target to be Serialized.
Return Value

            Serialized object.

Implements
ISerializer Serialize(Object)
See Also
JsonNetSerializer Class
JsonNetSerializer Members
Glimpse.Core.Extensibility Namespace


LoggerBase Class

LoggerBase Class Glimpse API Documentation
An abstract base class which provides ILogger implementations with message formatting abilities.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility LoggerBase
Glimpse.Core.Extensibility NLogLogger

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class LoggerBase : ILogger
public abstract class LoggerBase : ILogger
See Also
LoggerBase Members
Glimpse.Core.Extensibility Namespace


LoggerBase Members

LoggerBase Members Glimpse API Documentation

The LoggerBase type exposes the following members.
Constructors
 | Name | Description
Protected method | LoggerBase | Initializes a new instance of the LoggerBase class
Back to Top
Methods
 | Name | Description
Public method | Debug(String) | Log message at Debug level.
Public method | Debug(String, Exception) | Log message at Debug level.
Public method | Debug(String, Object ) | Log message at Debug level.
Public method | Debug(String, Exception, Object ) | Log message at Debug level.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Error(String) | Log message at Error level.
Public method | Error(String, Exception) | Log message at Error level.
Public method | Error(String, Object ) | Log message at Error level.
Public method | Error(String, Exception, Object ) | Log message at Error level.
Public method | Fatal(String) | Log message at Fatal level.
Public method | Fatal(String, Exception) | Log message at Fatal level.
Public method | Fatal(String, Object ) | Log message at Fatal level.
Public method | Fatal(String, Exception, Object ) | Log message at Fatal level.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Info(String) | Log message at Info level.
Public method | Info(String, Exception) | Log message at Info level.
Public method | Info(String, Object ) | Log message at Info level.
Public method | Info(String, Exception, Object ) | Log message at Info level.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Trace(String) | Log message at Trace level.
Public method | Trace(String, Exception) | Log message at Trace level.
Public method | Trace(String, Object ) | Log message at Trace level.
Public method | Trace(String, Exception, Object ) | Log message at Trace level.
Public method | Warn(String) | Log message at Warn level.
Public method | Warn(String, Exception) | Log message at Warn level.
Public method | Warn(String, Object ) | Log message at Warn level.
Public method | Warn(String, Exception, Object ) | Log message at Warn level.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
LoggerBase Class
Glimpse.Core.Extensibility Namespace


LoggerBase Constructor

LoggerBase Constructor Glimpse API Documentation
Initializes a new instance of the LoggerBase class

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LoggerBase()
protected LoggerBase()
See Also
LoggerBase Class
LoggerBase Members
Glimpse.Core.Extensibility Namespace


LoggerBase Methods

LoggerBase Methods Glimpse API Documentation
The LoggerBase type exposes the following members.
Methods
 | Name | Description
Public method | Debug(String) | Log message at Debug level.
Public method | Debug(String, Exception) | Log message at Debug level.
Public method | Debug(String, Object ) | Log message at Debug level.
Public method | Debug(String, Exception, Object ) | Log message at Debug level.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Error(String) | Log message at Error level.
Public method | Error(String, Exception) | Log message at Error level.
Public method | Error(String, Object ) | Log message at Error level.
Public method | Error(String, Exception, Object ) | Log message at Error level.
Public method | Fatal(String) | Log message at Fatal level.
Public method | Fatal(String, Exception) | Log message at Fatal level.
Public method | Fatal(String, Object ) | Log message at Fatal level.
Public method | Fatal(String, Exception, Object ) | Log message at Fatal level.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Info(String) | Log message at Info level.
Public method | Info(String, Exception) | Log message at Info level.
Public method | Info(String, Object ) | Log message at Info level.
Public method | Info(String, Exception, Object ) | Log message at Info level.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Trace(String) | Log message at Trace level.
Public method | Trace(String, Exception) | Log message at Trace level.
Public method | Trace(String, Object ) | Log message at Trace level.
Public method | Trace(String, Exception, Object ) | Log message at Trace level.
Public method | Warn(String) | Log message at Warn level.
Public method | Warn(String, Exception) | Log message at Warn level.
Public method | Warn(String, Object ) | Log message at Warn level.
Public method | Warn(String, Exception, Object ) | Log message at Warn level.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
LoggerBase Class
Glimpse.Core.Extensibility Namespace


Debug Method

LoggerBase Debug Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Debug(String) | Log message at Debug level.
Public method | Debug(String, Exception) | Log message at Debug level.
Public method | Debug(String, Object ) | Log message at Debug level.
Public method | Debug(String, Exception, Object ) | Log message at Debug level.
Back to Top
See Also
LoggerBase Class
LoggerBase Members
Glimpse.Core.Extensibility Namespace


Debug Method (String)

LoggerBase Debug Method (String) Glimpse API Documentation
Log message at Debug level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Debug(
    string message
)
public abstract void Debug(
    string message
)
Parameters
message
Type:   Online System String
The message.
Implements
ILogger Debug(String)
See Also
LoggerBase Class
LoggerBase Members
Debug Overload
Glimpse.Core.Extensibility Namespace


Debug Method (String, Exception)

LoggerBase Debug Method (String, Exception) Glimpse API Documentation
Log message at Debug level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Debug(
    string message,
    Exception exception
)
public abstract void Debug(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
Implements
ILogger Debug(String, Exception)
See Also
LoggerBase Class
LoggerBase Members
Debug Overload
Glimpse.Core.Extensibility Namespace


Debug Method (String, Object[])

LoggerBase Debug Method (String, Object ) Glimpse API Documentation
Log message at Debug level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Debug(
    string messageFormat,
    params Object[] args
)
public void Debug(
    string messageFormat,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
args
Type:    Online System Object
The args.
Implements
ILogger Debug(String,  Object )
See Also
LoggerBase Class
LoggerBase Members
Debug Overload
Glimpse.Core.Extensibility Namespace


Debug Method (String, Exception, Object[])

LoggerBase Debug Method (String, Exception, Object ) Glimpse API Documentation
Log message at Debug level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Debug(
    string messageFormat,
    Exception exception,
    params Object[] args
)
public void Debug(
    string messageFormat,
    Exception exception,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
exception
Type:   Online System Exception
The exception.
args
Type:    Online System Object
The args.
Implements
ILogger Debug(String, Exception,  Object )
See Also
LoggerBase Class
LoggerBase Members
Debug Overload
Glimpse.Core.Extensibility Namespace


Error Method

LoggerBase Error Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Error(String) | Log message at Error level.
Public method | Error(String, Exception) | Log message at Error level.
Public method | Error(String, Object ) | Log message at Error level.
Public method | Error(String, Exception, Object ) | Log message at Error level.
Back to Top
See Also
LoggerBase Class
LoggerBase Members
Glimpse.Core.Extensibility Namespace


Error Method (String)

LoggerBase Error Method (String) Glimpse API Documentation
Log message at Error level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Error(
    string message
)
public abstract void Error(
    string message
)
Parameters
message
Type:   Online System String
The message.
Implements
ILogger Error(String)
See Also
LoggerBase Class
LoggerBase Members
Error Overload
Glimpse.Core.Extensibility Namespace


Error Method (String, Exception)

LoggerBase Error Method (String, Exception) Glimpse API Documentation
Log message at Error level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Error(
    string message,
    Exception exception
)
public abstract void Error(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
Implements
ILogger Error(String, Exception)
See Also
LoggerBase Class
LoggerBase Members
Error Overload
Glimpse.Core.Extensibility Namespace


Error Method (String, Object[])

LoggerBase Error Method (String, Object ) Glimpse API Documentation
Log message at Error level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Error(
    string messageFormat,
    params Object[] args
)
public void Error(
    string messageFormat,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
args
Type:    Online System Object
The args.
Implements
ILogger Error(String,  Object )
See Also
LoggerBase Class
LoggerBase Members
Error Overload
Glimpse.Core.Extensibility Namespace


Error Method (String, Exception, Object[])

LoggerBase Error Method (String, Exception, Object ) Glimpse API Documentation
Log message at Error level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Error(
    string messageFormat,
    Exception exception,
    params Object[] args
)
public void Error(
    string messageFormat,
    Exception exception,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
exception
Type:   Online System Exception
The exception.
args
Type:    Online System Object
The args.
Implements
ILogger Error(String, Exception,  Object )
See Also
LoggerBase Class
LoggerBase Members
Error Overload
Glimpse.Core.Extensibility Namespace


Fatal Method

LoggerBase Fatal Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Fatal(String) | Log message at Fatal level.
Public method | Fatal(String, Exception) | Log message at Fatal level.
Public method | Fatal(String, Object ) | Log message at Fatal level.
Public method | Fatal(String, Exception, Object ) | Log message at Fatal level.
Back to Top
See Also
LoggerBase Class
LoggerBase Members
Glimpse.Core.Extensibility Namespace


Fatal Method (String)

LoggerBase Fatal Method (String) Glimpse API Documentation
Log message at Fatal level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Fatal(
    string message
)
public abstract void Fatal(
    string message
)
Parameters
message
Type:   Online System String
The message.
Implements
ILogger Fatal(String)
See Also
LoggerBase Class
LoggerBase Members
Fatal Overload
Glimpse.Core.Extensibility Namespace


Fatal Method (String, Exception)

LoggerBase Fatal Method (String, Exception) Glimpse API Documentation
Log message at Fatal level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Fatal(
    string message,
    Exception exception
)
public abstract void Fatal(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
Implements
ILogger Fatal(String, Exception)
See Also
LoggerBase Class
LoggerBase Members
Fatal Overload
Glimpse.Core.Extensibility Namespace


Fatal Method (String, Object[])

LoggerBase Fatal Method (String, Object ) Glimpse API Documentation
Log message at Fatal level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Fatal(
    string messageFormat,
    params Object[] args
)
public void Fatal(
    string messageFormat,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
args
Type:    Online System Object
The args.
Implements
ILogger Fatal(String,  Object )
See Also
LoggerBase Class
LoggerBase Members
Fatal Overload
Glimpse.Core.Extensibility Namespace


Fatal Method (String, Exception, Object[])

LoggerBase Fatal Method (String, Exception, Object ) Glimpse API Documentation
Log message at Fatal level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Fatal(
    string messageFormat,
    Exception exception,
    params Object[] args
)
public void Fatal(
    string messageFormat,
    Exception exception,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
exception
Type:   Online System Exception
The exception.
args
Type:    Online System Object
The args.
Implements
ILogger Fatal(String, Exception,  Object )
See Also
LoggerBase Class
LoggerBase Members
Fatal Overload
Glimpse.Core.Extensibility Namespace


Info Method

LoggerBase Info Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Info(String) | Log message at Info level.
Public method | Info(String, Exception) | Log message at Info level.
Public method | Info(String, Object ) | Log message at Info level.
Public method | Info(String, Exception, Object ) | Log message at Info level.
Back to Top
See Also
LoggerBase Class
LoggerBase Members
Glimpse.Core.Extensibility Namespace


Info Method (String)

LoggerBase Info Method (String) Glimpse API Documentation
Log message at Info level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Info(
    string message
)
public abstract void Info(
    string message
)
Parameters
message
Type:   Online System String
The message.
Implements
ILogger Info(String)
See Also
LoggerBase Class
LoggerBase Members
Info Overload
Glimpse.Core.Extensibility Namespace


Info Method (String, Exception)

LoggerBase Info Method (String, Exception) Glimpse API Documentation
Log message at Info level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Info(
    string message,
    Exception exception
)
public abstract void Info(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
Implements
ILogger Info(String, Exception)
See Also
LoggerBase Class
LoggerBase Members
Info Overload
Glimpse.Core.Extensibility Namespace


Info Method (String, Object[])

LoggerBase Info Method (String, Object ) Glimpse API Documentation
Log message at Info level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Info(
    string messageFormat,
    params Object[] args
)
public void Info(
    string messageFormat,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
args
Type:    Online System Object
The args.
Implements
ILogger Info(String,  Object )
See Also
LoggerBase Class
LoggerBase Members
Info Overload
Glimpse.Core.Extensibility Namespace


Info Method (String, Exception, Object[])

LoggerBase Info Method (String, Exception, Object ) Glimpse API Documentation
Log message at Info level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Info(
    string messageFormat,
    Exception exception,
    params Object[] args
)
public void Info(
    string messageFormat,
    Exception exception,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
exception
Type:   Online System Exception
The exception.
args
Type:    Online System Object
The args.
Implements
ILogger Info(String, Exception,  Object )
See Also
LoggerBase Class
LoggerBase Members
Info Overload
Glimpse.Core.Extensibility Namespace


Trace Method

LoggerBase Trace Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Trace(String) | Log message at Trace level.
Public method | Trace(String, Exception) | Log message at Trace level.
Public method | Trace(String, Object ) | Log message at Trace level.
Public method | Trace(String, Exception, Object ) | Log message at Trace level.
Back to Top
See Also
LoggerBase Class
LoggerBase Members
Glimpse.Core.Extensibility Namespace


Trace Method (String)

LoggerBase Trace Method (String) Glimpse API Documentation
Log message at Trace level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Trace(
    string message
)
public abstract void Trace(
    string message
)
Parameters
message
Type:   Online System String
The message.
Implements
ILogger Trace(String)
See Also
LoggerBase Class
LoggerBase Members
Trace Overload
Glimpse.Core.Extensibility Namespace


Trace Method (String, Exception)

LoggerBase Trace Method (String, Exception) Glimpse API Documentation
Log message at Trace level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Trace(
    string message,
    Exception exception
)
public abstract void Trace(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
Implements
ILogger Trace(String, Exception)
See Also
LoggerBase Class
LoggerBase Members
Trace Overload
Glimpse.Core.Extensibility Namespace


Trace Method (String, Object[])

LoggerBase Trace Method (String, Object ) Glimpse API Documentation
Log message at Trace level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Trace(
    string messageFormat,
    params Object[] args
)
public void Trace(
    string messageFormat,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
args
Type:    Online System Object
The args.
Implements
ILogger Trace(String,  Object )
See Also
LoggerBase Class
LoggerBase Members
Trace Overload
Glimpse.Core.Extensibility Namespace


Trace Method (String, Exception, Object[])

LoggerBase Trace Method (String, Exception, Object ) Glimpse API Documentation
Log message at Trace level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Trace(
    string messageFormat,
    Exception exception,
    params Object[] args
)
public void Trace(
    string messageFormat,
    Exception exception,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
exception
Type:   Online System Exception
The exception.
args
Type:    Online System Object
The args.
Implements
ILogger Trace(String, Exception,  Object )
See Also
LoggerBase Class
LoggerBase Members
Trace Overload
Glimpse.Core.Extensibility Namespace


Warn Method

LoggerBase Warn Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Warn(String) | Log message at Warn level.
Public method | Warn(String, Exception) | Log message at Warn level.
Public method | Warn(String, Object ) | Log message at Warn level.
Public method | Warn(String, Exception, Object ) | Log message at Warn level.
Back to Top
See Also
LoggerBase Class
LoggerBase Members
Glimpse.Core.Extensibility Namespace


Warn Method (String)

LoggerBase Warn Method (String) Glimpse API Documentation
Log message at Warn level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Warn(
    string message
)
public abstract void Warn(
    string message
)
Parameters
message
Type:   Online System String
The message.
Implements
ILogger Warn(String)
See Also
LoggerBase Class
LoggerBase Members
Warn Overload
Glimpse.Core.Extensibility Namespace


Warn Method (String, Exception)

LoggerBase Warn Method (String, Exception) Glimpse API Documentation
Log message at Warn level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Warn(
    string message,
    Exception exception
)
public abstract void Warn(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
Implements
ILogger Warn(String, Exception)
See Also
LoggerBase Class
LoggerBase Members
Warn Overload
Glimpse.Core.Extensibility Namespace


Warn Method (String, Object[])

LoggerBase Warn Method (String, Object ) Glimpse API Documentation
Log message at Warn level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Warn(
    string messageFormat,
    params Object[] args
)
public void Warn(
    string messageFormat,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
args
Type:    Online System Object
The args.
Implements
ILogger Warn(String,  Object )
See Also
LoggerBase Class
LoggerBase Members
Warn Overload
Glimpse.Core.Extensibility Namespace


Warn Method (String, Exception, Object[])

LoggerBase Warn Method (String, Exception, Object ) Glimpse API Documentation
Log message at Warn level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Warn(
    string messageFormat,
    Exception exception,
    params Object[] args
)
public void Warn(
    string messageFormat,
    Exception exception,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
exception
Type:   Online System Exception
The exception.
args
Type:    Online System Object
The args.
Implements
ILogger Warn(String, Exception,  Object )
See Also
LoggerBase Class
LoggerBase Members
Warn Overload
Glimpse.Core.Extensibility Namespace


MessageBroker Class

MessageBroker Class Glimpse API Documentation
The default implementation of IMessageBroker which supports subscribing to messages based on types, base types and interfaces.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility MessageBroker

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MessageBroker : IMessageBroker
public class MessageBroker : IMessageBroker
See Also
MessageBroker Members
Glimpse.Core.Extensibility Namespace


MessageBroker Members

MessageBroker Members Glimpse API Documentation

The MessageBroker type exposes the following members.
Constructors
 | Name | Description
Public method | MessageBroker | Initializes a new instance of the MessageBroker class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Publish T | Publishes the specified message using the type as the topic.
Public method | Subscribe T | Subscribes the specified action to the Type specified.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Unsubscribe T | Unsubscribes the listener from the specified subscription id.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Logger | Gets or sets the logger.
Back to Top
See Also
MessageBroker Class
Glimpse.Core.Extensibility Namespace


MessageBroker Constructor

MessageBroker Constructor Glimpse API Documentation
Initializes a new instance of the MessageBroker class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageBroker(
    ILogger logger
)
public MessageBroker(
    ILogger logger
)
Parameters
logger
Type: Glimpse.Core.Extensibility ILogger
The logger.
Exceptions
Exception | Condition
Online System ArgumentNullException | Throws an exception if logger is null.
See Also
MessageBroker Class
MessageBroker Members
Glimpse.Core.Extensibility Namespace


MessageBroker Methods

MessageBroker Methods Glimpse API Documentation
The MessageBroker type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Publish T | Publishes the specified message using the type as the topic.
Public method | Subscribe T | Subscribes the specified action to the Type specified.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Unsubscribe T | Unsubscribes the listener from the specified subscription id.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
MessageBroker Class
Glimpse.Core.Extensibility Namespace


Publish(T) Method

MessageBroker Publish T Method Glimpse API Documentation
Publishes the specified message using the type as the topic.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Publish<T>(
    T message
)
public void Publish<T>(
    T message
)
Parameters
message
Type: T
The message.
Type Parameters
T
Type of the message
Implements
IMessageBroker Publish T (T)
See Also
MessageBroker Class
MessageBroker Members
Glimpse.Core.Extensibility Namespace


Subscribe(T) Method

MessageBroker Subscribe T Method Glimpse API Documentation
Subscribes the specified action to the Type specified.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid Subscribe<T>(
    Action<T> action
)
public Guid Subscribe<T>(
    Action<T> action
)
Parameters
action
Type:   Online System Action  T
The action.
Type Parameters
T
Type of the message
Return Value

            A subscription Id, which should be retained in order to unsubscribe.

Implements
IMessageBroker Subscribe T (Action T )
Exceptions
Exception | Condition
Online System ArgumentNullException | Throws an exception if action is null.
See Also
MessageBroker Class
MessageBroker Members
Glimpse.Core.Extensibility Namespace


Unsubscribe(T) Method

MessageBroker Unsubscribe T Method Glimpse API Documentation
Unsubscribes the listener from the specified subscription id.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Unsubscribe<T>(
    Guid subscriptionId
)
public void Unsubscribe<T>(
    Guid subscriptionId
)
Parameters
subscriptionId
Type:   Online System Guid
The subscription id.
Type Parameters
T
Type of the message
Implements
IMessageBroker Unsubscribe T (Guid)
See Also
MessageBroker Class
MessageBroker Members
Glimpse.Core.Extensibility Namespace


MessageBroker Properties

MessageBroker Properties Glimpse API Documentation
The MessageBroker type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Gets or sets the logger.
Back to Top
See Also
MessageBroker Class
Glimpse.Core.Extensibility Namespace


Logger Property

MessageBroker Logger Property Glimpse API Documentation
Gets or sets the logger.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILogger Logger { get; set; }
public ILogger Logger { get; set; }
Field Value

            The logger.

See Also
MessageBroker Class
MessageBroker Members
Glimpse.Core.Extensibility Namespace


NLogLogger Class

NLogLogger Class Glimpse API Documentation
An implementation of ILogger based on NLog.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility LoggerBase
Glimpse.Core.Extensibility NLogLogger

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NLogLogger : LoggerBase
public class NLogLogger : LoggerBase
See Also
NLogLogger Members
Glimpse.Core.Extensibility Namespace


NLogLogger Members

NLogLogger Members Glimpse API Documentation

The NLogLogger type exposes the following members.
Constructors
 | Name | Description
Public method | NLogLogger | Initializes a new instance of the NLogLogger class.
Back to Top
Methods
 | Name | Description
Public method | Debug(String) | Log message at Debug level. (Overrides LoggerBase Debug(String).)
Public method | Debug(String, Object ) | Log message at Debug level. (Inherited from LoggerBase.)
Public method | Debug(String, Exception) | Log message at Debug level. (Overrides LoggerBase Debug(String, Exception).)
Public method | Debug(String, Exception, Object ) | Log message at Debug level. (Inherited from LoggerBase.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Error(String) | Log message at Error level. (Overrides LoggerBase Error(String).)
Public method | Error(String, Object ) | Log message at Error level. (Inherited from LoggerBase.)
Public method | Error(String, Exception) | Log message at Error level. (Overrides LoggerBase Error(String, Exception).)
Public method | Error(String, Exception, Object ) | Log message at Error level. (Inherited from LoggerBase.)
Public method | Fatal(String) | Log message at Fatal level. (Overrides LoggerBase Fatal(String).)
Public method | Fatal(String, Object ) | Log message at Fatal level. (Inherited from LoggerBase.)
Public method | Fatal(String, Exception) | Log message at Fatal level. (Overrides LoggerBase Fatal(String, Exception).)
Public method | Fatal(String, Exception, Object ) | Log message at Fatal level. (Inherited from LoggerBase.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Info(String) | Log message at Info level. (Overrides LoggerBase Info(String).)
Public method | Info(String, Object ) | Log message at Info level. (Inherited from LoggerBase.)
Public method | Info(String, Exception) | Log message at Info level. (Overrides LoggerBase Info(String, Exception).)
Public method | Info(String, Exception, Object ) | Log message at Info level. (Inherited from LoggerBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Trace(String) | Log message at Trace level. (Overrides LoggerBase Trace(String).)
Public method | Trace(String, Object ) | Log message at Trace level. (Inherited from LoggerBase.)
Public method | Trace(String, Exception) | Log message at Trace level. (Overrides LoggerBase Trace(String, Exception).)
Public method | Trace(String, Exception, Object ) | Log message at Trace level. (Inherited from LoggerBase.)
Public method | Warn(String) | Log message at Warn level. (Overrides LoggerBase Warn(String).)
Public method | Warn(String, Object ) | Log message at Warn level. (Inherited from LoggerBase.)
Public method | Warn(String, Exception) | Log message at Warn level. (Overrides LoggerBase Warn(String, Exception).)
Public method | Warn(String, Exception, Object ) | Log message at Warn level. (Inherited from LoggerBase.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
NLogLogger Class
Glimpse.Core.Extensibility Namespace


NLogLogger Constructor

NLogLogger Constructor Glimpse API Documentation
Initializes a new instance of the NLogLogger class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NLogLogger(
    Logger logger
)
public NLogLogger(
    Logger logger
)
Parameters
logger
Type: Logger
The logger.
See Also
NLogLogger Class
NLogLogger Members
Glimpse.Core.Extensibility Namespace


NLogLogger Methods

NLogLogger Methods Glimpse API Documentation
The NLogLogger type exposes the following members.
Methods
 | Name | Description
Public method | Debug(String) | Log message at Debug level. (Overrides LoggerBase Debug(String).)
Public method | Debug(String, Object ) | Log message at Debug level. (Inherited from LoggerBase.)
Public method | Debug(String, Exception) | Log message at Debug level. (Overrides LoggerBase Debug(String, Exception).)
Public method | Debug(String, Exception, Object ) | Log message at Debug level. (Inherited from LoggerBase.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Error(String) | Log message at Error level. (Overrides LoggerBase Error(String).)
Public method | Error(String, Object ) | Log message at Error level. (Inherited from LoggerBase.)
Public method | Error(String, Exception) | Log message at Error level. (Overrides LoggerBase Error(String, Exception).)
Public method | Error(String, Exception, Object ) | Log message at Error level. (Inherited from LoggerBase.)
Public method | Fatal(String) | Log message at Fatal level. (Overrides LoggerBase Fatal(String).)
Public method | Fatal(String, Object ) | Log message at Fatal level. (Inherited from LoggerBase.)
Public method | Fatal(String, Exception) | Log message at Fatal level. (Overrides LoggerBase Fatal(String, Exception).)
Public method | Fatal(String, Exception, Object ) | Log message at Fatal level. (Inherited from LoggerBase.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Info(String) | Log message at Info level. (Overrides LoggerBase Info(String).)
Public method | Info(String, Object ) | Log message at Info level. (Inherited from LoggerBase.)
Public method | Info(String, Exception) | Log message at Info level. (Overrides LoggerBase Info(String, Exception).)
Public method | Info(String, Exception, Object ) | Log message at Info level. (Inherited from LoggerBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Trace(String) | Log message at Trace level. (Overrides LoggerBase Trace(String).)
Public method | Trace(String, Object ) | Log message at Trace level. (Inherited from LoggerBase.)
Public method | Trace(String, Exception) | Log message at Trace level. (Overrides LoggerBase Trace(String, Exception).)
Public method | Trace(String, Exception, Object ) | Log message at Trace level. (Inherited from LoggerBase.)
Public method | Warn(String) | Log message at Warn level. (Overrides LoggerBase Warn(String).)
Public method | Warn(String, Object ) | Log message at Warn level. (Inherited from LoggerBase.)
Public method | Warn(String, Exception) | Log message at Warn level. (Overrides LoggerBase Warn(String, Exception).)
Public method | Warn(String, Exception, Object ) | Log message at Warn level. (Inherited from LoggerBase.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
NLogLogger Class
Glimpse.Core.Extensibility Namespace


Debug Method

NLogLogger Debug Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Debug(String) | Log message at Debug level. (Overrides LoggerBase Debug(String).)
Public method | Debug(String, Object ) | Log message at Debug level. (Inherited from LoggerBase.)
Public method | Debug(String, Exception) | Log message at Debug level. (Overrides LoggerBase Debug(String, Exception).)
Public method | Debug(String, Exception, Object ) | Log message at Debug level. (Inherited from LoggerBase.)
Back to Top
See Also
NLogLogger Class
NLogLogger Members
Glimpse.Core.Extensibility Namespace


Debug Method (String)

NLogLogger Debug Method (String) Glimpse API Documentation
Log message at Debug level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Debug(
    string message
)
public override void Debug(
    string message
)
Parameters
message
Type:   Online System String
The message.
Implements
ILogger Debug(String)
See Also
NLogLogger Class
NLogLogger Members
Debug Overload
Glimpse.Core.Extensibility Namespace


Debug Method (String, Exception)

NLogLogger Debug Method (String, Exception) Glimpse API Documentation
Log message at Debug level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Debug(
    string message,
    Exception exception
)
public override void Debug(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
Implements
ILogger Debug(String, Exception)
See Also
NLogLogger Class
NLogLogger Members
Debug Overload
Glimpse.Core.Extensibility Namespace


Error Method

NLogLogger Error Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Error(String) | Log message at Error level. (Overrides LoggerBase Error(String).)
Public method | Error(String, Object ) | Log message at Error level. (Inherited from LoggerBase.)
Public method | Error(String, Exception) | Log message at Error level. (Overrides LoggerBase Error(String, Exception).)
Public method | Error(String, Exception, Object ) | Log message at Error level. (Inherited from LoggerBase.)
Back to Top
See Also
NLogLogger Class
NLogLogger Members
Glimpse.Core.Extensibility Namespace


Error Method (String)

NLogLogger Error Method (String) Glimpse API Documentation
Log message at Error level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Error(
    string message
)
public override void Error(
    string message
)
Parameters
message
Type:   Online System String
The message.
Implements
ILogger Error(String)
See Also
NLogLogger Class
NLogLogger Members
Error Overload
Glimpse.Core.Extensibility Namespace


Error Method (String, Exception)

NLogLogger Error Method (String, Exception) Glimpse API Documentation
Log message at Error level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Error(
    string message,
    Exception exception
)
public override void Error(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
Implements
ILogger Error(String, Exception)
See Also
NLogLogger Class
NLogLogger Members
Error Overload
Glimpse.Core.Extensibility Namespace


Fatal Method

NLogLogger Fatal Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Fatal(String) | Log message at Fatal level. (Overrides LoggerBase Fatal(String).)
Public method | Fatal(String, Object ) | Log message at Fatal level. (Inherited from LoggerBase.)
Public method | Fatal(String, Exception) | Log message at Fatal level. (Overrides LoggerBase Fatal(String, Exception).)
Public method | Fatal(String, Exception, Object ) | Log message at Fatal level. (Inherited from LoggerBase.)
Back to Top
See Also
NLogLogger Class
NLogLogger Members
Glimpse.Core.Extensibility Namespace


Fatal Method (String)

NLogLogger Fatal Method (String) Glimpse API Documentation
Log message at Fatal level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Fatal(
    string message
)
public override void Fatal(
    string message
)
Parameters
message
Type:   Online System String
The message.
Implements
ILogger Fatal(String)
See Also
NLogLogger Class
NLogLogger Members
Fatal Overload
Glimpse.Core.Extensibility Namespace


Fatal Method (String, Exception)

NLogLogger Fatal Method (String, Exception) Glimpse API Documentation
Log message at Fatal level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Fatal(
    string message,
    Exception exception
)
public override void Fatal(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
Implements
ILogger Fatal(String, Exception)
See Also
NLogLogger Class
NLogLogger Members
Fatal Overload
Glimpse.Core.Extensibility Namespace


Info Method

NLogLogger Info Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Info(String) | Log message at Info level. (Overrides LoggerBase Info(String).)
Public method | Info(String, Object ) | Log message at Info level. (Inherited from LoggerBase.)
Public method | Info(String, Exception) | Log message at Info level. (Overrides LoggerBase Info(String, Exception).)
Public method | Info(String, Exception, Object ) | Log message at Info level. (Inherited from LoggerBase.)
Back to Top
See Also
NLogLogger Class
NLogLogger Members
Glimpse.Core.Extensibility Namespace


Info Method (String)

NLogLogger Info Method (String) Glimpse API Documentation
Log message at Info level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Info(
    string message
)
public override void Info(
    string message
)
Parameters
message
Type:   Online System String
The message.
Implements
ILogger Info(String)
See Also
NLogLogger Class
NLogLogger Members
Info Overload
Glimpse.Core.Extensibility Namespace


Info Method (String, Exception)

NLogLogger Info Method (String, Exception) Glimpse API Documentation
Log message at Info level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Info(
    string message,
    Exception exception
)
public override void Info(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
Implements
ILogger Info(String, Exception)
See Also
NLogLogger Class
NLogLogger Members
Info Overload
Glimpse.Core.Extensibility Namespace


Trace Method

NLogLogger Trace Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Trace(String) | Log message at Trace level. (Overrides LoggerBase Trace(String).)
Public method | Trace(String, Object ) | Log message at Trace level. (Inherited from LoggerBase.)
Public method | Trace(String, Exception) | Log message at Trace level. (Overrides LoggerBase Trace(String, Exception).)
Public method | Trace(String, Exception, Object ) | Log message at Trace level. (Inherited from LoggerBase.)
Back to Top
See Also
NLogLogger Class
NLogLogger Members
Glimpse.Core.Extensibility Namespace


Trace Method (String)

NLogLogger Trace Method (String) Glimpse API Documentation
Log message at Trace level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Trace(
    string message
)
public override void Trace(
    string message
)
Parameters
message
Type:   Online System String
The message.
Implements
ILogger Trace(String)
See Also
NLogLogger Class
NLogLogger Members
Trace Overload
Glimpse.Core.Extensibility Namespace


Trace Method (String, Exception)

NLogLogger Trace Method (String, Exception) Glimpse API Documentation
Log message at Trace level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Trace(
    string message,
    Exception exception
)
public override void Trace(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
Implements
ILogger Trace(String, Exception)
See Also
NLogLogger Class
NLogLogger Members
Trace Overload
Glimpse.Core.Extensibility Namespace


Warn Method

NLogLogger Warn Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Warn(String) | Log message at Warn level. (Overrides LoggerBase Warn(String).)
Public method | Warn(String, Object ) | Log message at Warn level. (Inherited from LoggerBase.)
Public method | Warn(String, Exception) | Log message at Warn level. (Overrides LoggerBase Warn(String, Exception).)
Public method | Warn(String, Exception, Object ) | Log message at Warn level. (Inherited from LoggerBase.)
Back to Top
See Also
NLogLogger Class
NLogLogger Members
Glimpse.Core.Extensibility Namespace


Warn Method (String)

NLogLogger Warn Method (String) Glimpse API Documentation
Log message at Warn level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Warn(
    string message
)
public override void Warn(
    string message
)
Parameters
message
Type:   Online System String
The message.
Implements
ILogger Warn(String)
See Also
NLogLogger Class
NLogLogger Members
Warn Overload
Glimpse.Core.Extensibility Namespace


Warn Method (String, Exception)

NLogLogger Warn Method (String, Exception) Glimpse API Documentation
Log message at Warn level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Warn(
    string message,
    Exception exception
)
public override void Warn(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
Implements
ILogger Warn(String, Exception)
See Also
NLogLogger Class
NLogLogger Members
Warn Overload
Glimpse.Core.Extensibility Namespace


NuGetPackageAttribute Class

NuGetPackageAttribute Class Glimpse API Documentation
An attribute used to identify the corresponding NuGet package and Id for an assembly.
Inheritance Hierarchy
Online System Object
Online System Attribute
Glimpse.Core.Extensibility NuGetPackageAttribute

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NuGetPackageAttribute : Attribute
public class NuGetPackageAttribute : Attribute
See Also
NuGetPackageAttribute Members
Glimpse.Core.Extensibility Namespace


NuGetPackageAttribute Members

NuGetPackageAttribute Members Glimpse API Documentation

The NuGetPackageAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | NuGetPackageAttribute | Initializes a new instance of the NuGetPackageAttribute class.
Public method | NuGetPackageAttribute(String) | Initializes a new instance of the NuGetPackageAttribute class.
Public method | NuGetPackageAttribute(String, String) | Initializes a new instance of the NuGetPackageAttribute class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | GetId | Gets the id.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetVersion | Gets the version.
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
NuGetPackageAttribute Class
Glimpse.Core.Extensibility Namespace


NuGetPackageAttribute Constructor

NuGetPackageAttribute Constructor Glimpse API Documentation
Overload List
 | Name | Description
Public method | NuGetPackageAttribute | Initializes a new instance of the NuGetPackageAttribute class.
Public method | NuGetPackageAttribute(String) | Initializes a new instance of the NuGetPackageAttribute class.
Public method | NuGetPackageAttribute(String, String) | Initializes a new instance of the NuGetPackageAttribute class.
Back to Top
See Also
NuGetPackageAttribute Class
NuGetPackageAttribute Members
Glimpse.Core.Extensibility Namespace


NuGetPackageAttribute Constructor

NuGetPackageAttribute Constructor Glimpse API Documentation
Initializes a new instance of the NuGetPackageAttribute class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NuGetPackageAttribute()
public NuGetPackageAttribute()
See Also
NuGetPackageAttribute Class
NuGetPackageAttribute Members
NuGetPackageAttribute Overload
Glimpse.Core.Extensibility Namespace


NuGetPackageAttribute Constructor (String)

NuGetPackageAttribute Constructor (String) Glimpse API Documentation
Initializes a new instance of the NuGetPackageAttribute class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NuGetPackageAttribute(
    string id
)
public NuGetPackageAttribute(
    string id
)
Parameters
id
Type:   Online System String
The id.
See Also
NuGetPackageAttribute Class
NuGetPackageAttribute Members
NuGetPackageAttribute Overload
Glimpse.Core.Extensibility Namespace


NuGetPackageAttribute Constructor (String, String)

NuGetPackageAttribute Constructor (String, String) Glimpse API Documentation
Initializes a new instance of the NuGetPackageAttribute class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NuGetPackageAttribute(
    string id,
    string version
)
public NuGetPackageAttribute(
    string id,
    string version
)
Parameters
id
Type:   Online System String
The id.
version
Type:   Online System String
The version.
See Also
NuGetPackageAttribute Class
NuGetPackageAttribute Members
NuGetPackageAttribute Overload
Glimpse.Core.Extensibility Namespace


NuGetPackageAttribute Methods

NuGetPackageAttribute Methods Glimpse API Documentation
The NuGetPackageAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | GetId | Gets the id.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetVersion | Gets the version.
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
NuGetPackageAttribute Class
Glimpse.Core.Extensibility Namespace


GetId Method

NuGetPackageAttribute GetId Method Glimpse API Documentation
Gets the id.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetId(
    Assembly assembly
)
public string GetId(
    Assembly assembly
)
Parameters
assembly
Type:   Online System.Reflection Assembly
The assembly.
Return Value
The NuGet package Id for the specified assembly.
See Also
NuGetPackageAttribute Class
NuGetPackageAttribute Members
Glimpse.Core.Extensibility Namespace


GetVersion Method

NuGetPackageAttribute GetVersion Method Glimpse API Documentation
Gets the version.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetVersion(
    Assembly assembly
)
public string GetVersion(
    Assembly assembly
)
Parameters
assembly
Type:   Online System.Reflection Assembly
The assembly.
Return Value
The NuGet package version for the specified assembly.
See Also
NuGetPackageAttribute Class
NuGetPackageAttribute Members
Glimpse.Core.Extensibility Namespace


NuGetPackageAttribute Properties

NuGetPackageAttribute Properties Glimpse API Documentation
The NuGetPackageAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
NuGetPackageAttribute Class
Glimpse.Core.Extensibility Namespace


NullLogger Class

NullLogger Class Glimpse API Documentation
An ILogger implementation of the Null Object pattern for use when Glimpse if configured to not use logging.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility NullLogger

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NullLogger : ILogger
public class NullLogger : ILogger
See Also
NullLogger Members
Glimpse.Core.Extensibility Namespace


NullLogger Members

NullLogger Members Glimpse API Documentation

The NullLogger type exposes the following members.
Constructors
 | Name | Description
Public method | NullLogger | Initializes a new instance of the NullLogger class
Back to Top
Methods
 | Name | Description
Public method | Debug(String) | Log message at Debug level.
Public method | Debug(String, Exception) | Log message at Debug level.
Public method | Debug(String, Object ) | Log message at Debug level.
Public method | Debug(String, Exception, Object ) | Log message at Debug level.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Error(String) | Log message at Error level.
Public method | Error(String, Exception) | Log message at Error level.
Public method | Error(String, Object ) | Log message at Error level.
Public method | Error(String, Exception, Object ) | Log message at Error level.
Public method | Fatal(String) | Log message at Fatal level.
Public method | Fatal(String, Exception) | Log message at Fatal level.
Public method | Fatal(String, Object ) | Log message at Fatal level.
Public method | Fatal(String, Exception, Object ) | Log message at Fatal level.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Info(String) | Log message at Info level.
Public method | Info(String, Exception) | Log message at Info level.
Public method | Info(String, Object ) | Log message at Info level.
Public method | Info(String, Exception, Object ) | Log message at Info level.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Trace(String) | Log message at Trace level.
Public method | Trace(String, Exception) | Log message at Trace level.
Public method | Trace(String, Object ) | Log message at Trace level.
Public method | Trace(String, Exception, Object ) | Log message at Trace level.
Public method | Warn(String) | Log message at Warn level.
Public method | Warn(String, Exception) | Log message at Warn level.
Public method | Warn(String, Object ) | Log message at Warn level.
Public method | Warn(String, Exception, Object ) | Log message at Warn level.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
NullLogger Class
Glimpse.Core.Extensibility Namespace


NullLogger Constructor

NullLogger Constructor Glimpse API Documentation
Initializes a new instance of the NullLogger class

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NullLogger()
public NullLogger()
See Also
NullLogger Class
NullLogger Members
Glimpse.Core.Extensibility Namespace


NullLogger Methods

NullLogger Methods Glimpse API Documentation
The NullLogger type exposes the following members.
Methods
 | Name | Description
Public method | Debug(String) | Log message at Debug level.
Public method | Debug(String, Exception) | Log message at Debug level.
Public method | Debug(String, Object ) | Log message at Debug level.
Public method | Debug(String, Exception, Object ) | Log message at Debug level.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Error(String) | Log message at Error level.
Public method | Error(String, Exception) | Log message at Error level.
Public method | Error(String, Object ) | Log message at Error level.
Public method | Error(String, Exception, Object ) | Log message at Error level.
Public method | Fatal(String) | Log message at Fatal level.
Public method | Fatal(String, Exception) | Log message at Fatal level.
Public method | Fatal(String, Object ) | Log message at Fatal level.
Public method | Fatal(String, Exception, Object ) | Log message at Fatal level.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Info(String) | Log message at Info level.
Public method | Info(String, Exception) | Log message at Info level.
Public method | Info(String, Object ) | Log message at Info level.
Public method | Info(String, Exception, Object ) | Log message at Info level.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Trace(String) | Log message at Trace level.
Public method | Trace(String, Exception) | Log message at Trace level.
Public method | Trace(String, Object ) | Log message at Trace level.
Public method | Trace(String, Exception, Object ) | Log message at Trace level.
Public method | Warn(String) | Log message at Warn level.
Public method | Warn(String, Exception) | Log message at Warn level.
Public method | Warn(String, Object ) | Log message at Warn level.
Public method | Warn(String, Exception, Object ) | Log message at Warn level.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
NullLogger Class
Glimpse.Core.Extensibility Namespace


Debug Method

NullLogger Debug Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Debug(String) | Log message at Debug level.
Public method | Debug(String, Exception) | Log message at Debug level.
Public method | Debug(String, Object ) | Log message at Debug level.
Public method | Debug(String, Exception, Object ) | Log message at Debug level.
Back to Top
See Also
NullLogger Class
NullLogger Members
Glimpse.Core.Extensibility Namespace


Debug Method (String)

NullLogger Debug Method (String) Glimpse API Documentation
Log message at Debug level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Debug(
    string message
)
public void Debug(
    string message
)
Parameters
message
Type:   Online System String
The message.
Implements
ILogger Debug(String)
See Also
NullLogger Class
NullLogger Members
Debug Overload
Glimpse.Core.Extensibility Namespace


Debug Method (String, Exception)

NullLogger Debug Method (String, Exception) Glimpse API Documentation
Log message at Debug level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Debug(
    string message,
    Exception exception
)
public void Debug(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
Implements
ILogger Debug(String, Exception)
See Also
NullLogger Class
NullLogger Members
Debug Overload
Glimpse.Core.Extensibility Namespace


Debug Method (String, Object[])

NullLogger Debug Method (String, Object ) Glimpse API Documentation
Log message at Debug level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Debug(
    string messageFormat,
    params Object[] args
)
public void Debug(
    string messageFormat,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
args
Type:    Online System Object
The args.
Implements
ILogger Debug(String,  Object )
See Also
NullLogger Class
NullLogger Members
Debug Overload
Glimpse.Core.Extensibility Namespace


Debug Method (String, Exception, Object[])

NullLogger Debug Method (String, Exception, Object ) Glimpse API Documentation
Log message at Debug level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Debug(
    string messageFormat,
    Exception exception,
    params Object[] args
)
public void Debug(
    string messageFormat,
    Exception exception,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
exception
Type:   Online System Exception
The exception.
args
Type:    Online System Object
The args.
Implements
ILogger Debug(String, Exception,  Object )
See Also
NullLogger Class
NullLogger Members
Debug Overload
Glimpse.Core.Extensibility Namespace


Error Method

NullLogger Error Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Error(String) | Log message at Error level.
Public method | Error(String, Exception) | Log message at Error level.
Public method | Error(String, Object ) | Log message at Error level.
Public method | Error(String, Exception, Object ) | Log message at Error level.
Back to Top
See Also
NullLogger Class
NullLogger Members
Glimpse.Core.Extensibility Namespace


Error Method (String)

NullLogger Error Method (String) Glimpse API Documentation
Log message at Error level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Error(
    string message
)
public void Error(
    string message
)
Parameters
message
Type:   Online System String
The message.
Implements
ILogger Error(String)
See Also
NullLogger Class
NullLogger Members
Error Overload
Glimpse.Core.Extensibility Namespace


Error Method (String, Exception)

NullLogger Error Method (String, Exception) Glimpse API Documentation
Log message at Error level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Error(
    string message,
    Exception exception
)
public void Error(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
Implements
ILogger Error(String, Exception)
See Also
NullLogger Class
NullLogger Members
Error Overload
Glimpse.Core.Extensibility Namespace


Error Method (String, Object[])

NullLogger Error Method (String, Object ) Glimpse API Documentation
Log message at Error level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Error(
    string messageFormat,
    params Object[] args
)
public void Error(
    string messageFormat,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
args
Type:    Online System Object
The args.
Implements
ILogger Error(String,  Object )
See Also
NullLogger Class
NullLogger Members
Error Overload
Glimpse.Core.Extensibility Namespace


Error Method (String, Exception, Object[])

NullLogger Error Method (String, Exception, Object ) Glimpse API Documentation
Log message at Error level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Error(
    string messageFormat,
    Exception exception,
    params Object[] args
)
public void Error(
    string messageFormat,
    Exception exception,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
exception
Type:   Online System Exception
The exception.
args
Type:    Online System Object
The args.
Implements
ILogger Error(String, Exception,  Object )
See Also
NullLogger Class
NullLogger Members
Error Overload
Glimpse.Core.Extensibility Namespace


Fatal Method

NullLogger Fatal Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Fatal(String) | Log message at Fatal level.
Public method | Fatal(String, Exception) | Log message at Fatal level.
Public method | Fatal(String, Object ) | Log message at Fatal level.
Public method | Fatal(String, Exception, Object ) | Log message at Fatal level.
Back to Top
See Also
NullLogger Class
NullLogger Members
Glimpse.Core.Extensibility Namespace


Fatal Method (String)

NullLogger Fatal Method (String) Glimpse API Documentation
Log message at Fatal level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Fatal(
    string message
)
public void Fatal(
    string message
)
Parameters
message
Type:   Online System String
The message.
Implements
ILogger Fatal(String)
See Also
NullLogger Class
NullLogger Members
Fatal Overload
Glimpse.Core.Extensibility Namespace


Fatal Method (String, Exception)

NullLogger Fatal Method (String, Exception) Glimpse API Documentation
Log message at Fatal level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Fatal(
    string message,
    Exception exception
)
public void Fatal(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
Implements
ILogger Fatal(String, Exception)
See Also
NullLogger Class
NullLogger Members
Fatal Overload
Glimpse.Core.Extensibility Namespace


Fatal Method (String, Object[])

NullLogger Fatal Method (String, Object ) Glimpse API Documentation
Log message at Fatal level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Fatal(
    string messageFormat,
    params Object[] args
)
public void Fatal(
    string messageFormat,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
args
Type:    Online System Object
The args.
Implements
ILogger Fatal(String,  Object )
See Also
NullLogger Class
NullLogger Members
Fatal Overload
Glimpse.Core.Extensibility Namespace


Fatal Method (String, Exception, Object[])

NullLogger Fatal Method (String, Exception, Object ) Glimpse API Documentation
Log message at Fatal level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Fatal(
    string messageFormat,
    Exception exception,
    params Object[] args
)
public void Fatal(
    string messageFormat,
    Exception exception,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
exception
Type:   Online System Exception
The exception.
args
Type:    Online System Object
The args.
Implements
ILogger Fatal(String, Exception,  Object )
See Also
NullLogger Class
NullLogger Members
Fatal Overload
Glimpse.Core.Extensibility Namespace


Info Method

NullLogger Info Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Info(String) | Log message at Info level.
Public method | Info(String, Exception) | Log message at Info level.
Public method | Info(String, Object ) | Log message at Info level.
Public method | Info(String, Exception, Object ) | Log message at Info level.
Back to Top
See Also
NullLogger Class
NullLogger Members
Glimpse.Core.Extensibility Namespace


Info Method (String)

NullLogger Info Method (String) Glimpse API Documentation
Log message at Info level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Info(
    string message
)
public void Info(
    string message
)
Parameters
message
Type:   Online System String
The message.
Implements
ILogger Info(String)
See Also
NullLogger Class
NullLogger Members
Info Overload
Glimpse.Core.Extensibility Namespace


Info Method (String, Exception)

NullLogger Info Method (String, Exception) Glimpse API Documentation
Log message at Info level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Info(
    string message,
    Exception exception
)
public void Info(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
Implements
ILogger Info(String, Exception)
See Also
NullLogger Class
NullLogger Members
Info Overload
Glimpse.Core.Extensibility Namespace


Info Method (String, Object[])

NullLogger Info Method (String, Object ) Glimpse API Documentation
Log message at Info level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Info(
    string messageFormat,
    params Object[] args
)
public void Info(
    string messageFormat,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
args
Type:    Online System Object
The args.
Implements
ILogger Info(String,  Object )
See Also
NullLogger Class
NullLogger Members
Info Overload
Glimpse.Core.Extensibility Namespace


Info Method (String, Exception, Object[])

NullLogger Info Method (String, Exception, Object ) Glimpse API Documentation
Log message at Info level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Info(
    string messageFormat,
    Exception exception,
    params Object[] args
)
public void Info(
    string messageFormat,
    Exception exception,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
exception
Type:   Online System Exception
The exception.
args
Type:    Online System Object
The args.
Implements
ILogger Info(String, Exception,  Object )
See Also
NullLogger Class
NullLogger Members
Info Overload
Glimpse.Core.Extensibility Namespace


Trace Method

NullLogger Trace Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Trace(String) | Log message at Trace level.
Public method | Trace(String, Exception) | Log message at Trace level.
Public method | Trace(String, Object ) | Log message at Trace level.
Public method | Trace(String, Exception, Object ) | Log message at Trace level.
Back to Top
See Also
NullLogger Class
NullLogger Members
Glimpse.Core.Extensibility Namespace


Trace Method (String)

NullLogger Trace Method (String) Glimpse API Documentation
Log message at Trace level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Trace(
    string message
)
public void Trace(
    string message
)
Parameters
message
Type:   Online System String
The message.
Implements
ILogger Trace(String)
See Also
NullLogger Class
NullLogger Members
Trace Overload
Glimpse.Core.Extensibility Namespace


Trace Method (String, Exception)

NullLogger Trace Method (String, Exception) Glimpse API Documentation
Log message at Trace level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Trace(
    string message,
    Exception exception
)
public void Trace(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
Implements
ILogger Trace(String, Exception)
See Also
NullLogger Class
NullLogger Members
Trace Overload
Glimpse.Core.Extensibility Namespace


Trace Method (String, Object[])

NullLogger Trace Method (String, Object ) Glimpse API Documentation
Log message at Trace level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Trace(
    string messageFormat,
    params Object[] args
)
public void Trace(
    string messageFormat,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
args
Type:    Online System Object
The args.
Implements
ILogger Trace(String,  Object )
See Also
NullLogger Class
NullLogger Members
Trace Overload
Glimpse.Core.Extensibility Namespace


Trace Method (String, Exception, Object[])

NullLogger Trace Method (String, Exception, Object ) Glimpse API Documentation
Log message at Trace level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Trace(
    string messageFormat,
    Exception exception,
    params Object[] args
)
public void Trace(
    string messageFormat,
    Exception exception,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
exception
Type:   Online System Exception
The exception.
args
Type:    Online System Object
The args.
Implements
ILogger Trace(String, Exception,  Object )
See Also
NullLogger Class
NullLogger Members
Trace Overload
Glimpse.Core.Extensibility Namespace


Warn Method

NullLogger Warn Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Warn(String) | Log message at Warn level.
Public method | Warn(String, Exception) | Log message at Warn level.
Public method | Warn(String, Object ) | Log message at Warn level.
Public method | Warn(String, Exception, Object ) | Log message at Warn level.
Back to Top
See Also
NullLogger Class
NullLogger Members
Glimpse.Core.Extensibility Namespace


Warn Method (String)

NullLogger Warn Method (String) Glimpse API Documentation
Log message at Warn level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Warn(
    string message
)
public void Warn(
    string message
)
Parameters
message
Type:   Online System String
The message.
Implements
ILogger Warn(String)
See Also
NullLogger Class
NullLogger Members
Warn Overload
Glimpse.Core.Extensibility Namespace


Warn Method (String, Exception)

NullLogger Warn Method (String, Exception) Glimpse API Documentation
Log message at Warn level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Warn(
    string message,
    Exception exception
)
public void Warn(
    string message,
    Exception exception
)
Parameters
message
Type:   Online System String
The message.
exception
Type:   Online System Exception
The exception.
Implements
ILogger Warn(String, Exception)
See Also
NullLogger Class
NullLogger Members
Warn Overload
Glimpse.Core.Extensibility Namespace


Warn Method (String, Object[])

NullLogger Warn Method (String, Object ) Glimpse API Documentation
Log message at Warn level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Warn(
    string messageFormat,
    params Object[] args
)
public void Warn(
    string messageFormat,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
args
Type:    Online System Object
The args.
Implements
ILogger Warn(String,  Object )
See Also
NullLogger Class
NullLogger Members
Warn Overload
Glimpse.Core.Extensibility Namespace


Warn Method (String, Exception, Object[])

NullLogger Warn Method (String, Exception, Object ) Glimpse API Documentation
Log message at Warn level.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Warn(
    string messageFormat,
    Exception exception,
    params Object[] args
)
public void Warn(
    string messageFormat,
    Exception exception,
    params Object[] args
)
Parameters
messageFormat
Type:   Online System String
The message format.
exception
Type:   Online System Exception
The exception.
args
Type:    Online System Object
The args.
Implements
ILogger Warn(String, Exception,  Object )
See Also
NullLogger Class
NullLogger Members
Warn Overload
Glimpse.Core.Extensibility Namespace


ResourceContext Class

ResourceContext Class Glimpse API Documentation
The implementation of IResourceContext, used in the Execute method of IResource.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility ResourceContext

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ResourceContext : IResourceContext,
    IContext
public class ResourceContext : IResourceContext,
    IContext
See Also
ResourceContext Members
Glimpse.Core.Extensibility Namespace


ResourceContext Members

ResourceContext Members Glimpse API Documentation

The ResourceContext type exposes the following members.
Constructors
 | Name | Description
Public method | ResourceContext | Initializes a new instance of the ResourceContext class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Logger | Gets or sets the logger.
Public property | Parameters | Gets or sets the parameters that the resource has declared.
Public property | PersistenceStore | Gets or sets the read only persistence store so that historical requests can be accessed.
Back to Top
See Also
ResourceContext Class
Glimpse.Core.Extensibility Namespace


ResourceContext Constructor

ResourceContext Constructor Glimpse API Documentation
Initializes a new instance of the ResourceContext class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResourceContext(
    IDictionary<string, string> parameters,
    IReadOnlyPersistenceStore persistenceStore,
    ILogger logger
)
public ResourceContext(
    IDictionary<string, string> parameters,
    IReadOnlyPersistenceStore persistenceStore,
    ILogger logger
)
Parameters
parameters
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
The parameters.
persistenceStore
Type: Glimpse.Core.Framework IReadOnlyPersistenceStore
The persistence store.
logger
Type: Glimpse.Core.Extensibility ILogger
The logger.
See Also
ResourceContext Class
ResourceContext Members
Glimpse.Core.Extensibility Namespace


ResourceContext Methods

ResourceContext Methods Glimpse API Documentation
The ResourceContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ResourceContext Class
Glimpse.Core.Extensibility Namespace


ResourceContext Properties

ResourceContext Properties Glimpse API Documentation
The ResourceContext type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Gets or sets the logger.
Public property | Parameters | Gets or sets the parameters that the resource has declared.
Public property | PersistenceStore | Gets or sets the read only persistence store so that historical requests can be accessed.
Back to Top
See Also
ResourceContext Class
Glimpse.Core.Extensibility Namespace


Logger Property

ResourceContext Logger Property Glimpse API Documentation
Gets or sets the logger.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILogger Logger { get; set; }
public ILogger Logger { get; set; }
Field Value

            The logger.

Implements
IContext Logger
See Also
ResourceContext Class
ResourceContext Members
Glimpse.Core.Extensibility Namespace


Parameters Property

ResourceContext Parameters Property Glimpse API Documentation
Gets or sets the parameters that the resource has declared.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, string> Parameters { get; set; }
public IDictionary<string, string> Parameters { get; set; }
Field Value

            The parameters.

Implements
IResourceContext Parameters
See Also
ResourceContext Class
ResourceContext Members
Glimpse.Core.Extensibility Namespace


PersistenceStore Property

ResourceContext PersistenceStore Property Glimpse API Documentation
Gets or sets the read only persistence store so that historical requests can be accessed.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IReadOnlyPersistenceStore PersistenceStore { get; set; }
public IReadOnlyPersistenceStore PersistenceStore { get; set; }
Field Value

            The persistence store.

Implements
IResourceContext PersistenceStore
See Also
ResourceContext Class
ResourceContext Members
Glimpse.Core.Extensibility Namespace


ResourceParameter Class

ResourceParameter Class Glimpse API Documentation
A collection of commonly used ResourceParameterMetadata objects.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility ResourceParameter

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class ResourceParameter
public static class ResourceParameter
See Also
ResourceParameter Members
Glimpse.Core.Extensibility Namespace


ResourceParameter Members

ResourceParameter Members Glimpse API Documentation

The ResourceParameter type exposes the following members.
Fields
Name | Description
Callback | The optional 'Callback' parameter used for JsonP requests.
RequestId | The required 'Request Id' parameter.
Timestamp | The required 'Stamp' parameter.
VersionNumber | The required 'Version' parameter used for cache busting.
Back to Top
See Also
ResourceParameter Class
Glimpse.Core.Extensibility Namespace


ResourceParameter Fields

ResourceParameter Fields Glimpse API Documentation
The ResourceParameter type exposes the following members.
Fields
Name | Description
Callback | The optional 'Callback' parameter used for JsonP requests.
RequestId | The required 'Request Id' parameter.
Timestamp | The required 'Stamp' parameter.
VersionNumber | The required 'Version' parameter used for cache busting.
Back to Top
See Also
ResourceParameter Class
Glimpse.Core.Extensibility Namespace


Callback Field

ResourceParameter Callback Field Glimpse API Documentation
The optional 'Callback' parameter used for JsonP requests.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ResourceParameterMetadata Callback
public static readonly ResourceParameterMetadata Callback
See Also
ResourceParameter Class
ResourceParameter Members
Glimpse.Core.Extensibility Namespace


RequestId Field

ResourceParameter RequestId Field Glimpse API Documentation
The required 'Request Id' parameter.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ResourceParameterMetadata RequestId
public static readonly ResourceParameterMetadata RequestId
See Also
ResourceParameter Class
ResourceParameter Members
Glimpse.Core.Extensibility Namespace


Timestamp Field

ResourceParameter Timestamp Field Glimpse API Documentation
The required 'Stamp' parameter.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ResourceParameterMetadata Timestamp
public static readonly ResourceParameterMetadata Timestamp
See Also
ResourceParameter Class
ResourceParameter Members
Glimpse.Core.Extensibility Namespace


VersionNumber Field

ResourceParameter VersionNumber Field Glimpse API Documentation
The required 'Version' parameter used for cache busting.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ResourceParameterMetadata VersionNumber
public static readonly ResourceParameterMetadata VersionNumber
See Also
ResourceParameter Class
ResourceParameter Members
Glimpse.Core.Extensibility Namespace


ResourceParameterMetadata Class

ResourceParameterMetadata Class Glimpse API Documentation
ResourceParameterMetadata describes the parameters for an IResource.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility ResourceParameterMetadata

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ResourceParameterMetadata
public class ResourceParameterMetadata
See Also
ResourceParameterMetadata Members
Glimpse.Core.Extensibility Namespace


ResourceParameterMetadata Members

ResourceParameterMetadata Members Glimpse API Documentation

The ResourceParameterMetadata type exposes the following members.
Constructors
 | Name | Description
Public method | ResourceParameterMetadata | Initializes a new instance of the ResourceParameterMetadata class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | IsRequired | Gets or sets a value indicating whether this parameter is required.
Public property | Name | Gets or sets the name of the parameter.
Back to Top
See Also
ResourceParameterMetadata Class
Glimpse.Core.Extensibility Namespace


ResourceParameterMetadata Constructor

ResourceParameterMetadata Constructor Glimpse API Documentation
Initializes a new instance of the ResourceParameterMetadata class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResourceParameterMetadata(
    string name,
    bool isRequired = true
)
public ResourceParameterMetadata(
    string name,
    bool isRequired = true
)
Parameters
name
Type:   Online System String
The name.
isRequired (Optional)
Type:   Online System Boolean
if set to true [is required].
See Also
ResourceParameterMetadata Class
ResourceParameterMetadata Members
Glimpse.Core.Extensibility Namespace


ResourceParameterMetadata Methods

ResourceParameterMetadata Methods Glimpse API Documentation
The ResourceParameterMetadata type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ResourceParameterMetadata Class
Glimpse.Core.Extensibility Namespace


ResourceParameterMetadata Properties

ResourceParameterMetadata Properties Glimpse API Documentation
The ResourceParameterMetadata type exposes the following members.
Properties
 | Name | Description
Public property | IsRequired | Gets or sets a value indicating whether this parameter is required.
Public property | Name | Gets or sets the name of the parameter.
Back to Top
See Also
ResourceParameterMetadata Class
Glimpse.Core.Extensibility Namespace


IsRequired Property

ResourceParameterMetadata IsRequired Property Glimpse API Documentation
Gets or sets a value indicating whether this parameter is required.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsRequired { get; set; }
public bool IsRequired { get; set; }
Field Value
true if this instance is required; otherwise, false.

See Also
ResourceParameterMetadata Class
ResourceParameterMetadata Members
Glimpse.Core.Extensibility Namespace


Name Property

ResourceParameterMetadata Name Property Glimpse API Documentation
Gets or sets the name of the parameter.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Field Value

            The name.

Remarks

            Names will typically become Html form fields or Uri query string parameter keys.

See Also
ResourceParameterMetadata Class
ResourceParameterMetadata Members
Glimpse.Core.Extensibility Namespace


ResourceResultContext Class

ResourceResultContext Class Glimpse API Documentation
The implementation of IResourceResultContext used in the Execute method of IResourceResult.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility ResourceResultContext

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ResourceResultContext : IResourceResultContext,
    IContext
public class ResourceResultContext : IResourceResultContext,
    IContext
See Also
ResourceResultContext Members
Glimpse.Core.Extensibility Namespace


ResourceResultContext Members

ResourceResultContext Members Glimpse API Documentation

The ResourceResultContext type exposes the following members.
Constructors
 | Name | Description
Public method | ResourceResultContext | Initializes a new instance of the ResourceResultContext class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | FrameworkProvider | Gets or sets the framework provider.
Public property | HtmlEncoder | Gets or sets the HTML encoder.
Public property | Logger | Gets or sets the logger.
Public property | Serializer | Gets or sets the serializer.
Back to Top
See Also
ResourceResultContext Class
Glimpse.Core.Extensibility Namespace


ResourceResultContext Constructor

ResourceResultContext Constructor Glimpse API Documentation
Initializes a new instance of the ResourceResultContext class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResourceResultContext(
    ILogger logger,
    IFrameworkProvider frameworkProvider,
    ISerializer serializer,
    IHtmlEncoder htmlEncoder
)
public ResourceResultContext(
    ILogger logger,
    IFrameworkProvider frameworkProvider,
    ISerializer serializer,
    IHtmlEncoder htmlEncoder
)
Parameters
logger
Type: Glimpse.Core.Extensibility ILogger
The logger.
frameworkProvider
Type: Glimpse.Core.Framework IFrameworkProvider
The framework provider.
serializer
Type: Glimpse.Core.Extensibility ISerializer
The serializer.
htmlEncoder
Type: Glimpse.Core.Extensibility IHtmlEncoder
The HTML encoder.
See Also
ResourceResultContext Class
ResourceResultContext Members
Glimpse.Core.Extensibility Namespace


ResourceResultContext Methods

ResourceResultContext Methods Glimpse API Documentation
The ResourceResultContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ResourceResultContext Class
Glimpse.Core.Extensibility Namespace


ResourceResultContext Properties

ResourceResultContext Properties Glimpse API Documentation
The ResourceResultContext type exposes the following members.
Properties
 | Name | Description
Public property | FrameworkProvider | Gets or sets the framework provider.
Public property | HtmlEncoder | Gets or sets the HTML encoder.
Public property | Logger | Gets or sets the logger.
Public property | Serializer | Gets or sets the serializer.
Back to Top
See Also
ResourceResultContext Class
Glimpse.Core.Extensibility Namespace


FrameworkProvider Property

ResourceResultContext FrameworkProvider Property Glimpse API Documentation
Gets or sets the framework provider.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IFrameworkProvider FrameworkProvider { get; set; }
public IFrameworkProvider FrameworkProvider { get; set; }
Field Value

            The framework provider.

Implements
IResourceResultContext FrameworkProvider
See Also
ResourceResultContext Class
ResourceResultContext Members
Glimpse.Core.Extensibility Namespace


HtmlEncoder Property

ResourceResultContext HtmlEncoder Property Glimpse API Documentation
Gets or sets the HTML encoder.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IHtmlEncoder HtmlEncoder { get; set; }
public IHtmlEncoder HtmlEncoder { get; set; }
Field Value

            The HTML encoder.

Implements
IResourceResultContext HtmlEncoder
See Also
ResourceResultContext Class
ResourceResultContext Members
Glimpse.Core.Extensibility Namespace


Logger Property

ResourceResultContext Logger Property Glimpse API Documentation
Gets or sets the logger.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILogger Logger { get; set; }
public ILogger Logger { get; set; }
Field Value

            The logger.

Implements
IContext Logger
See Also
ResourceResultContext Class
ResourceResultContext Members
Glimpse.Core.Extensibility Namespace


Serializer Property

ResourceResultContext Serializer Property Glimpse API Documentation
Gets or sets the serializer.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ISerializer Serializer { get; set; }
public ISerializer Serializer { get; set; }
Field Value

            The serializer.

Implements
IResourceResultContext Serializer
See Also
ResourceResultContext Class
ResourceResultContext Members
Glimpse.Core.Extensibility Namespace


ResourceResultDecorator Class

ResourceResultDecorator Class Glimpse API Documentation
An IResourceResult abstraction for adding additional functionality to IResourceResult via the common Online decorator pattern.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility ResourceResultDecorator
Glimpse.Core.ResourceResult CacheControlDecorator

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class ResourceResultDecorator : IResourceResult,
    IWrapper<IResourceResult>
public abstract class ResourceResultDecorator : IResourceResult,
    IWrapper<IResourceResult>
See Also
ResourceResultDecorator Members
Glimpse.Core.Extensibility Namespace


ResourceResultDecorator Members

ResourceResultDecorator Members Glimpse API Documentation

The ResourceResultDecorator type exposes the following members.
Constructors
 | Name | Description
Protected method | ResourceResultDecorator | Initializes a new instance of the ResourceResultDecorator class.
Back to Top
Methods
 | Name | Description
Protected method | Decorate | Decorates the specified context.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the resource result with the specified context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetWrappedObject | Gets the wrapped object.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Protected property | WrappedResourceResult | Gets or sets the wrapped resource result.
Back to Top
See Also
ResourceResultDecorator Class
Glimpse.Core.Extensibility Namespace


ResourceResultDecorator Constructor

ResourceResultDecorator Constructor Glimpse API Documentation
Initializes a new instance of the ResourceResultDecorator class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ResourceResultDecorator(
    IResourceResult wrappedResourceResult
)
protected ResourceResultDecorator(
    IResourceResult wrappedResourceResult
)
Parameters
wrappedResourceResult
Type: Glimpse.Core.Extensibility IResourceResult
The wrapped resource result.
See Also
ResourceResultDecorator Class
ResourceResultDecorator Members
Glimpse.Core.Extensibility Namespace


ResourceResultDecorator Methods

ResourceResultDecorator Methods Glimpse API Documentation
The ResourceResultDecorator type exposes the following members.
Methods
 | Name | Description
Protected method | Decorate | Decorates the specified context.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the resource result with the specified context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetWrappedObject | Gets the wrapped object.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ResourceResultDecorator Class
Glimpse.Core.Extensibility Namespace


Decorate Method

ResourceResultDecorator Decorate Method Glimpse API Documentation
Decorates the specified context.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void Decorate(
    IResourceResultContext context
)
protected abstract void Decorate(
    IResourceResultContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceResultContext
The context.
See Also
ResourceResultDecorator Class
ResourceResultDecorator Members
Glimpse.Core.Extensibility Namespace


Execute Method

ResourceResultDecorator Execute Method Glimpse API Documentation
Executes the resource result with the specified context.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Execute(
    IResourceResultContext context
)
public void Execute(
    IResourceResultContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceResultContext
The context.
Implements
IResourceResult Execute(IResourceResultContext)
See Also
ResourceResultDecorator Class
ResourceResultDecorator Members
Glimpse.Core.Extensibility Namespace


GetWrappedObject Method

ResourceResultDecorator GetWrappedObject Method Glimpse API Documentation
Gets the wrapped object.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IResourceResult GetWrappedObject()
public IResourceResult GetWrappedObject()
Return Value

            Returned the wrapped object.

Implements
IWrapper T  GetWrappedObject
See Also
ResourceResultDecorator Class
ResourceResultDecorator Members
Glimpse.Core.Extensibility Namespace


ResourceResultDecorator Properties

ResourceResultDecorator Properties Glimpse API Documentation
The ResourceResultDecorator type exposes the following members.
Properties
 | Name | Description
Protected property | WrappedResourceResult | Gets or sets the wrapped resource result.
Back to Top
See Also
ResourceResultDecorator Class
Glimpse.Core.Extensibility Namespace


WrappedResourceResult Property

ResourceResultDecorator WrappedResourceResult Property Glimpse API Documentation
Gets or sets the wrapped resource result.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IResourceResult WrappedResourceResult { get; set; }
protected IResourceResult WrappedResourceResult { get; set; }
Field Value

            The wrapped resource result.

See Also
ResourceResultDecorator Class
ResourceResultDecorator Members
Glimpse.Core.Extensibility Namespace


RuntimeEvent Enumeration

RuntimeEvent Enumeration Glimpse API Documentation
Used to describe when a given IRuntimePolicy should be executed.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum RuntimeEvent
[FlagsAttribute]
public enum RuntimeEvent
Members
Member name | Value | Description
Initialize | 1 | During the Glimpse initialization process.
BeginRequest | 2 | When a Http request is beginning.
BeginSessionAccess | 4 | When a Http request has begun to access user session store.
ExecuteResource | 8 | When a Glimpse IResource is being executed.
EndSessionAccess | 16 | When a Http request has ended access to the user session store.
EndRequest | 32 | When a Http request has ended.
See Also
Glimpse.Core.Extensibility Namespace


RuntimePolicy Enumeration

RuntimePolicy Enumeration Glimpse API Documentation
Used to describe what operations Glimpse is allowed to perform during a Http request/response.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum RuntimePolicy
[FlagsAttribute]
public enum RuntimePolicy
Members
Member name | Value | Description
Off | 1 | Off allows Glimpse to perform any operations on a Http request/response.
ExecuteResourceOnly | 3 | ExecuteResourceOnly allows Glimpse to only respond to IResource requests. This mode is effectively a special type of Off.
PersistResults | 4 | PersistResults allows Glimpse to write request metadata to current IPersistenceStore instance.
ModifyResponseHeaders | 12 | ModifyResponseHeaders allows Glimpse to write custom Http headers and set cookies on the Http response.
ModifyResponseBody | 28 | ModifyResponseBody allows Glimpse to write to the Http response body.
DisplayGlimpseClient | 60 | DisplayGlimpseClient allows Glimpse to write the Glimpse JavaScript client <script> tag to the Http response body.
On | 60 | On allows Glimpse to run all operations against an Http request/response.
See Also
Glimpse.Core.Extensibility Namespace


RuntimePolicyContext Class

RuntimePolicyContext Class Glimpse API Documentation
The implementation of IRuntimePolicyContext used in the Execute method of IRuntimePolicy.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility RuntimePolicyContext

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RuntimePolicyContext : IRuntimePolicyContext,
    IContext
public class RuntimePolicyContext : IRuntimePolicyContext,
    IContext
See Also
RuntimePolicyContext Members
Glimpse.Core.Extensibility Namespace


RuntimePolicyContext Members

RuntimePolicyContext Members Glimpse API Documentation

The RuntimePolicyContext type exposes the following members.
Constructors
 | Name | Description
Public method | RuntimePolicyContext | Initializes a new instance of the RuntimePolicyContext class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetRequestContext T | Gets the request context.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Logger | Gets or sets the logger.
Public property | RequestMetadata | Gets or sets the request metadata.
Back to Top
See Also
RuntimePolicyContext Class
Glimpse.Core.Extensibility Namespace


RuntimePolicyContext Constructor

RuntimePolicyContext Constructor Glimpse API Documentation
Initializes a new instance of the RuntimePolicyContext class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RuntimePolicyContext(
    IRequestMetadata requestMetadata,
    ILogger logger,
    Object requestContext
)
public RuntimePolicyContext(
    IRequestMetadata requestMetadata,
    ILogger logger,
    Object requestContext
)
Parameters
requestMetadata
Type: Glimpse.Core.Framework IRequestMetadata
The request metadata.
logger
Type: Glimpse.Core.Extensibility ILogger
The logger.
requestContext
Type:   Online System Object
The request context.
Exceptions
Exception | Condition
Online System ArgumentNullException | Throws an exception if any parameters are null.
See Also
RuntimePolicyContext Class
RuntimePolicyContext Members
Glimpse.Core.Extensibility Namespace


RuntimePolicyContext Methods

RuntimePolicyContext Methods Glimpse API Documentation
The RuntimePolicyContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetRequestContext T | Gets the request context.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
RuntimePolicyContext Class
Glimpse.Core.Extensibility Namespace


GetRequestContext(T) Method

RuntimePolicyContext GetRequestContext T Method Glimpse API Documentation
Gets the request context.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T GetRequestContext<T>()
where T : class
public T GetRequestContext<T>()
where T : class
Type Parameters
T
Type of result that is expected.
Return Value

            The request context that is being used.

Implements
IRuntimePolicyContext GetRequestContext T
See Also
RuntimePolicyContext Class
RuntimePolicyContext Members
Glimpse.Core.Extensibility Namespace


RuntimePolicyContext Properties

RuntimePolicyContext Properties Glimpse API Documentation
The RuntimePolicyContext type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Gets or sets the logger.
Public property | RequestMetadata | Gets or sets the request metadata.
Back to Top
See Also
RuntimePolicyContext Class
Glimpse.Core.Extensibility Namespace


Logger Property

RuntimePolicyContext Logger Property Glimpse API Documentation
Gets or sets the logger.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILogger Logger { get; set; }
public ILogger Logger { get; set; }
Field Value

            The logger.

Implements
IContext Logger
See Also
RuntimePolicyContext Class
RuntimePolicyContext Members
Glimpse.Core.Extensibility Namespace


RequestMetadata Property

RuntimePolicyContext RequestMetadata Property Glimpse API Documentation
Gets or sets the request metadata.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRequestMetadata RequestMetadata { get; set; }
public IRequestMetadata RequestMetadata { get; set; }
Field Value

            The request metadata.

Implements
IRuntimePolicyContext RequestMetadata
See Also
RuntimePolicyContext Class
RuntimePolicyContext Members
Glimpse.Core.Extensibility Namespace


ScriptOrder Enumeration

ScriptOrder Enumeration Glimpse API Documentation
The ScriptOrder enumeration specifies the sorting order placement of <script> tags generated by IClientScript's within a page response.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ScriptOrder
public enum ScriptOrder
Members
Member name | Value | Description
IncludeBeforeClientInterfaceScript | 0 | The first <script> tags rendered. The Glimpse client has not yet been rendered, as such IClientScript's with this ScriptOrder should only perform setup tasks.
ClientInterfaceScript | 1 | The <script> tags representing the main Glimpse client.
IncludeAfterClientInterfaceScript | 2 | The <script> tags rendered immediately after the Glimpse client. These scripts usually customize or extend the Glimpse client.
RequestMetadataScript | 3 | The <script> tags representing a resource to obtain Glimpse's server side configuration metadata.
IncludeBeforeRequestDataScript | 4 | The <script> tags rendered after Glimpse's server side configuration metadata. These scripts usually append or alter the server side metadata before the client has actually rendered.
RequestDataScript | 5 | The <script> tags representing a resource to all metadata gathered for the given Http request.
IncludeAfterRequestDataScript | 6 | The last <script> tags rendered. These scripts usually append or alter Http request data.
See Also
Glimpse.Core.Extensibility Namespace


SerializationConverter(T) Class

SerializationConverter T Class Glimpse API Documentation
The ISerializationConverter abstraction which makes creating converters that deal with one type easier.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility SerializationConverter T
Glimpse.Core.SerializationConverter CSharpTypeConverter
Glimpse.Core.SerializationConverter GlimpseMetadataConverter
Glimpse.Core.SerializationConverter GlimpseRequestConverter
Glimpse.Core.SerializationConverter GlimpseRequestHeadersConverter
Glimpse.Core.SerializationConverter ListOfTraceMessageConverter
Glimpse.Core.SerializationConverter MethodInfoConverter
Glimpse.Core.SerializationConverter TabMetadataConverter
Glimpse.Core.SerializationConverter TabResultConverter
Glimpse.Core.SerializationConverter TimelineEventModelConverter

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class SerializationConverter<T> : ISerializationConverter
public abstract class SerializationConverter<T> : ISerializationConverter
Type Parameters
T

            The type supported to convert.

See Also
SerializationConverter T  Members
Glimpse.Core.Extensibility Namespace


SerializationConverter(T) Members

SerializationConverter T Members Glimpse API Documentation

The SerializationConverter T type exposes the following members.
Constructors
 | Name | Description
Protected method | SerializationConverter T | Initializes a new instance of the SerializationConverter T class
Back to Top
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object.
Public method | Convert(T) | Converts the specified object.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for.
Back to Top
See Also
SerializationConverter T Class
Glimpse.Core.Extensibility Namespace


SerializationConverter(T) Constructor

SerializationConverter T Constructor Glimpse API Documentation
Initializes a new instance of the SerializationConverter T class

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SerializationConverter()
protected SerializationConverter()
See Also
SerializationConverter T  Class
SerializationConverter T  Members
Glimpse.Core.Extensibility Namespace


SerializationConverter(T) Methods

SerializationConverter T Methods Glimpse API Documentation
The SerializationConverter T type exposes the following members.
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object.
Public method | Convert(T) | Converts the specified object.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
SerializationConverter T Class
Glimpse.Core.Extensibility Namespace


Convert Method

SerializationConverter T Convert Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Convert(Object) | Converts the specified object.
Public method | Convert(T) | Converts the specified object.
Back to Top
See Also
SerializationConverter T Class
SerializationConverter T Members
Glimpse.Core.Extensibility Namespace


Convert Method (Object)

SerializationConverter T Convert Method (Object) Glimpse API Documentation
Converts the specified object.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Convert(
    Object obj
)
public Object Convert(
    Object obj
)
Parameters
obj
Type:   Online System Object
The object to transform.
Return Value
The new object representation.
Implements
ISerializationConverter Convert(Object)
See Also
SerializationConverter T  Class
SerializationConverter T  Members
Convert Overload
Glimpse.Core.Extensibility Namespace


Convert Method (T)

SerializationConverter T Convert Method (T) Glimpse API Documentation
Converts the specified object.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Object Convert(
    T obj
)
public abstract Object Convert(
    T obj
)
Parameters
obj
Type: T
The object to transform.
Return Value
The new object representation.
See Also
SerializationConverter T  Class
SerializationConverter T  Members
Convert Overload
Glimpse.Core.Extensibility Namespace


SerializationConverter(T) Properties

SerializationConverter T Properties Glimpse API Documentation
The SerializationConverter T type exposes the following members.
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for.
Back to Top
See Also
SerializationConverter T Class
Glimpse.Core.Extensibility Namespace


SupportedTypes Property

SerializationConverter T SupportedTypes Property Glimpse API Documentation
Gets the supported types the converter will be invoked for.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Type> SupportedTypes { get; }
public IEnumerable<Type> SupportedTypes { get; }
Field Value

            The supported types.

Implements
ISerializationConverter SupportedTypes
See Also
SerializationConverter T  Class
SerializationConverter T  Members
Glimpse.Core.Extensibility Namespace


TabBase Class

TabBase Class Glimpse API Documentation
Base implementation that allows simplified the implementation of a tab. NOTE, this implementation is intended for by tabs that can execute on any provider (i.e. aren't bound to HttpContextBase in the case of the ASP.NET provider). Most tabs wont be tied to a specific provider.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility TabBase

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class TabBase : ITab
public abstract class TabBase : ITab
See Also
TabBase Members
Glimpse.Core.Extensibility Namespace


TabBase Members

TabBase Members Glimpse API Documentation

The TabBase type exposes the following members.
Constructors
 | Name | Description
Protected method | TabBase | Initializes a new instance of the TabBase class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetData | Gets the data that should be shown in the UI.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ExecuteOn | Gets when the GetData(ITabContext) method should run.
Public property | Name | Gets the name that will show in the tab.
Public property | RequestContextType | Gets the type of the request context that the Tab relies on. NOTE, this implementation returns null, hence tabs implementing this base can used by any provider.
Back to Top
See Also
TabBase Class
Glimpse.Core.Extensibility Namespace


TabBase Constructor

TabBase Constructor Glimpse API Documentation
Initializes a new instance of the TabBase class

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TabBase()
protected TabBase()
See Also
TabBase Class
TabBase Members
Glimpse.Core.Extensibility Namespace


TabBase Methods

TabBase Methods Glimpse API Documentation
The TabBase type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetData | Gets the data that should be shown in the UI.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TabBase Class
Glimpse.Core.Extensibility Namespace


GetData Method

TabBase GetData Method Glimpse API Documentation
Gets the data that should be shown in the UI.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Object GetData(
    ITabContext context
)
public abstract Object GetData(
    ITabContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility ITabContext
The context.
Return Value
Object that will be shown.
Implements
ITab GetData(ITabContext)
See Also
TabBase Class
TabBase Members
Glimpse.Core.Extensibility Namespace


TabBase Properties

TabBase Properties Glimpse API Documentation
The TabBase type exposes the following members.
Properties
 | Name | Description
Public property | ExecuteOn | Gets when the GetData(ITabContext) method should run.
Public property | Name | Gets the name that will show in the tab.
Public property | RequestContextType | Gets the type of the request context that the Tab relies on. NOTE, this implementation returns null, hence tabs implementing this base can used by any provider.
Back to Top
See Also
TabBase Class
Glimpse.Core.Extensibility Namespace


ExecuteOn Property

TabBase ExecuteOn Property Glimpse API Documentation
Gets when the GetData(ITabContext) method should run.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual RuntimeEvent ExecuteOn { get; }
public virtual RuntimeEvent ExecuteOn { get; }
Field Value
The execute on.
Implements
ITab ExecuteOn
See Also
TabBase Class
TabBase Members
Glimpse.Core.Extensibility Namespace


Name Property

TabBase Name Property Glimpse API Documentation
Gets the name that will show in the tab.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string Name { get; }
public abstract string Name { get; }
Field Value
The name.
Implements
ITab Name
See Also
TabBase Class
TabBase Members
Glimpse.Core.Extensibility Namespace


RequestContextType Property

TabBase RequestContextType Property Glimpse API Documentation
Gets the type of the request context that the Tab relies on. NOTE, this implementation returns null, hence tabs implementing this base can used by any provider.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type RequestContextType { get; }
public Type RequestContextType { get; }
Field Value
The type of the request context.
Implements
ITab RequestContextType
See Also
TabBase Class
TabBase Members
Glimpse.Core.Extensibility Namespace


TabBase(T) Class

TabBase T Class Glimpse API Documentation
Base implementation that allows simplified the implementation of a tab. NOTE, this implementation is intended for by tabs that can only be executed by a specific provider (i.e. ones bound to HttpContextBase in the case of the ASP.NET provider).
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility TabBase T

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class TabBase<T> : ITab
public abstract class TabBase<T> : ITab
Type Parameters
T
Type of the code provider that the tab is bound to
See Also
TabBase T  Members
Glimpse.Core.Extensibility Namespace


TabBase(T) Members

TabBase T Members Glimpse API Documentation

The TabBase T type exposes the following members.
Constructors
 | Name | Description
Protected method | TabBase T | Initializes a new instance of the TabBase T class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetData | Gets the data that should be shown in the UI.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ExecuteOn | Gets when the GetData(ITabContext) method should run.
Public property | Name | Gets the name that will show in the tab.
Public property | RequestContextType | Gets the type of the request context that the Tab relies on. NOTE, this implementation returns the type that the base was inherited with..
Back to Top
See Also
TabBase T Class
Glimpse.Core.Extensibility Namespace


TabBase(T) Constructor

TabBase T Constructor Glimpse API Documentation
Initializes a new instance of the TabBase T class

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TabBase()
protected TabBase()
See Also
TabBase T  Class
TabBase T  Members
Glimpse.Core.Extensibility Namespace


TabBase(T) Methods

TabBase T Methods Glimpse API Documentation
The TabBase T type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetData | Gets the data that should be shown in the UI.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TabBase T Class
Glimpse.Core.Extensibility Namespace


GetData Method

TabBase T GetData Method Glimpse API Documentation
Gets the data that should be shown in the UI.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Object GetData(
    ITabContext context
)
public abstract Object GetData(
    ITabContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility ITabContext
The context.
Return Value
Object that will be shown.
Implements
ITab GetData(ITabContext)
See Also
TabBase T  Class
TabBase T  Members
Glimpse.Core.Extensibility Namespace


TabBase(T) Properties

TabBase T Properties Glimpse API Documentation
The TabBase T type exposes the following members.
Properties
 | Name | Description
Public property | ExecuteOn | Gets when the GetData(ITabContext) method should run.
Public property | Name | Gets the name that will show in the tab.
Public property | RequestContextType | Gets the type of the request context that the Tab relies on. NOTE, this implementation returns the type that the base was inherited with..
Back to Top
See Also
TabBase T Class
Glimpse.Core.Extensibility Namespace


ExecuteOn Property

TabBase T ExecuteOn Property Glimpse API Documentation
Gets when the GetData(ITabContext) method should run.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual RuntimeEvent ExecuteOn { get; }
public virtual RuntimeEvent ExecuteOn { get; }
Field Value
The execute on.
Implements
ITab ExecuteOn
See Also
TabBase T  Class
TabBase T  Members
Glimpse.Core.Extensibility Namespace


Name Property

TabBase T Name Property Glimpse API Documentation
Gets the name that will show in the tab.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string Name { get; }
public abstract string Name { get; }
Field Value
The name.
Implements
ITab Name
See Also
TabBase T  Class
TabBase T  Members
Glimpse.Core.Extensibility Namespace


RequestContextType Property

TabBase T RequestContextType Property Glimpse API Documentation
Gets the type of the request context that the Tab relies on. NOTE, this implementation returns the type that the base was inherited with..

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type RequestContextType { get; }
public Type RequestContextType { get; }
Field Value
The type of the request context.
Implements
ITab RequestContextType
See Also
TabBase T  Class
TabBase T  Members
Glimpse.Core.Extensibility Namespace


TabContext Class

TabContext Class Glimpse API Documentation
The ITabContext implementation used by the GetData method of ITab.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility TabContext

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TabContext : ITabContext, IContext
public class TabContext : ITabContext, IContext
See Also
TabContext Members
Glimpse.Core.Extensibility Namespace


TabContext Members

TabContext Members Glimpse API Documentation

The TabContext type exposes the following members.
Constructors
 | Name | Description
Public method | TabContext | Initializes a new instance of the TabContext class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetRequestContext T | Gets the request context.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetMessages T | Gets all messages of type T that have been persisted with PersistMessage<T>. (Defined by TabContextExtensions.)
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Logger | Gets or sets the logger.
Public property | MessageBroker | Gets or sets access to the message broker. This broker can be used to access messages that are published over various topics during a given request.
Public property | TabStore | Gets access to the tab store. This is where content can be stored within the context of each request.
Back to Top
See Also
TabContext Class
Glimpse.Core.Extensibility Namespace


TabContext Constructor

TabContext Constructor Glimpse API Documentation
Initializes a new instance of the TabContext class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TabContext(
    Object requestContext,
    IDataStore tabStore,
    ILogger logger,
    IMessageBroker messageBroker
)
public TabContext(
    Object requestContext,
    IDataStore tabStore,
    ILogger logger,
    IMessageBroker messageBroker
)
Parameters
requestContext
Type:   Online System Object
The request context.
tabStore
Type: Glimpse.Core.Extensibility IDataStore
The tab store.
logger
Type: Glimpse.Core.Extensibility ILogger
The logger.
messageBroker
Type: Glimpse.Core.Extensibility IMessageBroker
The message broker.
Exceptions
Exception | Condition
Online System ArgumentNullException | Throws an exception if any parameter if null.
See Also
TabContext Class
TabContext Members
Glimpse.Core.Extensibility Namespace


TabContext Methods

TabContext Methods Glimpse API Documentation
The TabContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetRequestContext T | Gets the request context.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetMessages T | Gets all messages of type T that have been persisted with PersistMessage<T>. (Defined by TabContextExtensions.)
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TabContext Class
Glimpse.Core.Extensibility Namespace


GetRequestContext(T) Method

TabContext GetRequestContext T Method Glimpse API Documentation
Gets the request context.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T GetRequestContext<T>()
where T : class
public T GetRequestContext<T>()
where T : class
Type Parameters
T
Type of result that is expected.
Return Value

            The request context that is being used.

Implements
ITabContext GetRequestContext T
See Also
TabContext Class
TabContext Members
Glimpse.Core.Extensibility Namespace


TabContext Properties

TabContext Properties Glimpse API Documentation
The TabContext type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Gets or sets the logger.
Public property | MessageBroker | Gets or sets access to the message broker. This broker can be used to access messages that are published over various topics during a given request.
Public property | TabStore | Gets access to the tab store. This is where content can be stored within the context of each request.
Back to Top
See Also
TabContext Class
Glimpse.Core.Extensibility Namespace


Logger Property

TabContext Logger Property Glimpse API Documentation
Gets or sets the logger.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILogger Logger { get; set; }
public ILogger Logger { get; set; }
Field Value

            The logger.

Implements
IContext Logger
See Also
TabContext Class
TabContext Members
Glimpse.Core.Extensibility Namespace


MessageBroker Property

TabContext MessageBroker Property Glimpse API Documentation
Gets or sets access to the message broker. This broker can be used to access messages that are published over various topics during a given request.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IMessageBroker MessageBroker { get; set; }
public IMessageBroker MessageBroker { get; set; }
Field Value

            The message broker.

Implements
ITabContext MessageBroker
See Also
TabContext Class
TabContext Members
Glimpse.Core.Extensibility Namespace


TabStore Property

TabContext TabStore Property Glimpse API Documentation
Gets access to the tab store. This is where content can be stored within the context of each request.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDataStore TabStore { get; private set; }
public IDataStore TabStore { get; private set; }
Field Value

            The tab store.

Implements
ITabContext TabStore
See Also
TabContext Class
TabContext Members
Glimpse.Core.Extensibility Namespace


TabSetupContext Class

TabSetupContext Class Glimpse API Documentation
The implementation of ITabSetupContext used by the Setup method of ITabSetup.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility TabSetupContext

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TabSetupContext : ITabSetupContext,
    IContext
public class TabSetupContext : ITabSetupContext,
    IContext
See Also
TabSetupContext Members
Glimpse.Core.Extensibility Namespace


TabSetupContext Members

TabSetupContext Members Glimpse API Documentation

The TabSetupContext type exposes the following members.
Constructors
 | Name | Description
Public method | TabSetupContext | Initializes a new instance of the TabSetupContext class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetTabStore | Gets the tab store.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | PersistMessages T | Persists all messages of type T to a thread safe store. Persisted messages can be retrieved with GetMessages<T>. (Defined by TabContextExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Logger | Gets or sets the logger.
Public property | MessageBroker | Gets or sets the message broker.
Back to Top
See Also
TabSetupContext Class
Glimpse.Core.Extensibility Namespace


TabSetupContext Constructor

TabSetupContext Constructor Glimpse API Documentation
Initializes a new instance of the TabSetupContext class.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TabSetupContext(
    ILogger logger,
    IMessageBroker messageBroker,
    Func<IDataStore> tabStoreStrategy
)
public TabSetupContext(
    ILogger logger,
    IMessageBroker messageBroker,
    Func<IDataStore> tabStoreStrategy
)
Parameters
logger
Type: Glimpse.Core.Extensibility ILogger
The logger.
messageBroker
Type: Glimpse.Core.Extensibility IMessageBroker
The message broker.
tabStoreStrategy
Type:   Online System Func  IDataStore
The tab store strategy.
Exceptions
Exception | Condition
Online System ArgumentNullException | Throws an exception if any parameter is null.
See Also
TabSetupContext Class
TabSetupContext Members
Glimpse.Core.Extensibility Namespace


TabSetupContext Methods

TabSetupContext Methods Glimpse API Documentation
The TabSetupContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetTabStore | Gets the tab store.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | PersistMessages T | Persists all messages of type T to a thread safe store. Persisted messages can be retrieved with GetMessages<T>. (Defined by TabContextExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TabSetupContext Class
Glimpse.Core.Extensibility Namespace


GetTabStore Method

TabSetupContext GetTabStore Method Glimpse API Documentation
Gets the tab store.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDataStore GetTabStore()
public IDataStore GetTabStore()
Return Value

            Data store that can be used.

Implements
ITabSetupContext GetTabStore
See Also
TabSetupContext Class
TabSetupContext Members
Glimpse.Core.Extensibility Namespace


TabSetupContext Properties

TabSetupContext Properties Glimpse API Documentation
The TabSetupContext type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Gets or sets the logger.
Public property | MessageBroker | Gets or sets the message broker.
Back to Top
See Also
TabSetupContext Class
Glimpse.Core.Extensibility Namespace


Logger Property

TabSetupContext Logger Property Glimpse API Documentation
Gets or sets the logger.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILogger Logger { get; set; }
public ILogger Logger { get; set; }
Field Value

            The logger.

Implements
IContext Logger
See Also
TabSetupContext Class
TabSetupContext Members
Glimpse.Core.Extensibility Namespace


MessageBroker Property

TabSetupContext MessageBroker Property Glimpse API Documentation
Gets or sets the message broker.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IMessageBroker MessageBroker { get; set; }
public IMessageBroker MessageBroker { get; set; }
Field Value

            The message broker.

Implements
ITabSetupContext MessageBroker
See Also
TabSetupContext Class
TabSetupContext Members
Glimpse.Core.Extensibility Namespace


TimerResult Class

TimerResult Class Glimpse API Documentation
The result of a Time method call on a IExecutionTimer.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility TimerResult
Glimpse.Core.Extensibility TimerResult T

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TimerResult
public class TimerResult
See Also
TimerResult Members
Glimpse.Core.Extensibility Namespace


TimerResult Members

TimerResult Members Glimpse API Documentation

The TimerResult type exposes the following members.
Constructors
 | Name | Description
Public method | TimerResult | Initializes a new instance of the TimerResult class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Duration | Gets or sets the duration.
Public property | Offset | Gets or sets the offset from the beginning of the Http request.
Public property | StartTime | Gets or sets the start time.
Back to Top
See Also
TimerResult Class
Glimpse.Core.Extensibility Namespace


TimerResult Constructor

TimerResult Constructor Glimpse API Documentation
Initializes a new instance of the TimerResult class

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimerResult()
public TimerResult()
See Also
TimerResult Class
TimerResult Members
Glimpse.Core.Extensibility Namespace


TimerResult Methods

TimerResult Methods Glimpse API Documentation
The TimerResult type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TimerResult Class
Glimpse.Core.Extensibility Namespace


TimerResult Properties

TimerResult Properties Glimpse API Documentation
The TimerResult type exposes the following members.
Properties
 | Name | Description
Public property | Duration | Gets or sets the duration.
Public property | Offset | Gets or sets the offset from the beginning of the Http request.
Public property | StartTime | Gets or sets the start time.
Back to Top
See Also
TimerResult Class
Glimpse.Core.Extensibility Namespace


Duration Property

TimerResult Duration Property Glimpse API Documentation
Gets or sets the duration.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan Duration { get; set; }
public TimeSpan Duration { get; set; }
Field Value

            The duration.

See Also
TimerResult Class
TimerResult Members
Glimpse.Core.Extensibility Namespace


Offset Property

TimerResult Offset Property Glimpse API Documentation
Gets or sets the offset from the beginning of the Http request.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan Offset { get; set; }
public TimeSpan Offset { get; set; }
Field Value

            The offset.

See Also
TimerResult Class
TimerResult Members
Glimpse.Core.Extensibility Namespace


StartTime Property

TimerResult StartTime Property Glimpse API Documentation
Gets or sets the start time.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime StartTime { get; set; }
public DateTime StartTime { get; set; }
Field Value

            The start time.

See Also
TimerResult Class
TimerResult Members
Glimpse.Core.Extensibility Namespace


TimerResult(T) Class

TimerResult T Class Glimpse API Documentation
A subtype of TimerResult which includes the result of non-void method calls.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility TimerResult
Glimpse.Core.Extensibility TimerResult T

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TimerResult<T> : TimerResult
public class TimerResult<T> : TimerResult
Type Parameters
T
The type returned by the executed method.
See Also
TimerResult T  Members
Glimpse.Core.Extensibility Namespace


TimerResult(T) Members

TimerResult T Members Glimpse API Documentation

The TimerResult T type exposes the following members.
Constructors
 | Name | Description
Public method | TimerResult T | Initializes a new instance of the TimerResult T class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Duration | Gets or sets the duration. (Inherited from TimerResult.)
Public property | Offset | Gets or sets the offset from the beginning of the Http request. (Inherited from TimerResult.)
Public property | Result | Gets or sets the result.
Public property | StartTime | Gets or sets the start time. (Inherited from TimerResult.)
Back to Top
See Also
TimerResult T Class
Glimpse.Core.Extensibility Namespace


TimerResult(T) Constructor

TimerResult T Constructor Glimpse API Documentation
Initializes a new instance of the TimerResult T class

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimerResult()
public TimerResult()
See Also
TimerResult T  Class
TimerResult T  Members
Glimpse.Core.Extensibility Namespace


TimerResult(T) Methods

TimerResult T Methods Glimpse API Documentation
The TimerResult T type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TimerResult T Class
Glimpse.Core.Extensibility Namespace


TimerResult(T) Properties

TimerResult T Properties Glimpse API Documentation
The TimerResult T type exposes the following members.
Properties
 | Name | Description
Public property | Duration | Gets or sets the duration. (Inherited from TimerResult.)
Public property | Offset | Gets or sets the offset from the beginning of the Http request. (Inherited from TimerResult.)
Public property | Result | Gets or sets the result.
Public property | StartTime | Gets or sets the start time. (Inherited from TimerResult.)
Back to Top
See Also
TimerResult T Class
Glimpse.Core.Extensibility Namespace


Result Property

TimerResult T Result Property Glimpse API Documentation
Gets or sets the result.

Namespace: Glimpse.Core.Extensibility
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T Result { get; set; }
public T Result { get; set; }
Field Value

            The result.

See Also
TimerResult T  Class
TimerResult T  Members
Glimpse.Core.Extensibility Namespace


Glimpse.Core.Extensions Namespace

Glimpse.Core.Extensions Namespace Glimpse API Documentation
All Glimpse specific extention methonds are defined within this namespace.
Classes
 | Class | Description
Public class | AlternateMethodContextExtensions | Extension methods to simplify common tasks completed with IAlternateMethodContext.
Public class | DataStoreExtensions | Extension methods to simplify common tasks completed with IDataStore.
Public class | DictionaryExtensions | Extension methods to simplify common tasks completed with Online IDictionary TKey, TValue .
Public class | EnumExtensions | Extension methods to simplify common tasks completed with Online Enum.
Public class | NameValueCollectionExtension | Extension methods to simplify common tasks completed with Online NameValueCollection.
Public class | ObjectExtensions | Extension methods to simplify common tasks completed with Online Object.
Public class | TabContextExtensions | Extension methods to simplify common tasks completed with ITabSetupContext and ITabContext together.


AlternateMethodContextExtensions Class

AlternateMethodContextExtensions Class Glimpse API Documentation
Extension methods to simplify common tasks completed with IAlternateMethodContext.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensions AlternateMethodContextExtensions

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class AlternateMethodContextExtensions
public static class AlternateMethodContextExtensions
See Also
AlternateMethodContextExtensions Members
Glimpse.Core.Extensions Namespace


AlternateMethodContextExtensions Members

AlternateMethodContextExtensions Members Glimpse API Documentation

The AlternateMethodContextExtensions type exposes the following members.
Methods
Name | Description
TryProceedWithTimer | Calls Proceed on the original implementation, if the current RuntimePolicy is not Off, and provides a corresponding TimerResult.
Back to Top
See Also
AlternateMethodContextExtensions Class
Glimpse.Core.Extensions Namespace


AlternateMethodContextExtensions Methods

AlternateMethodContextExtensions Methods Glimpse API Documentation
The AlternateMethodContextExtensions type exposes the following members.
Methods
Name | Description
TryProceedWithTimer | Calls Proceed on the original implementation, if the current RuntimePolicy is not Off, and provides a corresponding TimerResult.
Back to Top
See Also
AlternateMethodContextExtensions Class
Glimpse.Core.Extensions Namespace


TryProceedWithTimer Method

AlternateMethodContextExtensions TryProceedWithTimer Method Glimpse API Documentation
Calls Proceed on the original implementation, if the current RuntimePolicy is not Off, and provides a corresponding TimerResult.

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryProceedWithTimer(
    this IAlternateMethodContext context,
    out TimerResult timerResult
)
public static bool TryProceedWithTimer(
    this IAlternateMethodContext context,
    out TimerResult timerResult
)
Parameters
context
Type: Glimpse.Core.Extensibility IAlternateMethodContext
The context.
timerResult
Type: Glimpse.Core.Extensibility TimerResult
The timer result.
Return Value

            Returns true if Proceed was called on the original object, and sets timerResult. Returns false and sets timerResult to null if RuntimePolicy is Off.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IAlternateMethodContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
AlternateMethodContextExtensions Class
AlternateMethodContextExtensions Members
Glimpse.Core.Extensions Namespace


DataStoreExtensions Class

DataStoreExtensions Class Glimpse API Documentation
Extension methods to simplify common tasks completed with IDataStore.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensions DataStoreExtensions

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class DataStoreExtensions
public static class DataStoreExtensions
See Also
DataStoreExtensions Members
Glimpse.Core.Extensions Namespace


DataStoreExtensions Members

DataStoreExtensions Members Glimpse API Documentation

The DataStoreExtensions type exposes the following members.
Methods
Name | Description
Contains T | Determines whether store contains and item with a key of T.
Get T (IDataStore) | Gets an item from store using <T> as a key. This method should be used in combination with Set<T>.
Get T (IDataStore, String) | Gets an item from store using the key and casts to <T>.
Set T | Sets an item in store using <T> as a key. This method should be used in combination with Get<T>.
Back to Top
See Also
DataStoreExtensions Class
Glimpse.Core.Extensions Namespace


DataStoreExtensions Methods

DataStoreExtensions Methods Glimpse API Documentation
The DataStoreExtensions type exposes the following members.
Methods
Name | Description
Contains T | Determines whether store contains and item with a key of T.
Get T (IDataStore) | Gets an item from store using <T> as a key. This method should be used in combination with Set<T>.
Get T (IDataStore, String) | Gets an item from store using the key and casts to <T>.
Set T | Sets an item in store using <T> as a key. This method should be used in combination with Get<T>.
Back to Top
See Also
DataStoreExtensions Class
Glimpse.Core.Extensions Namespace


Contains(T) Method

DataStoreExtensions Contains T Method Glimpse API Documentation
Determines whether store contains and item with a key of T.

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool Contains<T>(
    this IDataStore store
)
public static bool Contains<T>(
    this IDataStore store
)
Parameters
store
Type: Glimpse.Core.Extensibility IDataStore
The data store instance.
Type Parameters
T
The item key.
Return Value
true if store contains the item; otherwise, false.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IDataStore. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
DataStoreExtensions Class
DataStoreExtensions Members
Glimpse.Core.Extensions Namespace


Get Method

DataStoreExtensions Get Method Glimpse API Documentation
Overload List
Name | Description
Get T (IDataStore) | Gets an item from store using <T> as a key. This method should be used in combination with Set<T>.
Get T (IDataStore, String) | Gets an item from store using the key and casts to <T>.
Back to Top
See Also
DataStoreExtensions Class
DataStoreExtensions Members
Glimpse.Core.Extensions Namespace


Get(T) Method (IDataStore)

DataStoreExtensions Get T Method (IDataStore) Glimpse API Documentation
Gets an item from store using <T> as a key. This method should be used in combination with Set<T>.

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static T Get<T>(
    this IDataStore store
)
public static T Get<T>(
    this IDataStore store
)
Parameters
store
Type: Glimpse.Core.Extensibility IDataStore
The data store instance.
Type Parameters
T
The type of item to retrieve and the key when used in combination with Set<T>.
Return Value

            An item of type T, null or an   Online InvalidCastException is thrown depending on the type of store. Call Contains<T> first to ensure results.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IDataStore. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
Online System InvalidCastException | May throw an invalid cast exception if the IDataStore item and type do not match.
See Also
DataStoreExtensions Class
DataStoreExtensions Members
Get Overload
Glimpse.Core.Extensions Namespace


Get(T) Method (IDataStore, String)

DataStoreExtensions Get T Method (IDataStore, String) Glimpse API Documentation
Gets an item from store using the key and casts to <T>.

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static T Get<T>(
    this IDataStore store,
    string key
)
public static T Get<T>(
    this IDataStore store,
    string key
)
Parameters
store
Type: Glimpse.Core.Extensibility IDataStore
The data store instance.
key
Type:   Online System String
The item key.
Type Parameters
T
The type of item to retrieve.
Return Value

            An item of type T, null or an   Online InvalidCastException is thrown depending on the type of store. Call Contains<T> first to ensure results.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IDataStore. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
Online System InvalidCastException | May throw an invalid cast exception if the IDataStore item and type do not match.
See Also
DataStoreExtensions Class
DataStoreExtensions Members
Get Overload
Glimpse.Core.Extensions Namespace


Set(T) Method

DataStoreExtensions Set T Method Glimpse API Documentation
Sets an item in store using <T> as a key. This method should be used in combination with Get<T>.

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Set<T>(
    this IDataStore store,
    T value
)
public static void Set<T>(
    this IDataStore store,
    T value
)
Parameters
store
Type: Glimpse.Core.Extensibility IDataStore
The data store instance.
value
Type: T
The item to store.
Type Parameters
T
The type of item to set.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type IDataStore. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
Examples
View Colorized Copy to Clipboard Print
dataStore.Set("I am a string"); // inferred type
var result = dataStore.Get<string>();
Assert.Equals(result, "I am a string");

dataStore.Set<IList<int>>(new List{ 1, 2, 3 }); // specified type
var result = dataStore.Get<IList<int>>();
Assert.Equals(result.Count, 3);
dataStore.Set("I am a string"); // inferred type
var result = dataStore.Get<string>();
Assert.Equals(result, "I am a string");

dataStore.Set<IList<int>>(new List{ 1, 2, 3 }); // specified type
var result = dataStore.Get<IList<int>>();
Assert.Equals(result.Count, 3);
See Also
DataStoreExtensions Class
DataStoreExtensions Members
Glimpse.Core.Extensions Namespace


DictionaryExtensions Class

DictionaryExtensions Class Glimpse API Documentation
Extension methods to simplify common tasks completed with Online IDictionary TKey, TValue .
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensions DictionaryExtensions

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class DictionaryExtensions
public static class DictionaryExtensions
See Also
DictionaryExtensions Members
Glimpse.Core.Extensions Namespace


DictionaryExtensions Members

DictionaryExtensions Members Glimpse API Documentation

The DictionaryExtensions type exposes the following members.
Methods
Name | Description
GetValueOrDefault TKey, TValue | Gets the value, if available, or ifNotFound.
Back to Top
See Also
DictionaryExtensions Class
Glimpse.Core.Extensions Namespace


DictionaryExtensions Methods

DictionaryExtensions Methods Glimpse API Documentation
The DictionaryExtensions type exposes the following members.
Methods
Name | Description
GetValueOrDefault TKey, TValue | Gets the value, if available, or ifNotFound.
Back to Top
See Also
DictionaryExtensions Class
Glimpse.Core.Extensions Namespace


GetValueOrDefault(TKey, TValue) Method

DictionaryExtensions GetValueOrDefault TKey, TValue Method Glimpse API Documentation
Gets the value, if available, or ifNotFound.

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TValue GetValueOrDefault<TKey, TValue>(
    this IDictionary<TKey, TValue> dictionary,
    TKey key,
    TValue ifNotFound = null
)
public static TValue GetValueOrDefault<TKey, TValue>(
    this IDictionary<TKey, TValue> dictionary,
    TKey key,
    TValue ifNotFound = null
)
Parameters
dictionary
Type:   Online System.Collections.Generic IDictionary  TKey, TValue
The dictionary to search.
key
Type: TKey
The item key.
ifNotFound (Optional)
Type: TValue
The fallback value.
Type Parameters
TKey
The type of the key.
TValue
The type of the value.
Return Value

            Returns the item in dictionary that matches key, falling back to the value of ifNotFound if the item is unavailable.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online IDictionary  TKey, TValue . When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
DictionaryExtensions Class
DictionaryExtensions Members
Glimpse.Core.Extensions Namespace


EnumExtensions Class

EnumExtensions Class Glimpse API Documentation
Extension methods to simplify common tasks completed with Online Enum.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensions EnumExtensions

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class EnumExtensions
public static class EnumExtensions
See Also
EnumExtensions Members
Glimpse.Core.Extensions Namespace


EnumExtensions Members

EnumExtensions Members Glimpse API Documentation

The EnumExtensions type exposes the following members.
Methods
Name | Description
ToDescription | Converts an Online Enum value to a string if it is annotated with a Online DescriptionAttribute.
Back to Top
See Also
EnumExtensions Class
Glimpse.Core.Extensions Namespace


EnumExtensions Methods

EnumExtensions Methods Glimpse API Documentation
The EnumExtensions type exposes the following members.
Methods
Name | Description
ToDescription | Converts an Online Enum value to a string if it is annotated with a Online DescriptionAttribute.
Back to Top
See Also
EnumExtensions Class
Glimpse.Core.Extensions Namespace


ToDescription Method

EnumExtensions ToDescription Method Glimpse API Documentation
Converts an Online Enum value to a string if it is annotated with a Online DescriptionAttribute.

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToDescription(
    this Enum enumeration
)
public static string ToDescription(
    this Enum enumeration
)
Parameters
enumeration
Type:   Online System Enum
The enumeration.
Return Value

            The   Online DescriptionAttribute string of the corresponding   Online Enum member, or an empty string if no   Online DescriptionAttribute is present.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online Enum. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
EnumExtensions Class
EnumExtensions Members
Glimpse.Core.Extensions Namespace


NameValueCollectionExtension Class

NameValueCollectionExtension Class Glimpse API Documentation
Extension methods to simplify common tasks completed with Online NameValueCollection.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensions NameValueCollectionExtension

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class NameValueCollectionExtension
public static class NameValueCollectionExtension
See Also
NameValueCollectionExtension Members
Glimpse.Core.Extensions Namespace


NameValueCollectionExtension Members

NameValueCollectionExtension Members Glimpse API Documentation

The NameValueCollectionExtension type exposes the following members.
Methods
Name | Description
ToDictionary | Converts a Online NameValueCollection to a IDictionary<string, string>.
Back to Top
See Also
NameValueCollectionExtension Class
Glimpse.Core.Extensions Namespace


NameValueCollectionExtension Methods

NameValueCollectionExtension Methods Glimpse API Documentation
The NameValueCollectionExtension type exposes the following members.
Methods
Name | Description
ToDictionary | Converts a Online NameValueCollection to a IDictionary<string, string>.
Back to Top
See Also
NameValueCollectionExtension Class
Glimpse.Core.Extensions Namespace


ToDictionary Method

NameValueCollectionExtension ToDictionary Method Glimpse API Documentation
Converts a Online NameValueCollection to a IDictionary<string, string>.

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IDictionary<string, string> ToDictionary(
    this NameValueCollection input
)
public static IDictionary<string, string> ToDictionary(
    this NameValueCollection input
)
Parameters
input
Type:   Online System.Collections.Specialized NameValueCollection
The   Online NameValueCollection to convert.
Return Value

            A IDictionary<string, string> containing the same key/value pairs as input.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online NameValueCollection. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
NameValueCollectionExtension Class
NameValueCollectionExtension Members
Glimpse.Core.Extensions Namespace


ObjectExtensions Class

ObjectExtensions Class Glimpse API Documentation
Extension methods to simplify common tasks completed with Online Object.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensions ObjectExtensions

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class ObjectExtensions
public static class ObjectExtensions
See Also
ObjectExtensions Members
Glimpse.Core.Extensions Namespace


ObjectExtensions Members

ObjectExtensions Members Glimpse API Documentation

The ObjectExtensions type exposes the following members.
Methods
Name | Description
GetTypeOrNull | Returns the value of GetType if value is not null.
ToStringOrDefault | Returns the value of ToString if value is not null.
Back to Top
See Also
ObjectExtensions Class
Glimpse.Core.Extensions Namespace


ObjectExtensions Methods

ObjectExtensions Methods Glimpse API Documentation
The ObjectExtensions type exposes the following members.
Methods
Name | Description
GetTypeOrNull | Returns the value of GetType if value is not null.
ToStringOrDefault | Returns the value of ToString if value is not null.
Back to Top
See Also
ObjectExtensions Class
Glimpse.Core.Extensions Namespace


GetTypeOrNull Method

ObjectExtensions GetTypeOrNull Method Glimpse API Documentation
Returns the value of GetType if value is not null.

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Type GetTypeOrNull(
    this Object value
)
public static Type GetTypeOrNull(
    this Object value
)
Parameters
value
Type:   Online System Object
The value.
Return Value
The value of GetType if value is not null.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
ObjectExtensions Class
ObjectExtensions Members
Glimpse.Core.Extensions Namespace


ToStringOrDefault Method

ObjectExtensions ToStringOrDefault Method Glimpse API Documentation
Returns the value of ToString if value is not null.

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToStringOrDefault(
    this Object value
)
public static string ToStringOrDefault(
    this Object value
)
Parameters
value
Type:   Online System Object
The value.
Return Value
The value of ToString if value is not null.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type   Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
ObjectExtensions Class
ObjectExtensions Members
Glimpse.Core.Extensions Namespace


TabContextExtensions Class

TabContextExtensions Class Glimpse API Documentation
Extension methods to simplify common tasks completed with ITabSetupContext and ITabContext together.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensions TabContextExtensions

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class TabContextExtensions
public static class TabContextExtensions
See Also
TabContextExtensions Members
Glimpse.Core.Extensions Namespace


TabContextExtensions Members

TabContextExtensions Members Glimpse API Documentation

The TabContextExtensions type exposes the following members.
Methods
Name | Description
GetMessages T | Gets all messages of type T that have been persisted with PersistMessage<T>.
PersistMessages T | Persists all messages of type T to a thread safe store. Persisted messages can be retrieved with GetMessages<T>.
Back to Top
See Also
TabContextExtensions Class
Glimpse.Core.Extensions Namespace


TabContextExtensions Methods

TabContextExtensions Methods Glimpse API Documentation
The TabContextExtensions type exposes the following members.
Methods
Name | Description
GetMessages T | Gets all messages of type T that have been persisted with PersistMessage<T>.
PersistMessages T | Persists all messages of type T to a thread safe store. Persisted messages can be retrieved with GetMessages<T>.
Back to Top
See Also
TabContextExtensions Class
Glimpse.Core.Extensions Namespace


GetMessages(T) Method

TabContextExtensions GetMessages T Method Glimpse API Documentation
Gets all messages of type T that have been persisted with PersistMessage<T>.

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<T> GetMessages<T>(
    this ITabContext context
)
public static IEnumerable<T> GetMessages<T>(
    this ITabContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility ITabContext
The context.
Type Parameters
T
The type of message to get.
Return Value

            An   Online IEnumerable T  of any persisted messages. If no messages has been persisted, an empty enumerable will be returned.

Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ITabContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
TabContextExtensions Class
TabContextExtensions Members
Glimpse.Core.Extensions Namespace


PersistMessages(T) Method

TabContextExtensions PersistMessages T Method Glimpse API Documentation
Persists all messages of type T to a thread safe store. Persisted messages can be retrieved with GetMessages<T>.

Namespace: Glimpse.Core.Extensions
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void PersistMessages<T>(
    this ITabSetupContext context
)
public static void PersistMessages<T>(
    this ITabSetupContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility ITabSetupContext
The context.
Type Parameters
T
The type of message to persist.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type ITabSetupContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
TabContextExtensions Class
TabContextExtensions Members
Glimpse.Core.Extensions Namespace


Glimpse.Core.Framework Namespace

Glimpse.Core.Framework Namespace Glimpse API Documentation
All types for integrating Glimpse with a .NET web development frameowrk are defined within this namespace.
Classes
 | Class | Description
Public class | ApplicationPersistenceStore | An IPersistenceStore which stores Glimpse request and configuration data in application store.
Public class | CastleDynamicProxyFactory | An implementation of IProxyFactory which leverages Online Castle DynamicProxy.
Public class | Factory | The main bootstrapper for Glimpse, Factory (or its derived types) is responsible for instantiating all required configurable types.
Public class | GlimpseConfiguration | Contains all configuration required by IGlimpseRuntime instances to execute.
Public class | GlimpseException | A custom exception thrown for unrecoverable Glimpse issues.
Public class | GlimpseMetadata | A class which describes Glimpse system metadata, as required by a client.
Public class | GlimpseRequest | A class which describes a given Http request, along with the corresponding tab data gathered for that request.
Public class | GlimpseRequestHeaders | Used to return a subset of GlimpseRequest properties by HistoryResource.
Public class | GlimpseRuntime | The heart and soul of Glimpse. The runtime coordinate all input from a IFrameworkProvider, persists collected runtime information and writes responses out to the IFrameworkProvider.
Protected class | GlimpseRuntime RuntimeMessage | The message used to to track the beginning and end of Http requests.
Public class | ReflectionDiscoverableCollection T | An implementation of IDiscoverableCollection T which uses .NET reflection to find and load types.
Public class | ResourceEndpointConfiguration | Defines methods to implement a resource endpoint configuration.
Public class | ResourceParameters | A class which contains all the parameters, whether named or ordered, needed to execute a resource.
Public class | TabMetadata | Contains any metadata associated with a given tab.
Public class | TabResult | Contains the results of executing an ITab, along with its key.
Interfaces
 | Interface | Description
Public interface | IDiscoverableCollection T | Defines methods to self discover collection content.
Public interface | IFrameworkProvider | Defines methods to required to implement a Glimpse framework provider. Framework providers allow Glimpse to work generically against any .NET based web development framework.
Public interface | IGlimpseConfiguration | Defines properties to provide access to system providers, stores, collections, factories, etc.
Public interface | IGlimpseRuntime | Defines methods to implement the Glimpse runtime
Public interface | IPersistenceStore | Defines methods to implement a store that Glimpse can use to persist requests.
Public interface | IReadOnlyPersistenceStore | Defines methods to implement a read only store that Glimpse can use to retrieve requests and system metadata.
Public interface | IRequestMetadata | Defines properties that describe the metadata associated with a request
Public interface | IServiceLocator | Defines methods to implement a service locator
Enumerations
 | Enumeration | Description
Public enumeration | CacheSetting | The Online Enum providing type safe access to cache directives as defined in Online Section 14.9 of RFC 2616.


ApplicationPersistenceStore Class

ApplicationPersistenceStore Class Glimpse API Documentation
An IPersistenceStore which stores Glimpse request and configuration data in application store.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Framework ApplicationPersistenceStore

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ApplicationPersistenceStore : IPersistenceStore,
    IReadOnlyPersistenceStore
public class ApplicationPersistenceStore : IPersistenceStore,
    IReadOnlyPersistenceStore
Remarks

            An example of an application store is HttpContext.Current.Application in ASP.NET.

See Also
ApplicationPersistenceStore Members
Glimpse.Core.Framework Namespace


ApplicationPersistenceStore Members

ApplicationPersistenceStore Members Glimpse API Documentation

The ApplicationPersistenceStore type exposes the following members.
Constructors
 | Name | Description
Public method | ApplicationPersistenceStore | Initializes a new instance of the ApplicationPersistenceStore class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetByRequestId | Gets the by request id.
Public method | GetByRequestIdAndTabKey | Gets the by request id and tab key.
Public method | GetByRequestParentId | Gets the by request parent id.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetMetadata | Gets the metadata.
Public method | GetTop | Gets the top.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Save(GlimpseMetadata) | Saves the specified system metadata.
Public method | Save(GlimpseRequest) | Saves the specified request.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ApplicationPersistenceStore Class
Glimpse.Core.Framework Namespace


ApplicationPersistenceStore Constructor

ApplicationPersistenceStore Constructor Glimpse API Documentation
Initializes a new instance of the ApplicationPersistenceStore class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ApplicationPersistenceStore(
    IDataStore dataStore
)
public ApplicationPersistenceStore(
    IDataStore dataStore
)
Parameters
dataStore
Type: Glimpse.Core.Extensibility IDataStore
The data store.
See Also
ApplicationPersistenceStore Class
ApplicationPersistenceStore Members
Glimpse.Core.Framework Namespace


ApplicationPersistenceStore Methods

ApplicationPersistenceStore Methods Glimpse API Documentation
The ApplicationPersistenceStore type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetByRequestId | Gets the by request id.
Public method | GetByRequestIdAndTabKey | Gets the by request id and tab key.
Public method | GetByRequestParentId | Gets the by request parent id.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetMetadata | Gets the metadata.
Public method | GetTop | Gets the top.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Save(GlimpseMetadata) | Saves the specified system metadata.
Public method | Save(GlimpseRequest) | Saves the specified request.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ApplicationPersistenceStore Class
Glimpse.Core.Framework Namespace


GetByRequestId Method

ApplicationPersistenceStore GetByRequestId Method Glimpse API Documentation
Gets the by request id.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlimpseRequest GetByRequestId(
    Guid requestId
)
public GlimpseRequest GetByRequestId(
    Guid requestId
)
Parameters
requestId
Type:   Online System Guid
The request id.
Return Value

            Instance of the request that matches the request id.

Implements
IReadOnlyPersistenceStore GetByRequestId(Guid)
See Also
ApplicationPersistenceStore Class
ApplicationPersistenceStore Members
Glimpse.Core.Framework Namespace


GetByRequestIdAndTabKey Method

ApplicationPersistenceStore GetByRequestIdAndTabKey Method Glimpse API Documentation
Gets the by request id and tab key.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TabResult GetByRequestIdAndTabKey(
    Guid requestId,
    string tabKey
)
public TabResult GetByRequestIdAndTabKey(
    Guid requestId,
    string tabKey
)
Parameters
requestId
Type:   Online System Guid
The request id.
tabKey
Type:   Online System String
The tab key.
Return Value

            Instance of the tab data that matches the request id and tab key.

Implements
IReadOnlyPersistenceStore GetByRequestIdAndTabKey(Guid, String)
Exceptions
Exception | Condition
Online System ArgumentException | Throws an exception if tabKey is null.
See Also
ApplicationPersistenceStore Class
ApplicationPersistenceStore Members
Glimpse.Core.Framework Namespace


GetByRequestParentId Method

ApplicationPersistenceStore GetByRequestParentId Method Glimpse API Documentation
Gets the by request parent id.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<GlimpseRequest> GetByRequestParentId(
    Guid parentRequestId
)
public IEnumerable<GlimpseRequest> GetByRequestParentId(
    Guid parentRequestId
)
Parameters
parentRequestId
Type:   Online System Guid
The parent request id.
Return Value

            Collection of requests that matches the parent request id.

Implements
IReadOnlyPersistenceStore GetByRequestParentId(Guid)
See Also
ApplicationPersistenceStore Class
ApplicationPersistenceStore Members
Glimpse.Core.Framework Namespace


GetMetadata Method

ApplicationPersistenceStore GetMetadata Method Glimpse API Documentation
Gets the metadata.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlimpseMetadata GetMetadata()
public GlimpseMetadata GetMetadata()
Return Value

            Metadata that is currently applied.

Implements
IReadOnlyPersistenceStore GetMetadata
See Also
ApplicationPersistenceStore Class
ApplicationPersistenceStore Members
Glimpse.Core.Framework Namespace


GetTop Method

ApplicationPersistenceStore GetTop Method Glimpse API Documentation
Gets the top.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<GlimpseRequest> GetTop(
    int count
)
public IEnumerable<GlimpseRequest> GetTop(
    int count
)
Parameters
count
Type:   Online System Int32
The count.
Return Value

            Collection of requests that represent the top x number of requests.

Implements
IReadOnlyPersistenceStore GetTop(Int32)
See Also
ApplicationPersistenceStore Class
ApplicationPersistenceStore Members
Glimpse.Core.Framework Namespace


Save Method

ApplicationPersistenceStore Save Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Save(GlimpseMetadata) | Saves the specified system metadata.
Public method | Save(GlimpseRequest) | Saves the specified request.
Back to Top
See Also
ApplicationPersistenceStore Class
ApplicationPersistenceStore Members
Glimpse.Core.Framework Namespace


Save Method (GlimpseMetadata)

ApplicationPersistenceStore Save Method (GlimpseMetadata) Glimpse API Documentation
Saves the specified system metadata.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Save(
    GlimpseMetadata metadata
)
public void Save(
    GlimpseMetadata metadata
)
Parameters
metadata
Type: Glimpse.Core.Framework GlimpseMetadata
The metadata.
Implements
IPersistenceStore Save(GlimpseMetadata)
See Also
ApplicationPersistenceStore Class
ApplicationPersistenceStore Members
Save Overload
Glimpse.Core.Framework Namespace


Save Method (GlimpseRequest)

ApplicationPersistenceStore Save Method (GlimpseRequest) Glimpse API Documentation
Saves the specified request.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Save(
    GlimpseRequest request
)
public void Save(
    GlimpseRequest request
)
Parameters
request
Type: Glimpse.Core.Framework GlimpseRequest
The request.
Implements
IPersistenceStore Save(GlimpseRequest)
See Also
ApplicationPersistenceStore Class
ApplicationPersistenceStore Members
Save Overload
Glimpse.Core.Framework Namespace


CacheSetting Enumeration

CacheSetting Enumeration Glimpse API Documentation
The Online Enum providing type safe access to cache directives as defined in Online Section 14.9 of RFC 2616.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum CacheSetting
public enum CacheSetting
Members
Member name | Value | Description
Public | 0 | Indicates that the response may be cached by any cache.
Private | 1 | Indicates that the response is intended for a single user and must not be cached by a shared cache.
NoCache | 2 | Indicates that the response should not be cached.
NoStore | 3 | Indicates that the response should not be stored for sensitivity purposes.
See Also
Glimpse.Core.Framework Namespace
  Online Hypertext Transfer Protocol Protocol - HTTP/1.1


CastleDynamicProxyFactory Class

CastleDynamicProxyFactory Class Glimpse API Documentation
An implementation of IProxyFactory which leverages Online Castle DynamicProxy.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Framework CastleDynamicProxyFactory

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CastleDynamicProxyFactory : IProxyFactory
public class CastleDynamicProxyFactory : IProxyFactory
See Also
CastleDynamicProxyFactory Members
Glimpse.Core.Framework Namespace


CastleDynamicProxyFactory Members

CastleDynamicProxyFactory Members Glimpse API Documentation

The CastleDynamicProxyFactory type exposes the following members.
Constructors
 | Name | Description
Public method | CastleDynamicProxyFactory | Initializes a new instance of the CastleDynamicProxyFactory class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | ExtendClass T (IEnumerable IAlternateMethod ) | Extends the class.
Public method | ExtendClass T (IEnumerable IAlternateMethod , IEnumerable Object ) | Extends the class.
Public method | ExtendClass T (IEnumerable IAlternateMethod , IEnumerable Object , IEnumerable Object ) | Extends the class.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsExtendClassEligible | Determines whether the specified type is eligible to be extended.
Public method | IsWrapClassEligible | Determines whether the specified type eligible to be class wrapped.
Public method | IsWrapInterfaceEligible TToWrap | Determines whether the specified type is eligible to be interface wrapped.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | WrapClass T (T, IEnumerable IAlternateMethod ) | Wraps the class.
Public method | WrapClass T (T, IEnumerable IAlternateMethod , IEnumerable Object ) | Wraps the class.
Public method | WrapClass T (T, IEnumerable IAlternateMethod , IEnumerable Object , IEnumerable Object ) | Wraps the class.
Public method | WrapInterface T (T, IEnumerable IAlternateMethod ) | Wraps the interface.
Public method | WrapInterface T (T, IEnumerable IAlternateMethod , IEnumerable Object ) | Wraps the interface.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Logger | Gets or sets the logger.
Public property | MessageBroker | Gets or sets the message broker.
Public property | ProxyGenerator | Gets or sets the proxy generator.
Public property | RuntimePolicyStrategy | Gets or sets the runtime policy strategy.
Public property | TimerStrategy | Gets or sets the timer strategy.
Back to Top
See Also
CastleDynamicProxyFactory Class
Glimpse.Core.Framework Namespace


CastleDynamicProxyFactory Constructor

CastleDynamicProxyFactory Constructor Glimpse API Documentation
Initializes a new instance of the CastleDynamicProxyFactory class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CastleDynamicProxyFactory(
    ILogger logger,
    IMessageBroker messageBroker,
    Func<IExecutionTimer> timerStrategy,
    Func<RuntimePolicy> runtimePolicyStrategy
)
public CastleDynamicProxyFactory(
    ILogger logger,
    IMessageBroker messageBroker,
    Func<IExecutionTimer> timerStrategy,
    Func<RuntimePolicy> runtimePolicyStrategy
)
Parameters
logger
Type: Glimpse.Core.Extensibility ILogger
The logger.
messageBroker
Type: Glimpse.Core.Extensibility IMessageBroker
The message broker.
timerStrategy
Type:   Online System Func  IExecutionTimer
The timer strategy.
runtimePolicyStrategy
Type:   Online System Func  RuntimePolicy
The runtime policy strategy.
Exceptions
Exception | Condition
Online System ArgumentNullException | Throws an exception if any parameter if null.
See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
Glimpse.Core.Framework Namespace


CastleDynamicProxyFactory Methods

CastleDynamicProxyFactory Methods Glimpse API Documentation
The CastleDynamicProxyFactory type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | ExtendClass T (IEnumerable IAlternateMethod ) | Extends the class.
Public method | ExtendClass T (IEnumerable IAlternateMethod , IEnumerable Object ) | Extends the class.
Public method | ExtendClass T (IEnumerable IAlternateMethod , IEnumerable Object , IEnumerable Object ) | Extends the class.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsExtendClassEligible | Determines whether the specified type is eligible to be extended.
Public method | IsWrapClassEligible | Determines whether the specified type eligible to be class wrapped.
Public method | IsWrapInterfaceEligible TToWrap | Determines whether the specified type is eligible to be interface wrapped.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | WrapClass T (T, IEnumerable IAlternateMethod ) | Wraps the class.
Public method | WrapClass T (T, IEnumerable IAlternateMethod , IEnumerable Object ) | Wraps the class.
Public method | WrapClass T (T, IEnumerable IAlternateMethod , IEnumerable Object , IEnumerable Object ) | Wraps the class.
Public method | WrapInterface T (T, IEnumerable IAlternateMethod ) | Wraps the interface.
Public method | WrapInterface T (T, IEnumerable IAlternateMethod , IEnumerable Object ) | Wraps the interface.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
CastleDynamicProxyFactory Class
Glimpse.Core.Framework Namespace


ExtendClass Method

CastleDynamicProxyFactory ExtendClass Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | ExtendClass T (IEnumerable IAlternateMethod ) | Extends the class.
Public method | ExtendClass T (IEnumerable IAlternateMethod , IEnumerable Object ) | Extends the class.
Public method | ExtendClass T (IEnumerable IAlternateMethod , IEnumerable Object , IEnumerable Object ) | Extends the class.
Back to Top
See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
Glimpse.Core.Framework Namespace


ExtendClass(T) Method (IEnumerable(IAlternateMethod))

CastleDynamicProxyFactory ExtendClass T Method (IEnumerable IAlternateMethod ) Glimpse API Documentation
Extends the class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T ExtendClass<T>(
    IEnumerable<IAlternateMethod> methodImplementations
)
where T : class
public T ExtendClass<T>(
    IEnumerable<IAlternateMethod> methodImplementations
)
where T : class
Parameters
methodImplementations
Type:   Online System.Collections.Generic IEnumerable  IAlternateMethod
The method implementations.
Type Parameters
T
Instance type
Return Value

            Extended instance.

Implements
IProxyFactory ExtendClass T (IEnumerable IAlternateMethod )
See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
ExtendClass Overload
Glimpse.Core.Framework Namespace


ExtendClass(T) Method (IEnumerable(IAlternateMethod), IEnumerable(Object))

CastleDynamicProxyFactory ExtendClass T Method (IEnumerable IAlternateMethod , IEnumerable Object ) Glimpse API Documentation
Extends the class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T ExtendClass<T>(
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins
)
where T : class
public T ExtendClass<T>(
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins
)
where T : class
Parameters
methodImplementations
Type:   Online System.Collections.Generic IEnumerable  IAlternateMethod
The method implementations.
mixins
Type:   Online System.Collections.Generic IEnumerable    Online Object
The mixins.
Type Parameters
T
Instance type
Return Value

            Extended instance.

Implements
IProxyFactory ExtendClass T (IEnumerable IAlternateMethod , IEnumerable Object )
See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
ExtendClass Overload
Glimpse.Core.Framework Namespace


ExtendClass(T) Method (IEnumerable(IAlternateMethod), IEnumerable(Object), IEnumerable(Object))

CastleDynamicProxyFactory ExtendClass T Method (IEnumerable IAlternateMethod , IEnumerable Object , IEnumerable Object ) Glimpse API Documentation
Extends the class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T ExtendClass<T>(
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins,
    IEnumerable<Object> constructorArguments
)
where T : class
public T ExtendClass<T>(
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins,
    IEnumerable<Object> constructorArguments
)
where T : class
Parameters
methodImplementations
Type:   Online System.Collections.Generic IEnumerable  IAlternateMethod
The method implementations.
mixins
Type:   Online System.Collections.Generic IEnumerable    Online Object
The mixins.
constructorArguments
Type:   Online System.Collections.Generic IEnumerable    Online Object
The constructor arguments.
Type Parameters
T
Instance type
Return Value

            Extended instance.

Implements
IProxyFactory ExtendClass T (IEnumerable IAlternateMethod , IEnumerable Object , IEnumerable Object )
See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
ExtendClass Overload
Glimpse.Core.Framework Namespace


IsExtendClassEligible Method

CastleDynamicProxyFactory IsExtendClassEligible Method Glimpse API Documentation
Determines whether the specified type is eligible to be extended.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsExtendClassEligible(
    Type type
)
public bool IsExtendClassEligible(
    Type type
)
Parameters
type
Type:   Online System Type
The type.
Return Value
true if the type is eligible to be extended; otherwise, false.

Implements
IProxyFactory IsExtendClassEligible(Type)
See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
Glimpse.Core.Framework Namespace


IsWrapClassEligible Method

CastleDynamicProxyFactory IsWrapClassEligible Method Glimpse API Documentation
Determines whether the specified type eligible to be class wrapped.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsWrapClassEligible(
    Type type
)
public bool IsWrapClassEligible(
    Type type
)
Parameters
type
Type:   Online System Type
The type.
Return Value
true if the type of eligible for class wrapping; otherwise, false.

Implements
IProxyFactory IsWrapClassEligible(Type)
Remarks

            Wrapping takes a target instance, generates a new type that extends
            the input types and injects the target object within the new instance.

See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
Glimpse.Core.Framework Namespace


IsWrapInterfaceEligible(TToWrap) Method

CastleDynamicProxyFactory IsWrapInterfaceEligible TToWrap Method Glimpse API Documentation
Determines whether the specified type is eligible to be interface wrapped.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsWrapInterfaceEligible<TToWrap>(
    Type type
)
public bool IsWrapInterfaceEligible<TToWrap>(
    Type type
)
Parameters
type
Type:   Online System Type
The type.
Type Parameters
TToWrap
The type to wrap.
Return Value
true if type is eligible for interface wrapping; otherwise, false.

Implements
IProxyFactory IsWrapInterfaceEligible TToWrap (Type)
Remarks

            Wrapping takes a target instance, generates a new type that extends
            the input types and injects the target object within the new instance.

See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
Glimpse.Core.Framework Namespace


WrapClass Method

CastleDynamicProxyFactory WrapClass Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | WrapClass T (T, IEnumerable IAlternateMethod ) | Wraps the class.
Public method | WrapClass T (T, IEnumerable IAlternateMethod , IEnumerable Object ) | Wraps the class.
Public method | WrapClass T (T, IEnumerable IAlternateMethod , IEnumerable Object , IEnumerable Object ) | Wraps the class.
Back to Top
See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
Glimpse.Core.Framework Namespace


WrapClass(T) Method (T, IEnumerable(IAlternateMethod))

CastleDynamicProxyFactory WrapClass T Method (T, IEnumerable IAlternateMethod ) Glimpse API Documentation
Wraps the class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T WrapClass<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations
)
where T : class
public T WrapClass<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations
)
where T : class
Parameters
instance
Type: T
The instance.
methodImplementations
Type:   Online System.Collections.Generic IEnumerable  IAlternateMethod
The method implementations.
Type Parameters
T
Instance type
Return Value

            Wrapped instance.

Implements
IProxyFactory WrapClass T (T, IEnumerable IAlternateMethod )
Remarks

            Wrapping takes a target instance, generates a new type that extends
            the input types and injects the target object within the new instance.

See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
WrapClass Overload
Glimpse.Core.Framework Namespace


WrapClass(T) Method (T, IEnumerable(IAlternateMethod), IEnumerable(Object))

CastleDynamicProxyFactory WrapClass T Method (T, IEnumerable IAlternateMethod , IEnumerable Object ) Glimpse API Documentation
Wraps the class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T WrapClass<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins
)
where T : class
public T WrapClass<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins
)
where T : class
Parameters
instance
Type: T
The instance.
methodImplementations
Type:   Online System.Collections.Generic IEnumerable  IAlternateMethod
The method implementations.
mixins
Type:   Online System.Collections.Generic IEnumerable    Online Object
The mixins.
Type Parameters
T
Instance type
Return Value

            Wrapped instance.

Implements
IProxyFactory WrapClass T (T, IEnumerable IAlternateMethod , IEnumerable Object )
Remarks

            Wrapping takes a target instance, generates a new type that extends
            the input types and injects the target object within the new instance.

See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
WrapClass Overload
Glimpse.Core.Framework Namespace


WrapClass(T) Method (T, IEnumerable(IAlternateMethod), IEnumerable(Object), IEnumerable(Object))

CastleDynamicProxyFactory WrapClass T Method (T, IEnumerable IAlternateMethod , IEnumerable Object , IEnumerable Object ) Glimpse API Documentation
Wraps the class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T WrapClass<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins,
    IEnumerable<Object> constructorArguments
)
where T : class
public T WrapClass<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins,
    IEnumerable<Object> constructorArguments
)
where T : class
Parameters
instance
Type: T
The instance.
methodImplementations
Type:   Online System.Collections.Generic IEnumerable  IAlternateMethod
The method implementations.
mixins
Type:   Online System.Collections.Generic IEnumerable    Online Object
The mixins.
constructorArguments
Type:   Online System.Collections.Generic IEnumerable    Online Object
The constructor arguments.
Type Parameters
T
Instance type
Return Value

            Wrapped instance.

Implements
IProxyFactory WrapClass T (T, IEnumerable IAlternateMethod , IEnumerable Object , IEnumerable Object )
Remarks

            Wrapping takes a target instance, generates a new type that extends
            the input types and injects the target object within the new instance.

See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
WrapClass Overload
Glimpse.Core.Framework Namespace


WrapInterface Method

CastleDynamicProxyFactory WrapInterface Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | WrapInterface T (T, IEnumerable IAlternateMethod ) | Wraps the interface.
Public method | WrapInterface T (T, IEnumerable IAlternateMethod , IEnumerable Object ) | Wraps the interface.
Back to Top
See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
Glimpse.Core.Framework Namespace


WrapInterface(T) Method (T, IEnumerable(IAlternateMethod))

CastleDynamicProxyFactory WrapInterface T Method (T, IEnumerable IAlternateMethod ) Glimpse API Documentation
Wraps the interface.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T WrapInterface<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations
)
where T : class
public T WrapInterface<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations
)
where T : class
Parameters
instance
Type: T
The instance.
methodImplementations
Type:   Online System.Collections.Generic IEnumerable  IAlternateMethod
The method implementations.
Type Parameters
T
Instance type
Return Value

            Wrapped instance.

Implements
IProxyFactory WrapInterface T (T, IEnumerable IAlternateMethod )
Remarks

            Wrapping takes a target instance, generates a new type that extends
            the input types and injects the target object within the new instance.

See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
WrapInterface Overload
Glimpse.Core.Framework Namespace


WrapInterface(T) Method (T, IEnumerable(IAlternateMethod), IEnumerable(Object))

CastleDynamicProxyFactory WrapInterface T Method (T, IEnumerable IAlternateMethod , IEnumerable Object ) Glimpse API Documentation
Wraps the interface.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T WrapInterface<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins
)
where T : class
public T WrapInterface<T>(
    T instance,
    IEnumerable<IAlternateMethod> methodImplementations,
    IEnumerable<Object> mixins
)
where T : class
Parameters
instance
Type: T
The instance.
methodImplementations
Type:   Online System.Collections.Generic IEnumerable  IAlternateMethod
The method implementations.
mixins
Type:   Online System.Collections.Generic IEnumerable    Online Object
The mixins.
Type Parameters
T
Instance type
Return Value

            Wrapped instance.

Implements
IProxyFactory WrapInterface T (T, IEnumerable IAlternateMethod , IEnumerable Object )
Remarks

            Wrapping takes a target instance, generates a new type that extends
            the input types and injects the target object within the new instance.

See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
WrapInterface Overload
Glimpse.Core.Framework Namespace


CastleDynamicProxyFactory Properties

CastleDynamicProxyFactory Properties Glimpse API Documentation
The CastleDynamicProxyFactory type exposes the following members.
Properties
 | Name | Description
Public property | Logger | Gets or sets the logger.
Public property | MessageBroker | Gets or sets the message broker.
Public property | ProxyGenerator | Gets or sets the proxy generator.
Public property | RuntimePolicyStrategy | Gets or sets the runtime policy strategy.
Public property | TimerStrategy | Gets or sets the timer strategy.
Back to Top
See Also
CastleDynamicProxyFactory Class
Glimpse.Core.Framework Namespace


Logger Property

CastleDynamicProxyFactory Logger Property Glimpse API Documentation
Gets or sets the logger.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILogger Logger { get; set; }
public ILogger Logger { get; set; }
Field Value

            The logger.

See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
Glimpse.Core.Framework Namespace


MessageBroker Property

CastleDynamicProxyFactory MessageBroker Property Glimpse API Documentation
Gets or sets the message broker.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IMessageBroker MessageBroker { get; set; }
public IMessageBroker MessageBroker { get; set; }
Field Value

            The message broker.

See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
Glimpse.Core.Framework Namespace


ProxyGenerator Property

CastleDynamicProxyFactory ProxyGenerator Property Glimpse API Documentation
Gets or sets the proxy generator.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ProxyGenerator ProxyGenerator { get; set; }
public ProxyGenerator ProxyGenerator { get; set; }
Field Value

            The proxy generator.

See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
Glimpse.Core.Framework Namespace


RuntimePolicyStrategy Property

CastleDynamicProxyFactory RuntimePolicyStrategy Property Glimpse API Documentation
Gets or sets the runtime policy strategy.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Func<RuntimePolicy> RuntimePolicyStrategy { get; set; }
public Func<RuntimePolicy> RuntimePolicyStrategy { get; set; }
Field Value

            The runtime policy strategy.

See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
Glimpse.Core.Framework Namespace


TimerStrategy Property

CastleDynamicProxyFactory TimerStrategy Property Glimpse API Documentation
Gets or sets the timer strategy.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Func<IExecutionTimer> TimerStrategy { get; set; }
public Func<IExecutionTimer> TimerStrategy { get; set; }
Field Value

            The timer strategy.

See Also
CastleDynamicProxyFactory Class
CastleDynamicProxyFactory Members
Glimpse.Core.Framework Namespace


Factory Class

Factory Class Glimpse API Documentation
The main bootstrapper for Glimpse, Factory (or its derived types) is responsible for instantiating all required configurable types.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Framework Factory

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Factory
public class Factory
See Also
Factory Members
Glimpse.Core.Framework Namespace


Factory Members

Factory Members Glimpse API Documentation

The Factory type exposes the following members.
Constructors
 | Name | Description
Public method | Factory | Initializes a new instance of the Factory class without any IServiceLocator implementations.
Public method | Factory(IServiceLocator) | Initializes a new instance of the Factory class without a IServiceLocator implementation from the framework provider.
Public method | Factory(IServiceLocator, IServiceLocator) | Initializes a new instance of the Factory class.
Public method | Factory(IServiceLocator, IServiceLocator, Section) | Initializes a new instance of the Factory class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | InstantiateBaseResourceUri | Instantiates a string that represents the base Uri Glimpse will use for invoking all instances of IResource.
Public method | InstantiateClientScripts | Instantiates a collection of IClientScripts.
Public method | InstantiateConfiguration | Instantiates an instance of IGlimpseConfiguration.
Public method | InstantiateDefaultResource | Instantiates an instance of IResource.
Public method | InstantiateDefaultRuntimePolicy | Instantiates the default instance of RuntimePolicy.
Public method | InstantiateFrameworkProvider | Instantiates an instance of IFrameworkProvider.
Public method | InstantiateHtmlEncoder | Instantiates an instance of IHtmlEncoder.
Public method | InstantiateInspectors | Instantiates a collection of IInspectors.
Public method | InstantiateLogger | Instantiates an instance of ILogger.
Public method | InstantiateMessageBroker | Instantiates an instance of IMessageBroker.
Public method | InstantiatePersistenceStore | Instantiates an instance of IPersistenceStore.
Public method | InstantiateProxyFactory | Instantiates an instance of IProxyFactory.
Public method | InstantiateResourceEndpointConfiguration | Instantiates an instance of ResourceEndpointConfiguration.
Public method | InstantiateResources | Instantiates a collection of IResources.
Public method | InstantiateRuntime | Instantiates an instance of IGlimpseRuntime.
Public method | InstantiateRuntimePolicies | Instantiates a collection of IRuntimePolicys.
Public method | InstantiateRuntimePolicyStrategy | Instantiates a strategy pattern for accessing an instance of RuntimePolicy.
Public method | InstantiateSerializationConverters | Instantiates a collection of ISerializationConverters.
Public method | InstantiateSerializer | Instantiates an instance of ISerializer.
Public method | InstantiateTabs | Instantiates a collection of ITabs.
Public method | InstantiateTimerStrategy | Instantiates a strategy pattern for accessing an instance of IExecutionTimer.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
Factory Class
Glimpse.Core.Framework Namespace


Factory Constructor

Factory Constructor Glimpse API Documentation
Overload List
 | Name | Description
Public method | Factory | Initializes a new instance of the Factory class without any IServiceLocator implementations.
Public method | Factory(IServiceLocator) | Initializes a new instance of the Factory class without a IServiceLocator implementation from the framework provider.
Public method | Factory(IServiceLocator, IServiceLocator) | Initializes a new instance of the Factory class.
Public method | Factory(IServiceLocator, IServiceLocator, Section) | Initializes a new instance of the Factory class.
Back to Top
See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


Factory Constructor

Factory Constructor Glimpse API Documentation
Initializes a new instance of the Factory class without any IServiceLocator implementations.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Factory()
public Factory()
See Also
Factory Class
Factory Members
Factory Overload
Glimpse.Core.Framework Namespace


Factory Constructor (IServiceLocator)

Factory Constructor (IServiceLocator) Glimpse API Documentation
Initializes a new instance of the Factory class without a IServiceLocator implementation from the framework provider.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Factory(
    IServiceLocator providerServiceLocator
)
public Factory(
    IServiceLocator providerServiceLocator
)
Parameters
providerServiceLocator
Type: Glimpse.Core.Framework IServiceLocator
The framework provider's service locator.
See Also
Factory Class
Factory Members
Factory Overload
Glimpse.Core.Framework Namespace


Factory Constructor (IServiceLocator, IServiceLocator)

Factory Constructor (IServiceLocator, IServiceLocator) Glimpse API Documentation
Initializes a new instance of the Factory class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Factory(
    IServiceLocator providerServiceLocator,
    IServiceLocator userServiceLocator
)
public Factory(
    IServiceLocator providerServiceLocator,
    IServiceLocator userServiceLocator
)
Parameters
providerServiceLocator
Type: Glimpse.Core.Framework IServiceLocator
The framework provider's service locator.
userServiceLocator
Type: Glimpse.Core.Framework IServiceLocator
The user's service locator.
See Also
Factory Class
Factory Members
Factory Overload
Glimpse.Core.Framework Namespace


Factory Constructor (IServiceLocator, IServiceLocator, Section)

Factory Constructor (IServiceLocator, IServiceLocator, Section) Glimpse API Documentation
Initializes a new instance of the Factory class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Factory(
    IServiceLocator providerServiceLocator,
    IServiceLocator userServiceLocator,
    Section configuration
)
public Factory(
    IServiceLocator providerServiceLocator,
    IServiceLocator userServiceLocator,
    Section configuration
)
Parameters
providerServiceLocator
Type: Glimpse.Core.Framework IServiceLocator
The framework provider's service locator.
userServiceLocator
Type: Glimpse.Core.Framework IServiceLocator
The user's service locator.
configuration
Type: Glimpse.Core.Configuration Section
The Glimpse configuration to use.
See Also
Factory Class
Factory Members
Factory Overload
Glimpse.Core.Framework Namespace


Factory Methods

Factory Methods Glimpse API Documentation
The Factory type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | InstantiateBaseResourceUri | Instantiates a string that represents the base Uri Glimpse will use for invoking all instances of IResource.
Public method | InstantiateClientScripts | Instantiates a collection of IClientScripts.
Public method | InstantiateConfiguration | Instantiates an instance of IGlimpseConfiguration.
Public method | InstantiateDefaultResource | Instantiates an instance of IResource.
Public method | InstantiateDefaultRuntimePolicy | Instantiates the default instance of RuntimePolicy.
Public method | InstantiateFrameworkProvider | Instantiates an instance of IFrameworkProvider.
Public method | InstantiateHtmlEncoder | Instantiates an instance of IHtmlEncoder.
Public method | InstantiateInspectors | Instantiates a collection of IInspectors.
Public method | InstantiateLogger | Instantiates an instance of ILogger.
Public method | InstantiateMessageBroker | Instantiates an instance of IMessageBroker.
Public method | InstantiatePersistenceStore | Instantiates an instance of IPersistenceStore.
Public method | InstantiateProxyFactory | Instantiates an instance of IProxyFactory.
Public method | InstantiateResourceEndpointConfiguration | Instantiates an instance of ResourceEndpointConfiguration.
Public method | InstantiateResources | Instantiates a collection of IResources.
Public method | InstantiateRuntime | Instantiates an instance of IGlimpseRuntime.
Public method | InstantiateRuntimePolicies | Instantiates a collection of IRuntimePolicys.
Public method | InstantiateRuntimePolicyStrategy | Instantiates a strategy pattern for accessing an instance of RuntimePolicy.
Public method | InstantiateSerializationConverters | Instantiates a collection of ISerializationConverters.
Public method | InstantiateSerializer | Instantiates an instance of ISerializer.
Public method | InstantiateTabs | Instantiates a collection of ITabs.
Public method | InstantiateTimerStrategy | Instantiates a strategy pattern for accessing an instance of IExecutionTimer.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
Factory Class
Glimpse.Core.Framework Namespace


InstantiateBaseResourceUri Method

Factory InstantiateBaseResourceUri Method Glimpse API Documentation
Instantiates a string that represents the base Uri Glimpse will use for invoking all instances of IResource.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string InstantiateBaseResourceUri()
public string InstantiateBaseResourceUri()
Return Value
A   Online String instance based on configuration settings.
See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateClientScripts Method

Factory InstantiateClientScripts Method Glimpse API Documentation
Instantiates a collection of IClientScripts.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<IClientScript> InstantiateClientScripts()
public ICollection<IClientScript> InstantiateClientScripts()
Return Value

            A collection of IClientScript instances resolved by one of the IServiceLocators, otherwise all IClientScripts discovered in the configured discovery location.

See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateConfiguration Method

Factory InstantiateConfiguration Method Glimpse API Documentation
Instantiates an instance of IGlimpseConfiguration.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IGlimpseConfiguration InstantiateConfiguration()
public IGlimpseConfiguration InstantiateConfiguration()
Return Value
A IGlimpseConfiguration instance resolved by one of the IServiceLocators, otherwise GlimpseConfiguration with each constructor parameter created with the corresponding Factory method.
See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateDefaultResource Method

Factory InstantiateDefaultResource Method Glimpse API Documentation
Instantiates an instance of IResource.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IResource InstantiateDefaultResource()
public IResource InstantiateDefaultResource()
Return Value
A IResource instance resolved by one of the IServiceLocators, otherwise ConfigurationResource.
See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateDefaultRuntimePolicy Method

Factory InstantiateDefaultRuntimePolicy Method Glimpse API Documentation
Instantiates the default instance of RuntimePolicy.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RuntimePolicy InstantiateDefaultRuntimePolicy()
public RuntimePolicy InstantiateDefaultRuntimePolicy()
Return Value
A RuntimePolicy instance based on configuration settings.
See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateFrameworkProvider Method

Factory InstantiateFrameworkProvider Method Glimpse API Documentation
Instantiates an instance of IFrameworkProvider.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IFrameworkProvider InstantiateFrameworkProvider()
public IFrameworkProvider InstantiateFrameworkProvider()
Return Value
A IFrameworkProvider instance resolved by one of the IServiceLocators.
Exceptions
Exception | Condition
Glimpse.Core.Framework GlimpseException | An exception is thrown is an instance of IFrameworkProvider is not provided by a IServiceLocator.
See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateHtmlEncoder Method

Factory InstantiateHtmlEncoder Method Glimpse API Documentation
Instantiates an instance of IHtmlEncoder.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IHtmlEncoder InstantiateHtmlEncoder()
public IHtmlEncoder InstantiateHtmlEncoder()
Return Value
A IHtmlEncoder instance resolved by one of the IServiceLocators, otherwise AntiXssEncoder (leveraging the   Online Microsoft Web Protection Library).
See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateInspectors Method

Factory InstantiateInspectors Method Glimpse API Documentation
Instantiates a collection of IInspectors.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<IInspector> InstantiateInspectors()
public ICollection<IInspector> InstantiateInspectors()
Return Value

            A collection of IInspector instances resolved by one of the IServiceLocators, otherwise all IInspectors discovered in the configured discovery location.

See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateLogger Method

Factory InstantiateLogger Method Glimpse API Documentation
Instantiates an instance of ILogger.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILogger InstantiateLogger()
public ILogger InstantiateLogger()
Return Value
A ILogger instance resolved by one of the IServiceLocators, otherwise a NullLogger or NLogLogger (leveraging the   Online NLog project) based on configuration settings.
See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateMessageBroker Method

Factory InstantiateMessageBroker Method Glimpse API Documentation
Instantiates an instance of IMessageBroker.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IMessageBroker InstantiateMessageBroker()
public IMessageBroker InstantiateMessageBroker()
Return Value
A IMessageBroker instance resolved by one of the IServiceLocators, otherwise MessageBroker.
See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiatePersistenceStore Method

Factory InstantiatePersistenceStore Method Glimpse API Documentation
Instantiates an instance of IPersistenceStore.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPersistenceStore InstantiatePersistenceStore()
public IPersistenceStore InstantiatePersistenceStore()
Return Value
A IPersistenceStore instance resolved by one of the IServiceLocators, otherwise ApplicationPersistenceStore.
See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateProxyFactory Method

Factory InstantiateProxyFactory Method Glimpse API Documentation
Instantiates an instance of IProxyFactory.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IProxyFactory InstantiateProxyFactory()
public IProxyFactory InstantiateProxyFactory()
Return Value
A IProxyFactory instance resolved by one of the IServiceLocators, otherwise CastleDynamicProxyFactory (leveraging   Online Castle DynamicProxy.).
See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateResourceEndpointConfiguration Method

Factory InstantiateResourceEndpointConfiguration Method Glimpse API Documentation
Instantiates an instance of ResourceEndpointConfiguration.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResourceEndpointConfiguration InstantiateResourceEndpointConfiguration()
public ResourceEndpointConfiguration InstantiateResourceEndpointConfiguration()
Return Value
A ResourceEndpointConfiguration instance resolved by one of the IServiceLocators.
Exceptions
Exception | Condition
Glimpse.Core.Framework GlimpseException | An exception is thrown is an instance of ResourceEndpointConfiguration is not provided by a IServiceLocator.
See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateResources Method

Factory InstantiateResources Method Glimpse API Documentation
Instantiates a collection of IResources.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<IResource> InstantiateResources()
public ICollection<IResource> InstantiateResources()
Return Value

            A collection of IResource instances resolved by one of the IServiceLocators, otherwise all IResources discovered in the configured discovery location.

See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateRuntime Method

Factory InstantiateRuntime Method Glimpse API Documentation
Instantiates an instance of IGlimpseRuntime.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IGlimpseRuntime InstantiateRuntime()
public IGlimpseRuntime InstantiateRuntime()
Return Value
A IGlimpseRuntime instance resolved by one of the IServiceLocators, otherwise GlimpseRuntime.
See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateRuntimePolicies Method

Factory InstantiateRuntimePolicies Method Glimpse API Documentation
Instantiates a collection of IRuntimePolicys.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<IRuntimePolicy> InstantiateRuntimePolicies()
public ICollection<IRuntimePolicy> InstantiateRuntimePolicies()
Return Value

            A collection of IRuntimePolicy instances resolved by one of the IServiceLocators, otherwise all IRuntimePolicys discovered in the configured discovery location.

See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateRuntimePolicyStrategy Method

Factory InstantiateRuntimePolicyStrategy Method Glimpse API Documentation
Instantiates a strategy pattern for accessing an instance of RuntimePolicy.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Func<RuntimePolicy> InstantiateRuntimePolicyStrategy()
public Func<RuntimePolicy> InstantiateRuntimePolicyStrategy()
Return Value

            A Func<RuntimePolicy> to access the request specific RuntimePolicy.

See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateSerializationConverters Method

Factory InstantiateSerializationConverters Method Glimpse API Documentation
Instantiates a collection of ISerializationConverters.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<ISerializationConverter> InstantiateSerializationConverters()
public ICollection<ISerializationConverter> InstantiateSerializationConverters()
Return Value

            A collection of ISerializationConverter instances resolved by one of the IServiceLocators, otherwise all ISerializationConverters discovered in the configured discovery location.

See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateSerializer Method

Factory InstantiateSerializer Method Glimpse API Documentation
Instantiates an instance of ISerializer.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ISerializer InstantiateSerializer()
public ISerializer InstantiateSerializer()
Return Value
A ISerializer instance resolved by one of the IServiceLocators, otherwise JsonNetSerializer (leveraging   Online Json.Net).
See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateTabs Method

Factory InstantiateTabs Method Glimpse API Documentation
Instantiates a collection of ITabs.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<ITab> InstantiateTabs()
public ICollection<ITab> InstantiateTabs()
Return Value

            A collection of ITab instances resolved by one of the IServiceLocators, otherwise all ITabs discovered in the configured discovery location.

See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


InstantiateTimerStrategy Method

Factory InstantiateTimerStrategy Method Glimpse API Documentation
Instantiates a strategy pattern for accessing an instance of IExecutionTimer.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Func<IExecutionTimer> InstantiateTimerStrategy()
public Func<IExecutionTimer> InstantiateTimerStrategy()
Return Value

            A Func<IExecutionTimer> to access the request specific IExecutionTimer.

See Also
Factory Class
Factory Members
Glimpse.Core.Framework Namespace


GlimpseConfiguration Class

GlimpseConfiguration Class Glimpse API Documentation
Contains all configuration required by IGlimpseRuntime instances to execute.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Framework GlimpseConfiguration

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlimpseConfiguration : IGlimpseConfiguration
public class GlimpseConfiguration : IGlimpseConfiguration
See Also
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


GlimpseConfiguration Members

GlimpseConfiguration Members Glimpse API Documentation

The GlimpseConfiguration type exposes the following members.
Constructors
 | Name | Description
Public method | GlimpseConfiguration | Initializes a new instance of the GlimpseConfiguration class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ClientScripts | Gets or sets the client scripts collection.
Public property | DefaultResource | Gets or sets the default IResource to execute.
Public property | DefaultRuntimePolicy | Gets or sets the default runtime policy.
Public property | EndpointBaseUri | Gets or sets the endpoint base URI.
Public property | FrameworkProvider | Gets or sets the IFrameworkProvider.
Public property | HtmlEncoder | Gets or sets the IHtmlEncoder.
Public property | Inspectors | Gets or sets the collection of IInspector.
Public property | Logger | Gets or sets the ILogger.
Public property | MessageBroker | Gets or sets the IMessageBroker.
Public property | PersistenceStore | Gets or sets the IPersistenceStore.
Public property | ProxyFactory | Gets or sets the IProxyFactory.
Public property | ResourceEndpoint | Gets or sets the ResourceEndpointConfiguration.
Public property | Resources | Gets or sets the collection of IResource.
Public property | RuntimePolicies | Gets or sets the collection of IRuntimePolicy.
Public property | RuntimePolicyStrategy | Gets or sets the RuntimePolicy strategy.
Public property | Serializer | Gets or sets the ISerializer.
Public property | Tabs | Gets or sets the collection of ITab.
Public property | TimerStrategy | Gets or sets the IExecutionTimer strategy.
Back to Top
See Also
GlimpseConfiguration Class
Glimpse.Core.Framework Namespace


GlimpseConfiguration Constructor

GlimpseConfiguration Constructor Glimpse API Documentation
Initializes a new instance of the GlimpseConfiguration class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlimpseConfiguration(
    IFrameworkProvider frameworkProvider,
    ResourceEndpointConfiguration endpointConfiguration,
    ICollection<IClientScript> clientScripts,
    ILogger logger,
    RuntimePolicy defaultRuntimePolicy,
    IHtmlEncoder htmlEncoder,
    IPersistenceStore persistenceStore,
    ICollection<IInspector> inspectors,
    ICollection<IResource> resources,
    ISerializer serializer,
    ICollection<ITab> tabs,
    ICollection<IRuntimePolicy> runtimePolicies,
    IResource defaultResource,
    IProxyFactory proxyFactory,
    IMessageBroker messageBroker,
    string endpointBaseUri,
    Func<IExecutionTimer> timerStrategy,
    Func<RuntimePolicy> runtimePolicyStrategy
)
public GlimpseConfiguration(
    IFrameworkProvider frameworkProvider,
    ResourceEndpointConfiguration endpointConfiguration,
    ICollection<IClientScript> clientScripts,
    ILogger logger,
    RuntimePolicy defaultRuntimePolicy,
    IHtmlEncoder htmlEncoder,
    IPersistenceStore persistenceStore,
    ICollection<IInspector> inspectors,
    ICollection<IResource> resources,
    ISerializer serializer,
    ICollection<ITab> tabs,
    ICollection<IRuntimePolicy> runtimePolicies,
    IResource defaultResource,
    IProxyFactory proxyFactory,
    IMessageBroker messageBroker,
    string endpointBaseUri,
    Func<IExecutionTimer> timerStrategy,
    Func<RuntimePolicy> runtimePolicyStrategy
)
Parameters
frameworkProvider
Type: Glimpse.Core.Framework IFrameworkProvider
The framework provider.
endpointConfiguration
Type: Glimpse.Core.Framework ResourceEndpointConfiguration
The resource endpoint configuration.
clientScripts
Type:   Online System.Collections.Generic ICollection  IClientScript
The client scripts collection.
logger
Type: Glimpse.Core.Extensibility ILogger
The logger.
defaultRuntimePolicy
Type: Glimpse.Core.Extensibility RuntimePolicy
The default runtime policy.
htmlEncoder
Type: Glimpse.Core.Extensibility IHtmlEncoder
The Html encoder.
persistenceStore
Type: Glimpse.Core.Framework IPersistenceStore
The persistence store.
inspectors
Type:   Online System.Collections.Generic ICollection  IInspector
The inspectors collection.
resources
Type:   Online System.Collections.Generic ICollection  IResource
The resources collection.
serializer
Type: Glimpse.Core.Extensibility ISerializer
The serializer.
tabs
Type:   Online System.Collections.Generic ICollection  ITab
The tabs collection.
runtimePolicies
Type:   Online System.Collections.Generic ICollection  IRuntimePolicy
The runtime policies collection.
defaultResource
Type: Glimpse.Core.Extensibility IResource
The default resource.
proxyFactory
Type: Glimpse.Core.Extensibility IProxyFactory
The proxy factory.
messageBroker
Type: Glimpse.Core.Extensibility IMessageBroker
The message broker.
endpointBaseUri
Type:   Online System String
The endpoint base Uri.
timerStrategy
Type:   Online System Func  IExecutionTimer
The timer strategy.
runtimePolicyStrategy
Type:   Online System Func  RuntimePolicy
The runtime policy strategy.
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown if any parameter is null.
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


GlimpseConfiguration Methods

GlimpseConfiguration Methods Glimpse API Documentation
The GlimpseConfiguration type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
GlimpseConfiguration Class
Glimpse.Core.Framework Namespace


GlimpseConfiguration Properties

GlimpseConfiguration Properties Glimpse API Documentation
The GlimpseConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | ClientScripts | Gets or sets the client scripts collection.
Public property | DefaultResource | Gets or sets the default IResource to execute.
Public property | DefaultRuntimePolicy | Gets or sets the default runtime policy.
Public property | EndpointBaseUri | Gets or sets the endpoint base URI.
Public property | FrameworkProvider | Gets or sets the IFrameworkProvider.
Public property | HtmlEncoder | Gets or sets the IHtmlEncoder.
Public property | Inspectors | Gets or sets the collection of IInspector.
Public property | Logger | Gets or sets the ILogger.
Public property | MessageBroker | Gets or sets the IMessageBroker.
Public property | PersistenceStore | Gets or sets the IPersistenceStore.
Public property | ProxyFactory | Gets or sets the IProxyFactory.
Public property | ResourceEndpoint | Gets or sets the ResourceEndpointConfiguration.
Public property | Resources | Gets or sets the collection of IResource.
Public property | RuntimePolicies | Gets or sets the collection of IRuntimePolicy.
Public property | RuntimePolicyStrategy | Gets or sets the RuntimePolicy strategy.
Public property | Serializer | Gets or sets the ISerializer.
Public property | Tabs | Gets or sets the collection of ITab.
Public property | TimerStrategy | Gets or sets the IExecutionTimer strategy.
Back to Top
See Also
GlimpseConfiguration Class
Glimpse.Core.Framework Namespace


ClientScripts Property

GlimpseConfiguration ClientScripts Property Glimpse API Documentation
Gets or sets the client scripts collection.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<IClientScript> ClientScripts { get; set; }
public ICollection<IClientScript> ClientScripts { get; set; }
Field Value

            The client scripts.

Implements
IGlimpseConfiguration ClientScripts
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown if the value is set to null.
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


DefaultResource Property

GlimpseConfiguration DefaultResource Property Glimpse API Documentation
Gets or sets the default IResource to execute.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IResource DefaultResource { get; set; }
public IResource DefaultResource { get; set; }
Field Value

            The default resource.

Implements
IGlimpseConfiguration DefaultResource
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown if the value is set to null.
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


DefaultRuntimePolicy Property

GlimpseConfiguration DefaultRuntimePolicy Property Glimpse API Documentation
Gets or sets the default runtime policy.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RuntimePolicy DefaultRuntimePolicy { get; set; }
public RuntimePolicy DefaultRuntimePolicy { get; set; }
Field Value

            The default runtime policy.

Implements
IGlimpseConfiguration DefaultRuntimePolicy
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


EndpointBaseUri Property

GlimpseConfiguration EndpointBaseUri Property Glimpse API Documentation
Gets or sets the endpoint base URI.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string EndpointBaseUri { get; set; }
public string EndpointBaseUri { get; set; }
Field Value

            The endpoint base URI.

Implements
IGlimpseConfiguration EndpointBaseUri
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown if the value is set to null.
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


FrameworkProvider Property

GlimpseConfiguration FrameworkProvider Property Glimpse API Documentation
Gets or sets the IFrameworkProvider.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IFrameworkProvider FrameworkProvider { get; set; }
public IFrameworkProvider FrameworkProvider { get; set; }
Field Value

            The configured IFrameworkProvider.

Implements
IGlimpseConfiguration FrameworkProvider
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown if the value is set to null.
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


HtmlEncoder Property

GlimpseConfiguration HtmlEncoder Property Glimpse API Documentation
Gets or sets the IHtmlEncoder.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IHtmlEncoder HtmlEncoder { get; set; }
public IHtmlEncoder HtmlEncoder { get; set; }
Field Value

            The configured IHtmlEncoder.

Implements
IGlimpseConfiguration HtmlEncoder
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown if the value is set to null.
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


Inspectors Property

GlimpseConfiguration Inspectors Property Glimpse API Documentation
Gets or sets the collection of IInspector.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<IInspector> Inspectors { get; set; }
public ICollection<IInspector> Inspectors { get; set; }
Field Value

            The configured collection of IInspector.

Implements
IGlimpseConfiguration Inspectors
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown if the value is set to null.
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


Logger Property

GlimpseConfiguration Logger Property Glimpse API Documentation
Gets or sets the ILogger.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILogger Logger { get; set; }
public ILogger Logger { get; set; }
Field Value

            The configured ILogger.

Implements
IGlimpseConfiguration Logger
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown if the value is set to null.
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


MessageBroker Property

GlimpseConfiguration MessageBroker Property Glimpse API Documentation
Gets or sets the IMessageBroker.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IMessageBroker MessageBroker { get; set; }
public IMessageBroker MessageBroker { get; set; }
Field Value

            The configured IMessageBroker.

Implements
IGlimpseConfiguration MessageBroker
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown if the value is set to null.
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


PersistenceStore Property

GlimpseConfiguration PersistenceStore Property Glimpse API Documentation
Gets or sets the IPersistenceStore.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPersistenceStore PersistenceStore { get; set; }
public IPersistenceStore PersistenceStore { get; set; }
Field Value

            The configured IPersistenceStore.

Implements
IGlimpseConfiguration PersistenceStore
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown if the value is set to null.
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


ProxyFactory Property

GlimpseConfiguration ProxyFactory Property Glimpse API Documentation
Gets or sets the IProxyFactory.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IProxyFactory ProxyFactory { get; set; }
public IProxyFactory ProxyFactory { get; set; }
Field Value

            The configured IProxyFactory.

Implements
IGlimpseConfiguration ProxyFactory
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown if the value is set to null.
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


ResourceEndpoint Property

GlimpseConfiguration ResourceEndpoint Property Glimpse API Documentation
Gets or sets the ResourceEndpointConfiguration.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResourceEndpointConfiguration ResourceEndpoint { get; set; }
public ResourceEndpointConfiguration ResourceEndpoint { get; set; }
Field Value

            The configured ResourceEndpointConfiguration.

Implements
IGlimpseConfiguration ResourceEndpoint
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown if the value is set to null.
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


Resources Property

GlimpseConfiguration Resources Property Glimpse API Documentation
Gets or sets the collection of IResource.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<IResource> Resources { get; set; }
public ICollection<IResource> Resources { get; set; }
Field Value

            The configured collection of IResource.

Implements
IGlimpseConfiguration Resources
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown if the value is set to null.
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


RuntimePolicies Property

GlimpseConfiguration RuntimePolicies Property Glimpse API Documentation
Gets or sets the collection of IRuntimePolicy.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<IRuntimePolicy> RuntimePolicies { get; set; }
public ICollection<IRuntimePolicy> RuntimePolicies { get; set; }
Field Value

            The configured collection of IRuntimePolicy.

Implements
IGlimpseConfiguration RuntimePolicies
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown if the value is set to null.
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


RuntimePolicyStrategy Property

GlimpseConfiguration RuntimePolicyStrategy Property Glimpse API Documentation
Gets or sets the RuntimePolicy strategy.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Func<RuntimePolicy> RuntimePolicyStrategy { get; set; }
public Func<RuntimePolicy> RuntimePolicyStrategy { get; set; }
Field Value

            The configured RuntimePolicy.

Implements
IGlimpseConfiguration RuntimePolicyStrategy
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown if the value is set to null.
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


Serializer Property

GlimpseConfiguration Serializer Property Glimpse API Documentation
Gets or sets the ISerializer.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ISerializer Serializer { get; set; }
public ISerializer Serializer { get; set; }
Field Value

            The configured ISerializer.

Implements
IGlimpseConfiguration Serializer
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown if the value is set to null.
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


Tabs Property

GlimpseConfiguration Tabs Property Glimpse API Documentation
Gets or sets the collection of ITab.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<ITab> Tabs { get; set; }
public ICollection<ITab> Tabs { get; set; }
Field Value

            The configured ITab.

Implements
IGlimpseConfiguration Tabs
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown if the value is set to null.
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


TimerStrategy Property

GlimpseConfiguration TimerStrategy Property Glimpse API Documentation
Gets or sets the IExecutionTimer strategy.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Func<IExecutionTimer> TimerStrategy { get; set; }
public Func<IExecutionTimer> TimerStrategy { get; set; }
Field Value

            The configured IExecutionTimer strategy.

Implements
IGlimpseConfiguration TimerStrategy
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown if the value is set to null.
See Also
GlimpseConfiguration Class
GlimpseConfiguration Members
Glimpse.Core.Framework Namespace


GlimpseException Class

GlimpseException Class Glimpse API Documentation
A custom exception thrown for unrecoverable Glimpse issues.
Inheritance Hierarchy
Online System Object
Online System Exception
Glimpse.Core.Framework GlimpseException

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlimpseException : Exception
public class GlimpseException : Exception
See Also
GlimpseException Members
Glimpse.Core.Framework Namespace


GlimpseException Members

GlimpseException Members Glimpse API Documentation

The GlimpseException type exposes the following members.
Constructors
 | Name | Description
Public method | GlimpseException | Initializes a new instance of the GlimpseException class.
Public method | GlimpseException(String) | Initializes a new instance of the GlimpseException class.
Public method | GlimpseException(SerializationInfo, StreamingContext) | Initializes a new instance of the GlimpseException class.
Public method | GlimpseException(String, Exception) | Initializes a new instance of the GlimpseException class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
GlimpseException Class
Glimpse.Core.Framework Namespace


GlimpseException Constructor

GlimpseException Constructor Glimpse API Documentation
Overload List
 | Name | Description
Public method | GlimpseException | Initializes a new instance of the GlimpseException class.
Public method | GlimpseException(String) | Initializes a new instance of the GlimpseException class.
Public method | GlimpseException(SerializationInfo, StreamingContext) | Initializes a new instance of the GlimpseException class.
Public method | GlimpseException(String, Exception) | Initializes a new instance of the GlimpseException class.
Back to Top
See Also
GlimpseException Class
GlimpseException Members
Glimpse.Core.Framework Namespace


GlimpseException Constructor

GlimpseException Constructor Glimpse API Documentation
Initializes a new instance of the GlimpseException class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlimpseException()
public GlimpseException()
See Also
GlimpseException Class
GlimpseException Members
GlimpseException Overload
Glimpse.Core.Framework Namespace


GlimpseException Constructor (String)

GlimpseException Constructor (String) Glimpse API Documentation
Initializes a new instance of the GlimpseException class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlimpseException(
    string message
)
public GlimpseException(
    string message
)
Parameters
message
Type:   Online System String
The message.
See Also
GlimpseException Class
GlimpseException Members
GlimpseException Overload
Glimpse.Core.Framework Namespace


GlimpseException Constructor (SerializationInfo, StreamingContext)

GlimpseException Constructor (SerializationInfo, StreamingContext) Glimpse API Documentation
Initializes a new instance of the GlimpseException class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlimpseException(
    SerializationInfo info,
    StreamingContext context
)
public GlimpseException(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info
Type:   Online System.Runtime.Serialization SerializationInfo
The info.
context
Type:   Online System.Runtime.Serialization StreamingContext
The context.
See Also
GlimpseException Class
GlimpseException Members
GlimpseException Overload
Glimpse.Core.Framework Namespace


GlimpseException Constructor (String, Exception)

GlimpseException Constructor (String, Exception) Glimpse API Documentation
Initializes a new instance of the GlimpseException class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlimpseException(
    string message,
    Exception innerException
)
public GlimpseException(
    string message,
    Exception innerException
)
Parameters
message
Type:   Online System String
The message.
innerException
Type:   Online System Exception
The inner exception.
See Also
GlimpseException Class
GlimpseException Members
GlimpseException Overload
Glimpse.Core.Framework Namespace


GlimpseException Methods

GlimpseException Methods Glimpse API Documentation
The GlimpseException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
GlimpseException Class
Glimpse.Core.Framework Namespace


GlimpseException Properties

GlimpseException Properties Glimpse API Documentation
The GlimpseException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
GlimpseException Class
Glimpse.Core.Framework Namespace


GlimpseException Events

GlimpseException Events Glimpse API Documentation
The GlimpseException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
GlimpseException Class
Glimpse.Core.Framework Namespace


GlimpseMetadata Class

GlimpseMetadata Class Glimpse API Documentation
A class which describes Glimpse system metadata, as required by a client.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Framework GlimpseMetadata

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlimpseMetadata
public class GlimpseMetadata
See Also
GlimpseMetadata Members
Glimpse.Core.Framework Namespace


GlimpseMetadata Members

GlimpseMetadata Members Glimpse API Documentation

The GlimpseMetadata type exposes the following members.
Constructors
 | Name | Description
Public method | GlimpseMetadata | Initializes a new instance of the GlimpseMetadata class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Resources | Gets or sets the collection resources keys and their corresponding Uri templates.
Public property | Tabs | Gets or sets the collection of tab specific metadata.
Public property | Version | Gets or sets the running version of Glimpse.
Back to Top
See Also
GlimpseMetadata Class
Glimpse.Core.Framework Namespace


GlimpseMetadata Constructor

GlimpseMetadata Constructor Glimpse API Documentation
Initializes a new instance of the GlimpseMetadata class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlimpseMetadata()
public GlimpseMetadata()
See Also
GlimpseMetadata Class
GlimpseMetadata Members
Glimpse.Core.Framework Namespace


GlimpseMetadata Methods

GlimpseMetadata Methods Glimpse API Documentation
The GlimpseMetadata type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
GlimpseMetadata Class
Glimpse.Core.Framework Namespace


GlimpseMetadata Properties

GlimpseMetadata Properties Glimpse API Documentation
The GlimpseMetadata type exposes the following members.
Properties
 | Name | Description
Public property | Resources | Gets or sets the collection resources keys and their corresponding Uri templates.
Public property | Tabs | Gets or sets the collection of tab specific metadata.
Public property | Version | Gets or sets the running version of Glimpse.
Back to Top
See Also
GlimpseMetadata Class
Glimpse.Core.Framework Namespace


Resources Property

GlimpseMetadata Resources Property Glimpse API Documentation
Gets or sets the collection resources keys and their corresponding Uri templates.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, string> Resources { get; set; }
public IDictionary<string, string> Resources { get; set; }
Field Value

            The resources keys and Uri templates.

See Also
GlimpseMetadata Class
GlimpseMetadata Members
Glimpse.Core.Framework Namespace


Tabs Property

GlimpseMetadata Tabs Property Glimpse API Documentation
Gets or sets the collection of tab specific metadata.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, TabMetadata> Tabs { get; set; }
public IDictionary<string, TabMetadata> Tabs { get; set; }
Field Value

            The tab's metadata.

See Also
GlimpseMetadata Class
GlimpseMetadata Members
Glimpse.Core.Framework Namespace


Version Property

GlimpseMetadata Version Property Glimpse API Documentation
Gets or sets the running version of Glimpse.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Version { get; set; }
public string Version { get; set; }
Field Value

            The running version of Glimpse.

See Also
GlimpseMetadata Class
GlimpseMetadata Members
Glimpse.Core.Framework Namespace


GlimpseRequest Class

GlimpseRequest Class Glimpse API Documentation
A class which describes a given Http request, along with the corresponding tab data gathered for that request.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Framework GlimpseRequest

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlimpseRequest
public class GlimpseRequest
See Also
GlimpseRequest Members
Glimpse.Core.Framework Namespace


GlimpseRequest Members

GlimpseRequest Members Glimpse API Documentation

The GlimpseRequest type exposes the following members.
Constructors
 | Name | Description
Public method | GlimpseRequest | Initializes a new instance of the GlimpseRequest class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ClientId | Gets or sets the client id used for session tracking.
Public property | DateTime | Gets or sets the date time of the request.
Public property | Duration | Gets or sets the duration of the request.
Public property | ParentRequestId | Gets or sets the parent request id.
Public property | RequestHttpMethod | Gets or sets the request's HTTP method.
Public property | RequestId | Gets or sets the request id.
Public property | RequestIsAjax | Gets or sets a value indicating whether the request is an Ajax request.
Public property | RequestUri | Gets or sets the request's Uri.
Public property | ResponseContentType | Gets or sets the type of the response's content type.
Public property | ResponseStatusCode | Gets or sets the response status code.
Public property | TabData | Gets or sets the tab data for the Http request.
Public property | UserAgent | Gets or sets the user agent for the request.
Back to Top
See Also
GlimpseRequest Class
Glimpse.Core.Framework Namespace


GlimpseRequest Constructor

GlimpseRequest Constructor Glimpse API Documentation
Initializes a new instance of the GlimpseRequest class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlimpseRequest(
    Guid requestId,
    IRequestMetadata requestMetadata,
    IDictionary<string, TabResult> tabData,
    TimeSpan duration
)
public GlimpseRequest(
    Guid requestId,
    IRequestMetadata requestMetadata,
    IDictionary<string, TabResult> tabData,
    TimeSpan duration
)
Parameters
requestId
Type:   Online System Guid
The request id.
requestMetadata
Type: Glimpse.Core.Framework IRequestMetadata
The request metadata.
tabData
Type:   Online System.Collections.Generic IDictionary    Online String, TabResult
The plugin data.
duration
Type:   Online System TimeSpan
The duration.
See Also
GlimpseRequest Class
GlimpseRequest Members
Glimpse.Core.Framework Namespace


GlimpseRequest Methods

GlimpseRequest Methods Glimpse API Documentation
The GlimpseRequest type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
GlimpseRequest Class
Glimpse.Core.Framework Namespace


GlimpseRequest Properties

GlimpseRequest Properties Glimpse API Documentation
The GlimpseRequest type exposes the following members.
Properties
 | Name | Description
Public property | ClientId | Gets or sets the client id used for session tracking.
Public property | DateTime | Gets or sets the date time of the request.
Public property | Duration | Gets or sets the duration of the request.
Public property | ParentRequestId | Gets or sets the parent request id.
Public property | RequestHttpMethod | Gets or sets the request's HTTP method.
Public property | RequestId | Gets or sets the request id.
Public property | RequestIsAjax | Gets or sets a value indicating whether the request is an Ajax request.
Public property | RequestUri | Gets or sets the request's Uri.
Public property | ResponseContentType | Gets or sets the type of the response's content type.
Public property | ResponseStatusCode | Gets or sets the response status code.
Public property | TabData | Gets or sets the tab data for the Http request.
Public property | UserAgent | Gets or sets the user agent for the request.
Back to Top
See Also
GlimpseRequest Class
Glimpse.Core.Framework Namespace


ClientId Property

GlimpseRequest ClientId Property Glimpse API Documentation
Gets or sets the client id used for session tracking.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ClientId { get; set; }
public string ClientId { get; set; }
Field Value

            The client id.

See Also
GlimpseRequest Class
GlimpseRequest Members
Glimpse.Core.Framework Namespace


DateTime Property

GlimpseRequest DateTime Property Glimpse API Documentation
Gets or sets the date time of the request.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime DateTime { get; set; }
public DateTime DateTime { get; set; }
Field Value

            The date time of the request.

See Also
GlimpseRequest Class
GlimpseRequest Members
Glimpse.Core.Framework Namespace


Duration Property

GlimpseRequest Duration Property Glimpse API Documentation
Gets or sets the duration of the request.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan Duration { get; set; }
public TimeSpan Duration { get; set; }
Field Value

            The duration of the request.

See Also
GlimpseRequest Class
GlimpseRequest Members
Glimpse.Core.Framework Namespace


ParentRequestId Property

GlimpseRequest ParentRequestId Property Glimpse API Documentation
Gets or sets the parent request id.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<Guid> ParentRequestId { get; set; }
public Nullable<Guid> ParentRequestId { get; set; }
Field Value

            The parent request id.

See Also
GlimpseRequest Class
GlimpseRequest Members
Glimpse.Core.Framework Namespace


RequestHttpMethod Property

GlimpseRequest RequestHttpMethod Property Glimpse API Documentation
Gets or sets the request's HTTP method.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RequestHttpMethod { get; set; }
public string RequestHttpMethod { get; set; }
Field Value

            The request's HTTP method.

See Also
GlimpseRequest Class
GlimpseRequest Members
Glimpse.Core.Framework Namespace


RequestId Property

GlimpseRequest RequestId Property Glimpse API Documentation
Gets or sets the request id.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid RequestId { get; set; }
public Guid RequestId { get; set; }
Field Value

            The request id.

See Also
GlimpseRequest Class
GlimpseRequest Members
Glimpse.Core.Framework Namespace


RequestIsAjax Property

GlimpseRequest RequestIsAjax Property Glimpse API Documentation
Gets or sets a value indicating whether the request is an Ajax request.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool RequestIsAjax { get; set; }
public bool RequestIsAjax { get; set; }
Field Value
true if the request is an Ajax request; otherwise, false.

See Also
GlimpseRequest Class
GlimpseRequest Members
Glimpse.Core.Framework Namespace


RequestUri Property

GlimpseRequest RequestUri Property Glimpse API Documentation
Gets or sets the request's Uri.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RequestUri { get; set; }
public string RequestUri { get; set; }
Field Value

            The request's Uri.

See Also
GlimpseRequest Class
GlimpseRequest Members
Glimpse.Core.Framework Namespace


ResponseContentType Property

GlimpseRequest ResponseContentType Property Glimpse API Documentation
Gets or sets the type of the response's content type.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ResponseContentType { get; set; }
public string ResponseContentType { get; set; }
Field Value

            The content type of the response.

See Also
GlimpseRequest Class
GlimpseRequest Members
Glimpse.Core.Framework Namespace


ResponseStatusCode Property

GlimpseRequest ResponseStatusCode Property Glimpse API Documentation
Gets or sets the response status code.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ResponseStatusCode { get; set; }
public int ResponseStatusCode { get; set; }
Field Value

            The response status code.

See Also
GlimpseRequest Class
GlimpseRequest Members
Glimpse.Core.Framework Namespace


TabData Property

GlimpseRequest TabData Property Glimpse API Documentation
Gets or sets the tab data for the Http request.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, TabResult> TabData { get; set; }
public IDictionary<string, TabResult> TabData { get; set; }
Field Value

            The tab data.

See Also
GlimpseRequest Class
GlimpseRequest Members
Glimpse.Core.Framework Namespace


UserAgent Property

GlimpseRequest UserAgent Property Glimpse API Documentation
Gets or sets the user agent for the request.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UserAgent { get; set; }
public string UserAgent { get; set; }
Field Value

            The user agent.

See Also
GlimpseRequest Class
GlimpseRequest Members
Glimpse.Core.Framework Namespace


GlimpseRequestHeaders Class

GlimpseRequestHeaders Class Glimpse API Documentation
Used to return a subset of GlimpseRequest properties by HistoryResource.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Framework GlimpseRequestHeaders

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlimpseRequestHeaders
public class GlimpseRequestHeaders
See Also
GlimpseRequestHeaders Members
Glimpse.Core.Framework Namespace


GlimpseRequestHeaders Members

GlimpseRequestHeaders Members Glimpse API Documentation

The GlimpseRequestHeaders type exposes the following members.
Constructors
 | Name | Description
Public method | GlimpseRequestHeaders | Initializes a new instance of the GlimpseRequestHeaders class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ClientId | Gets the client id.
Public property | DateTime | Gets the date time.
Public property | Duration | Gets the duration.
Public property | ParentRequestId | Gets the parent request id.
Public property | RequestHttpMethod | Gets the request HTTP method.
Public property | RequestId | Gets the request id.
Public property | RequestIsAjax | Gets a value indicating whether [request is ajax].
Public property | RequestUri | Gets the request URI.
Public property | ResponseContentType | Gets the type of the response content.
Public property | ResponseStatusCode | Gets the response status code.
Public property | UserAgent | Gets the user agent.
Back to Top
See Also
GlimpseRequestHeaders Class
Glimpse.Core.Framework Namespace


GlimpseRequestHeaders Constructor

GlimpseRequestHeaders Constructor Glimpse API Documentation
Initializes a new instance of the GlimpseRequestHeaders class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlimpseRequestHeaders(
    GlimpseRequest glimpseRequest
)
public GlimpseRequestHeaders(
    GlimpseRequest glimpseRequest
)
Parameters
glimpseRequest
Type: Glimpse.Core.Framework GlimpseRequest
The glimpse request.
See Also
GlimpseRequestHeaders Class
GlimpseRequestHeaders Members
Glimpse.Core.Framework Namespace


GlimpseRequestHeaders Methods

GlimpseRequestHeaders Methods Glimpse API Documentation
The GlimpseRequestHeaders type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
GlimpseRequestHeaders Class
Glimpse.Core.Framework Namespace


GlimpseRequestHeaders Properties

GlimpseRequestHeaders Properties Glimpse API Documentation
The GlimpseRequestHeaders type exposes the following members.
Properties
 | Name | Description
Public property | ClientId | Gets the client id.
Public property | DateTime | Gets the date time.
Public property | Duration | Gets the duration.
Public property | ParentRequestId | Gets the parent request id.
Public property | RequestHttpMethod | Gets the request HTTP method.
Public property | RequestId | Gets the request id.
Public property | RequestIsAjax | Gets a value indicating whether [request is ajax].
Public property | RequestUri | Gets the request URI.
Public property | ResponseContentType | Gets the type of the response content.
Public property | ResponseStatusCode | Gets the response status code.
Public property | UserAgent | Gets the user agent.
Back to Top
See Also
GlimpseRequestHeaders Class
Glimpse.Core.Framework Namespace


ClientId Property

GlimpseRequestHeaders ClientId Property Glimpse API Documentation
Gets the client id.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ClientId { get; }
public string ClientId { get; }
Field Value

            The client id.

See Also
GlimpseRequestHeaders Class
GlimpseRequestHeaders Members
Glimpse.Core.Framework Namespace


DateTime Property

GlimpseRequestHeaders DateTime Property Glimpse API Documentation
Gets the date time.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime DateTime { get; }
public DateTime DateTime { get; }
Field Value

            The date time.

See Also
GlimpseRequestHeaders Class
GlimpseRequestHeaders Members
Glimpse.Core.Framework Namespace


Duration Property

GlimpseRequestHeaders Duration Property Glimpse API Documentation
Gets the duration.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan Duration { get; }
public TimeSpan Duration { get; }
Field Value

            The duration.

See Also
GlimpseRequestHeaders Class
GlimpseRequestHeaders Members
Glimpse.Core.Framework Namespace


ParentRequestId Property

GlimpseRequestHeaders ParentRequestId Property Glimpse API Documentation
Gets the parent request id.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<Guid> ParentRequestId { get; }
public Nullable<Guid> ParentRequestId { get; }
Field Value

            The parent request id.

See Also
GlimpseRequestHeaders Class
GlimpseRequestHeaders Members
Glimpse.Core.Framework Namespace


RequestHttpMethod Property

GlimpseRequestHeaders RequestHttpMethod Property Glimpse API Documentation
Gets the request HTTP method.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RequestHttpMethod { get; }
public string RequestHttpMethod { get; }
Field Value

            The request HTTP method.

See Also
GlimpseRequestHeaders Class
GlimpseRequestHeaders Members
Glimpse.Core.Framework Namespace


RequestId Property

GlimpseRequestHeaders RequestId Property Glimpse API Documentation
Gets the request id.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid RequestId { get; }
public Guid RequestId { get; }
Field Value

            The request id.

See Also
GlimpseRequestHeaders Class
GlimpseRequestHeaders Members
Glimpse.Core.Framework Namespace


RequestIsAjax Property

GlimpseRequestHeaders RequestIsAjax Property Glimpse API Documentation
Gets a value indicating whether [request is ajax].

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool RequestIsAjax { get; }
public bool RequestIsAjax { get; }
Field Value
true if [request is ajax]; otherwise, false.

See Also
GlimpseRequestHeaders Class
GlimpseRequestHeaders Members
Glimpse.Core.Framework Namespace


RequestUri Property

GlimpseRequestHeaders RequestUri Property Glimpse API Documentation
Gets the request URI.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RequestUri { get; }
public string RequestUri { get; }
Field Value

            The request URI.

See Also
GlimpseRequestHeaders Class
GlimpseRequestHeaders Members
Glimpse.Core.Framework Namespace


ResponseContentType Property

GlimpseRequestHeaders ResponseContentType Property Glimpse API Documentation
Gets the type of the response content.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ResponseContentType { get; }
public string ResponseContentType { get; }
Field Value

            The type of the response content.

See Also
GlimpseRequestHeaders Class
GlimpseRequestHeaders Members
Glimpse.Core.Framework Namespace


ResponseStatusCode Property

GlimpseRequestHeaders ResponseStatusCode Property Glimpse API Documentation
Gets the response status code.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ResponseStatusCode { get; }
public int ResponseStatusCode { get; }
Field Value

            The response status code.

See Also
GlimpseRequestHeaders Class
GlimpseRequestHeaders Members
Glimpse.Core.Framework Namespace


UserAgent Property

GlimpseRequestHeaders UserAgent Property Glimpse API Documentation
Gets the user agent.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UserAgent { get; }
public string UserAgent { get; }
Field Value

            The user agent.

See Also
GlimpseRequestHeaders Class
GlimpseRequestHeaders Members
Glimpse.Core.Framework Namespace


GlimpseRuntime Class

GlimpseRuntime Class Glimpse API Documentation
The heart and soul of Glimpse. The runtime coordinate all input from a IFrameworkProvider, persists collected runtime information and writes responses out to the IFrameworkProvider.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Framework GlimpseRuntime

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlimpseRuntime : IGlimpseRuntime
public class GlimpseRuntime : IGlimpseRuntime
See Also
GlimpseRuntime Members
Glimpse.Core.Framework Namespace


GlimpseRuntime Members

GlimpseRuntime Members Glimpse API Documentation

The GlimpseRuntime type exposes the following members.
Constructors
 | Name | Description
Public method | GlimpseRuntime | Initializes a new instance of the GlimpseRuntime class.
Back to Top
Methods
 | Name | Description
Public method | BeginRequest | Begins Glimpse's processing of a Http request.
Public method | BeginSessionAccess | Begins access to session data.
Public method | EndRequest | Ends Glimpse's processing a Http request.
Public method | EndSessionAccess | Ends access to session data.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | ExecuteDefaultResource | Executes the default resource.
Public method | ExecuteResource | Executes the resource.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Initialize | Initializes this instance of the Glimpse runtime.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Configuration | Gets or sets the configuration.
Public property | IsInitialized | Gets a value indicating whether this instance has been initialized.
 | Version | Gets the executing version of Glimpse.
Back to Top
See Also
GlimpseRuntime Class
Glimpse.Core.Framework Namespace


GlimpseRuntime Constructor

GlimpseRuntime Constructor Glimpse API Documentation
Initializes a new instance of the GlimpseRuntime class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlimpseRuntime(
    IGlimpseConfiguration configuration
)
public GlimpseRuntime(
    IGlimpseConfiguration configuration
)
Parameters
configuration
Type: Glimpse.Core.Framework IGlimpseConfiguration
The configuration.
Exceptions
Exception | Condition
Online System ArgumentNullException | Throws an exception if configuration is null.
See Also
GlimpseRuntime Class
GlimpseRuntime Members
Glimpse.Core.Framework Namespace


GlimpseRuntime Methods

GlimpseRuntime Methods Glimpse API Documentation
The GlimpseRuntime type exposes the following members.
Methods
 | Name | Description
Public method | BeginRequest | Begins Glimpse's processing of a Http request.
Public method | BeginSessionAccess | Begins access to session data.
Public method | EndRequest | Ends Glimpse's processing a Http request.
Public method | EndSessionAccess | Ends access to session data.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | ExecuteDefaultResource | Executes the default resource.
Public method | ExecuteResource | Executes the resource.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Initialize | Initializes this instance of the Glimpse runtime.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
GlimpseRuntime Class
Glimpse.Core.Framework Namespace


BeginRequest Method

GlimpseRuntime BeginRequest Method Glimpse API Documentation
Begins Glimpse's processing of a Http request.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void BeginRequest()
public void BeginRequest()
Implements
IGlimpseRuntime BeginRequest
Exceptions
Exception | Condition
Glimpse.Core.Framework GlimpseException | Throws an exception if GlimpseRuntime is not yet initialized.
See Also
GlimpseRuntime Class
GlimpseRuntime Members
Glimpse.Core.Framework Namespace


BeginSessionAccess Method

GlimpseRuntime BeginSessionAccess Method Glimpse API Documentation
Begins access to session data.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void BeginSessionAccess()
public void BeginSessionAccess()
Implements
IGlimpseRuntime BeginSessionAccess
See Also
GlimpseRuntime Class
GlimpseRuntime Members
Glimpse.Core.Framework Namespace


EndRequest Method

GlimpseRuntime EndRequest Method Glimpse API Documentation
Ends Glimpse's processing a Http request.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void EndRequest()
public void EndRequest()
Implements
IGlimpseRuntime EndRequest
Exceptions
Exception | Condition
Glimpse.Core.Framework GlimpseException | Throws an exception if BeginRequest has not yet been called on a given request.
See Also
GlimpseRuntime Class
GlimpseRuntime Members
Glimpse.Core.Framework Namespace


EndSessionAccess Method

GlimpseRuntime EndSessionAccess Method Glimpse API Documentation
Ends access to session data.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void EndSessionAccess()
public void EndSessionAccess()
Implements
IGlimpseRuntime EndSessionAccess
See Also
GlimpseRuntime Class
GlimpseRuntime Members
Glimpse.Core.Framework Namespace


ExecuteDefaultResource Method

GlimpseRuntime ExecuteDefaultResource Method Glimpse API Documentation
Executes the default resource.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ExecuteDefaultResource()
public void ExecuteDefaultResource()
Implements
IGlimpseRuntime ExecuteDefaultResource
See Also
GlimpseRuntime Class
GlimpseRuntime Members
Glimpse.Core.Framework Namespace


ExecuteResource Method

GlimpseRuntime ExecuteResource Method Glimpse API Documentation
Executes the resource.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ExecuteResource(
    string resourceName,
    ResourceParameters parameters
)
public void ExecuteResource(
    string resourceName,
    ResourceParameters parameters
)
Parameters
resourceName
Type:   Online System String
Name of the resource.
parameters
Type: Glimpse.Core.Framework ResourceParameters
The parameters.
Implements
IGlimpseRuntime ExecuteResource(String, ResourceParameters)
Exceptions
Exception | Condition
Online System ArgumentNullException | Throws an exception if either parameter is null.
See Also
GlimpseRuntime Class
GlimpseRuntime Members
Glimpse.Core.Framework Namespace


Initialize Method

GlimpseRuntime Initialize Method Glimpse API Documentation
Initializes this instance of the Glimpse runtime.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Initialize()
public bool Initialize()
Return Value
true if system initialized successfully, false otherwise

Implements
IGlimpseRuntime Initialize
See Also
GlimpseRuntime Class
GlimpseRuntime Members
Glimpse.Core.Framework Namespace


GlimpseRuntime Properties

GlimpseRuntime Properties Glimpse API Documentation
The GlimpseRuntime type exposes the following members.
Properties
 | Name | Description
Public property | Configuration | Gets or sets the configuration.
Public property | IsInitialized | Gets a value indicating whether this instance has been initialized.
 | Version | Gets the executing version of Glimpse.
Back to Top
See Also
GlimpseRuntime Class
Glimpse.Core.Framework Namespace


Configuration Property

GlimpseRuntime Configuration Property Glimpse API Documentation
Gets or sets the configuration.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IGlimpseConfiguration Configuration { get; set; }
public IGlimpseConfiguration Configuration { get; set; }
Field Value

            The configuration.

See Also
GlimpseRuntime Class
GlimpseRuntime Members
Glimpse.Core.Framework Namespace


IsInitialized Property

GlimpseRuntime IsInitialized Property Glimpse API Documentation
Gets a value indicating whether this instance has been initialized.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsInitialized { get; private set; }
public bool IsInitialized { get; private set; }
Field Value
true if this instance is initialized; otherwise, false.

Implements
IGlimpseRuntime IsInitialized
See Also
GlimpseRuntime Class
GlimpseRuntime Members
Glimpse.Core.Framework Namespace


Version Property

GlimpseRuntime Version Property Glimpse API Documentation
Gets the executing version of Glimpse.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Version { get; private set; }
public static string Version { get; private set; }
Field Value

            The version of Glimpse.

Remarks
Glimpse versioning follows the rules of   Online Semantic Versioning.
See Also
GlimpseRuntime Class
GlimpseRuntime Members
Glimpse.Core.Framework Namespace


GlimpseRuntime.RuntimeMessage Class

GlimpseRuntime RuntimeMessage Class Glimpse API Documentation
The message used to to track the beginning and end of Http requests.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Framework GlimpseRuntime RuntimeMessage

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected class RuntimeMessage : ITimelineMessage,
    ITimedMessage, IMessage, ISourceMessage
protected class RuntimeMessage : ITimelineMessage,
    ITimedMessage, IMessage, ISourceMessage
See Also
GlimpseRuntime RuntimeMessage Members
Glimpse.Core.Framework Namespace


GlimpseRuntime.RuntimeMessage Members

GlimpseRuntime RuntimeMessage Members Glimpse API Documentation

The heart and soul of Glimpse. The runtime coordinate all input from a IFrameworkProvider, persists collected runtime information and writes responses out to the IFrameworkProvider.

The GlimpseRuntime RuntimeMessage type exposes the following members.
Constructors
 | Name | Description
Public method | GlimpseRuntime RuntimeMessage | Initializes a new instance of the GlimpseRuntime RuntimeMessage class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Duration | Gets or sets the duration.
Public property | EventCategory | Gets or sets the event category.
Public property | EventName | Gets or sets the name of the event.
Public property | EventSubText | Gets or sets the event sub text.
Public property | ExecutedMethod | Gets or sets the executed method.
Public property | ExecutedType | Gets or sets the type of the executed.
Public property | Id | Gets the id of the request.
Public property | Offset | Gets or sets the offset.
Public property | StartTime | Gets or sets the start time.
Back to Top
See Also
GlimpseRuntime RuntimeMessage Class
Glimpse.Core.Framework Namespace


GlimpseRuntime.RuntimeMessage Constructor

GlimpseRuntime RuntimeMessage Constructor Glimpse API Documentation
Initializes a new instance of the GlimpseRuntime RuntimeMessage class

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RuntimeMessage()
public RuntimeMessage()
See Also
GlimpseRuntime RuntimeMessage Class
GlimpseRuntime RuntimeMessage Members
Glimpse.Core.Framework Namespace


GlimpseRuntime.RuntimeMessage Methods

GlimpseRuntime RuntimeMessage Methods Glimpse API Documentation
The GlimpseRuntime RuntimeMessage type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
GlimpseRuntime RuntimeMessage Class
Glimpse.Core.Framework Namespace


GlimpseRuntime.RuntimeMessage Properties

GlimpseRuntime RuntimeMessage Properties Glimpse API Documentation
The GlimpseRuntime RuntimeMessage type exposes the following members.
Properties
 | Name | Description
Public property | Duration | Gets or sets the duration.
Public property | EventCategory | Gets or sets the event category.
Public property | EventName | Gets or sets the name of the event.
Public property | EventSubText | Gets or sets the event sub text.
Public property | ExecutedMethod | Gets or sets the executed method.
Public property | ExecutedType | Gets or sets the type of the executed.
Public property | Id | Gets the id of the request.
Public property | Offset | Gets or sets the offset.
Public property | StartTime | Gets or sets the start time.
Back to Top
See Also
GlimpseRuntime RuntimeMessage Class
Glimpse.Core.Framework Namespace


Duration Property

GlimpseRuntime RuntimeMessage Duration Property Glimpse API Documentation
Gets or sets the duration.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan Duration { get; set; }
public TimeSpan Duration { get; set; }
Field Value

            The duration.

Implements
ITimedMessage Duration
See Also
GlimpseRuntime RuntimeMessage Class
GlimpseRuntime RuntimeMessage Members
Glimpse.Core.Framework Namespace


EventCategory Property

GlimpseRuntime RuntimeMessage EventCategory Property Glimpse API Documentation
Gets or sets the event category.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimelineCategory EventCategory { get; set; }
public TimelineCategory EventCategory { get; set; }
Field Value

            The event category.

Implements
ITimelineMessage EventCategory
See Also
GlimpseRuntime RuntimeMessage Class
GlimpseRuntime RuntimeMessage Members
Glimpse.Core.Framework Namespace


EventName Property

GlimpseRuntime RuntimeMessage EventName Property Glimpse API Documentation
Gets or sets the name of the event.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string EventName { get; set; }
public string EventName { get; set; }
Field Value

            The name of the event.

Implements
ITimelineMessage EventName
See Also
GlimpseRuntime RuntimeMessage Class
GlimpseRuntime RuntimeMessage Members
Glimpse.Core.Framework Namespace


EventSubText Property

GlimpseRuntime RuntimeMessage EventSubText Property Glimpse API Documentation
Gets or sets the event sub text.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string EventSubText { get; set; }
public string EventSubText { get; set; }
Field Value

            The event sub text.

Implements
ITimelineMessage EventSubText
See Also
GlimpseRuntime RuntimeMessage Class
GlimpseRuntime RuntimeMessage Members
Glimpse.Core.Framework Namespace


ExecutedMethod Property

GlimpseRuntime RuntimeMessage ExecutedMethod Property Glimpse API Documentation
Gets or sets the executed method.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MethodInfo ExecutedMethod { get; set; }
public MethodInfo ExecutedMethod { get; set; }
Field Value

            The executed method.

Implements
ISourceMessage ExecutedMethod
See Also
GlimpseRuntime RuntimeMessage Class
GlimpseRuntime RuntimeMessage Members
Glimpse.Core.Framework Namespace


ExecutedType Property

GlimpseRuntime RuntimeMessage ExecutedType Property Glimpse API Documentation
Gets or sets the type of the executed.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type ExecutedType { get; set; }
public Type ExecutedType { get; set; }
Field Value

            The type of the executed.

Implements
ISourceMessage ExecutedType
See Also
GlimpseRuntime RuntimeMessage Class
GlimpseRuntime RuntimeMessage Members
Glimpse.Core.Framework Namespace


Id Property

GlimpseRuntime RuntimeMessage Id Property Glimpse API Documentation
Gets the id of the request.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid Id { get; private set; }
public Guid Id { get; private set; }
Field Value

            The id.

Implements
IMessage Id
See Also
GlimpseRuntime RuntimeMessage Class
GlimpseRuntime RuntimeMessage Members
Glimpse.Core.Framework Namespace


Offset Property

GlimpseRuntime RuntimeMessage Offset Property Glimpse API Documentation
Gets or sets the offset.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan Offset { get; set; }
public TimeSpan Offset { get; set; }
Field Value

            The offset.

Implements
ITimedMessage Offset
See Also
GlimpseRuntime RuntimeMessage Class
GlimpseRuntime RuntimeMessage Members
Glimpse.Core.Framework Namespace


StartTime Property

GlimpseRuntime RuntimeMessage StartTime Property Glimpse API Documentation
Gets or sets the start time.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime StartTime { get; set; }
public DateTime StartTime { get; set; }
Field Value

            The start time.

Implements
ITimedMessage StartTime
See Also
GlimpseRuntime RuntimeMessage Class
GlimpseRuntime RuntimeMessage Members
Glimpse.Core.Framework Namespace


IDiscoverableCollection(T) Interface

IDiscoverableCollection T Interface Glimpse API Documentation
Defines methods to self discover collection content.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IDiscoverableCollection<T> : ICollection<T>,
    IEnumerable<T>, IEnumerable
public interface IDiscoverableCollection<T> : ICollection<T>,
    IEnumerable<T>, IEnumerable
Type Parameters
T
Collection item type
See Also
IDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


IDiscoverableCollection(T) Members

IDiscoverableCollection T Members Glimpse API Documentation

The IDiscoverableCollection T type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an item to the Online ICollection T . (Inherited from Online ICollection T .)
Public method | Online Clear | Removes all items from the Online ICollection T . (Inherited from Online ICollection T .)
Public method | Online Contains | Determines whether the Online ICollection T contains a specific value. (Inherited from Online ICollection T .)
Public method | Online CopyTo | Copies the elements of the Online ICollection T to an Online Array, starting at a particular Online Array index. (Inherited from Online ICollection T .)
Public method | Discover | Discovers this instance. Triggers the loading of content.
Public method | Online GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from Online IEnumerable T .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online IEnumerable.)
Public method | IgnoreType | Ignores the type.
Public method | Online Remove | Removes the first occurrence of a specific object from the Online ICollection T . (Inherited from Online ICollection T .)
Back to Top
Properties
 | Name | Description
Public property | AutoDiscover | Gets a value indicating whether [auto discover].
Public property | Online Count | Gets the number of elements contained in the Online ICollection T . (Inherited from Online ICollection T .)
Public property | DiscoveryLocation | Gets the discovery location.
Public property | Online IsReadOnly | Gets a value indicating whether the Online ICollection T is read-only. (Inherited from Online ICollection T .)
Back to Top
See Also
IDiscoverableCollection T Interface
Glimpse.Core.Framework Namespace


IDiscoverableCollection(T) Methods

IDiscoverableCollection T Methods Glimpse API Documentation
The IDiscoverableCollection T type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an item to the Online ICollection T . (Inherited from Online ICollection T .)
Public method | Online Clear | Removes all items from the Online ICollection T . (Inherited from Online ICollection T .)
Public method | Online Contains | Determines whether the Online ICollection T contains a specific value. (Inherited from Online ICollection T .)
Public method | Online CopyTo | Copies the elements of the Online ICollection T to an Online Array, starting at a particular Online Array index. (Inherited from Online ICollection T .)
Public method | Discover | Discovers this instance. Triggers the loading of content.
Public method | Online GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from Online IEnumerable T .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online IEnumerable.)
Public method | IgnoreType | Ignores the type.
Public method | Online Remove | Removes the first occurrence of a specific object from the Online ICollection T . (Inherited from Online ICollection T .)
Back to Top
See Also
IDiscoverableCollection T Interface
Glimpse.Core.Framework Namespace


Discover Method

IDiscoverableCollection T Discover Method Glimpse API Documentation
Discovers this instance. Triggers the loading of content.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Discover()
void Discover()
See Also
IDiscoverableCollection T  Interface
IDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


IgnoreType Method

IDiscoverableCollection T IgnoreType Method Glimpse API Documentation
Ignores the type.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void IgnoreType(
    Type type
)
void IgnoreType(
    Type type
)
Parameters
type
Type:   Online System Type
The type.
See Also
IDiscoverableCollection T  Interface
IDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


IDiscoverableCollection(T) Properties

IDiscoverableCollection T Properties Glimpse API Documentation
The IDiscoverableCollection T type exposes the following members.
Properties
 | Name | Description
Public property | AutoDiscover | Gets a value indicating whether [auto discover].
Public property | Online Count | Gets the number of elements contained in the Online ICollection T . (Inherited from Online ICollection T .)
Public property | DiscoveryLocation | Gets the discovery location.
Public property | Online IsReadOnly | Gets a value indicating whether the Online ICollection T is read-only. (Inherited from Online ICollection T .)
Back to Top
See Also
IDiscoverableCollection T Interface
Glimpse.Core.Framework Namespace


AutoDiscover Property

IDiscoverableCollection T AutoDiscover Property Glimpse API Documentation
Gets a value indicating whether [auto discover].

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool AutoDiscover { get; }
bool AutoDiscover { get; }
Field Value
true if [auto discover]; otherwise, false.
Remarks

            Indicates whether the system can automatically call Discover()

See Also
IDiscoverableCollection T  Interface
IDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


DiscoveryLocation Property

IDiscoverableCollection T DiscoveryLocation Property Glimpse API Documentation
Gets the discovery location.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string DiscoveryLocation { get; }
string DiscoveryLocation { get; }
Field Value
The discovery location.
See Also
IDiscoverableCollection T  Interface
IDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


IFrameworkProvider Interface

IFrameworkProvider Interface Glimpse API Documentation
Defines methods to required to implement a Glimpse framework provider. Framework providers allow Glimpse to work generically against any .NET based web development framework.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IFrameworkProvider
public interface IFrameworkProvider
Remarks

            Required by any different Framework Provider - i.e. ASP.NET, Self Hosted WebAPI,
            NancyFX, etc. See Glimpse.AspNet.AspNetFrameworkProvider
            as reference implementation.

See Also
IFrameworkProvider Members
Glimpse.Core.Framework Namespace


IFrameworkProvider Members

IFrameworkProvider Members Glimpse API Documentation

The IFrameworkProvider type exposes the following members.
Methods
 | Name | Description
Public method | InjectHttpResponseBody | Injects the Http response body.
Public method | SetCookie | Sets the cookie.
Public method | SetHttpResponseHeader | Sets the Http response header.
Public method | SetHttpResponseStatusCode | Sets the Http response status code.
Public method | WriteHttpResponse( Byte ) | Writes the Http response.
Public method | WriteHttpResponse(String) | Writes the Http response.
Back to Top
Properties
 | Name | Description
Public property | HttpRequestStore | Gets the Http request store.
Public property | HttpServerStore | Gets the Http server store.
Public property | RequestMetadata | Gets the request metadata.
Public property | RuntimeContext | Gets the runtime context.
Back to Top
See Also
IFrameworkProvider Interface
Glimpse.Core.Framework Namespace


IFrameworkProvider Methods

IFrameworkProvider Methods Glimpse API Documentation
The IFrameworkProvider type exposes the following members.
Methods
 | Name | Description
Public method | InjectHttpResponseBody | Injects the Http response body.
Public method | SetCookie | Sets the cookie.
Public method | SetHttpResponseHeader | Sets the Http response header.
Public method | SetHttpResponseStatusCode | Sets the Http response status code.
Public method | WriteHttpResponse( Byte ) | Writes the Http response.
Public method | WriteHttpResponse(String) | Writes the Http response.
Back to Top
See Also
IFrameworkProvider Interface
Glimpse.Core.Framework Namespace


InjectHttpResponseBody Method

IFrameworkProvider InjectHttpResponseBody Method Glimpse API Documentation
Injects the Http response body.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void InjectHttpResponseBody(
    string htmlSnippet
)
void InjectHttpResponseBody(
    string htmlSnippet
)
Parameters
htmlSnippet
Type:   Online System String
The HTML snippet.
Remarks

            Inserts the given html snippet into the html document just before the end </body> tag.

See Also
IFrameworkProvider Interface
IFrameworkProvider Members
Glimpse.Core.Framework Namespace


SetCookie Method

IFrameworkProvider SetCookie Method Glimpse API Documentation
Sets the cookie.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void SetCookie(
    string name,
    string value
)
void SetCookie(
    string name,
    string value
)
Parameters
name
Type:   Online System String
The name.
value
Type:   Online System String
The value.
See Also
IFrameworkProvider Interface
IFrameworkProvider Members
Glimpse.Core.Framework Namespace


SetHttpResponseHeader Method

IFrameworkProvider SetHttpResponseHeader Method Glimpse API Documentation
Sets the Http response header.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void SetHttpResponseHeader(
    string name,
    string value
)
void SetHttpResponseHeader(
    string name,
    string value
)
Parameters
name
Type:   Online System String
The name.
value
Type:   Online System String
The value.
See Also
IFrameworkProvider Interface
IFrameworkProvider Members
Glimpse.Core.Framework Namespace


SetHttpResponseStatusCode Method

IFrameworkProvider SetHttpResponseStatusCode Method Glimpse API Documentation
Sets the Http response status code.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void SetHttpResponseStatusCode(
    int statusCode
)
void SetHttpResponseStatusCode(
    int statusCode
)
Parameters
statusCode
Type:   Online System Int32
The status code.
See Also
IFrameworkProvider Interface
IFrameworkProvider Members
Glimpse.Core.Framework Namespace


WriteHttpResponse Method

IFrameworkProvider WriteHttpResponse Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | WriteHttpResponse( Byte ) | Writes the Http response.
Public method | WriteHttpResponse(String) | Writes the Http response.
Back to Top
See Also
IFrameworkProvider Interface
IFrameworkProvider Members
Glimpse.Core.Framework Namespace


WriteHttpResponse Method (Byte[])

IFrameworkProvider WriteHttpResponse Method ( Byte ) Glimpse API Documentation
Writes the Http response.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void WriteHttpResponse(
    byte[] content
)
void WriteHttpResponse(
    byte[] content
)
Parameters
content
Type:    Online System Byte
The content.
Remarks

            Used by the resource infrastructure to output binary content (i.e. embedded content,
            images, etc).

See Also
IFrameworkProvider Interface
IFrameworkProvider Members
WriteHttpResponse Overload
Glimpse.Core.Framework Namespace
Glimpse.Core.Extensibility IResourceResult
Glimpse.Core.Extensibility IResource


WriteHttpResponse Method (String)

IFrameworkProvider WriteHttpResponse Method (String) Glimpse API Documentation
Writes the Http response.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void WriteHttpResponse(
    string content
)
void WriteHttpResponse(
    string content
)
Parameters
content
Type:   Online System String
The content.
Remarks

            Used by the resource infrastructure to output string content (i.e. generated strings,
            JSON objects, etc).

See Also
IFrameworkProvider Interface
IFrameworkProvider Members
WriteHttpResponse Overload
Glimpse.Core.Framework Namespace
Glimpse.Core.Extensibility IResourceResult


IFrameworkProvider Properties

IFrameworkProvider Properties Glimpse API Documentation
The IFrameworkProvider type exposes the following members.
Properties
 | Name | Description
Public property | HttpRequestStore | Gets the Http request store.
Public property | HttpServerStore | Gets the Http server store.
Public property | RequestMetadata | Gets the request metadata.
Public property | RuntimeContext | Gets the runtime context.
Back to Top
See Also
IFrameworkProvider Interface
Glimpse.Core.Framework Namespace


HttpRequestStore Property

IFrameworkProvider HttpRequestStore Property Glimpse API Documentation
Gets the Http request store.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IDataStore HttpRequestStore { get; }
IDataStore HttpRequestStore { get; }
Field Value
The Http request store.
Remarks

            A request store is a place for Glimpse to store data that lives and dies with an Http request.

Examples

            In ASP.NET, HttpContext.Items is a request store.

See Also
IFrameworkProvider Interface
IFrameworkProvider Members
Glimpse.Core.Framework Namespace


HttpServerStore Property

IFrameworkProvider HttpServerStore Property Glimpse API Documentation
Gets the Http server store.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IDataStore HttpServerStore { get; }
IDataStore HttpServerStore { get; }
Field Value
The Http server store.
Remarks

            A server store is a place for Glimpse to store data a persists across Http requests.

Examples

            In ASP.NET, HttpContext.Application is a server store.

See Also
IFrameworkProvider Interface
IFrameworkProvider Members
Glimpse.Core.Framework Namespace


RequestMetadata Property

IFrameworkProvider RequestMetadata Property Glimpse API Documentation
Gets the request metadata.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IRequestMetadata RequestMetadata { get; }
IRequestMetadata RequestMetadata { get; }
Field Value
The request metadata.
Remarks

            An instance of IRequestMetadata which provides relevant metadata about an Http request.

Examples

            In ASP.NET, a HttpRequest contains must data required for creating a IRequestMetadata.

See Also
IFrameworkProvider Interface
IFrameworkProvider Members
Glimpse.Core.Framework Namespace


RuntimeContext Property

IFrameworkProvider RuntimeContext Property Glimpse API Documentation
Gets the runtime context.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object RuntimeContext { get; }
Object RuntimeContext { get; }
Field Value
The runtime context.
Remarks

            Instance of the underlying context that the web development framework uses.

Examples

            In ASP.NET, HttpContext is the runtime context.

See Also
IFrameworkProvider Interface
IFrameworkProvider Members
Glimpse.Core.Framework Namespace


IGlimpseConfiguration Interface

IGlimpseConfiguration Interface Glimpse API Documentation
Defines properties to provide access to system providers, stores, collections, factories, etc.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IGlimpseConfiguration
public interface IGlimpseConfiguration
See Also
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


IGlimpseConfiguration Members

IGlimpseConfiguration Members Glimpse API Documentation

The IGlimpseConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | ClientScripts | Gets the client scripts.
Public property | DefaultResource | Gets the default resource.
Public property | DefaultRuntimePolicy | Gets the default runtime policy.
Public property | EndpointBaseUri | Gets the endpoint base URI.
Public property | FrameworkProvider | Gets the framework provider.
Public property | HtmlEncoder | Gets the HTML encoder.
Public property | Inspectors | Gets the inspectors.
Public property | Logger | Gets the logger.
Public property | MessageBroker | Gets the message broker.
Public property | PersistenceStore | Gets the persistence store.
Public property | ProxyFactory | Gets the proxy factory.
Public property | ResourceEndpoint | Gets the resource endpoint.
Public property | Resources | Gets the resources.
Public property | RuntimePolicies | Gets the runtime policies.
Public property | RuntimePolicyStrategy | Gets or sets the runtime policy strategy.
Public property | Serializer | Gets the serializer.
Public property | Tabs | Gets the tabs.
Public property | TimerStrategy | Gets or sets the timer strategy.
Back to Top
See Also
IGlimpseConfiguration Interface
Glimpse.Core.Framework Namespace


IGlimpseConfiguration Properties

IGlimpseConfiguration Properties Glimpse API Documentation
The IGlimpseConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | ClientScripts | Gets the client scripts.
Public property | DefaultResource | Gets the default resource.
Public property | DefaultRuntimePolicy | Gets the default runtime policy.
Public property | EndpointBaseUri | Gets the endpoint base URI.
Public property | FrameworkProvider | Gets the framework provider.
Public property | HtmlEncoder | Gets the HTML encoder.
Public property | Inspectors | Gets the inspectors.
Public property | Logger | Gets the logger.
Public property | MessageBroker | Gets the message broker.
Public property | PersistenceStore | Gets the persistence store.
Public property | ProxyFactory | Gets the proxy factory.
Public property | ResourceEndpoint | Gets the resource endpoint.
Public property | Resources | Gets the resources.
Public property | RuntimePolicies | Gets the runtime policies.
Public property | RuntimePolicyStrategy | Gets or sets the runtime policy strategy.
Public property | Serializer | Gets the serializer.
Public property | Tabs | Gets the tabs.
Public property | TimerStrategy | Gets or sets the timer strategy.
Back to Top
See Also
IGlimpseConfiguration Interface
Glimpse.Core.Framework Namespace


ClientScripts Property

IGlimpseConfiguration ClientScripts Property Glimpse API Documentation
Gets the client scripts.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ICollection<IClientScript> ClientScripts { get; }
ICollection<IClientScript> ClientScripts { get; }
Field Value
The client scripts.
See Also
IGlimpseConfiguration Interface
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


DefaultResource Property

IGlimpseConfiguration DefaultResource Property Glimpse API Documentation
Gets the default resource.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IResource DefaultResource { get; }
IResource DefaultResource { get; }
Field Value
The default resource.
See Also
IGlimpseConfiguration Interface
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


DefaultRuntimePolicy Property

IGlimpseConfiguration DefaultRuntimePolicy Property Glimpse API Documentation
Gets the default runtime policy.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
RuntimePolicy DefaultRuntimePolicy { get; }
RuntimePolicy DefaultRuntimePolicy { get; }
Field Value
The default runtime policy.
See Also
IGlimpseConfiguration Interface
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


EndpointBaseUri Property

IGlimpseConfiguration EndpointBaseUri Property Glimpse API Documentation
Gets the endpoint base URI.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string EndpointBaseUri { get; }
string EndpointBaseUri { get; }
Field Value
The endpoint base URI.
See Also
IGlimpseConfiguration Interface
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


FrameworkProvider Property

IGlimpseConfiguration FrameworkProvider Property Glimpse API Documentation
Gets the framework provider.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IFrameworkProvider FrameworkProvider { get; }
IFrameworkProvider FrameworkProvider { get; }
Field Value
The framework provider.
See Also
IGlimpseConfiguration Interface
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


HtmlEncoder Property

IGlimpseConfiguration HtmlEncoder Property Glimpse API Documentation
Gets the HTML encoder.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IHtmlEncoder HtmlEncoder { get; }
IHtmlEncoder HtmlEncoder { get; }
Field Value
The HTML encoder.
See Also
IGlimpseConfiguration Interface
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


Inspectors Property

IGlimpseConfiguration Inspectors Property Glimpse API Documentation
Gets the inspectors.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ICollection<IInspector> Inspectors { get; }
ICollection<IInspector> Inspectors { get; }
Field Value
The inspectors.
See Also
IGlimpseConfiguration Interface
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


Logger Property

IGlimpseConfiguration Logger Property Glimpse API Documentation
Gets the logger.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ILogger Logger { get; }
ILogger Logger { get; }
Field Value
The logger.
See Also
IGlimpseConfiguration Interface
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


MessageBroker Property

IGlimpseConfiguration MessageBroker Property Glimpse API Documentation
Gets the message broker.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IMessageBroker MessageBroker { get; }
IMessageBroker MessageBroker { get; }
Field Value
The message broker.
See Also
IGlimpseConfiguration Interface
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


PersistenceStore Property

IGlimpseConfiguration PersistenceStore Property Glimpse API Documentation
Gets the persistence store.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IPersistenceStore PersistenceStore { get; }
IPersistenceStore PersistenceStore { get; }
Field Value
The persistence store.
See Also
IGlimpseConfiguration Interface
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


ProxyFactory Property

IGlimpseConfiguration ProxyFactory Property Glimpse API Documentation
Gets the proxy factory.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IProxyFactory ProxyFactory { get; }
IProxyFactory ProxyFactory { get; }
Field Value
The proxy factory.
See Also
IGlimpseConfiguration Interface
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


ResourceEndpoint Property

IGlimpseConfiguration ResourceEndpoint Property Glimpse API Documentation
Gets the resource endpoint.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ResourceEndpointConfiguration ResourceEndpoint { get; }
ResourceEndpointConfiguration ResourceEndpoint { get; }
Field Value
The resource endpoint.
See Also
IGlimpseConfiguration Interface
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


Resources Property

IGlimpseConfiguration Resources Property Glimpse API Documentation
Gets the resources.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ICollection<IResource> Resources { get; }
ICollection<IResource> Resources { get; }
Field Value
The resources.
See Also
IGlimpseConfiguration Interface
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


RuntimePolicies Property

IGlimpseConfiguration RuntimePolicies Property Glimpse API Documentation
Gets the runtime policies.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ICollection<IRuntimePolicy> RuntimePolicies { get; }
ICollection<IRuntimePolicy> RuntimePolicies { get; }
Field Value
The runtime policies.
See Also
IGlimpseConfiguration Interface
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


RuntimePolicyStrategy Property

IGlimpseConfiguration RuntimePolicyStrategy Property Glimpse API Documentation
Gets or sets the runtime policy strategy.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Func<RuntimePolicy> RuntimePolicyStrategy { get; set; }
Func<RuntimePolicy> RuntimePolicyStrategy { get; set; }
Field Value
The runtime policy strategy.
See Also
IGlimpseConfiguration Interface
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


Serializer Property

IGlimpseConfiguration Serializer Property Glimpse API Documentation
Gets the serializer.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ISerializer Serializer { get; }
ISerializer Serializer { get; }
Field Value
The serializer.
See Also
IGlimpseConfiguration Interface
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


Tabs Property

IGlimpseConfiguration Tabs Property Glimpse API Documentation
Gets the tabs.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ICollection<ITab> Tabs { get; }
ICollection<ITab> Tabs { get; }
Field Value
The tabs.
See Also
IGlimpseConfiguration Interface
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


TimerStrategy Property

IGlimpseConfiguration TimerStrategy Property Glimpse API Documentation
Gets or sets the timer strategy.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Func<IExecutionTimer> TimerStrategy { get; set; }
Func<IExecutionTimer> TimerStrategy { get; set; }
Field Value
The timer strategy.
See Also
IGlimpseConfiguration Interface
IGlimpseConfiguration Members
Glimpse.Core.Framework Namespace


IGlimpseRuntime Interface

IGlimpseRuntime Interface Glimpse API Documentation
Defines methods to implement the Glimpse runtime

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IGlimpseRuntime
public interface IGlimpseRuntime
See Also
IGlimpseRuntime Members
Glimpse.Core.Framework Namespace


IGlimpseRuntime Members

IGlimpseRuntime Members Glimpse API Documentation

The IGlimpseRuntime type exposes the following members.
Methods
 | Name | Description
Public method | BeginRequest | Begins the request.
Public method | BeginSessionAccess | Begins the session access.
Public method | EndRequest | Ends the request.
Public method | EndSessionAccess | Ends the session access.
Public method | ExecuteDefaultResource | Executes the default resource.
Public method | ExecuteResource | Executes the resource.
Public method | Initialize | Initializes this instance.
Back to Top
Properties
 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized.
Back to Top
See Also
IGlimpseRuntime Interface
Glimpse.Core.Framework Namespace


IGlimpseRuntime Methods

IGlimpseRuntime Methods Glimpse API Documentation
The IGlimpseRuntime type exposes the following members.
Methods
 | Name | Description
Public method | BeginRequest | Begins the request.
Public method | BeginSessionAccess | Begins the session access.
Public method | EndRequest | Ends the request.
Public method | EndSessionAccess | Ends the session access.
Public method | ExecuteDefaultResource | Executes the default resource.
Public method | ExecuteResource | Executes the resource.
Public method | Initialize | Initializes this instance.
Back to Top
See Also
IGlimpseRuntime Interface
Glimpse.Core.Framework Namespace


BeginRequest Method

IGlimpseRuntime BeginRequest Method Glimpse API Documentation
Begins the request.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void BeginRequest()
void BeginRequest()
Remarks

            Called when ever the implementing framework registers a request start. Specifically,
            with the ASP.NET provider, this is wired to the BeginRequest method.

See Also
IGlimpseRuntime Interface
IGlimpseRuntime Members
Glimpse.Core.Framework Namespace


BeginSessionAccess Method

IGlimpseRuntime BeginSessionAccess Method Glimpse API Documentation
Begins the session access.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void BeginSessionAccess()
void BeginSessionAccess()
Remarks

            Called when ever the implementing framework registers a clients session start. Code that is
            executed off this methods should have access to the session state store. Specifically,
            with the ASP.NET provider, this is wired to the PostAcquireRequestState method.

See Also
IGlimpseRuntime Interface
IGlimpseRuntime Members
Glimpse.Core.Framework Namespace


EndRequest Method

IGlimpseRuntime EndRequest Method Glimpse API Documentation
Ends the request.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void EndRequest()
void EndRequest()
Remarks

            Called when ever the implementing framework registers a request end. Specifically,
            with the ASP.NET provider, this is wired to the PostReleaseRequestState method.

See Also
IGlimpseRuntime Interface
IGlimpseRuntime Members
Glimpse.Core.Framework Namespace


EndSessionAccess Method

IGlimpseRuntime EndSessionAccess Method Glimpse API Documentation
Ends the session access.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void EndSessionAccess()
void EndSessionAccess()
Remarks

            Called when ever the implementing framework registers a clients session end. Code that is
            executed off this methods should still have access to the session state store. Specifically,
            with the ASP.NET provider, this is wired to the PostRequestHandlerExecute method.

See Also
IGlimpseRuntime Interface
IGlimpseRuntime Members
Glimpse.Core.Framework Namespace


ExecuteDefaultResource Method

IGlimpseRuntime ExecuteDefaultResource Method Glimpse API Documentation
Executes the default resource.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ExecuteDefaultResource()
void ExecuteDefaultResource()
Remarks

            Specifically, with the ASP.NET provider, this is wired to the
            ProcessRequest method.

See Also
IGlimpseRuntime Interface
IGlimpseRuntime Members
Glimpse.Core.Framework Namespace
Glimpse.Core.Extensibility IResourceResult
Glimpse.Core.Extensibility IResource


ExecuteResource Method

IGlimpseRuntime ExecuteResource Method Glimpse API Documentation
Executes the resource.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ExecuteResource(
    string resourceName,
    ResourceParameters parameters
)
void ExecuteResource(
    string resourceName,
    ResourceParameters parameters
)
Parameters
resourceName
Type:   Online System String
Name of the resource.
parameters
Type: Glimpse.Core.Framework ResourceParameters
The parameters.
Remarks

            Specifically, with the ASP.NET provider, this is wired to the
            ProcessRequest method.

See Also
IGlimpseRuntime Interface
IGlimpseRuntime Members
Glimpse.Core.Framework Namespace
Glimpse.Core.Extensibility IResourceResult
Glimpse.Core.Extensibility IResource


Initialize Method

IGlimpseRuntime Initialize Method Glimpse API Documentation
Initializes this instance.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Initialize()
bool Initialize()
Return Value
true if system initialized successfully, false otherwise
Remarks

            Typically used to wire up framework events to the corresponding runtime methods. Depending
            on framework implementation, this could be called multiple times per "application pool"
            recycle. Specifically, with the ASP.NET provider, this is wired to/implemented by the
            Init method.

See Also
IGlimpseRuntime Interface
IGlimpseRuntime Members
Glimpse.Core.Framework Namespace


IGlimpseRuntime Properties

IGlimpseRuntime Properties Glimpse API Documentation
The IGlimpseRuntime type exposes the following members.
Properties
 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized.
Back to Top
See Also
IGlimpseRuntime Interface
Glimpse.Core.Framework Namespace


IsInitialized Property

IGlimpseRuntime IsInitialized Property Glimpse API Documentation
Gets a value indicating whether this instance is initialized.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsInitialized { get; }
bool IsInitialized { get; }
Field Value
true if this instance is initialized; otherwise, false.
See Also
IGlimpseRuntime Interface
IGlimpseRuntime Members
Glimpse.Core.Framework Namespace


IPersistenceStore Interface

IPersistenceStore Interface Glimpse API Documentation
Defines methods to implement a store that Glimpse can use to persist requests.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPersistenceStore : IReadOnlyPersistenceStore
public interface IPersistenceStore : IReadOnlyPersistenceStore
See Also
IPersistenceStore Members
Glimpse.Core.Framework Namespace


IPersistenceStore Members

IPersistenceStore Members Glimpse API Documentation

The IPersistenceStore type exposes the following members.
Methods
 | Name | Description
Public method | GetByRequestId | Gets the by request id. (Inherited from IReadOnlyPersistenceStore.)
Public method | GetByRequestIdAndTabKey | Gets the by request id and tab key. (Inherited from IReadOnlyPersistenceStore.)
Public method | GetByRequestParentId | Gets the by request parent id. (Inherited from IReadOnlyPersistenceStore.)
Public method | GetMetadata | Gets the metadata. (Inherited from IReadOnlyPersistenceStore.)
Public method | GetTop | Gets the top. (Inherited from IReadOnlyPersistenceStore.)
Public method | Save(GlimpseMetadata) | Saves the specified system metadata.
Public method | Save(GlimpseRequest) | Saves the specified request.
Back to Top
See Also
IPersistenceStore Interface
Glimpse.Core.Framework Namespace


IPersistenceStore Methods

IPersistenceStore Methods Glimpse API Documentation
The IPersistenceStore type exposes the following members.
Methods
 | Name | Description
Public method | GetByRequestId | Gets the by request id. (Inherited from IReadOnlyPersistenceStore.)
Public method | GetByRequestIdAndTabKey | Gets the by request id and tab key. (Inherited from IReadOnlyPersistenceStore.)
Public method | GetByRequestParentId | Gets the by request parent id. (Inherited from IReadOnlyPersistenceStore.)
Public method | GetMetadata | Gets the metadata. (Inherited from IReadOnlyPersistenceStore.)
Public method | GetTop | Gets the top. (Inherited from IReadOnlyPersistenceStore.)
Public method | Save(GlimpseMetadata) | Saves the specified system metadata.
Public method | Save(GlimpseRequest) | Saves the specified request.
Back to Top
See Also
IPersistenceStore Interface
Glimpse.Core.Framework Namespace


Save Method

IPersistenceStore Save Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Save(GlimpseMetadata) | Saves the specified system metadata.
Public method | Save(GlimpseRequest) | Saves the specified request.
Back to Top
See Also
IPersistenceStore Interface
IPersistenceStore Members
Glimpse.Core.Framework Namespace


Save Method (GlimpseMetadata)

IPersistenceStore Save Method (GlimpseMetadata) Glimpse API Documentation
Saves the specified system metadata.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Save(
    GlimpseMetadata metadata
)
void Save(
    GlimpseMetadata metadata
)
Parameters
metadata
Type: Glimpse.Core.Framework GlimpseMetadata
The metadata.
See Also
IPersistenceStore Interface
IPersistenceStore Members
Save Overload
Glimpse.Core.Framework Namespace


Save Method (GlimpseRequest)

IPersistenceStore Save Method (GlimpseRequest) Glimpse API Documentation
Saves the specified request.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Save(
    GlimpseRequest request
)
void Save(
    GlimpseRequest request
)
Parameters
request
Type: Glimpse.Core.Framework GlimpseRequest
The request.
See Also
IPersistenceStore Interface
IPersistenceStore Members
Save Overload
Glimpse.Core.Framework Namespace


IReadOnlyPersistenceStore Interface

IReadOnlyPersistenceStore Interface Glimpse API Documentation
Defines methods to implement a read only store that Glimpse can use to retrieve requests and system metadata.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IReadOnlyPersistenceStore
public interface IReadOnlyPersistenceStore
See Also
IReadOnlyPersistenceStore Members
Glimpse.Core.Framework Namespace


IReadOnlyPersistenceStore Members

IReadOnlyPersistenceStore Members Glimpse API Documentation

The IReadOnlyPersistenceStore type exposes the following members.
Methods
 | Name | Description
Public method | GetByRequestId | Gets the by request id.
Public method | GetByRequestIdAndTabKey | Gets the by request id and tab key.
Public method | GetByRequestParentId | Gets the by request parent id.
Public method | GetMetadata | Gets the metadata.
Public method | GetTop | Gets the top.
Back to Top
See Also
IReadOnlyPersistenceStore Interface
Glimpse.Core.Framework Namespace


IReadOnlyPersistenceStore Methods

IReadOnlyPersistenceStore Methods Glimpse API Documentation
The IReadOnlyPersistenceStore type exposes the following members.
Methods
 | Name | Description
Public method | GetByRequestId | Gets the by request id.
Public method | GetByRequestIdAndTabKey | Gets the by request id and tab key.
Public method | GetByRequestParentId | Gets the by request parent id.
Public method | GetMetadata | Gets the metadata.
Public method | GetTop | Gets the top.
Back to Top
See Also
IReadOnlyPersistenceStore Interface
Glimpse.Core.Framework Namespace


GetByRequestId Method

IReadOnlyPersistenceStore GetByRequestId Method Glimpse API Documentation
Gets the by request id.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlimpseRequest GetByRequestId(
    Guid requestId
)
GlimpseRequest GetByRequestId(
    Guid requestId
)
Parameters
requestId
Type:   Online System Guid
The request id.
Return Value
Instance of the request that matches the request id.
See Also
IReadOnlyPersistenceStore Interface
IReadOnlyPersistenceStore Members
Glimpse.Core.Framework Namespace


GetByRequestIdAndTabKey Method

IReadOnlyPersistenceStore GetByRequestIdAndTabKey Method Glimpse API Documentation
Gets the by request id and tab key.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TabResult GetByRequestIdAndTabKey(
    Guid requestId,
    string tabKey
)
TabResult GetByRequestIdAndTabKey(
    Guid requestId,
    string tabKey
)
Parameters
requestId
Type:   Online System Guid
The request id.
tabKey
Type:   Online System String
The tab key.
Return Value
Instance of the tab data that matches the request id and tab key.
See Also
IReadOnlyPersistenceStore Interface
IReadOnlyPersistenceStore Members
Glimpse.Core.Framework Namespace


GetByRequestParentId Method

IReadOnlyPersistenceStore GetByRequestParentId Method Glimpse API Documentation
Gets the by request parent id.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<GlimpseRequest> GetByRequestParentId(
    Guid parentRequestId
)
IEnumerable<GlimpseRequest> GetByRequestParentId(
    Guid parentRequestId
)
Parameters
parentRequestId
Type:   Online System Guid
The parent request id.
Return Value
Collection of requests that matches the parent request id.
See Also
IReadOnlyPersistenceStore Interface
IReadOnlyPersistenceStore Members
Glimpse.Core.Framework Namespace


GetMetadata Method

IReadOnlyPersistenceStore GetMetadata Method Glimpse API Documentation
Gets the metadata.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlimpseMetadata GetMetadata()
GlimpseMetadata GetMetadata()
Return Value
Metadata that is currently applied.
See Also
IReadOnlyPersistenceStore Interface
IReadOnlyPersistenceStore Members
Glimpse.Core.Framework Namespace


GetTop Method

IReadOnlyPersistenceStore GetTop Method Glimpse API Documentation
Gets the top.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<GlimpseRequest> GetTop(
    int count
)
IEnumerable<GlimpseRequest> GetTop(
    int count
)
Parameters
count
Type:   Online System Int32
The count.
Return Value
Collection of requests that represent the top x number of requests.
See Also
IReadOnlyPersistenceStore Interface
IReadOnlyPersistenceStore Members
Glimpse.Core.Framework Namespace


IRequestMetadata Interface

IRequestMetadata Interface Glimpse API Documentation
Defines properties that describe the metadata associated with a request

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IRequestMetadata
public interface IRequestMetadata
See Also
IRequestMetadata Members
Glimpse.Core.Framework Namespace


IRequestMetadata Members

IRequestMetadata Members Glimpse API Documentation

The IRequestMetadata type exposes the following members.
Methods
 | Name | Description
Public method | GetCookie | Gets the cookie.
Public method | GetHttpHeader | Gets the HTTP header.
Back to Top
Properties
 | Name | Description
Public property | ClientId | Gets the client id.
Public property | IpAddress | Gets the IP address.
Public property | RequestHttpMethod | Gets the request HTTP method.
Public property | RequestIsAjax | Gets a value indicating whether request is ajax.
Public property | RequestUri | Gets the request URI.
Public property | ResponseContentType | Gets the type of the response content.
Public property | ResponseStatusCode | Gets the response status code.
Back to Top
See Also
IRequestMetadata Interface
Glimpse.Core.Framework Namespace


IRequestMetadata Methods

IRequestMetadata Methods Glimpse API Documentation
The IRequestMetadata type exposes the following members.
Methods
 | Name | Description
Public method | GetCookie | Gets the cookie.
Public method | GetHttpHeader | Gets the HTTP header.
Back to Top
See Also
IRequestMetadata Interface
Glimpse.Core.Framework Namespace


GetCookie Method

IRequestMetadata GetCookie Method Glimpse API Documentation
Gets the cookie.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string GetCookie(
    string name
)
string GetCookie(
    string name
)
Parameters
name
Type:   Online System String
The name.
Return Value
Value of the Http cookie.
See Also
IRequestMetadata Interface
IRequestMetadata Members
Glimpse.Core.Framework Namespace


GetHttpHeader Method

IRequestMetadata GetHttpHeader Method Glimpse API Documentation
Gets the HTTP header.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string GetHttpHeader(
    string name
)
string GetHttpHeader(
    string name
)
Parameters
name
Type:   Online System String
The name.
Return Value
Value of the Http header.
See Also
IRequestMetadata Interface
IRequestMetadata Members
Glimpse.Core.Framework Namespace


IRequestMetadata Properties

IRequestMetadata Properties Glimpse API Documentation
The IRequestMetadata type exposes the following members.
Properties
 | Name | Description
Public property | ClientId | Gets the client id.
Public property | IpAddress | Gets the IP address.
Public property | RequestHttpMethod | Gets the request HTTP method.
Public property | RequestIsAjax | Gets a value indicating whether request is ajax.
Public property | RequestUri | Gets the request URI.
Public property | ResponseContentType | Gets the type of the response content.
Public property | ResponseStatusCode | Gets the response status code.
Back to Top
See Also
IRequestMetadata Interface
Glimpse.Core.Framework Namespace


ClientId Property

IRequestMetadata ClientId Property Glimpse API Documentation
Gets the client id.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string ClientId { get; }
string ClientId { get; }
Field Value
The client id.
See Also
IRequestMetadata Interface
IRequestMetadata Members
Glimpse.Core.Framework Namespace


IpAddress Property

IRequestMetadata IpAddress Property Glimpse API Documentation
Gets the IP address.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string IpAddress { get; }
string IpAddress { get; }
Field Value
The IP address.
See Also
IRequestMetadata Interface
IRequestMetadata Members
Glimpse.Core.Framework Namespace


RequestHttpMethod Property

IRequestMetadata RequestHttpMethod Property Glimpse API Documentation
Gets the request HTTP method.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string RequestHttpMethod { get; }
string RequestHttpMethod { get; }
Field Value
The request HTTP method.
See Also
IRequestMetadata Interface
IRequestMetadata Members
Glimpse.Core.Framework Namespace


RequestIsAjax Property

IRequestMetadata RequestIsAjax Property Glimpse API Documentation
Gets a value indicating whether request is ajax.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool RequestIsAjax { get; }
bool RequestIsAjax { get; }
Field Value
true if request is ajax; otherwise, false.
See Also
IRequestMetadata Interface
IRequestMetadata Members
Glimpse.Core.Framework Namespace


RequestUri Property

IRequestMetadata RequestUri Property Glimpse API Documentation
Gets the request URI.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string RequestUri { get; }
string RequestUri { get; }
Field Value
The request URI.
See Also
IRequestMetadata Interface
IRequestMetadata Members
Glimpse.Core.Framework Namespace


ResponseContentType Property

IRequestMetadata ResponseContentType Property Glimpse API Documentation
Gets the type of the response content.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string ResponseContentType { get; }
string ResponseContentType { get; }
Field Value
The type of the response content.
See Also
IRequestMetadata Interface
IRequestMetadata Members
Glimpse.Core.Framework Namespace


ResponseStatusCode Property

IRequestMetadata ResponseStatusCode Property Glimpse API Documentation
Gets the response status code.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int ResponseStatusCode { get; }
int ResponseStatusCode { get; }
Field Value
The response status code.
See Also
IRequestMetadata Interface
IRequestMetadata Members
Glimpse.Core.Framework Namespace


IServiceLocator Interface

IServiceLocator Interface Glimpse API Documentation
Defines methods to implement a service locator

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IServiceLocator
public interface IServiceLocator
Remarks

            Means by which authors can provide alternative implementations to the
            default ones which the system will use by default. Primary extension injection
            mechanism.

See Also
IServiceLocator Members
Glimpse.Core.Framework Namespace


IServiceLocator Members

IServiceLocator Members Glimpse API Documentation

The IServiceLocator type exposes the following members.
Methods
 | Name | Description
Public method | GetAllInstances T | Gets all instances.
Public method | GetInstance T | Gets the instance.
Back to Top
See Also
IServiceLocator Interface
Glimpse.Core.Framework Namespace


IServiceLocator Methods

IServiceLocator Methods Glimpse API Documentation
The IServiceLocator type exposes the following members.
Methods
 | Name | Description
Public method | GetAllInstances T | Gets all instances.
Public method | GetInstance T | Gets the instance.
Back to Top
See Also
IServiceLocator Interface
Glimpse.Core.Framework Namespace


GetAllInstances(T) Method

IServiceLocator GetAllInstances T Method Glimpse API Documentation
Gets all instances.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ICollection<T> GetAllInstances<T>()
where T : class
ICollection<T> GetAllInstances<T>()
where T : class
Type Parameters
T
The type to be resolved and a collection of returned.
Return Value
The instance that matches are the input Type.
See Also
IServiceLocator Interface
IServiceLocator Members
Glimpse.Core.Framework Namespace


GetInstance(T) Method

IServiceLocator GetInstance T Method Glimpse API Documentation
Gets the instance.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T GetInstance<T>()
where T : class
T GetInstance<T>()
where T : class
Type Parameters
T
The type to be resolved and returned.
Return Value
The instance that matches are the input Type.
See Also
IServiceLocator Interface
IServiceLocator Members
Glimpse.Core.Framework Namespace


ReflectionDiscoverableCollection(T) Class

ReflectionDiscoverableCollection T Class Glimpse API Documentation
An implementation of IDiscoverableCollection T which uses .NET reflection to find and load types.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Framework ReflectionDiscoverableCollection T

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ReflectionDiscoverableCollection<T> : IDiscoverableCollection<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable
public class ReflectionDiscoverableCollection<T> : IDiscoverableCollection<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable
Type Parameters
T
The type to find and load.
See Also
ReflectionDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


ReflectionDiscoverableCollection(T) Members

ReflectionDiscoverableCollection T Members Glimpse API Documentation

The ReflectionDiscoverableCollection T type exposes the following members.
Constructors
 | Name | Description
Public method | ReflectionDiscoverableCollection T | Initializes a new instance of the ReflectionDiscoverableCollection T class.
Back to Top
Methods
 | Name | Description
Public method | Add | Adds the specified item.
Public method | Clear | Clears this instance.
Public method | Contains | Determines whether the collection contains the specified item.
Public method | CopyTo | Copies to.
Public method | Discover | Discovers this all instanced of T within the discovery location.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | Gets the enumerator.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IgnoreType | Ignores the type.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove | Removes the specified item.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AutoDiscover | Gets or sets a value indicating whether or not auto discover.
Public property | Count | Gets the number of elements contained in the Online ICollection T .
Public property | DiscoveryLocation | Gets or sets the file path to the discovery location.
Public property | IsReadOnly | Gets a value indicating whether the Online ICollection T is read-only.
Back to Top
See Also
ReflectionDiscoverableCollection T Class
Glimpse.Core.Framework Namespace


ReflectionDiscoverableCollection(T) Constructor

ReflectionDiscoverableCollection T Constructor Glimpse API Documentation
Initializes a new instance of the ReflectionDiscoverableCollection T class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReflectionDiscoverableCollection(
    ILogger logger
)
public ReflectionDiscoverableCollection(
    ILogger logger
)
Parameters
logger
Type: Glimpse.Core.Extensibility ILogger
The logger.
See Also
ReflectionDiscoverableCollection T  Class
ReflectionDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


ReflectionDiscoverableCollection(T) Methods

ReflectionDiscoverableCollection T Methods Glimpse API Documentation
The ReflectionDiscoverableCollection T type exposes the following members.
Methods
 | Name | Description
Public method | Add | Adds the specified item.
Public method | Clear | Clears this instance.
Public method | Contains | Determines whether the collection contains the specified item.
Public method | CopyTo | Copies to.
Public method | Discover | Discovers this all instanced of T within the discovery location.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | Gets the enumerator.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IgnoreType | Ignores the type.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove | Removes the specified item.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ReflectionDiscoverableCollection T Class
Glimpse.Core.Framework Namespace


Add Method

ReflectionDiscoverableCollection T Add Method Glimpse API Documentation
Adds the specified item.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    T item
)
public void Add(
    T item
)
Parameters
item
Type: T
The item.
Implements
  Online ICollection T  Add(T)
See Also
ReflectionDiscoverableCollection T  Class
ReflectionDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


Clear Method

ReflectionDiscoverableCollection T Clear Method Glimpse API Documentation
Clears this instance.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Implements
  Online ICollection T  Clear
See Also
ReflectionDiscoverableCollection T  Class
ReflectionDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


Contains Method

ReflectionDiscoverableCollection T Contains Method Glimpse API Documentation
Determines whether the collection contains the specified item.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Contains(
    T item
)
public bool Contains(
    T item
)
Parameters
item
Type: T
The item.
Return Value
true if the collection contains the specified item; otherwise, false.

Implements
  Online ICollection T  Contains(T)
See Also
ReflectionDiscoverableCollection T  Class
ReflectionDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


CopyTo Method

ReflectionDiscoverableCollection T CopyTo Method Glimpse API Documentation
Copies to.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CopyTo(
    T[] array,
    int arrayIndex
)
public void CopyTo(
    T[] array,
    int arrayIndex
)
Parameters
array
Type:  T
The array.
arrayIndex
Type:   Online System Int32
Index of the array.
Implements
  Online ICollection T  CopyTo( T , Int32)
See Also
ReflectionDiscoverableCollection T  Class
ReflectionDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


Discover Method

ReflectionDiscoverableCollection T Discover Method Glimpse API Documentation
Discovers this all instanced of T within the discovery location.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Discover()
public void Discover()
Implements
IDiscoverableCollection T  Discover
See Also
ReflectionDiscoverableCollection T  Class
ReflectionDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


GetEnumerator Method

ReflectionDiscoverableCollection T GetEnumerator Method Glimpse API Documentation
Gets the enumerator.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<T> GetEnumerator()
public IEnumerator<T> GetEnumerator()
Return Value
The enumerator.
Implements
  Online IEnumerable T  GetEnumerator
See Also
ReflectionDiscoverableCollection T  Class
ReflectionDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


IgnoreType Method

ReflectionDiscoverableCollection T IgnoreType Method Glimpse API Documentation
Ignores the type.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void IgnoreType(
    Type type
)
public void IgnoreType(
    Type type
)
Parameters
type
Type:   Online System Type
The type.
Implements
IDiscoverableCollection T  IgnoreType(Type)
See Also
ReflectionDiscoverableCollection T  Class
ReflectionDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


Remove Method

ReflectionDiscoverableCollection T Remove Method Glimpse API Documentation
Removes the specified item.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Remove(
    T item
)
public bool Remove(
    T item
)
Parameters
item
Type: T
The item.
Return Value
true is the item was removed.
Implements
  Online ICollection T  Remove(T)
See Also
ReflectionDiscoverableCollection T  Class
ReflectionDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


ReflectionDiscoverableCollection(T) Properties

ReflectionDiscoverableCollection T Properties Glimpse API Documentation
The ReflectionDiscoverableCollection T type exposes the following members.
Properties
 | Name | Description
Public property | AutoDiscover | Gets or sets a value indicating whether or not auto discover.
Public property | Count | Gets the number of elements contained in the Online ICollection T .
Public property | DiscoveryLocation | Gets or sets the file path to the discovery location.
Public property | IsReadOnly | Gets a value indicating whether the Online ICollection T is read-only.
Back to Top
See Also
ReflectionDiscoverableCollection T Class
Glimpse.Core.Framework Namespace


AutoDiscover Property

ReflectionDiscoverableCollection T AutoDiscover Property Glimpse API Documentation
Gets or sets a value indicating whether or not auto discover.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AutoDiscover { get; set; }
public bool AutoDiscover { get; set; }
Field Value
true if [auto discover]; otherwise, false.

Implements
IDiscoverableCollection T  AutoDiscover
See Also
ReflectionDiscoverableCollection T  Class
ReflectionDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


Count Property

ReflectionDiscoverableCollection T Count Property Glimpse API Documentation
Gets the number of elements contained in the Online ICollection T .

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Return Value
The number of elements contained in the   Online ICollection T .
Implements
  Online ICollection T  Count
See Also
ReflectionDiscoverableCollection T  Class
ReflectionDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


DiscoveryLocation Property

ReflectionDiscoverableCollection T DiscoveryLocation Property Glimpse API Documentation
Gets or sets the file path to the discovery location.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DiscoveryLocation { get; set; }
public string DiscoveryLocation { get; set; }
Field Value

            The discovery location.

Implements
IDiscoverableCollection T  DiscoveryLocation
Exceptions
Exception | Condition
Online System.IO DirectoryNotFoundException | Throws an exception if the directory does not exist.
See Also
ReflectionDiscoverableCollection T  Class
ReflectionDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


IsReadOnly Property

ReflectionDiscoverableCollection T IsReadOnly Property Glimpse API Documentation
Gets a value indicating whether the Online ICollection T is read-only.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsReadOnly { get; }
public bool IsReadOnly { get; }
Return Value
true if the   Online ICollection T  is read-only; otherwise, false.
Implements
  Online ICollection T  IsReadOnly
See Also
ReflectionDiscoverableCollection T  Class
ReflectionDiscoverableCollection T  Members
Glimpse.Core.Framework Namespace


ResourceEndpointConfiguration Class

ResourceEndpointConfiguration Class Glimpse API Documentation
Defines methods to implement a resource endpoint configuration.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Framework ResourceEndpointConfiguration

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class ResourceEndpointConfiguration
public abstract class ResourceEndpointConfiguration
See Also
ResourceEndpointConfiguration Members
Glimpse.Core.Framework Namespace


ResourceEndpointConfiguration Members

ResourceEndpointConfiguration Members Glimpse API Documentation

The ResourceEndpointConfiguration type exposes the following members.
Constructors
 | Name | Description
Protected method | ResourceEndpointConfiguration | Initializes a new instance of the ResourceEndpointConfiguration class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GenerateUriTemplate(IResource, String, ILogger) | Generates the URI template.
Protected method | GenerateUriTemplate(String, String, IEnumerable ResourceParameterMetadata , ILogger) | Generates the URI template.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ResourceEndpointConfiguration Class
Glimpse.Core.Framework Namespace


ResourceEndpointConfiguration Constructor

ResourceEndpointConfiguration Constructor Glimpse API Documentation
Initializes a new instance of the ResourceEndpointConfiguration class

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ResourceEndpointConfiguration()
protected ResourceEndpointConfiguration()
See Also
ResourceEndpointConfiguration Class
ResourceEndpointConfiguration Members
Glimpse.Core.Framework Namespace


ResourceEndpointConfiguration Methods

ResourceEndpointConfiguration Methods Glimpse API Documentation
The ResourceEndpointConfiguration type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GenerateUriTemplate(IResource, String, ILogger) | Generates the URI template.
Protected method | GenerateUriTemplate(String, String, IEnumerable ResourceParameterMetadata , ILogger) | Generates the URI template.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ResourceEndpointConfiguration Class
Glimpse.Core.Framework Namespace


GenerateUriTemplate Method

ResourceEndpointConfiguration GenerateUriTemplate Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | GenerateUriTemplate(IResource, String, ILogger) | Generates the URI template.
Protected method | GenerateUriTemplate(String, String, IEnumerable ResourceParameterMetadata , ILogger) | Generates the URI template.
Back to Top
See Also
ResourceEndpointConfiguration Class
ResourceEndpointConfiguration Members
Glimpse.Core.Framework Namespace


GenerateUriTemplate Method (IResource, String, ILogger)

ResourceEndpointConfiguration GenerateUriTemplate Method (IResource, String, ILogger) Glimpse API Documentation
Generates the URI template.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GenerateUriTemplate(
    IResource resource,
    string baseUri,
    ILogger logger
)
public string GenerateUriTemplate(
    IResource resource,
    string baseUri,
    ILogger logger
)
Parameters
resource
Type: Glimpse.Core.Extensibility IResource
The resource.
baseUri
Type:   Online System String
The base URI.
logger
Type: Glimpse.Core.Extensibility ILogger
The logger.
Return Value
A Uri template a client can expand to invoke a resource.
Exceptions
Exception | Condition
Online System ArgumentNullException | Throws and exception if resource or logger is null.
See Also
ResourceEndpointConfiguration Class
ResourceEndpointConfiguration Members
GenerateUriTemplate Overload
Glimpse.Core.Framework Namespace


GenerateUriTemplate Method (String, String, IEnumerable(ResourceParameterMetadata), ILogger)

ResourceEndpointConfiguration GenerateUriTemplate Method (String, String, IEnumerable ResourceParameterMetadata , ILogger) Glimpse API Documentation
Generates the URI template.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract string GenerateUriTemplate(
    string resourceName,
    string baseUri,
    IEnumerable<ResourceParameterMetadata> parameters,
    ILogger logger
)
protected abstract string GenerateUriTemplate(
    string resourceName,
    string baseUri,
    IEnumerable<ResourceParameterMetadata> parameters,
    ILogger logger
)
Parameters
resourceName
Type:   Online System String
Name of the resource.
baseUri
Type:   Online System String
The base URI.
parameters
Type:   Online System.Collections.Generic IEnumerable  ResourceParameterMetadata
The parameters.
logger
Type: Glimpse.Core.Extensibility ILogger
The logger.
Return Value
A Uri template a client can expand to invoke a resource.
See Also
ResourceEndpointConfiguration Class
ResourceEndpointConfiguration Members
GenerateUriTemplate Overload
Glimpse.Core.Framework Namespace


ResourceParameters Class

ResourceParameters Class Glimpse API Documentation
A class which contains all the parameters, whether named or ordered, needed to execute a resource.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Framework ResourceParameters

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ResourceParameters
public class ResourceParameters
See Also
ResourceParameters Members
Glimpse.Core.Framework Namespace


ResourceParameters Members

ResourceParameters Members Glimpse API Documentation

The ResourceParameters type exposes the following members.
Constructors
 | Name | Description
Public method | ResourceParameters(IDictionary String, String ) | Initializes a new instance of the ResourceParameters class with a set of named parameters.
Public method | ResourceParameters( String ) | Initializes a new instance of the ResourceParameters class with a set of ordered parameters.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetParametersFor | Gets the parameters for a given IResource.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | None | Creates an instance of ResourceParameter which contains no parameter values.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ResourceParameters Class
Glimpse.Core.Framework Namespace


ResourceParameters Constructor

ResourceParameters Constructor Glimpse API Documentation
Overload List
 | Name | Description
Public method | ResourceParameters(IDictionary String, String ) | Initializes a new instance of the ResourceParameters class with a set of named parameters.
Public method | ResourceParameters( String ) | Initializes a new instance of the ResourceParameters class with a set of ordered parameters.
Back to Top
See Also
ResourceParameters Class
ResourceParameters Members
Glimpse.Core.Framework Namespace


ResourceParameters Constructor (IDictionary(String, String))

ResourceParameters Constructor (IDictionary String, String ) Glimpse API Documentation
Initializes a new instance of the ResourceParameters class with a set of named parameters.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResourceParameters(
    IDictionary<string, string> namedParameters
)
public ResourceParameters(
    IDictionary<string, string> namedParameters
)
Parameters
namedParameters
Type:   Online System.Collections.Generic IDictionary    Online String,   Online String
The named parameters.
See Also
ResourceParameters Class
ResourceParameters Members
ResourceParameters Overload
Glimpse.Core.Framework Namespace


ResourceParameters Constructor (String[])

ResourceParameters Constructor ( String ) Glimpse API Documentation
Initializes a new instance of the ResourceParameters class with a set of ordered parameters.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResourceParameters(
    string[] orderedParameters
)
public ResourceParameters(
    string[] orderedParameters
)
Parameters
orderedParameters
Type:    Online System String
The ordered parameters.
See Also
ResourceParameters Class
ResourceParameters Members
ResourceParameters Overload
Glimpse.Core.Framework Namespace


ResourceParameters Methods

ResourceParameters Methods Glimpse API Documentation
The ResourceParameters type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetParametersFor | Gets the parameters for a given IResource.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | None | Creates an instance of ResourceParameter which contains no parameter values.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ResourceParameters Class
Glimpse.Core.Framework Namespace


GetParametersFor Method

ResourceParameters GetParametersFor Method Glimpse API Documentation
Gets the parameters for a given IResource.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, string> GetParametersFor(
    IResource resource
)
public IDictionary<string, string> GetParametersFor(
    IResource resource
)
Parameters
resource
Type: Glimpse.Core.Extensibility IResource
The resource.
Return Value
The parameters for a given resource.
See Also
ResourceParameters Class
ResourceParameters Members
Glimpse.Core.Framework Namespace


None Method

ResourceParameters None Method Glimpse API Documentation
Creates an instance of ResourceParameter which contains no parameter values.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ResourceParameters None()
public static ResourceParameters None()
Return Value
An implementation of the null object pattern for ResourceParameter.
See Also
ResourceParameters Class
ResourceParameters Members
Glimpse.Core.Framework Namespace


TabMetadata Class

TabMetadata Class Glimpse API Documentation
Contains any metadata associated with a given tab.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Framework TabMetadata

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TabMetadata
public class TabMetadata
See Also
TabMetadata Members
Glimpse.Core.Framework Namespace


TabMetadata Members

TabMetadata Members Glimpse API Documentation

The TabMetadata type exposes the following members.
Constructors
 | Name | Description
Public method | TabMetadata | Initializes a new instance of the TabMetadata class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | DocumentationUri | Gets or sets the documentation Uri.
Public property | HasMetadata | Gets a value indicating whether this instance has metadata.
Public property | Layout | Gets or sets the layout override instructions.
Back to Top
See Also
TabMetadata Class
Glimpse.Core.Framework Namespace


TabMetadata Constructor

TabMetadata Constructor Glimpse API Documentation
Initializes a new instance of the TabMetadata class

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TabMetadata()
public TabMetadata()
See Also
TabMetadata Class
TabMetadata Members
Glimpse.Core.Framework Namespace


TabMetadata Methods

TabMetadata Methods Glimpse API Documentation
The TabMetadata type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TabMetadata Class
Glimpse.Core.Framework Namespace


TabMetadata Properties

TabMetadata Properties Glimpse API Documentation
The TabMetadata type exposes the following members.
Properties
 | Name | Description
Public property | DocumentationUri | Gets or sets the documentation Uri.
Public property | HasMetadata | Gets a value indicating whether this instance has metadata.
Public property | Layout | Gets or sets the layout override instructions.
Back to Top
See Also
TabMetadata Class
Glimpse.Core.Framework Namespace


DocumentationUri Property

TabMetadata DocumentationUri Property Glimpse API Documentation
Gets or sets the documentation Uri.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DocumentationUri { get; set; }
public string DocumentationUri { get; set; }
Field Value

            The documentation URI.

See Also
TabMetadata Class
TabMetadata Members
Glimpse.Core.Framework Namespace


HasMetadata Property

TabMetadata HasMetadata Property Glimpse API Documentation
Gets a value indicating whether this instance has metadata.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasMetadata { get; }
public bool HasMetadata { get; }
Field Value
true if this instance has metadata; otherwise, false.

See Also
TabMetadata Class
TabMetadata Members
Glimpse.Core.Framework Namespace


Layout Property

TabMetadata Layout Property Glimpse API Documentation
Gets or sets the layout override instructions.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Layout { get; set; }
public Object Layout { get; set; }
Field Value

            The layout.

See Also
TabMetadata Class
TabMetadata Members
Glimpse.Core.Framework Namespace


TabResult Class

TabResult Class Glimpse API Documentation
Contains the results of executing an ITab, along with its key.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Framework TabResult

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TabResult
public class TabResult
See Also
TabResult Members
Glimpse.Core.Framework Namespace


TabResult Members

TabResult Members Glimpse API Documentation

The TabResult type exposes the following members.
Constructors
 | Name | Description
Public method | TabResult | Initializes a new instance of the TabResult class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Data | Gets or sets the data.
Public property | Name | Gets or sets the name.
Back to Top
See Also
TabResult Class
Glimpse.Core.Framework Namespace


TabResult Constructor

TabResult Constructor Glimpse API Documentation
Initializes a new instance of the TabResult class.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TabResult(
    string name,
    Object data
)
public TabResult(
    string name,
    Object data
)
Parameters
name
Type:   Online System String
The name.
data
Type:   Online System Object
The data.
See Also
TabResult Class
TabResult Members
Glimpse.Core.Framework Namespace


TabResult Methods

TabResult Methods Glimpse API Documentation
The TabResult type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TabResult Class
Glimpse.Core.Framework Namespace


TabResult Properties

TabResult Properties Glimpse API Documentation
The TabResult type exposes the following members.
Properties
 | Name | Description
Public property | Data | Gets or sets the data.
Public property | Name | Gets or sets the name.
Back to Top
See Also
TabResult Class
Glimpse.Core.Framework Namespace


Data Property

TabResult Data Property Glimpse API Documentation
Gets or sets the data.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Data { get; set; }
public Object Data { get; set; }
Field Value

            The data.

Remarks
The Data property will be serialized by the Glimpse runtime, as such, objects stored in Data should be serializable.
See Also
TabResult Class
TabResult Members
Glimpse.Core.Framework Namespace


Name Property

TabResult Name Property Glimpse API Documentation
Gets or sets the name.

Namespace: Glimpse.Core.Framework
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Field Value

            The name.

See Also
TabResult Class
TabResult Members
Glimpse.Core.Framework Namespace


Glimpse.Core.Inspector Namespace

Glimpse.Core.Inspector Namespace Glimpse API Documentation
All types for gathering runtime diagnostics information with Glimpse are defined within this namespace.
Classes
 | Class | Description
Public class | TraceInspector | The implementation of IInspector for capturing System.Diagnostics.Trace messages.


TraceInspector Class

TraceInspector Class Glimpse API Documentation
The implementation of IInspector for capturing System.Diagnostics.Trace messages.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Inspector TraceInspector

Namespace: Glimpse.Core.Inspector
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TraceInspector : IInspector
public class TraceInspector : IInspector
See Also
TraceInspector Members
Glimpse.Core.Inspector Namespace


TraceInspector Members

TraceInspector Members Glimpse API Documentation

The TraceInspector type exposes the following members.
Constructors
 | Name | Description
Public method | TraceInspector | Initializes a new instance of the TraceInspector class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Setup | Setups the specified context.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TraceInspector Class
Glimpse.Core.Inspector Namespace


TraceInspector Constructor

TraceInspector Constructor Glimpse API Documentation
Initializes a new instance of the TraceInspector class

Namespace: Glimpse.Core.Inspector
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TraceInspector()
public TraceInspector()
See Also
TraceInspector Class
TraceInspector Members
Glimpse.Core.Inspector Namespace


TraceInspector Methods

TraceInspector Methods Glimpse API Documentation
The TraceInspector type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Setup | Setups the specified context.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TraceInspector Class
Glimpse.Core.Inspector Namespace


Setup Method

TraceInspector Setup Method Glimpse API Documentation
Setups the specified context.

Namespace: Glimpse.Core.Inspector
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Setup(
    IInspectorContext context
)
public void Setup(
    IInspectorContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IInspectorContext
The context.
Implements
IInspector Setup(IInspectorContext)
Remarks

            Executed during the Initialize  phase of
            system startup. Specifically, with the ASP.NET provider, this is wired to/implemented by the
            System.Web.IHttpModule.Init method.

See Also
TraceInspector Class
TraceInspector Members
Glimpse.Core.Inspector Namespace


Glimpse.Core.Message Namespace

Glimpse.Core.Message Namespace Glimpse API Documentation
All messages for use with the Glimpse message broker are defined within this namespace.
Classes
 | Class | Description
Public class | MessageBase |
Public class | SourceMessageExtension | Extension methods for populating ISourceMessage instances.
Public class | TimedMessageExtension | Extension methods for populating ITimedMessage instances.
Public class | TimelineCategory | Definition for a timeline category.
Public class | TimelineMessage | Options that can used for timeline events.
Public class | TimelineMessageExtension |
Public class | TraceMessage |
Interfaces
 | Interface | Description
Public interface | IMessage | The definition of a simple message, which contains unique Id.
Public interface | ISourceMessage | The definition of a message which is published from a proxy implementation.
Public interface | ITimedMessage | The definition of a message which is published with execution timing information.
Public interface | ITimelineMessage |
Public interface | ITraceMessage |


IMessage Interface

IMessage Interface Glimpse API Documentation
The definition of a simple message, which contains unique Id.

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IMessage
public interface IMessage
See Also
IMessage Members
Glimpse.Core.Message Namespace


IMessage Members

IMessage Members Glimpse API Documentation

The IMessage type exposes the following members.
Properties
 | Name | Description
Public property | Id | Gets the id.
Back to Top
See Also
IMessage Interface
Glimpse.Core.Message Namespace


IMessage Properties

IMessage Properties Glimpse API Documentation
The IMessage type exposes the following members.
Properties
 | Name | Description
Public property | Id | Gets the id.
Back to Top
See Also
IMessage Interface
Glimpse.Core.Message Namespace


Id Property

IMessage Id Property Glimpse API Documentation
Gets the id.

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Guid Id { get; }
Guid Id { get; }
Field Value

            The id.

See Also
IMessage Interface
IMessage Members
Glimpse.Core.Message Namespace


ISourceMessage Interface

ISourceMessage Interface Glimpse API Documentation
The definition of a message which is published from a proxy implementation.

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ISourceMessage
public interface ISourceMessage
See Also
ISourceMessage Members
Glimpse.Core.Message Namespace


ISourceMessage Members

ISourceMessage Members Glimpse API Documentation

The ISourceMessage type exposes the following members.
Properties
 | Name | Description
Public property | ExecutedMethod | Gets or sets the original executed method.
Public property | ExecutedType | Gets or sets the type of the original executed object.
Back to Top
See Also
ISourceMessage Interface
Glimpse.Core.Message Namespace


ISourceMessage Properties

ISourceMessage Properties Glimpse API Documentation
The ISourceMessage type exposes the following members.
Properties
 | Name | Description
Public property | ExecutedMethod | Gets or sets the original executed method.
Public property | ExecutedType | Gets or sets the type of the original executed object.
Back to Top
See Also
ISourceMessage Interface
Glimpse.Core.Message Namespace


ExecutedMethod Property

ISourceMessage ExecutedMethod Property Glimpse API Documentation
Gets or sets the original executed method.

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
MethodInfo ExecutedMethod { get; set; }
MethodInfo ExecutedMethod { get; set; }
Field Value

            The executed method.

See Also
ISourceMessage Interface
ISourceMessage Members
Glimpse.Core.Message Namespace


ExecutedType Property

ISourceMessage ExecutedType Property Glimpse API Documentation
Gets or sets the type of the original executed object.

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Type ExecutedType { get; set; }
Type ExecutedType { get; set; }
Field Value

            The type of the executed.

See Also
ISourceMessage Interface
ISourceMessage Members
Glimpse.Core.Message Namespace


ITimedMessage Interface

ITimedMessage Interface Glimpse API Documentation
The definition of a message which is published with execution timing information.

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITimedMessage : IMessage
public interface ITimedMessage : IMessage
See Also
ITimedMessage Members
Glimpse.Core.Message Namespace


ITimedMessage Members

ITimedMessage Members Glimpse API Documentation

The ITimedMessage type exposes the following members.
Properties
 | Name | Description
Public property | Duration | Gets or sets the duration of the executed method.
Public property | Id | Gets the id. (Inherited from IMessage.)
Public property | Offset | Gets or sets the offset from the Http request start.
Public property | StartTime | Gets or sets the start time.
Back to Top
See Also
ITimedMessage Interface
Glimpse.Core.Message Namespace


ITimedMessage Properties

ITimedMessage Properties Glimpse API Documentation
The ITimedMessage type exposes the following members.
Properties
 | Name | Description
Public property | Duration | Gets or sets the duration of the executed method.
Public property | Id | Gets the id. (Inherited from IMessage.)
Public property | Offset | Gets or sets the offset from the Http request start.
Public property | StartTime | Gets or sets the start time.
Back to Top
See Also
ITimedMessage Interface
Glimpse.Core.Message Namespace


Duration Property

ITimedMessage Duration Property Glimpse API Documentation
Gets or sets the duration of the executed method.

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TimeSpan Duration { get; set; }
TimeSpan Duration { get; set; }
Field Value

            The duration.

See Also
ITimedMessage Interface
ITimedMessage Members
Glimpse.Core.Message Namespace


Offset Property

ITimedMessage Offset Property Glimpse API Documentation
Gets or sets the offset from the Http request start.

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TimeSpan Offset { get; set; }
TimeSpan Offset { get; set; }
Field Value

            The offset.

See Also
ITimedMessage Interface
ITimedMessage Members
Glimpse.Core.Message Namespace


StartTime Property

ITimedMessage StartTime Property Glimpse API Documentation
Gets or sets the start time.

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
DateTime StartTime { get; set; }
DateTime StartTime { get; set; }
Field Value

            The start time.

See Also
ITimedMessage Interface
ITimedMessage Members
Glimpse.Core.Message Namespace


ITimelineMessage Interface

ITimelineMessage Interface Glimpse API Documentation

[Missing <summary> documentation for "T:Glimpse.Core.Message.ITimelineMessage"]

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITimelineMessage : ITimedMessage,
    IMessage
public interface ITimelineMessage : ITimedMessage,
    IMessage
See Also
ITimelineMessage Members
Glimpse.Core.Message Namespace


ITimelineMessage Members

ITimelineMessage Members Glimpse API Documentation

The ITimelineMessage type exposes the following members.
Properties
 | Name | Description
Public property | Duration | Gets or sets the duration of the executed method. (Inherited from ITimedMessage.)
Public property | EventCategory |
Public property | EventName |
Public property | EventSubText |
Public property | Id | Gets the id. (Inherited from IMessage.)
Public property | Offset | Gets or sets the offset from the Http request start. (Inherited from ITimedMessage.)
Public property | StartTime | Gets or sets the start time. (Inherited from ITimedMessage.)
Back to Top
See Also
ITimelineMessage Interface
Glimpse.Core.Message Namespace


ITimelineMessage Properties

ITimelineMessage Properties Glimpse API Documentation
The ITimelineMessage type exposes the following members.
Properties
 | Name | Description
Public property | Duration | Gets or sets the duration of the executed method. (Inherited from ITimedMessage.)
Public property | EventCategory |
Public property | EventName |
Public property | EventSubText |
Public property | Id | Gets the id. (Inherited from IMessage.)
Public property | Offset | Gets or sets the offset from the Http request start. (Inherited from ITimedMessage.)
Public property | StartTime | Gets or sets the start time. (Inherited from ITimedMessage.)
Back to Top
See Also
ITimelineMessage Interface
Glimpse.Core.Message Namespace


EventCategory Property

ITimelineMessage EventCategory Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Message.ITimelineMessage.EventCategory"]

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TimelineCategory EventCategory { get; set; }
TimelineCategory EventCategory { get; set; }
See Also
ITimelineMessage Interface
ITimelineMessage Members
Glimpse.Core.Message Namespace


EventName Property

ITimelineMessage EventName Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Message.ITimelineMessage.EventName"]

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string EventName { get; set; }
string EventName { get; set; }
See Also
ITimelineMessage Interface
ITimelineMessage Members
Glimpse.Core.Message Namespace


EventSubText Property

ITimelineMessage EventSubText Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Message.ITimelineMessage.EventSubText"]

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string EventSubText { get; set; }
string EventSubText { get; set; }
See Also
ITimelineMessage Interface
ITimelineMessage Members
Glimpse.Core.Message Namespace


ITraceMessage Interface

ITraceMessage Interface Glimpse API Documentation

[Missing <summary> documentation for "T:Glimpse.Core.Message.ITraceMessage"]

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITraceMessage
public interface ITraceMessage
See Also
ITraceMessage Members
Glimpse.Core.Message Namespace


ITraceMessage Members

ITraceMessage Members Glimpse API Documentation

The ITraceMessage type exposes the following members.
Properties
 | Name | Description
Public property | Category |
Public property | FromFirst |
Public property | FromLast |
Public property | IndentLevel |
Public property | Message |
Back to Top
See Also
ITraceMessage Interface
Glimpse.Core.Message Namespace


ITraceMessage Properties

ITraceMessage Properties Glimpse API Documentation
The ITraceMessage type exposes the following members.
Properties
 | Name | Description
Public property | Category |
Public property | FromFirst |
Public property | FromLast |
Public property | IndentLevel |
Public property | Message |
Back to Top
See Also
ITraceMessage Interface
Glimpse.Core.Message Namespace


Category Property

ITraceMessage Category Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Message.ITraceMessage.Category"]

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Category { get; }
string Category { get; }
See Also
ITraceMessage Interface
ITraceMessage Members
Glimpse.Core.Message Namespace


FromFirst Property

ITraceMessage FromFirst Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Message.ITraceMessage.FromFirst"]

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TimeSpan FromFirst { get; }
TimeSpan FromFirst { get; }
See Also
ITraceMessage Interface
ITraceMessage Members
Glimpse.Core.Message Namespace


FromLast Property

ITraceMessage FromLast Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Message.ITraceMessage.FromLast"]

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TimeSpan FromLast { get; }
TimeSpan FromLast { get; }
See Also
ITraceMessage Interface
ITraceMessage Members
Glimpse.Core.Message Namespace


IndentLevel Property

ITraceMessage IndentLevel Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Message.ITraceMessage.IndentLevel"]

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int IndentLevel { get; }
int IndentLevel { get; }
See Also
ITraceMessage Interface
ITraceMessage Members
Glimpse.Core.Message Namespace


Message Property

ITraceMessage Message Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Message.ITraceMessage.Message"]

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Message { get; }
string Message { get; }
See Also
ITraceMessage Interface
ITraceMessage Members
Glimpse.Core.Message Namespace


MessageBase Class

MessageBase Class Glimpse API Documentation

[Missing <summary> documentation for "T:Glimpse.Core.Message.MessageBase"]

Inheritance Hierarchy
Online System Object
Glimpse.Core.Message MessageBase

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MessageBase : IMessage
public class MessageBase : IMessage
See Also
MessageBase Members
Glimpse.Core.Message Namespace


MessageBase Members

MessageBase Members Glimpse API Documentation

The MessageBase type exposes the following members.
Constructors
 | Name | Description
Public method | MessageBase | Initializes a new instance of the MessageBase class
Public method | MessageBase(Guid) | Initializes a new instance of the MessageBase class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Id |
Back to Top
See Also
MessageBase Class
Glimpse.Core.Message Namespace


MessageBase Constructor

MessageBase Constructor Glimpse API Documentation
Overload List
 | Name | Description
Public method | MessageBase | Initializes a new instance of the MessageBase class
Public method | MessageBase(Guid) | Initializes a new instance of the MessageBase class
Back to Top
See Also
MessageBase Class
MessageBase Members
Glimpse.Core.Message Namespace


MessageBase Constructor

MessageBase Constructor Glimpse API Documentation
Initializes a new instance of the MessageBase class

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageBase()
public MessageBase()
See Also
MessageBase Class
MessageBase Members
MessageBase Overload
Glimpse.Core.Message Namespace


MessageBase Constructor (Guid)

MessageBase Constructor (Guid) Glimpse API Documentation
Initializes a new instance of the MessageBase class

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageBase(
    Guid id
)
public MessageBase(
    Guid id
)
Parameters
id
Type:   Online System Guid
[Missing <param name="id"/> documentation for "M:Glimpse.Core.Message.MessageBase.#ctor(System.Guid)"]
See Also
MessageBase Class
MessageBase Members
MessageBase Overload
Glimpse.Core.Message Namespace


MessageBase Methods

MessageBase Methods Glimpse API Documentation
The MessageBase type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
MessageBase Class
Glimpse.Core.Message Namespace


MessageBase Properties

MessageBase Properties Glimpse API Documentation
The MessageBase type exposes the following members.
Properties
 | Name | Description
Public property | Id |
Back to Top
See Also
MessageBase Class
Glimpse.Core.Message Namespace


Id Property

MessageBase Id Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Message.MessageBase.Id"]

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid Id { get; protected internal set; }
public Guid Id { get; protected internal set; }
Implements
IMessage Id
See Also
MessageBase Class
MessageBase Members
Glimpse.Core.Message Namespace


SourceMessageExtension Class

SourceMessageExtension Class Glimpse API Documentation
Extension methods for populating ISourceMessage instances.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Message SourceMessageExtension

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class SourceMessageExtension
public static class SourceMessageExtension
See Also
SourceMessageExtension Members
Glimpse.Core.Message Namespace


SourceMessageExtension Members

SourceMessageExtension Members Glimpse API Documentation

The SourceMessageExtension type exposes the following members.
Methods
Name | Description
AsSourceMessage T | Populates relevant properties on the source message.
Back to Top
See Also
SourceMessageExtension Class
Glimpse.Core.Message Namespace


SourceMessageExtension Methods

SourceMessageExtension Methods Glimpse API Documentation
The SourceMessageExtension type exposes the following members.
Methods
Name | Description
AsSourceMessage T | Populates relevant properties on the source message.
Back to Top
See Also
SourceMessageExtension Class
Glimpse.Core.Message Namespace


AsSourceMessage(T) Method

SourceMessageExtension AsSourceMessage T Method Glimpse API Documentation
Populates relevant properties on the source message.

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static T AsSourceMessage<T>(
    this T message,
    Type executedType,
    MethodInfo executedMethod
)
where T : ISourceMessage
public static T AsSourceMessage<T>(
    this T message,
    Type executedType,
    MethodInfo executedMethod
)
where T : ISourceMessage
Parameters
message
Type: T
The message.
executedType
Type:   Online System Type
Type of the executed.
executedMethod
Type:   Online System.Reflection MethodInfo
The executed method.
Type Parameters
T
The type of the message.
Return Value
The message with populated ISourceMessage properties.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
SourceMessageExtension Class
SourceMessageExtension Members
Glimpse.Core.Message Namespace


TimedMessageExtension Class

TimedMessageExtension Class Glimpse API Documentation
Extension methods for populating ITimedMessage instances.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Message TimedMessageExtension

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class TimedMessageExtension
public static class TimedMessageExtension
See Also
TimedMessageExtension Members
Glimpse.Core.Message Namespace


TimedMessageExtension Members

TimedMessageExtension Members Glimpse API Documentation

The TimedMessageExtension type exposes the following members.
Methods
Name | Description
AsTimedMessage T | Populates relevant properties on the source message.
Back to Top
See Also
TimedMessageExtension Class
Glimpse.Core.Message Namespace


TimedMessageExtension Methods

TimedMessageExtension Methods Glimpse API Documentation
The TimedMessageExtension type exposes the following members.
Methods
Name | Description
AsTimedMessage T | Populates relevant properties on the source message.
Back to Top
See Also
TimedMessageExtension Class
Glimpse.Core.Message Namespace


AsTimedMessage(T) Method

TimedMessageExtension AsTimedMessage T Method Glimpse API Documentation
Populates relevant properties on the source message.

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static T AsTimedMessage<T>(
    this T message,
    TimerResult timerResult
)
where T : ITimedMessage
public static T AsTimedMessage<T>(
    this T message,
    TimerResult timerResult
)
where T : ITimedMessage
Parameters
message
Type: T
The message.
timerResult
Type: Glimpse.Core.Extensibility TimerResult
The timer result.
Type Parameters
T
The type of the message.
Return Value
The message with populated ITimedMessage properties.
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
TimedMessageExtension Class
TimedMessageExtension Members
Glimpse.Core.Message Namespace


TimelineCategory Class

TimelineCategory Class Glimpse API Documentation
Definition for a timeline category.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Message TimelineCategory

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TimelineCategory
public class TimelineCategory
See Also
TimelineCategory Members
Glimpse.Core.Message Namespace


TimelineCategory Members

TimelineCategory Members Glimpse API Documentation

The TimelineCategory type exposes the following members.
Constructors
 | Name | Description
Public method | TimelineCategory | Initializes a new instance of the TimelineCategory class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Color | Gets or sets the main bar color.
Public property | ColorHighlight | Gets or sets the main bar border color.
Public property | Name | Gets or sets the name that will be displayed in the UI.
Back to Top
See Also
TimelineCategory Class
Glimpse.Core.Message Namespace


TimelineCategory Constructor

TimelineCategory Constructor Glimpse API Documentation
Initializes a new instance of the TimelineCategory class

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimelineCategory(
    string name,
    string color,
    string colorHighlight
)
public TimelineCategory(
    string name,
    string color,
    string colorHighlight
)
Parameters
name
Type:   Online System String
[Missing <param name="name"/> documentation for "M:Glimpse.Core.Message.TimelineCategory.#ctor(System.String,System.String,System.String)"]
color
Type:   Online System String
[Missing <param name="color"/> documentation for "M:Glimpse.Core.Message.TimelineCategory.#ctor(System.String,System.String,System.String)"]
colorHighlight
Type:   Online System String
[Missing <param name="colorHighlight"/> documentation for "M:Glimpse.Core.Message.TimelineCategory.#ctor(System.String,System.String,System.String)"]
See Also
TimelineCategory Class
TimelineCategory Members
Glimpse.Core.Message Namespace


TimelineCategory Methods

TimelineCategory Methods Glimpse API Documentation
The TimelineCategory type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TimelineCategory Class
Glimpse.Core.Message Namespace


TimelineCategory Properties

TimelineCategory Properties Glimpse API Documentation
The TimelineCategory type exposes the following members.
Properties
 | Name | Description
Public property | Color | Gets or sets the main bar color.
Public property | ColorHighlight | Gets or sets the main bar border color.
Public property | Name | Gets or sets the name that will be displayed in the UI.
Back to Top
See Also
TimelineCategory Class
Glimpse.Core.Message Namespace


Color Property

TimelineCategory Color Property Glimpse API Documentation
Gets or sets the main bar color.

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Color { get; set; }
public string Color { get; set; }
Field Value
The color.
See Also
TimelineCategory Class
TimelineCategory Members
Glimpse.Core.Message Namespace


ColorHighlight Property

TimelineCategory ColorHighlight Property Glimpse API Documentation
Gets or sets the main bar border color.

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ColorHighlight { get; set; }
public string ColorHighlight { get; set; }
Field Value
The color highlight.
See Also
TimelineCategory Class
TimelineCategory Members
Glimpse.Core.Message Namespace


Name Property

TimelineCategory Name Property Glimpse API Documentation
Gets or sets the name that will be displayed in the UI.

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Field Value
The name.
See Also
TimelineCategory Class
TimelineCategory Members
Glimpse.Core.Message Namespace


TimelineMessage Class

TimelineMessage Class Glimpse API Documentation
Options that can used for timeline events.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Message TimelineMessage

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TimelineMessage
public class TimelineMessage
See Also
TimelineMessage Members
Glimpse.Core.Message Namespace


TimelineMessage Members

TimelineMessage Members Glimpse API Documentation

The TimelineMessage type exposes the following members.
Constructors
 | Name | Description
Public method | TimelineMessage | Initializes a new instance of the TimelineMessage class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
Name | Description
Other | Gets the timeline category for a other events.
Request | Gets the timeline category for a request.
Back to Top
See Also
TimelineMessage Class
Glimpse.Core.Message Namespace


TimelineMessage Constructor

TimelineMessage Constructor Glimpse API Documentation
Initializes a new instance of the TimelineMessage class

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimelineMessage()
public TimelineMessage()
See Also
TimelineMessage Class
TimelineMessage Members
Glimpse.Core.Message Namespace


TimelineMessage Methods

TimelineMessage Methods Glimpse API Documentation
The TimelineMessage type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TimelineMessage Class
Glimpse.Core.Message Namespace


TimelineMessage Properties

TimelineMessage Properties Glimpse API Documentation
The TimelineMessage type exposes the following members.
Properties
Name | Description
Other | Gets the timeline category for a other events.
Request | Gets the timeline category for a request.
Back to Top
See Also
TimelineMessage Class
Glimpse.Core.Message Namespace


Other Property

TimelineMessage Other Property Glimpse API Documentation
Gets the timeline category for a other events.

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TimelineCategory Other { get; }
public static TimelineCategory Other { get; }
See Also
TimelineMessage Class
TimelineMessage Members
Glimpse.Core.Message Namespace


Request Property

TimelineMessage Request Property Glimpse API Documentation
Gets the timeline category for a request.

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TimelineCategory Request { get; }
public static TimelineCategory Request { get; }
See Also
TimelineMessage Class
TimelineMessage Members
Glimpse.Core.Message Namespace


TimelineMessageExtension Class

TimelineMessageExtension Class Glimpse API Documentation

[Missing <summary> documentation for "T:Glimpse.Core.Message.TimelineMessageExtension"]

Inheritance Hierarchy
Online System Object
Glimpse.Core.Message TimelineMessageExtension

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class TimelineMessageExtension
public static class TimelineMessageExtension
See Also
TimelineMessageExtension Members
Glimpse.Core.Message Namespace


TimelineMessageExtension Members

TimelineMessageExtension Members Glimpse API Documentation

Methods
Name | Description
AsTimelineMessage T (T, TimelineCategory, String) |
AsTimelineMessage T (T, String, TimelineCategory, String) |
Back to Top
See Also
TimelineMessageExtension Class
Glimpse.Core.Message Namespace


TimelineMessageExtension Methods

TimelineMessageExtension Methods Glimpse API Documentation
Methods
Name | Description
AsTimelineMessage T (T, TimelineCategory, String) |
AsTimelineMessage T (T, String, TimelineCategory, String) |
Back to Top
See Also
TimelineMessageExtension Class
Glimpse.Core.Message Namespace


AsTimelineMessage Method

TimelineMessageExtension AsTimelineMessage Method Glimpse API Documentation
Overload List
Name | Description
AsTimelineMessage T (T, TimelineCategory, String) |
AsTimelineMessage T (T, String, TimelineCategory, String) |
Back to Top
See Also
TimelineMessageExtension Class
TimelineMessageExtension Members
Glimpse.Core.Message Namespace


AsTimelineMessage(T) Method (T, TimelineCategory, String)

TimelineMessageExtension AsTimelineMessage T Method (T, TimelineCategory, String) Glimpse API Documentation

[Missing <summary> documentation for "M:Glimpse.Core.Message.TimelineMessageExtension.AsTimelineMessage``1(``0,Glimpse.Core.Message.TimelineCategory,System.String)"]

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static T AsTimelineMessage<T>(
    this T message,
    TimelineCategory eventCategory,
    string eventSubText = null
)
where T : ITimelineMessage
public static T AsTimelineMessage<T>(
    this T message,
    TimelineCategory eventCategory,
    string eventSubText = null
)
where T : ITimelineMessage
Parameters
message
Type: T
[Missing <param name="message"/> documentation for "M:Glimpse.Core.Message.TimelineMessageExtension.AsTimelineMessage``1(``0,Glimpse.Core.Message.TimelineCategory,System.String)"]
eventCategory
Type: Glimpse.Core.Message TimelineCategory
[Missing <param name="eventCategory"/> documentation for "M:Glimpse.Core.Message.TimelineMessageExtension.AsTimelineMessage``1(``0,Glimpse.Core.Message.TimelineCategory,System.String)"]
eventSubText (Optional)
Type:   Online System String
[Missing <param name="eventSubText"/> documentation for "M:Glimpse.Core.Message.TimelineMessageExtension.AsTimelineMessage``1(``0,Glimpse.Core.Message.TimelineCategory,System.String)"]
Type Parameters
T
[Missing <typeparam name="T"/> documentation for "M:Glimpse.Core.Message.TimelineMessageExtension.AsTimelineMessage``1(``0,Glimpse.Core.Message.TimelineCategory,System.String)"]
Return Value
[Missing <returns> documentation for "M:Glimpse.Core.Message.TimelineMessageExtension.AsTimelineMessage``1(``0,Glimpse.Core.Message.TimelineCategory,System.String)"]
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
TimelineMessageExtension Class
TimelineMessageExtension Members
AsTimelineMessage Overload
Glimpse.Core.Message Namespace


AsTimelineMessage(T) Method (T, String, TimelineCategory, String)

TimelineMessageExtension AsTimelineMessage T Method (T, String, TimelineCategory, String) Glimpse API Documentation

[Missing <summary> documentation for "M:Glimpse.Core.Message.TimelineMessageExtension.AsTimelineMessage``1(``0,System.String,Glimpse.Core.Message.TimelineCategory,System.String)"]

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static T AsTimelineMessage<T>(
    this T message,
    string eventName,
    TimelineCategory eventCategory,
    string eventSubText = null
)
where T : ITimelineMessage
public static T AsTimelineMessage<T>(
    this T message,
    string eventName,
    TimelineCategory eventCategory,
    string eventSubText = null
)
where T : ITimelineMessage
Parameters
message
Type: T
[Missing <param name="message"/> documentation for "M:Glimpse.Core.Message.TimelineMessageExtension.AsTimelineMessage``1(``0,System.String,Glimpse.Core.Message.TimelineCategory,System.String)"]
eventName
Type:   Online System String
[Missing <param name="eventName"/> documentation for "M:Glimpse.Core.Message.TimelineMessageExtension.AsTimelineMessage``1(``0,System.String,Glimpse.Core.Message.TimelineCategory,System.String)"]
eventCategory
Type: Glimpse.Core.Message TimelineCategory
[Missing <param name="eventCategory"/> documentation for "M:Glimpse.Core.Message.TimelineMessageExtension.AsTimelineMessage``1(``0,System.String,Glimpse.Core.Message.TimelineCategory,System.String)"]
eventSubText (Optional)
Type:   Online System String
[Missing <param name="eventSubText"/> documentation for "M:Glimpse.Core.Message.TimelineMessageExtension.AsTimelineMessage``1(``0,System.String,Glimpse.Core.Message.TimelineCategory,System.String)"]
Type Parameters
T
[Missing <typeparam name="T"/> documentation for "M:Glimpse.Core.Message.TimelineMessageExtension.AsTimelineMessage``1(``0,System.String,Glimpse.Core.Message.TimelineCategory,System.String)"]
Return Value
[Missing <returns> documentation for "M:Glimpse.Core.Message.TimelineMessageExtension.AsTimelineMessage``1(``0,System.String,Glimpse.Core.Message.TimelineCategory,System.String)"]
Usage Note
In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see   Online Extension Methods (Visual Basic) or   Online Extension Methods (C# Programming Guide).
See Also
TimelineMessageExtension Class
TimelineMessageExtension Members
AsTimelineMessage Overload
Glimpse.Core.Message Namespace


TraceMessage Class

TraceMessage Class Glimpse API Documentation

[Missing <summary> documentation for "T:Glimpse.Core.Message.TraceMessage"]

Inheritance Hierarchy
Online System Object
Glimpse.Core.Message TraceMessage

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TraceMessage : ITraceMessage
public class TraceMessage : ITraceMessage
See Also
TraceMessage Members
Glimpse.Core.Message Namespace


TraceMessage Members

TraceMessage Members Glimpse API Documentation

The TraceMessage type exposes the following members.
Constructors
 | Name | Description
Public method | TraceMessage | Initializes a new instance of the TraceMessage class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Category |
Public property | FromFirst |
Public property | FromLast |
Public property | IndentLevel |
Public property | Message |
Back to Top
See Also
TraceMessage Class
Glimpse.Core.Message Namespace


TraceMessage Constructor

TraceMessage Constructor Glimpse API Documentation
Initializes a new instance of the TraceMessage class

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TraceMessage()
public TraceMessage()
See Also
TraceMessage Class
TraceMessage Members
Glimpse.Core.Message Namespace


TraceMessage Methods

TraceMessage Methods Glimpse API Documentation
The TraceMessage type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TraceMessage Class
Glimpse.Core.Message Namespace


TraceMessage Properties

TraceMessage Properties Glimpse API Documentation
The TraceMessage type exposes the following members.
Properties
 | Name | Description
Public property | Category |
Public property | FromFirst |
Public property | FromLast |
Public property | IndentLevel |
Public property | Message |
Back to Top
See Also
TraceMessage Class
Glimpse.Core.Message Namespace


Category Property

TraceMessage Category Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Message.TraceMessage.Category"]

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Category { get; set; }
public string Category { get; set; }
Implements
ITraceMessage Category
See Also
TraceMessage Class
TraceMessage Members
Glimpse.Core.Message Namespace


FromFirst Property

TraceMessage FromFirst Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Message.TraceMessage.FromFirst"]

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan FromFirst { get; set; }
public TimeSpan FromFirst { get; set; }
Implements
ITraceMessage FromFirst
See Also
TraceMessage Class
TraceMessage Members
Glimpse.Core.Message Namespace


FromLast Property

TraceMessage FromLast Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Message.TraceMessage.FromLast"]

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan FromLast { get; set; }
public TimeSpan FromLast { get; set; }
Implements
ITraceMessage FromLast
See Also
TraceMessage Class
TraceMessage Members
Glimpse.Core.Message Namespace


IndentLevel Property

TraceMessage IndentLevel Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Message.TraceMessage.IndentLevel"]

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int IndentLevel { get; set; }
public int IndentLevel { get; set; }
Implements
ITraceMessage IndentLevel
See Also
TraceMessage Class
TraceMessage Members
Glimpse.Core.Message Namespace


Message Property

TraceMessage Message Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Message.TraceMessage.Message"]

Namespace: Glimpse.Core.Message
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Message { get; set; }
public string Message { get; set; }
Implements
ITraceMessage Message
See Also
TraceMessage Class
TraceMessage Members
Glimpse.Core.Message Namespace


Glimpse.Core.Model Namespace

Glimpse.Core.Model Namespace Glimpse API Documentation
All tab output types, commonly called a model, are defined within this namespace.
Classes
 | Class | Description
Public class | TimelineCategoryModel |
Public class | TimelineEventModel |
Public class | TimelineModel |


TimelineCategoryModel Class

TimelineCategoryModel Class Glimpse API Documentation

[Missing <summary> documentation for "T:Glimpse.Core.Model.TimelineCategoryModel"]

Inheritance Hierarchy
Online System Object
Glimpse.Core.Model TimelineCategoryModel

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TimelineCategoryModel
public class TimelineCategoryModel
See Also
TimelineCategoryModel Members
Glimpse.Core.Model Namespace


TimelineCategoryModel Members

TimelineCategoryModel Members Glimpse API Documentation

The TimelineCategoryModel type exposes the following members.
Constructors
 | Name | Description
Public method | TimelineCategoryModel | Initializes a new instance of the TimelineCategoryModel class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | EventColor |
Public property | EventColorHighlight |
Back to Top
See Also
TimelineCategoryModel Class
Glimpse.Core.Model Namespace


TimelineCategoryModel Constructor

TimelineCategoryModel Constructor Glimpse API Documentation
Initializes a new instance of the TimelineCategoryModel class

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimelineCategoryModel()
public TimelineCategoryModel()
See Also
TimelineCategoryModel Class
TimelineCategoryModel Members
Glimpse.Core.Model Namespace


TimelineCategoryModel Methods

TimelineCategoryModel Methods Glimpse API Documentation
The TimelineCategoryModel type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TimelineCategoryModel Class
Glimpse.Core.Model Namespace


TimelineCategoryModel Properties

TimelineCategoryModel Properties Glimpse API Documentation
The TimelineCategoryModel type exposes the following members.
Properties
 | Name | Description
Public property | EventColor |
Public property | EventColorHighlight |
Back to Top
See Also
TimelineCategoryModel Class
Glimpse.Core.Model Namespace


EventColor Property

TimelineCategoryModel EventColor Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Model.TimelineCategoryModel.EventColor"]

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string EventColor { get; set; }
public string EventColor { get; set; }
See Also
TimelineCategoryModel Class
TimelineCategoryModel Members
Glimpse.Core.Model Namespace


EventColorHighlight Property

TimelineCategoryModel EventColorHighlight Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Model.TimelineCategoryModel.EventColorHighlight"]

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string EventColorHighlight { get; set; }
public string EventColorHighlight { get; set; }
See Also
TimelineCategoryModel Class
TimelineCategoryModel Members
Glimpse.Core.Model Namespace


TimelineEventModel Class

TimelineEventModel Class Glimpse API Documentation

[Missing <summary> documentation for "T:Glimpse.Core.Model.TimelineEventModel"]

Inheritance Hierarchy
Online System Object
Glimpse.Core.Model TimelineEventModel

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TimelineEventModel
public class TimelineEventModel
See Also
TimelineEventModel Members
Glimpse.Core.Model Namespace


TimelineEventModel Members

TimelineEventModel Members Glimpse API Documentation

The TimelineEventModel type exposes the following members.
Constructors
 | Name | Description
Public method | TimelineEventModel | Initializes a new instance of the TimelineEventModel class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Category |
Public property | Details |
Public property | Duration |
Public property | EndPoint |
Public property | StartPoint |
Public property | StartTime |
Public property | SubText |
Public property | Title |
Back to Top
See Also
TimelineEventModel Class
Glimpse.Core.Model Namespace


TimelineEventModel Constructor

TimelineEventModel Constructor Glimpse API Documentation
Initializes a new instance of the TimelineEventModel class

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimelineEventModel()
public TimelineEventModel()
See Also
TimelineEventModel Class
TimelineEventModel Members
Glimpse.Core.Model Namespace


TimelineEventModel Methods

TimelineEventModel Methods Glimpse API Documentation
The TimelineEventModel type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TimelineEventModel Class
Glimpse.Core.Model Namespace


TimelineEventModel Properties

TimelineEventModel Properties Glimpse API Documentation
The TimelineEventModel type exposes the following members.
Properties
 | Name | Description
Public property | Category |
Public property | Details |
Public property | Duration |
Public property | EndPoint |
Public property | StartPoint |
Public property | StartTime |
Public property | SubText |
Public property | Title |
Back to Top
See Also
TimelineEventModel Class
Glimpse.Core.Model Namespace


Category Property

TimelineEventModel Category Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Model.TimelineEventModel.Category"]

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Category { get; set; }
public string Category { get; set; }
See Also
TimelineEventModel Class
TimelineEventModel Members
Glimpse.Core.Model Namespace


Details Property

TimelineEventModel Details Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Model.TimelineEventModel.Details"]

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, Object> Details { get; set; }
public IDictionary<string, Object> Details { get; set; }
See Also
TimelineEventModel Class
TimelineEventModel Members
Glimpse.Core.Model Namespace


Duration Property

TimelineEventModel Duration Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Model.TimelineEventModel.Duration"]

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan Duration { get; set; }
public TimeSpan Duration { get; set; }
See Also
TimelineEventModel Class
TimelineEventModel Members
Glimpse.Core.Model Namespace


EndPoint Property

TimelineEventModel EndPoint Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Model.TimelineEventModel.EndPoint"]

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan EndPoint { get; }
public TimeSpan EndPoint { get; }
See Also
TimelineEventModel Class
TimelineEventModel Members
Glimpse.Core.Model Namespace


StartPoint Property

TimelineEventModel StartPoint Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Model.TimelineEventModel.StartPoint"]

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan StartPoint { get; set; }
public TimeSpan StartPoint { get; set; }
See Also
TimelineEventModel Class
TimelineEventModel Members
Glimpse.Core.Model Namespace


StartTime Property

TimelineEventModel StartTime Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Model.TimelineEventModel.StartTime"]

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime StartTime { get; set; }
public DateTime StartTime { get; set; }
See Also
TimelineEventModel Class
TimelineEventModel Members
Glimpse.Core.Model Namespace


SubText Property

TimelineEventModel SubText Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Model.TimelineEventModel.SubText"]

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SubText { get; set; }
public string SubText { get; set; }
See Also
TimelineEventModel Class
TimelineEventModel Members
Glimpse.Core.Model Namespace


Title Property

TimelineEventModel Title Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Model.TimelineEventModel.Title"]

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Title { get; set; }
public string Title { get; set; }
See Also
TimelineEventModel Class
TimelineEventModel Members
Glimpse.Core.Model Namespace


TimelineModel Class

TimelineModel Class Glimpse API Documentation

[Missing <summary> documentation for "T:Glimpse.Core.Model.TimelineModel"]

Inheritance Hierarchy
Online System Object
Glimpse.Core.Model TimelineModel

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TimelineModel
public class TimelineModel
See Also
TimelineModel Members
Glimpse.Core.Model Namespace


TimelineModel Members

TimelineModel Members Glimpse API Documentation

The TimelineModel type exposes the following members.
Constructors
 | Name | Description
Public method | TimelineModel | Initializes a new instance of the TimelineModel class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Category |
Public property | Duration |
Public property | Events |
Back to Top
See Also
TimelineModel Class
Glimpse.Core.Model Namespace


TimelineModel Constructor

TimelineModel Constructor Glimpse API Documentation
Initializes a new instance of the TimelineModel class

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimelineModel()
public TimelineModel()
See Also
TimelineModel Class
TimelineModel Members
Glimpse.Core.Model Namespace


TimelineModel Methods

TimelineModel Methods Glimpse API Documentation
The TimelineModel type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TimelineModel Class
Glimpse.Core.Model Namespace


TimelineModel Properties

TimelineModel Properties Glimpse API Documentation
The TimelineModel type exposes the following members.
Properties
 | Name | Description
Public property | Category |
Public property | Duration |
Public property | Events |
Back to Top
See Also
TimelineModel Class
Glimpse.Core.Model Namespace


Category Property

TimelineModel Category Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Model.TimelineModel.Category"]

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, TimelineCategoryModel> Category { get; set; }
public IDictionary<string, TimelineCategoryModel> Category { get; set; }
See Also
TimelineModel Class
TimelineModel Members
Glimpse.Core.Model Namespace


Duration Property

TimelineModel Duration Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Model.TimelineModel.Duration"]

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan Duration { get; set; }
public TimeSpan Duration { get; set; }
See Also
TimelineModel Class
TimelineModel Members
Glimpse.Core.Model Namespace


Events Property

TimelineModel Events Property Glimpse API Documentation

[Missing <summary> documentation for "P:Glimpse.Core.Model.TimelineModel.Events"]

Namespace: Glimpse.Core.Model
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList<TimelineEventModel> Events { get; set; }
public IList<TimelineEventModel> Events { get; set; }
See Also
TimelineModel Class
TimelineModel Members
Glimpse.Core.Model Namespace


Glimpse.Core.Policy Namespace

Glimpse.Core.Policy Namespace Glimpse API Documentation
All core implementations of runtime policies for Glimpse are defined within this namespace.
Classes
 | Class | Description
Public class | AjaxPolicy | Policy which will limit Glimpse to only ModifyResponseHeaders if a Http request is an Ajax request.
Public class | ContentTypePolicy | Policy which will set Glimpse's runtime policy to Off if a Http response's content type is not on the white list.
Public class | ControlCookiePolicy | Policy which will set Glimpse's runtime policy to Off unless a marker cookie named 'glimpsePolicy' is present on the Http request.
Public class | GlimpseResourcePolicy | Policy which will limit Glimpse to only ExecuteResourceOnly if a Http request for an implementation of IResource.
Public class | StatusCodePolicy | Policy which will set Glimpse's runtime policy to Off if a Http response's status code is not on the white list.
Public class | UriPolicy | Policy which will set Glimpse's runtime policy to Off if a Http request's Uri matches a pattern in the black list.


AjaxPolicy Class

AjaxPolicy Class Glimpse API Documentation
Policy which will limit Glimpse to only ModifyResponseHeaders if a Http request is an Ajax request.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Policy AjaxPolicy

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AjaxPolicy : IRuntimePolicy
public class AjaxPolicy : IRuntimePolicy
See Also
AjaxPolicy Members
Glimpse.Core.Policy Namespace


AjaxPolicy Members

AjaxPolicy Members Glimpse API Documentation

The AjaxPolicy type exposes the following members.
Constructors
 | Name | Description
Public method | AjaxPolicy | Initializes a new instance of the AjaxPolicy class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified policy with the given context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ExecuteOn | Gets the point in an Http request lifecycle that a policy should execute.
Back to Top
See Also
AjaxPolicy Class
Glimpse.Core.Policy Namespace


AjaxPolicy Constructor

AjaxPolicy Constructor Glimpse API Documentation
Initializes a new instance of the AjaxPolicy class

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AjaxPolicy()
public AjaxPolicy()
See Also
AjaxPolicy Class
AjaxPolicy Members
Glimpse.Core.Policy Namespace


AjaxPolicy Methods

AjaxPolicy Methods Glimpse API Documentation
The AjaxPolicy type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified policy with the given context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
AjaxPolicy Class
Glimpse.Core.Policy Namespace


Execute Method

AjaxPolicy Execute Method Glimpse API Documentation
Executes the specified policy with the given context.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RuntimePolicy Execute(
    IRuntimePolicyContext policyContext
)
public RuntimePolicy Execute(
    IRuntimePolicyContext policyContext
)
Parameters
policyContext
Type: Glimpse.Core.Extensibility IRuntimePolicyContext
The policy context.
Return Value
ModifyResponseHeaders if request is an Ajax request, otherwise On.

Implements
IRuntimePolicy Execute(IRuntimePolicyContext)
Exceptions
Exception | Condition
Online System ArgumentNullException | Exception thrown if policyContext is null.
See Also
AjaxPolicy Class
AjaxPolicy Members
Glimpse.Core.Policy Namespace


AjaxPolicy Properties

AjaxPolicy Properties Glimpse API Documentation
The AjaxPolicy type exposes the following members.
Properties
 | Name | Description
Public property | ExecuteOn | Gets the point in an Http request lifecycle that a policy should execute.
Back to Top
See Also
AjaxPolicy Class
Glimpse.Core.Policy Namespace


ExecuteOn Property

AjaxPolicy ExecuteOn Property Glimpse API Documentation
Gets the point in an Http request lifecycle that a policy should execute.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RuntimeEvent ExecuteOn { get; }
public RuntimeEvent ExecuteOn { get; }
Field Value

            The moment to execute, AjaxPolicy uses BeginRequest.

Implements
IRuntimePolicy ExecuteOn
See Also
AjaxPolicy Class
AjaxPolicy Members
Glimpse.Core.Policy Namespace


ContentTypePolicy Class

ContentTypePolicy Class Glimpse API Documentation
Policy which will set Glimpse's runtime policy to Off if a Http response's content type is not on the white list.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Policy ContentTypePolicy

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ContentTypePolicy : IRuntimePolicy,
    IConfigurable
public class ContentTypePolicy : IRuntimePolicy,
    IConfigurable
See Also
ContentTypePolicy Members
Glimpse.Core.Policy Namespace


ContentTypePolicy Members

ContentTypePolicy Members Glimpse API Documentation

The ContentTypePolicy type exposes the following members.
Constructors
 | Name | Description
Public method | ContentTypePolicy | Initializes a new instance of the ContentTypePolicy class with an empty white list.
Public method | ContentTypePolicy(IList String ) | Initializes a new instance of the ContentTypePolicy class with the provided contentTypeWhiteList.
Back to Top
Methods
 | Name | Description
Public method | Configure | Provides implementations an instance of Section to self populate any end user configuration options.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified policy with the given context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ContentTypeWhiteList | Gets or sets the content type white list.
Public property | ExecuteOn | Gets the point in an Http request lifecycle that a policy should execute.
Back to Top
See Also
ContentTypePolicy Class
Glimpse.Core.Policy Namespace


ContentTypePolicy Constructor

ContentTypePolicy Constructor Glimpse API Documentation
Overload List
 | Name | Description
Public method | ContentTypePolicy | Initializes a new instance of the ContentTypePolicy class with an empty white list.
Public method | ContentTypePolicy(IList String ) | Initializes a new instance of the ContentTypePolicy class with the provided contentTypeWhiteList.
Back to Top
See Also
ContentTypePolicy Class
ContentTypePolicy Members
Glimpse.Core.Policy Namespace


ContentTypePolicy Constructor

ContentTypePolicy Constructor Glimpse API Documentation
Initializes a new instance of the ContentTypePolicy class with an empty white list.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ContentTypePolicy()
public ContentTypePolicy()
See Also
ContentTypePolicy Class
ContentTypePolicy Members
ContentTypePolicy Overload
Glimpse.Core.Policy Namespace


ContentTypePolicy Constructor (IList(String))

ContentTypePolicy Constructor (IList String ) Glimpse API Documentation
Initializes a new instance of the ContentTypePolicy class with the provided contentTypeWhiteList.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ContentTypePolicy(
    IList<string> contentTypeWhiteList
)
public ContentTypePolicy(
    IList<string> contentTypeWhiteList
)
Parameters
contentTypeWhiteList
Type:   Online System.Collections.Generic IList    Online String
The content type white list to validate against.
Exceptions
Exception | Condition
Online System ArgumentNullException | Exception thrown if contentTypeWhiteList is null.
See Also
ContentTypePolicy Class
ContentTypePolicy Members
ContentTypePolicy Overload
Glimpse.Core.Policy Namespace


ContentTypePolicy Methods

ContentTypePolicy Methods Glimpse API Documentation
The ContentTypePolicy type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Provides implementations an instance of Section to self populate any end user configuration options.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified policy with the given context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ContentTypePolicy Class
Glimpse.Core.Policy Namespace


Configure Method

ContentTypePolicy Configure Method Glimpse API Documentation
Provides implementations an instance of Section to self populate any end user configuration options.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    Section section
)
public void Configure(
    Section section
)
Parameters
section
Type: Glimpse.Core.Configuration Section
The configuration section, <glimpse> from web.config.
Implements
IConfigurable Configure(Section)
Remarks

            Populates the content type white list with values from web.config.
            A list of ratified Http status codes is available in   Online Section 10 of RFC 2616, the Http version 1.1 specification.

Examples

            Configure the content type white list in web.config with the following entries:

View Colorized Copy to Clipboard Print
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <runtimePolicies>
        <contentTypes>
            <!-- <clear /> clear to reset defaults -->
            <add contentType="{media\type}" />
        </contentTypes>
    </runtimePolicies>
</glimpse>
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <runtimePolicies>
        <contentTypes>
            <!-- <clear /> clear to reset defaults -->
            <add contentType="{media\type}" />
        </contentTypes>
    </runtimePolicies>
</glimpse>
See Also
ContentTypePolicy Class
ContentTypePolicy Members
Glimpse.Core.Policy Namespace


Execute Method

ContentTypePolicy Execute Method Glimpse API Documentation
Executes the specified policy with the given context.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RuntimePolicy Execute(
    IRuntimePolicyContext policyContext
)
public RuntimePolicy Execute(
    IRuntimePolicyContext policyContext
)
Parameters
policyContext
Type: Glimpse.Core.Extensibility IRuntimePolicyContext
The policy context.
Return Value
On if the response content type is contained on the white list, otherwise Off.

Implements
IRuntimePolicy Execute(IRuntimePolicyContext)
Exceptions
Exception | Condition
Online System ArgumentNullException | Exception thrown if policyContext is null.
See Also
ContentTypePolicy Class
ContentTypePolicy Members
Glimpse.Core.Policy Namespace


ContentTypePolicy Properties

ContentTypePolicy Properties Glimpse API Documentation
The ContentTypePolicy type exposes the following members.
Properties
 | Name | Description
Public property | ContentTypeWhiteList | Gets or sets the content type white list.
Public property | ExecuteOn | Gets the point in an Http request lifecycle that a policy should execute.
Back to Top
See Also
ContentTypePolicy Class
Glimpse.Core.Policy Namespace


ContentTypeWhiteList Property

ContentTypePolicy ContentTypeWhiteList Property Glimpse API Documentation
Gets or sets the content type white list.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList<string> ContentTypeWhiteList { get; set; }
public IList<string> ContentTypeWhiteList { get; set; }
Field Value

            The content type white list to validate against.

See Also
ContentTypePolicy Class
ContentTypePolicy Members
Glimpse.Core.Policy Namespace


ExecuteOn Property

ContentTypePolicy ExecuteOn Property Glimpse API Documentation
Gets the point in an Http request lifecycle that a policy should execute.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RuntimeEvent ExecuteOn { get; }
public RuntimeEvent ExecuteOn { get; }
Field Value

            The moment to execute, AjaxPolicy uses EndRequest.

Implements
IRuntimePolicy ExecuteOn
See Also
ContentTypePolicy Class
ContentTypePolicy Members
Glimpse.Core.Policy Namespace


ControlCookiePolicy Class

ControlCookiePolicy Class Glimpse API Documentation
Policy which will set Glimpse's runtime policy to Off unless a marker cookie named 'glimpsePolicy' is present on the Http request.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Policy ControlCookiePolicy

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ControlCookiePolicy : IRuntimePolicy
public class ControlCookiePolicy : IRuntimePolicy
See Also
ControlCookiePolicy Members
Glimpse.Core.Policy Namespace


ControlCookiePolicy Members

ControlCookiePolicy Members Glimpse API Documentation

The ControlCookiePolicy type exposes the following members.
Constructors
 | Name | Description
Public method | ControlCookiePolicy | Initializes a new instance of the ControlCookiePolicy class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified policy with the given context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ExecuteOn | Gets the point in an Http request lifecycle that a policy should execute.
Back to Top
See Also
ControlCookiePolicy Class
Glimpse.Core.Policy Namespace


ControlCookiePolicy Constructor

ControlCookiePolicy Constructor Glimpse API Documentation
Initializes a new instance of the ControlCookiePolicy class

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ControlCookiePolicy()
public ControlCookiePolicy()
See Also
ControlCookiePolicy Class
ControlCookiePolicy Members
Glimpse.Core.Policy Namespace


ControlCookiePolicy Methods

ControlCookiePolicy Methods Glimpse API Documentation
The ControlCookiePolicy type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified policy with the given context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ControlCookiePolicy Class
Glimpse.Core.Policy Namespace


Execute Method

ControlCookiePolicy Execute Method Glimpse API Documentation
Executes the specified policy with the given context.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RuntimePolicy Execute(
    IRuntimePolicyContext policyContext
)
public RuntimePolicy Execute(
    IRuntimePolicyContext policyContext
)
Parameters
policyContext
Type: Glimpse.Core.Extensibility IRuntimePolicyContext
The policy context.
Return Value
Off unless the request contains a 'glimpsePolicy' cookie, otherwise the parsed RuntimePolicy of the cookie.

Implements
IRuntimePolicy Execute(IRuntimePolicyContext)
Exceptions
Exception | Condition
Online System ArgumentNullException | Exception thrown if policyContext is null.
See Also
ControlCookiePolicy Class
ControlCookiePolicy Members
Glimpse.Core.Policy Namespace


ControlCookiePolicy Properties

ControlCookiePolicy Properties Glimpse API Documentation
The ControlCookiePolicy type exposes the following members.
Properties
 | Name | Description
Public property | ExecuteOn | Gets the point in an Http request lifecycle that a policy should execute.
Back to Top
See Also
ControlCookiePolicy Class
Glimpse.Core.Policy Namespace


ExecuteOn Property

ControlCookiePolicy ExecuteOn Property Glimpse API Documentation
Gets the point in an Http request lifecycle that a policy should execute.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RuntimeEvent ExecuteOn { get; }
public RuntimeEvent ExecuteOn { get; }
Field Value

            The moment to execute, AjaxPolicy uses BeginRequest.

Implements
IRuntimePolicy ExecuteOn
See Also
ControlCookiePolicy Class
ControlCookiePolicy Members
Glimpse.Core.Policy Namespace


GlimpseResourcePolicy Class

GlimpseResourcePolicy Class Glimpse API Documentation
Policy which will limit Glimpse to only ExecuteResourceOnly if a Http request for an implementation of IResource.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Policy GlimpseResourcePolicy

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlimpseResourcePolicy : IRuntimePolicy
public class GlimpseResourcePolicy : IRuntimePolicy
See Also
GlimpseResourcePolicy Members
Glimpse.Core.Policy Namespace


GlimpseResourcePolicy Members

GlimpseResourcePolicy Members Glimpse API Documentation

The GlimpseResourcePolicy type exposes the following members.
Constructors
 | Name | Description
Public method | GlimpseResourcePolicy | Initializes a new instance of the GlimpseResourcePolicy class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified policy with the given context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ExecuteOn | Gets the point in an Http request lifecycle that a policy should execute.
Back to Top
See Also
GlimpseResourcePolicy Class
Glimpse.Core.Policy Namespace


GlimpseResourcePolicy Constructor

GlimpseResourcePolicy Constructor Glimpse API Documentation
Initializes a new instance of the GlimpseResourcePolicy class

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlimpseResourcePolicy()
public GlimpseResourcePolicy()
See Also
GlimpseResourcePolicy Class
GlimpseResourcePolicy Members
Glimpse.Core.Policy Namespace


GlimpseResourcePolicy Methods

GlimpseResourcePolicy Methods Glimpse API Documentation
The GlimpseResourcePolicy type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified policy with the given context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
GlimpseResourcePolicy Class
Glimpse.Core.Policy Namespace


Execute Method

GlimpseResourcePolicy Execute Method Glimpse API Documentation
Executes the specified policy with the given context.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RuntimePolicy Execute(
    IRuntimePolicyContext policyContext
)
public RuntimePolicy Execute(
    IRuntimePolicyContext policyContext
)
Parameters
policyContext
Type: Glimpse.Core.Extensibility IRuntimePolicyContext
The policy context.
Return Value
ExecuteResourceOnly.

Implements
IRuntimePolicy Execute(IRuntimePolicyContext)
Exceptions
Exception | Condition
Online System ArgumentNullException | Exception thrown if policyContext is null.
See Also
GlimpseResourcePolicy Class
GlimpseResourcePolicy Members
Glimpse.Core.Policy Namespace


GlimpseResourcePolicy Properties

GlimpseResourcePolicy Properties Glimpse API Documentation
The GlimpseResourcePolicy type exposes the following members.
Properties
 | Name | Description
Public property | ExecuteOn | Gets the point in an Http request lifecycle that a policy should execute.
Back to Top
See Also
GlimpseResourcePolicy Class
Glimpse.Core.Policy Namespace


ExecuteOn Property

GlimpseResourcePolicy ExecuteOn Property Glimpse API Documentation
Gets the point in an Http request lifecycle that a policy should execute.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RuntimeEvent ExecuteOn { get; }
public RuntimeEvent ExecuteOn { get; }
Field Value

            The moment to execute, AjaxPolicy uses ExecuteResource.

Implements
IRuntimePolicy ExecuteOn
See Also
GlimpseResourcePolicy Class
GlimpseResourcePolicy Members
Glimpse.Core.Policy Namespace


StatusCodePolicy Class

StatusCodePolicy Class Glimpse API Documentation
Policy which will set Glimpse's runtime policy to Off if a Http response's status code is not on the white list.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Policy StatusCodePolicy

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class StatusCodePolicy : IRuntimePolicy,
    IConfigurable
public class StatusCodePolicy : IRuntimePolicy,
    IConfigurable
See Also
StatusCodePolicy Members
Glimpse.Core.Policy Namespace


StatusCodePolicy Members

StatusCodePolicy Members Glimpse API Documentation

The StatusCodePolicy type exposes the following members.
Constructors
 | Name | Description
Public method | StatusCodePolicy | Initializes a new instance of the StatusCodePolicy class with an empty white list.
Public method | StatusCodePolicy(IList Int32 ) | Initializes a new instance of the StatusCodePolicy class with the provided statusCodeWhiteList.
Back to Top
Methods
 | Name | Description
Public method | Configure | Provides implementations an instance of Section to self populate any end user configuration options.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified policy with the given context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ExecuteOn | Gets the point in an Http request lifecycle that a policy should execute.
Public property | StatusCodeWhiteList | Gets or sets the status code white list.
Back to Top
See Also
StatusCodePolicy Class
Glimpse.Core.Policy Namespace


StatusCodePolicy Constructor

StatusCodePolicy Constructor Glimpse API Documentation
Overload List
 | Name | Description
Public method | StatusCodePolicy | Initializes a new instance of the StatusCodePolicy class with an empty white list.
Public method | StatusCodePolicy(IList Int32 ) | Initializes a new instance of the StatusCodePolicy class with the provided statusCodeWhiteList.
Back to Top
See Also
StatusCodePolicy Class
StatusCodePolicy Members
Glimpse.Core.Policy Namespace


StatusCodePolicy Constructor

StatusCodePolicy Constructor Glimpse API Documentation
Initializes a new instance of the StatusCodePolicy class with an empty white list.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StatusCodePolicy()
public StatusCodePolicy()
See Also
StatusCodePolicy Class
StatusCodePolicy Members
StatusCodePolicy Overload
Glimpse.Core.Policy Namespace


StatusCodePolicy Constructor (IList(Int32))

StatusCodePolicy Constructor (IList Int32 ) Glimpse API Documentation
Initializes a new instance of the StatusCodePolicy class with the provided statusCodeWhiteList.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StatusCodePolicy(
    IList<int> statusCodeWhiteList
)
public StatusCodePolicy(
    IList<int> statusCodeWhiteList
)
Parameters
statusCodeWhiteList
Type:   Online System.Collections.Generic IList    Online Int32
The status code white list.
Exceptions
Exception | Condition
Online System ArgumentNullException | Exception thrown if statusCodeWhiteList is null.
See Also
StatusCodePolicy Class
StatusCodePolicy Members
StatusCodePolicy Overload
Glimpse.Core.Policy Namespace


StatusCodePolicy Methods

StatusCodePolicy Methods Glimpse API Documentation
The StatusCodePolicy type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Provides implementations an instance of Section to self populate any end user configuration options.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified policy with the given context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
StatusCodePolicy Class
Glimpse.Core.Policy Namespace


Configure Method

StatusCodePolicy Configure Method Glimpse API Documentation
Provides implementations an instance of Section to self populate any end user configuration options.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    Section section
)
public void Configure(
    Section section
)
Parameters
section
Type: Glimpse.Core.Configuration Section
The configuration section, <glimpse> from web.config.
Implements
IConfigurable Configure(Section)
Remarks

            Populates the status code white list with values from web.config.

Examples

            Configure the status code white list in web.config with the following entries:

View Colorized Copy to Clipboard Print
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <runtimePolicies>
        <statusCodes>
            <!-- <clear /> clear to reset defaults -->
            <add statusCode="{code}" />
        </statusCodes>
    </runtimePolicies>
</glimpse>
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <runtimePolicies>
        <statusCodes>
            <!-- <clear /> clear to reset defaults -->
            <add statusCode="{code}" />
        </statusCodes>
    </runtimePolicies>
</glimpse>
See Also
StatusCodePolicy Class
StatusCodePolicy Members
Glimpse.Core.Policy Namespace


Execute Method

StatusCodePolicy Execute Method Glimpse API Documentation
Executes the specified policy with the given context.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RuntimePolicy Execute(
    IRuntimePolicyContext policyContext
)
public RuntimePolicy Execute(
    IRuntimePolicyContext policyContext
)
Parameters
policyContext
Type: Glimpse.Core.Extensibility IRuntimePolicyContext
The policy context.
Return Value
On if the response status code is contained on the white list, otherwise Off.

Implements
IRuntimePolicy Execute(IRuntimePolicyContext)
Exceptions
Exception | Condition
Online System ArgumentNullException | Exception thrown if policyContext is null.
See Also
StatusCodePolicy Class
StatusCodePolicy Members
Glimpse.Core.Policy Namespace


StatusCodePolicy Properties

StatusCodePolicy Properties Glimpse API Documentation
The StatusCodePolicy type exposes the following members.
Properties
 | Name | Description
Public property | ExecuteOn | Gets the point in an Http request lifecycle that a policy should execute.
Public property | StatusCodeWhiteList | Gets or sets the status code white list.
Back to Top
See Also
StatusCodePolicy Class
Glimpse.Core.Policy Namespace


ExecuteOn Property

StatusCodePolicy ExecuteOn Property Glimpse API Documentation
Gets the point in an Http request lifecycle that a policy should execute.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RuntimeEvent ExecuteOn { get; }
public RuntimeEvent ExecuteOn { get; }
Field Value

            The moment to execute, AjaxPolicy uses EndRequest.

Implements
IRuntimePolicy ExecuteOn
See Also
StatusCodePolicy Class
StatusCodePolicy Members
Glimpse.Core.Policy Namespace


StatusCodeWhiteList Property

StatusCodePolicy StatusCodeWhiteList Property Glimpse API Documentation
Gets or sets the status code white list.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList<int> StatusCodeWhiteList { get; set; }
public IList<int> StatusCodeWhiteList { get; set; }
Field Value

            The status code white list to validate against.

See Also
StatusCodePolicy Class
StatusCodePolicy Members
Glimpse.Core.Policy Namespace


UriPolicy Class

UriPolicy Class Glimpse API Documentation
Policy which will set Glimpse's runtime policy to Off if a Http request's Uri matches a pattern in the black list.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Policy UriPolicy

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class UriPolicy : IRuntimePolicy, IConfigurable
public class UriPolicy : IRuntimePolicy, IConfigurable
See Also
UriPolicy Members
Glimpse.Core.Policy Namespace


UriPolicy Members

UriPolicy Members Glimpse API Documentation

The UriPolicy type exposes the following members.
Constructors
 | Name | Description
Public method | UriPolicy | Initializes a new instance of the UriPolicy class with an empty black list.
Public method | UriPolicy(IList Regex ) | Initializes a new instance of the UriPolicy class with the provided uriBlackList.
Back to Top
Methods
 | Name | Description
Public method | Configure | Provides implementations an instance of Section to self populate any end user configuration options.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified policy with the given context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ExecuteOn | Gets the point in an Http request lifecycle that a policy should execute.
Public property | UriBlackList | Gets or sets the Uri black list.
Back to Top
See Also
UriPolicy Class
Glimpse.Core.Policy Namespace


UriPolicy Constructor

UriPolicy Constructor Glimpse API Documentation
Overload List
 | Name | Description
Public method | UriPolicy | Initializes a new instance of the UriPolicy class with an empty black list.
Public method | UriPolicy(IList Regex ) | Initializes a new instance of the UriPolicy class with the provided uriBlackList.
Back to Top
See Also
UriPolicy Class
UriPolicy Members
Glimpse.Core.Policy Namespace


UriPolicy Constructor

UriPolicy Constructor Glimpse API Documentation
Initializes a new instance of the UriPolicy class with an empty black list.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UriPolicy()
public UriPolicy()
See Also
UriPolicy Class
UriPolicy Members
UriPolicy Overload
Glimpse.Core.Policy Namespace


UriPolicy Constructor (IList(Regex))

UriPolicy Constructor (IList Regex ) Glimpse API Documentation
Initializes a new instance of the UriPolicy class with the provided uriBlackList.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UriPolicy(
    IList<Regex> uriBlackList
)
public UriPolicy(
    IList<Regex> uriBlackList
)
Parameters
uriBlackList
Type:   Online System.Collections.Generic IList    Online Regex
The Uri black list to validate against. Regular expressions are also supported in the black list.
Exceptions
Exception | Condition
Online System ArgumentNullException | Exception thrown if uriBlackList is null.
See Also
UriPolicy Class
UriPolicy Members
UriPolicy Overload
Glimpse.Core.Policy Namespace


UriPolicy Methods

UriPolicy Methods Glimpse API Documentation
The UriPolicy type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Provides implementations an instance of Section to self populate any end user configuration options.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified policy with the given context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
UriPolicy Class
Glimpse.Core.Policy Namespace


Configure Method

UriPolicy Configure Method Glimpse API Documentation
Provides implementations an instance of Section to self populate any end user configuration options.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    Section section
)
public void Configure(
    Section section
)
Parameters
section
Type: Glimpse.Core.Configuration Section
The configuration section, <glimpse> from web.config.
Implements
IConfigurable Configure(Section)
Remarks

            Populates the Uri black list with values from web.config.

Examples

            Configure the Uri black list in web.config with the following entries:

View Colorized Copy to Clipboard Print
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <runtimePolicies>
        <uris>
            <!-- <clear /> clear to reset defaults -->
            <add regex="{regular expression or uri}" />
        </uris>
    </runtimePolicies>
</glimpse>
<glimpse defaultRuntimePolicy="On" endpointBaseUri="~/Glimpse.axd">
    <runtimePolicies>
        <uris>
            <!-- <clear /> clear to reset defaults -->
            <add regex="{regular expression or uri}" />
        </uris>
    </runtimePolicies>
</glimpse>
See Also
UriPolicy Class
UriPolicy Members
Glimpse.Core.Policy Namespace


Execute Method

UriPolicy Execute Method Glimpse API Documentation
Executes the specified policy with the given context.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RuntimePolicy Execute(
    IRuntimePolicyContext policyContext
)
public RuntimePolicy Execute(
    IRuntimePolicyContext policyContext
)
Parameters
policyContext
Type: Glimpse.Core.Extensibility IRuntimePolicyContext
The policy context.
Return Value
On if the request Uri is contained not matched in the black list, otherwise Off.

Implements
IRuntimePolicy Execute(IRuntimePolicyContext)
Exceptions
Exception | Condition
Online System ArgumentNullException | Exception thrown if policyContext is null.
See Also
UriPolicy Class
UriPolicy Members
Glimpse.Core.Policy Namespace


UriPolicy Properties

UriPolicy Properties Glimpse API Documentation
The UriPolicy type exposes the following members.
Properties
 | Name | Description
Public property | ExecuteOn | Gets the point in an Http request lifecycle that a policy should execute.
Public property | UriBlackList | Gets or sets the Uri black list.
Back to Top
See Also
UriPolicy Class
Glimpse.Core.Policy Namespace


ExecuteOn Property

UriPolicy ExecuteOn Property Glimpse API Documentation
Gets the point in an Http request lifecycle that a policy should execute.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RuntimeEvent ExecuteOn { get; }
public RuntimeEvent ExecuteOn { get; }
Field Value

            The moment to execute, AjaxPolicy uses BeginRequest.

Implements
IRuntimePolicy ExecuteOn
See Also
UriPolicy Class
UriPolicy Members
Glimpse.Core.Policy Namespace


UriBlackList Property

UriPolicy UriBlackList Property Glimpse API Documentation
Gets or sets the Uri black list.

Namespace: Glimpse.Core.Policy
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList<Regex> UriBlackList { get; set; }
public IList<Regex> UriBlackList { get; set; }
Field Value

            The Uri black list to validate against.

See Also
UriPolicy Class
UriPolicy Members
Glimpse.Core.Policy Namespace


Glimpse.Core.Resource Namespace

Glimpse.Core.Resource Namespace Glimpse API Documentation
All resources which provide data or assets to the Glimpse client are defined within this namespace.
Classes
 | Class | Description
Public class | AjaxResource | The IResource implementation responsible for providing the Glimpse client a listing of Ajax requests, filtered by parent request ID.
Public class | ClientResource | The IResource implementation responsible for providing the Glimpse JavaScript client to the browser.
Public class | ConfigurationResource | The IResource implementation responsible for providing the Glimpse configuration page, which is usually where a user turns Glimpse on and off.
Public class | FileResource | The IResource abstraction which makes returning static resources embedded into a Dll easier.
Public class | HistoryResource | The IResource implementation responsible for providing the Glimpse client a listing of historical requests, grouped by client.
Public class | LogoResource | The IResource implementation responsible for providing the Glimpse client the Glimpse logo.
Public class | MetadataResource | The IResource implementation responsible for providing the Glimpse client all pertinent system configuration information.
Public class | PopupResource | The IResource implementation responsible for providing the Glimpse client the Html needed to render the Glimpse pop-up window.
Public class | RequestResource | The IResource implementation responsible for providing the Glimpse client all diagnostics information gathered by Glimpse for a specific request.
Public class | SpriteResource | The IResource implementation responsible for providing the Glimpse client the image sprite containing user interface icons.
Public class | VersionCheckResource | The IResource implementation responsible for providing the Glimpse client the newest version number of Glimpse.


AjaxResource Class

AjaxResource Class Glimpse API Documentation
The IResource implementation responsible for providing the Glimpse client a listing of Ajax requests, filtered by parent request ID.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Resource AjaxResource

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AjaxResource : IResource,
    IKey
public class AjaxResource : IResource,
    IKey
See Also
AjaxResource Members
Glimpse.Core.Resource Namespace


AjaxResource Members

AjaxResource Members Glimpse API Documentation

The AjaxResource type exposes the following members.
Constructors
 | Name | Description
Public method | AjaxResource | Initializes a new instance of the AjaxResource class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Key | Gets the key.
Public property | Name | Gets the name of the resource.
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input.
Back to Top
See Also
AjaxResource Class
Glimpse.Core.Resource Namespace


AjaxResource Constructor

AjaxResource Constructor Glimpse API Documentation
Initializes a new instance of the AjaxResource class

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AjaxResource()
public AjaxResource()
See Also
AjaxResource Class
AjaxResource Members
Glimpse.Core.Resource Namespace


AjaxResource Methods

AjaxResource Methods Glimpse API Documentation
The AjaxResource type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
AjaxResource Class
Glimpse.Core.Resource Namespace


Execute Method

AjaxResource Execute Method Glimpse API Documentation
Executes the specified resource with the specific context.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IResourceResult Execute(
    IResourceContext context
)
public IResourceResult Execute(
    IResourceContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceContext
The context.
Return Value
IResourceResult that can be executed when the Http response is ready to be returned.

Implements
IResource Execute(IResourceContext)
Exceptions
Exception | Condition
Online System ArgumentNullException | Exception thrown if context is null.
See Also
AjaxResource Class
AjaxResource Members
Glimpse.Core.Resource Namespace


AjaxResource Properties

AjaxResource Properties Glimpse API Documentation
The AjaxResource type exposes the following members.
Properties
 | Name | Description
Public property | Key | Gets the key.
Public property | Name | Gets the name of the resource.
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input.
Back to Top
See Also
AjaxResource Class
Glimpse.Core.Resource Namespace


Key Property

AjaxResource Key Property Glimpse API Documentation
Gets the key.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Key { get; }
public string Key { get; }
Field Value

            The key. Only valid JavaScript identifiers should be used for future compatibility.

Implements
IKey Key
See Also
AjaxResource Class
AjaxResource Members
Glimpse.Core.Resource Namespace


Name Property

AjaxResource Name Property Glimpse API Documentation
Gets the name of the resource.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Field Value

            The name.

Implements
IResource Name
Remarks

            Resource name's should be unique across a given web application. If multiple IResource implementations contain the same name, Glimpse may throw an exception resulting in an Http 500 Server Error.

See Also
AjaxResource Class
AjaxResource Members
Glimpse.Core.Resource Namespace


Parameters Property

AjaxResource Parameters Property Glimpse API Documentation
Gets the required or optional parameters that a resource needs as processing input.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ResourceParameterMetadata> Parameters { get; }
public IEnumerable<ResourceParameterMetadata> Parameters { get; }
Field Value

            The parameters.

Implements
IResource Parameters
See Also
AjaxResource Class
AjaxResource Members
Glimpse.Core.Resource Namespace


ClientResource Class

ClientResource Class Glimpse API Documentation
The IResource implementation responsible for providing the Glimpse JavaScript client to the browser.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Resource FileResource
Glimpse.Core.Resource ClientResource

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ClientResource : FileResource,
    IKey
public class ClientResource : FileResource,
    IKey
See Also
ClientResource Members
Glimpse.Core.Resource Namespace


ClientResource Members

ClientResource Members Glimpse API Documentation

The ClientResource type exposes the following members.
Constructors
 | Name | Description
Public method | ClientResource | Initializes a new instance of the ClientResource class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context. (Inherited from FileResource.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Protected property | CacheDuration | Gets the duration of the cache, in seconds. (Inherited from FileResource.)
Public property | Key | Gets the key.
Public property | Name | Gets or sets the name of the resource. (Inherited from FileResource.)
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input. (Inherited from FileResource.)
Public property | ResourceName | Gets or sets the name of the embedded Dll resource. (Inherited from FileResource.)
Public property | ResourceType | Gets or sets the content type of the embedded Dll resource. (Inherited from FileResource.)
Back to Top
See Also
ClientResource Class
Glimpse.Core.Resource Namespace


ClientResource Constructor

ClientResource Constructor Glimpse API Documentation
Initializes a new instance of the ClientResource class.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ClientResource()
public ClientResource()
See Also
ClientResource Class
ClientResource Members
Glimpse.Core.Resource Namespace


ClientResource Methods

ClientResource Methods Glimpse API Documentation
The ClientResource type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context. (Inherited from FileResource.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ClientResource Class
Glimpse.Core.Resource Namespace


ClientResource Properties

ClientResource Properties Glimpse API Documentation
The ClientResource type exposes the following members.
Properties
 | Name | Description
Protected property | CacheDuration | Gets the duration of the cache, in seconds. (Inherited from FileResource.)
Public property | Key | Gets the key.
Public property | Name | Gets or sets the name of the resource. (Inherited from FileResource.)
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input. (Inherited from FileResource.)
Public property | ResourceName | Gets or sets the name of the embedded Dll resource. (Inherited from FileResource.)
Public property | ResourceType | Gets or sets the content type of the embedded Dll resource. (Inherited from FileResource.)
Back to Top
See Also
ClientResource Class
Glimpse.Core.Resource Namespace


Key Property

ClientResource Key Property Glimpse API Documentation
Gets the key.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Key { get; }
public string Key { get; }
Field Value

            The key. Only valid JavaScript identifiers should be used for future compatibility.

Implements
IKey Key
See Also
ClientResource Class
ClientResource Members
Glimpse.Core.Resource Namespace


ConfigurationResource Class

ConfigurationResource Class Glimpse API Documentation
The IResource implementation responsible for providing the Glimpse configuration page, which is usually where a user turns Glimpse on and off.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Resource ConfigurationResource

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ConfigurationResource : IResource,
    IKey
public class ConfigurationResource : IResource,
    IKey
See Also
ConfigurationResource Members
Glimpse.Core.Resource Namespace


ConfigurationResource Members

ConfigurationResource Members Glimpse API Documentation

The ConfigurationResource type exposes the following members.
Constructors
 | Name | Description
Public method | ConfigurationResource | Initializes a new instance of the ConfigurationResource class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Key | Gets the key.
Public property | Name | Gets the name of the resource.
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input.
Back to Top
See Also
ConfigurationResource Class
Glimpse.Core.Resource Namespace


ConfigurationResource Constructor

ConfigurationResource Constructor Glimpse API Documentation
Initializes a new instance of the ConfigurationResource class

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigurationResource()
public ConfigurationResource()
See Also
ConfigurationResource Class
ConfigurationResource Members
Glimpse.Core.Resource Namespace


ConfigurationResource Methods

ConfigurationResource Methods Glimpse API Documentation
The ConfigurationResource type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ConfigurationResource Class
Glimpse.Core.Resource Namespace


Execute Method

ConfigurationResource Execute Method Glimpse API Documentation
Executes the specified resource with the specific context.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IResourceResult Execute(
    IResourceContext context
)
public IResourceResult Execute(
    IResourceContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceContext
The context.
Return Value
IResourceResult that can be executed when the Http response is ready to be returned.

Implements
IResource Execute(IResourceContext)
See Also
ConfigurationResource Class
ConfigurationResource Members
Glimpse.Core.Resource Namespace


ConfigurationResource Properties

ConfigurationResource Properties Glimpse API Documentation
The ConfigurationResource type exposes the following members.
Properties
 | Name | Description
Public property | Key | Gets the key.
Public property | Name | Gets the name of the resource.
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input.
Back to Top
See Also
ConfigurationResource Class
Glimpse.Core.Resource Namespace


Key Property

ConfigurationResource Key Property Glimpse API Documentation
Gets the key.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Key { get; }
public string Key { get; }
Field Value

            The key. Only valid JavaScript identifiers should be used for future compatibility.

Implements
IKey Key
See Also
ConfigurationResource Class
ConfigurationResource Members
Glimpse.Core.Resource Namespace


Name Property

ConfigurationResource Name Property Glimpse API Documentation
Gets the name of the resource.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Field Value

            The name.

Implements
IResource Name
Remarks

            Resource name's should be unique across a given web application. If multiple IResource implementations contain the same name, Glimpse may throw an exception resulting in an Http 500 Server Error.

See Also
ConfigurationResource Class
ConfigurationResource Members
Glimpse.Core.Resource Namespace


Parameters Property

ConfigurationResource Parameters Property Glimpse API Documentation
Gets the required or optional parameters that a resource needs as processing input.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ResourceParameterMetadata> Parameters { get; }
public IEnumerable<ResourceParameterMetadata> Parameters { get; }
Field Value

            The parameters.

Implements
IResource Parameters
See Also
ConfigurationResource Class
ConfigurationResource Members
Glimpse.Core.Resource Namespace


FileResource Class

FileResource Class Glimpse API Documentation
The IResource abstraction which makes returning static resources embedded into a Dll easier.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Resource FileResource
Glimpse.Core.Resource ClientResource
Glimpse.Core.Resource LogoResource
Glimpse.Core.Resource SpriteResource

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class FileResource : IResource
public abstract class FileResource : IResource
See Also
FileResource Members
Glimpse.Core.Resource Namespace


FileResource Members

FileResource Members Glimpse API Documentation

The FileResource type exposes the following members.
Constructors
 | Name | Description
Protected method | FileResource | Initializes a new instance of the FileResource class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Protected property | CacheDuration | Gets the duration of the cache, in seconds.
Public property | Name | Gets or sets the name of the resource.
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input.
Public property | ResourceName | Gets or sets the name of the embedded Dll resource.
Public property | ResourceType | Gets or sets the content type of the embedded Dll resource.
Back to Top
See Also
FileResource Class
Glimpse.Core.Resource Namespace


FileResource Constructor

FileResource Constructor Glimpse API Documentation
Initializes a new instance of the FileResource class

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FileResource()
protected FileResource()
See Also
FileResource Class
FileResource Members
Glimpse.Core.Resource Namespace


FileResource Methods

FileResource Methods Glimpse API Documentation
The FileResource type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
FileResource Class
Glimpse.Core.Resource Namespace


Execute Method

FileResource Execute Method Glimpse API Documentation
Executes the specified resource with the specific context.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IResourceResult Execute(
    IResourceContext context
)
public IResourceResult Execute(
    IResourceContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceContext
The context.
Return Value
IResourceResult that can be executed when the Http response is ready to be returned.

Implements
IResource Execute(IResourceContext)
Exceptions
Exception | Condition
Online System ArgumentNullException | Throws an exception if context is null.
See Also
FileResource Class
FileResource Members
Glimpse.Core.Resource Namespace


FileResource Properties

FileResource Properties Glimpse API Documentation
The FileResource type exposes the following members.
Properties
 | Name | Description
Protected property | CacheDuration | Gets the duration of the cache, in seconds.
Public property | Name | Gets or sets the name of the resource.
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input.
Public property | ResourceName | Gets or sets the name of the embedded Dll resource.
Public property | ResourceType | Gets or sets the content type of the embedded Dll resource.
Back to Top
See Also
FileResource Class
Glimpse.Core.Resource Namespace


CacheDuration Property

FileResource CacheDuration Property Glimpse API Documentation
Gets the duration of the cache, in seconds.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual int CacheDuration { get; }
protected virtual int CacheDuration { get; }
Field Value

            The duration of the cache, in seconds.

Remarks

            CacheDuration will be set as the max-age parameter of the Cache-Control Http response header.

See Also
FileResource Class
FileResource Members
Glimpse.Core.Resource Namespace


Name Property

FileResource Name Property Glimpse API Documentation
Gets or sets the name of the resource.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; protected set; }
public string Name { get; protected set; }
Field Value

            The name.

Implements
IResource Name
Remarks

            Resource name's should be unique across a given web application. If multiple IResource implementations contain the same name, Glimpse may throw an exception resulting in an Http 500 Server Error.

See Also
FileResource Class
FileResource Members
Glimpse.Core.Resource Namespace


Parameters Property

FileResource Parameters Property Glimpse API Documentation
Gets the required or optional parameters that a resource needs as processing input.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerable<ResourceParameterMetadata> Parameters { get; }
public virtual IEnumerable<ResourceParameterMetadata> Parameters { get; }
Field Value

            The parameters.

Implements
IResource Parameters
See Also
FileResource Class
FileResource Members
Glimpse.Core.Resource Namespace


ResourceName Property

FileResource ResourceName Property Glimpse API Documentation
Gets or sets the name of the embedded Dll resource.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ResourceName { get; set; }
public string ResourceName { get; set; }
Field Value

            The name of the embedded Dll resource.

See Also
FileResource Class
FileResource Members
Glimpse.Core.Resource Namespace


ResourceType Property

FileResource ResourceType Property Glimpse API Documentation
Gets or sets the content type of the embedded Dll resource.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ResourceType { get; set; }
public string ResourceType { get; set; }
Field Value

            The content type of the embedded Dll resource.

See Also
FileResource Class
FileResource Members
Glimpse.Core.Resource Namespace


HistoryResource Class

HistoryResource Class Glimpse API Documentation
The IResource implementation responsible for providing the Glimpse client a listing of historical requests, grouped by client.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Resource HistoryResource

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class HistoryResource : IResource,
    IKey
public class HistoryResource : IResource,
    IKey
See Also
HistoryResource Members
Glimpse.Core.Resource Namespace


HistoryResource Members

HistoryResource Members Glimpse API Documentation

The HistoryResource type exposes the following members.
Constructors
 | Name | Description
Public method | HistoryResource | Initializes a new instance of the HistoryResource class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Key | Gets the key.
Public property | Name | Gets the name of the resource.
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input.
Back to Top
See Also
HistoryResource Class
Glimpse.Core.Resource Namespace


HistoryResource Constructor

HistoryResource Constructor Glimpse API Documentation
Initializes a new instance of the HistoryResource class

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HistoryResource()
public HistoryResource()
See Also
HistoryResource Class
HistoryResource Members
Glimpse.Core.Resource Namespace


HistoryResource Methods

HistoryResource Methods Glimpse API Documentation
The HistoryResource type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
HistoryResource Class
Glimpse.Core.Resource Namespace


Execute Method

HistoryResource Execute Method Glimpse API Documentation
Executes the specified resource with the specific context.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IResourceResult Execute(
    IResourceContext context
)
public IResourceResult Execute(
    IResourceContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceContext
The context.
Return Value
IResourceResult that can be executed when the Http response is ready to be returned.

Implements
IResource Execute(IResourceContext)
Exceptions
Exception | Condition
Online System ArgumentNullException | Exception thrown if context is null.
See Also
HistoryResource Class
HistoryResource Members
Glimpse.Core.Resource Namespace


HistoryResource Properties

HistoryResource Properties Glimpse API Documentation
The HistoryResource type exposes the following members.
Properties
 | Name | Description
Public property | Key | Gets the key.
Public property | Name | Gets the name of the resource.
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input.
Back to Top
See Also
HistoryResource Class
Glimpse.Core.Resource Namespace


Key Property

HistoryResource Key Property Glimpse API Documentation
Gets the key.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Key { get; }
public string Key { get; }
Field Value

            The key. Only valid JavaScript identifiers should be used for future compatibility.

Implements
IKey Key
See Also
HistoryResource Class
HistoryResource Members
Glimpse.Core.Resource Namespace


Name Property

HistoryResource Name Property Glimpse API Documentation
Gets the name of the resource.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Field Value

            The name.

Implements
IResource Name
Remarks

            Resource name's should be unique across a given web application. If multiple IResource implementations contain the same name, Glimpse may throw an exception resulting in an Http 500 Server Error.

See Also
HistoryResource Class
HistoryResource Members
Glimpse.Core.Resource Namespace


Parameters Property

HistoryResource Parameters Property Glimpse API Documentation
Gets the required or optional parameters that a resource needs as processing input.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ResourceParameterMetadata> Parameters { get; }
public IEnumerable<ResourceParameterMetadata> Parameters { get; }
Field Value

            The parameters.

Implements
IResource Parameters
See Also
HistoryResource Class
HistoryResource Members
Glimpse.Core.Resource Namespace


LogoResource Class

LogoResource Class Glimpse API Documentation
The IResource implementation responsible for providing the Glimpse client the Glimpse logo.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Resource FileResource
Glimpse.Core.Resource LogoResource

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LogoResource : FileResource,
    IKey
public class LogoResource : FileResource,
    IKey
See Also
LogoResource Members
Glimpse.Core.Resource Namespace


LogoResource Members

LogoResource Members Glimpse API Documentation

The LogoResource type exposes the following members.
Constructors
 | Name | Description
Public method | LogoResource | Initializes a new instance of the LogoResource class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context. (Inherited from FileResource.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Protected property | CacheDuration | Gets the duration of the cache, in seconds. (Inherited from FileResource.)
Public property | Key | Gets the key.
Public property | Name | Gets or sets the name of the resource. (Inherited from FileResource.)
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input. (Inherited from FileResource.)
Public property | ResourceName | Gets or sets the name of the embedded Dll resource. (Inherited from FileResource.)
Public property | ResourceType | Gets or sets the content type of the embedded Dll resource. (Inherited from FileResource.)
Back to Top
See Also
LogoResource Class
Glimpse.Core.Resource Namespace


LogoResource Constructor

LogoResource Constructor Glimpse API Documentation
Initializes a new instance of the LogoResource class.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogoResource()
public LogoResource()
See Also
LogoResource Class
LogoResource Members
Glimpse.Core.Resource Namespace


LogoResource Methods

LogoResource Methods Glimpse API Documentation
The LogoResource type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context. (Inherited from FileResource.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
LogoResource Class
Glimpse.Core.Resource Namespace


LogoResource Properties

LogoResource Properties Glimpse API Documentation
The LogoResource type exposes the following members.
Properties
 | Name | Description
Protected property | CacheDuration | Gets the duration of the cache, in seconds. (Inherited from FileResource.)
Public property | Key | Gets the key.
Public property | Name | Gets or sets the name of the resource. (Inherited from FileResource.)
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input. (Inherited from FileResource.)
Public property | ResourceName | Gets or sets the name of the embedded Dll resource. (Inherited from FileResource.)
Public property | ResourceType | Gets or sets the content type of the embedded Dll resource. (Inherited from FileResource.)
Back to Top
See Also
LogoResource Class
Glimpse.Core.Resource Namespace


Key Property

LogoResource Key Property Glimpse API Documentation
Gets the key.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Key { get; }
public string Key { get; }
Field Value

            The key. Only valid JavaScript identifiers should be used for future compatibility.

Implements
IKey Key
See Also
LogoResource Class
LogoResource Members
Glimpse.Core.Resource Namespace


MetadataResource Class

MetadataResource Class Glimpse API Documentation
The IResource implementation responsible for providing the Glimpse client all pertinent system configuration information.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Resource MetadataResource

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MetadataResource : IResource,
    IKey
public class MetadataResource : IResource,
    IKey
See Also
MetadataResource Members
Glimpse.Core.Resource Namespace


MetadataResource Members

MetadataResource Members Glimpse API Documentation

The MetadataResource type exposes the following members.
Constructors
 | Name | Description
Public method | MetadataResource | Initializes a new instance of the MetadataResource class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Key | Gets the key.
Public property | Name | Gets the name of the resource.
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input.
Back to Top
See Also
MetadataResource Class
Glimpse.Core.Resource Namespace


MetadataResource Constructor

MetadataResource Constructor Glimpse API Documentation
Initializes a new instance of the MetadataResource class

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MetadataResource()
public MetadataResource()
See Also
MetadataResource Class
MetadataResource Members
Glimpse.Core.Resource Namespace


MetadataResource Methods

MetadataResource Methods Glimpse API Documentation
The MetadataResource type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
MetadataResource Class
Glimpse.Core.Resource Namespace


Execute Method

MetadataResource Execute Method Glimpse API Documentation
Executes the specified resource with the specific context.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IResourceResult Execute(
    IResourceContext context
)
public IResourceResult Execute(
    IResourceContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceContext
The context.
Return Value
IResourceResult that can be executed when the Http response is ready to be returned.

Implements
IResource Execute(IResourceContext)
See Also
MetadataResource Class
MetadataResource Members
Glimpse.Core.Resource Namespace


MetadataResource Properties

MetadataResource Properties Glimpse API Documentation
The MetadataResource type exposes the following members.
Properties
 | Name | Description
Public property | Key | Gets the key.
Public property | Name | Gets the name of the resource.
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input.
Back to Top
See Also
MetadataResource Class
Glimpse.Core.Resource Namespace


Key Property

MetadataResource Key Property Glimpse API Documentation
Gets the key.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Key { get; }
public string Key { get; }
Field Value

            The key. Only valid JavaScript identifiers should be used for future compatibility.

Implements
IKey Key
See Also
MetadataResource Class
MetadataResource Members
Glimpse.Core.Resource Namespace


Name Property

MetadataResource Name Property Glimpse API Documentation
Gets the name of the resource.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Field Value

            The name.

Implements
IResource Name
Remarks

            Resource name's should be unique across a given web application. If multiple IResource implementations contain the same name, Glimpse may throw an exception resulting in an Http 500 Server Error.

See Also
MetadataResource Class
MetadataResource Members
Glimpse.Core.Resource Namespace


Parameters Property

MetadataResource Parameters Property Glimpse API Documentation
Gets the required or optional parameters that a resource needs as processing input.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ResourceParameterMetadata> Parameters { get; }
public IEnumerable<ResourceParameterMetadata> Parameters { get; }
Field Value

            The parameters.

Implements
IResource Parameters
See Also
MetadataResource Class
MetadataResource Members
Glimpse.Core.Resource Namespace


PopupResource Class

PopupResource Class Glimpse API Documentation
The IResource implementation responsible for providing the Glimpse client the Html needed to render the Glimpse pop-up window.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Resource PopupResource

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PopupResource : IPrivilegedResource,
    IResource, IKey
public class PopupResource : IPrivilegedResource,
    IResource, IKey
See Also
PopupResource Members
Glimpse.Core.Resource Namespace


PopupResource Members

PopupResource Members Glimpse API Documentation

The PopupResource type exposes the following members.
Constructors
 | Name | Description
Public method | PopupResource | Initializes a new instance of the PopupResource class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute(IResourceContext) | Executes the specified resource with the specific context.
Public method | Execute(IResourceContext, IGlimpseConfiguration) | Executes the specified context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Key | Gets the key.
Public property | Name | Gets the name of the resource.
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input.
Back to Top
See Also
PopupResource Class
Glimpse.Core.Resource Namespace


PopupResource Constructor

PopupResource Constructor Glimpse API Documentation
Initializes a new instance of the PopupResource class

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PopupResource()
public PopupResource()
See Also
PopupResource Class
PopupResource Members
Glimpse.Core.Resource Namespace


PopupResource Methods

PopupResource Methods Glimpse API Documentation
The PopupResource type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute(IResourceContext) | Executes the specified resource with the specific context.
Public method | Execute(IResourceContext, IGlimpseConfiguration) | Executes the specified context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
PopupResource Class
Glimpse.Core.Resource Namespace


Execute Method

PopupResource Execute Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Execute(IResourceContext) | Executes the specified resource with the specific context.
Public method | Execute(IResourceContext, IGlimpseConfiguration) | Executes the specified context.
Back to Top
See Also
PopupResource Class
PopupResource Members
Glimpse.Core.Resource Namespace


Execute Method (IResourceContext)

PopupResource Execute Method (IResourceContext) Glimpse API Documentation
Executes the specified resource with the specific context.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IResourceResult Execute(
    IResourceContext context
)
public IResourceResult Execute(
    IResourceContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceContext
The context.
Return Value
IResourceResult that can be executed when the Http response is ready to be returned.

Implements
IResource Execute(IResourceContext)
Exceptions
Exception | Condition
Online System NotSupportedException | Throws a Online NotSupportedException since this is a IPrivilegedResource.
See Also
PopupResource Class
PopupResource Members
Execute Overload
Glimpse.Core.Resource Namespace


Execute Method (IResourceContext, IGlimpseConfiguration)

PopupResource Execute Method (IResourceContext, IGlimpseConfiguration) Glimpse API Documentation
Executes the specified context.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IResourceResult Execute(
    IResourceContext context,
    IGlimpseConfiguration configuration
)
public IResourceResult Execute(
    IResourceContext context,
    IGlimpseConfiguration configuration
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceContext
The context.
configuration
Type: Glimpse.Core.Framework IGlimpseConfiguration
The configuration.
Return Value

            A IResourceResult.

Exceptions
Exception | Condition
Online System ArgumentNullException | Exception thrown if either context or configuration are null.
Remarks

            Use of IPrivilegedResource is reserved.

See Also
PopupResource Class
PopupResource Members
Execute Overload
Glimpse.Core.Resource Namespace


PopupResource Properties

PopupResource Properties Glimpse API Documentation
The PopupResource type exposes the following members.
Properties
 | Name | Description
Public property | Key | Gets the key.
Public property | Name | Gets the name of the resource.
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input.
Back to Top
See Also
PopupResource Class
Glimpse.Core.Resource Namespace


Key Property

PopupResource Key Property Glimpse API Documentation
Gets the key.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Key { get; }
public string Key { get; }
Field Value

            The key. Only valid JavaScript identifiers should be used for future compatibility.

Implements
IKey Key
See Also
PopupResource Class
PopupResource Members
Glimpse.Core.Resource Namespace


Name Property

PopupResource Name Property Glimpse API Documentation
Gets the name of the resource.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Field Value

            The name.

Implements
IResource Name
Remarks

            Resource name's should be unique across a given web application. If multiple IResource implementations contain the same name, Glimpse may throw an exception resulting in an Http 500 Server Error.

See Also
PopupResource Class
PopupResource Members
Glimpse.Core.Resource Namespace


Parameters Property

PopupResource Parameters Property Glimpse API Documentation
Gets the required or optional parameters that a resource needs as processing input.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ResourceParameterMetadata> Parameters { get; }
public IEnumerable<ResourceParameterMetadata> Parameters { get; }
Field Value

            The parameters.

Implements
IResource Parameters
See Also
PopupResource Class
PopupResource Members
Glimpse.Core.Resource Namespace


RequestResource Class

RequestResource Class Glimpse API Documentation
The IResource implementation responsible for providing the Glimpse client all diagnostics information gathered by Glimpse for a specific request.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Resource RequestResource

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RequestResource : IResource,
    IKey
public class RequestResource : IResource,
    IKey
See Also
RequestResource Members
Glimpse.Core.Resource Namespace


RequestResource Members

RequestResource Members Glimpse API Documentation

The RequestResource type exposes the following members.
Constructors
 | Name | Description
Public method | RequestResource | Initializes a new instance of the RequestResource class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Key | Gets the key.
Public property | Name | Gets the name of the resource.
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input.
Back to Top
See Also
RequestResource Class
Glimpse.Core.Resource Namespace


RequestResource Constructor

RequestResource Constructor Glimpse API Documentation
Initializes a new instance of the RequestResource class

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RequestResource()
public RequestResource()
See Also
RequestResource Class
RequestResource Members
Glimpse.Core.Resource Namespace


RequestResource Methods

RequestResource Methods Glimpse API Documentation
The RequestResource type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
RequestResource Class
Glimpse.Core.Resource Namespace


Execute Method

RequestResource Execute Method Glimpse API Documentation
Executes the specified resource with the specific context.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IResourceResult Execute(
    IResourceContext context
)
public IResourceResult Execute(
    IResourceContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceContext
The context.
Return Value
IResourceResult that can be executed when the Http response is ready to be returned.

Implements
IResource Execute(IResourceContext)
Exceptions
Exception | Condition
Online System ArgumentNullException | Exception thrown if context is null.
See Also
RequestResource Class
RequestResource Members
Glimpse.Core.Resource Namespace


RequestResource Properties

RequestResource Properties Glimpse API Documentation
The RequestResource type exposes the following members.
Properties
 | Name | Description
Public property | Key | Gets the key.
Public property | Name | Gets the name of the resource.
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input.
Back to Top
See Also
RequestResource Class
Glimpse.Core.Resource Namespace


Key Property

RequestResource Key Property Glimpse API Documentation
Gets the key.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Key { get; }
public string Key { get; }
Field Value

            The key. Only valid JavaScript identifiers should be used for future compatibility.

Implements
IKey Key
See Also
RequestResource Class
RequestResource Members
Glimpse.Core.Resource Namespace


Name Property

RequestResource Name Property Glimpse API Documentation
Gets the name of the resource.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Field Value

            The name.

Implements
IResource Name
Remarks

            Resource name's should be unique across a given web application. If multiple IResource implementations contain the same name, Glimpse may throw an exception resulting in an Http 500 Server Error.

See Also
RequestResource Class
RequestResource Members
Glimpse.Core.Resource Namespace


Parameters Property

RequestResource Parameters Property Glimpse API Documentation
Gets the required or optional parameters that a resource needs as processing input.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ResourceParameterMetadata> Parameters { get; }
public IEnumerable<ResourceParameterMetadata> Parameters { get; }
Field Value

            The parameters.

Implements
IResource Parameters
See Also
RequestResource Class
RequestResource Members
Glimpse.Core.Resource Namespace


SpriteResource Class

SpriteResource Class Glimpse API Documentation
The IResource implementation responsible for providing the Glimpse client the image sprite containing user interface icons.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Resource FileResource
Glimpse.Core.Resource SpriteResource

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SpriteResource : FileResource,
    IKey
public class SpriteResource : FileResource,
    IKey
See Also
SpriteResource Members
Glimpse.Core.Resource Namespace


SpriteResource Members

SpriteResource Members Glimpse API Documentation

The SpriteResource type exposes the following members.
Constructors
 | Name | Description
Public method | SpriteResource | Initializes a new instance of the SpriteResource class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context. (Inherited from FileResource.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Protected property | CacheDuration | Gets the duration of the cache, in seconds. (Inherited from FileResource.)
Public property | Key | Gets the key.
Public property | Name | Gets or sets the name of the resource. (Inherited from FileResource.)
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input. (Inherited from FileResource.)
Public property | ResourceName | Gets or sets the name of the embedded Dll resource. (Inherited from FileResource.)
Public property | ResourceType | Gets or sets the content type of the embedded Dll resource. (Inherited from FileResource.)
Back to Top
See Also
SpriteResource Class
Glimpse.Core.Resource Namespace


SpriteResource Constructor

SpriteResource Constructor Glimpse API Documentation
Initializes a new instance of the SpriteResource class.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SpriteResource()
public SpriteResource()
See Also
SpriteResource Class
SpriteResource Members
Glimpse.Core.Resource Namespace


SpriteResource Methods

SpriteResource Methods Glimpse API Documentation
The SpriteResource type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context. (Inherited from FileResource.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
SpriteResource Class
Glimpse.Core.Resource Namespace


SpriteResource Properties

SpriteResource Properties Glimpse API Documentation
The SpriteResource type exposes the following members.
Properties
 | Name | Description
Protected property | CacheDuration | Gets the duration of the cache, in seconds. (Inherited from FileResource.)
Public property | Key | Gets the key.
Public property | Name | Gets or sets the name of the resource. (Inherited from FileResource.)
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input. (Inherited from FileResource.)
Public property | ResourceName | Gets or sets the name of the embedded Dll resource. (Inherited from FileResource.)
Public property | ResourceType | Gets or sets the content type of the embedded Dll resource. (Inherited from FileResource.)
Back to Top
See Also
SpriteResource Class
Glimpse.Core.Resource Namespace


Key Property

SpriteResource Key Property Glimpse API Documentation
Gets the key.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Key { get; }
public string Key { get; }
Field Value

            The key. Only valid JavaScript identifiers should be used for future compatibility.

Implements
IKey Key
See Also
SpriteResource Class
SpriteResource Members
Glimpse.Core.Resource Namespace


VersionCheckResource Class

VersionCheckResource Class Glimpse API Documentation
The IResource implementation responsible for providing the Glimpse client the newest version number of Glimpse.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Resource VersionCheckResource

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class VersionCheckResource : IResource,
    IKey
public class VersionCheckResource : IResource,
    IKey
See Also
VersionCheckResource Members
Glimpse.Core.Resource Namespace


VersionCheckResource Members

VersionCheckResource Members Glimpse API Documentation

The VersionCheckResource type exposes the following members.
Constructors
 | Name | Description
Public method | VersionCheckResource | Initializes a new instance of the VersionCheckResource class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Key | Gets the key.
Public property | Name | Gets the name of the resource.
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input.
Back to Top
See Also
VersionCheckResource Class
Glimpse.Core.Resource Namespace


VersionCheckResource Constructor

VersionCheckResource Constructor Glimpse API Documentation
Initializes a new instance of the VersionCheckResource class

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public VersionCheckResource()
public VersionCheckResource()
See Also
VersionCheckResource Class
VersionCheckResource Members
Glimpse.Core.Resource Namespace


VersionCheckResource Methods

VersionCheckResource Methods Glimpse API Documentation
The VersionCheckResource type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the specified resource with the specific context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
VersionCheckResource Class
Glimpse.Core.Resource Namespace


Execute Method

VersionCheckResource Execute Method Glimpse API Documentation
Executes the specified resource with the specific context.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IResourceResult Execute(
    IResourceContext context
)
public IResourceResult Execute(
    IResourceContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceContext
The context.
Return Value
IResourceResult that can be executed when the Http response is ready to be returned.

Implements
IResource Execute(IResourceContext)
See Also
VersionCheckResource Class
VersionCheckResource Members
Glimpse.Core.Resource Namespace


VersionCheckResource Properties

VersionCheckResource Properties Glimpse API Documentation
The VersionCheckResource type exposes the following members.
Properties
 | Name | Description
Public property | Key | Gets the key.
Public property | Name | Gets the name of the resource.
Public property | Parameters | Gets the required or optional parameters that a resource needs as processing input.
Back to Top
See Also
VersionCheckResource Class
Glimpse.Core.Resource Namespace


Key Property

VersionCheckResource Key Property Glimpse API Documentation
Gets the key.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Key { get; }
public string Key { get; }
Field Value

            The key. Only valid JavaScript identifiers should be used for future compatibility.

Implements
IKey Key
See Also
VersionCheckResource Class
VersionCheckResource Members
Glimpse.Core.Resource Namespace


Name Property

VersionCheckResource Name Property Glimpse API Documentation
Gets the name of the resource.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Field Value

            The name.

Implements
IResource Name
Remarks

            Resource name's should be unique across a given web application. If multiple IResource implementations contain the same name, Glimpse may throw an exception resulting in an Http 500 Server Error.

See Also
VersionCheckResource Class
VersionCheckResource Members
Glimpse.Core.Resource Namespace


Parameters Property

VersionCheckResource Parameters Property Glimpse API Documentation
Gets the required or optional parameters that a resource needs as processing input.

Namespace: Glimpse.Core.Resource
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ResourceParameterMetadata> Parameters { get; }
public IEnumerable<ResourceParameterMetadata> Parameters { get; }
Field Value

            The parameters.

Implements
IResource Parameters
See Also
VersionCheckResource Class
VersionCheckResource Members
Glimpse.Core.Resource Namespace


Glimpse.Core.ResourceResult Namespace

Glimpse.Core.ResourceResult Namespace Glimpse API Documentation
All resource results which write [IResource] data to the framework provider are defined within this namespace.
Classes
 | Class | Description
Public class | CacheControlDecorator | The ResourceResultDecorator implementation responsible providing Http caching to IResourceResult implementations via the Cache-Control Http response header.
Public class | ExceptionResourceResult | The StatusCodeResourceResult implementation responsible returning .Net exceptions to a client in a way compatible with Http.
Public class | FileResourceResult | The IResourceResult implementation responsible returning binary files to a client.
Public class | HtmlResourceResult | The IResourceResult implementation responsible returning Html files to a client.
Public class | JsonResourceResult | The IResourceResult implementation responsible returning Json data to clients.
Public class | RedirectResourceResult | The IResourceResult implementation responsible redirecting a client to a new Uri.
Public class | StatusCodeResourceResult | The IResourceResult implementation responsible returning simple status code/message pairs to a client.


CacheControlDecorator Class

CacheControlDecorator Class Glimpse API Documentation
The ResourceResultDecorator implementation responsible providing Http caching to IResourceResult implementations via the Cache-Control Http response header.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility ResourceResultDecorator
Glimpse.Core.ResourceResult CacheControlDecorator

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CacheControlDecorator : ResourceResultDecorator
public class CacheControlDecorator : ResourceResultDecorator
See Also
CacheControlDecorator Members
Glimpse.Core.ResourceResult Namespace


CacheControlDecorator Members

CacheControlDecorator Members Glimpse API Documentation

The CacheControlDecorator type exposes the following members.
Constructors
 | Name | Description
Public method | CacheControlDecorator(IResourceResult) | Initializes a new instance of the CacheControlDecorator class.
Public method | CacheControlDecorator(Int64, Nullable CacheSetting , IResourceResult) | Initializes a new instance of the CacheControlDecorator class.
Back to Top
Methods
 | Name | Description
Protected method | Decorate | Decorates the specified context. (Overrides ResourceResultDecorator Decorate(IResourceResultContext).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the resource result with the specified context. (Inherited from ResourceResultDecorator.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetWrappedObject | Gets the wrapped object. (Inherited from ResourceResultDecorator.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CacheDuration | Gets or sets the duration of the cache.
Public property | CacheSetting | Gets or sets the cache directive.
Protected property | WrappedResourceResult | Gets or sets the wrapped resource result. (Inherited from ResourceResultDecorator.)
Back to Top
See Also
CacheControlDecorator Class
Glimpse.Core.ResourceResult Namespace


CacheControlDecorator Constructor

CacheControlDecorator Constructor Glimpse API Documentation
Overload List
 | Name | Description
Public method | CacheControlDecorator(IResourceResult) | Initializes a new instance of the CacheControlDecorator class.
Public method | CacheControlDecorator(Int64, Nullable CacheSetting , IResourceResult) | Initializes a new instance of the CacheControlDecorator class.
Back to Top
See Also
CacheControlDecorator Class
CacheControlDecorator Members
Glimpse.Core.ResourceResult Namespace


CacheControlDecorator Constructor (IResourceResult)

CacheControlDecorator Constructor (IResourceResult) Glimpse API Documentation
Initializes a new instance of the CacheControlDecorator class.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CacheControlDecorator(
    IResourceResult wrappedResourceResult
)
public CacheControlDecorator(
    IResourceResult wrappedResourceResult
)
Parameters
wrappedResourceResult
Type: Glimpse.Core.Extensibility IResourceResult
The wrapped resource result.
See Also
CacheControlDecorator Class
CacheControlDecorator Members
CacheControlDecorator Overload
Glimpse.Core.ResourceResult Namespace


CacheControlDecorator Constructor (Int64, Nullable(CacheSetting), IResourceResult)

CacheControlDecorator Constructor (Int64, Nullable CacheSetting , IResourceResult) Glimpse API Documentation
Initializes a new instance of the CacheControlDecorator class.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CacheControlDecorator(
    long cacheDuration,
    Nullable<CacheSetting> cacheSetting,
    IResourceResult wrappedResourceResult
)
public CacheControlDecorator(
    long cacheDuration,
    Nullable<CacheSetting> cacheSetting,
    IResourceResult wrappedResourceResult
)
Parameters
cacheDuration
Type:   Online System Int64
Duration of the cache.
cacheSetting
Type:   Online System Nullable  CacheSetting
The cache setting.
wrappedResourceResult
Type: Glimpse.Core.Extensibility IResourceResult
The wrapped resource result.
See Also
CacheControlDecorator Class
CacheControlDecorator Members
CacheControlDecorator Overload
Glimpse.Core.ResourceResult Namespace


CacheControlDecorator Methods

CacheControlDecorator Methods Glimpse API Documentation
The CacheControlDecorator type exposes the following members.
Methods
 | Name | Description
Protected method | Decorate | Decorates the specified context. (Overrides ResourceResultDecorator Decorate(IResourceResultContext).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the resource result with the specified context. (Inherited from ResourceResultDecorator.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetWrappedObject | Gets the wrapped object. (Inherited from ResourceResultDecorator.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
CacheControlDecorator Class
Glimpse.Core.ResourceResult Namespace


Decorate Method

CacheControlDecorator Decorate Method Glimpse API Documentation
Decorates the specified context.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Decorate(
    IResourceResultContext context
)
protected override void Decorate(
    IResourceResultContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceResultContext
The context.
See Also
CacheControlDecorator Class
CacheControlDecorator Members
Glimpse.Core.ResourceResult Namespace


CacheControlDecorator Properties

CacheControlDecorator Properties Glimpse API Documentation
The CacheControlDecorator type exposes the following members.
Properties
 | Name | Description
Public property | CacheDuration | Gets or sets the duration of the cache.
Public property | CacheSetting | Gets or sets the cache directive.
Protected property | WrappedResourceResult | Gets or sets the wrapped resource result. (Inherited from ResourceResultDecorator.)
Back to Top
See Also
CacheControlDecorator Class
Glimpse.Core.ResourceResult Namespace


CacheDuration Property

CacheControlDecorator CacheDuration Property Glimpse API Documentation
Gets or sets the duration of the cache.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long CacheDuration { get; set; }
public long CacheDuration { get; set; }
Field Value

            The duration of the cache in seconds.

See Also
CacheControlDecorator Class
CacheControlDecorator Members
Glimpse.Core.ResourceResult Namespace


CacheSetting Property

CacheControlDecorator CacheSetting Property Glimpse API Documentation
Gets or sets the cache directive.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<CacheSetting> CacheSetting { get; set; }
public Nullable<CacheSetting> CacheSetting { get; set; }
Field Value

            The cache directive.

See Also
CacheControlDecorator Class
CacheControlDecorator Members
Glimpse.Core.ResourceResult Namespace


ExceptionResourceResult Class

ExceptionResourceResult Class Glimpse API Documentation
The StatusCodeResourceResult implementation responsible returning .Net exceptions to a client in a way compatible with Http.
Inheritance Hierarchy
Online System Object
Glimpse.Core.ResourceResult StatusCodeResourceResult
Glimpse.Core.ResourceResult ExceptionResourceResult

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ExceptionResourceResult : StatusCodeResourceResult
public class ExceptionResourceResult : StatusCodeResourceResult
See Also
ExceptionResourceResult Members
Glimpse.Core.ResourceResult Namespace


ExceptionResourceResult Members

ExceptionResourceResult Members Glimpse API Documentation

The ExceptionResourceResult type exposes the following members.
Constructors
 | Name | Description
Public method | ExceptionResourceResult | Initializes a new instance of the ExceptionResourceResult class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the resource result with the specified context. (Inherited from StatusCodeResourceResult.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Message | Gets or sets the message to return to the client. (Inherited from StatusCodeResourceResult.)
Public property | StatusCode | Gets or sets the status code to return to the client. (Inherited from StatusCodeResourceResult.)
Back to Top
See Also
ExceptionResourceResult Class
Glimpse.Core.ResourceResult Namespace


ExceptionResourceResult Constructor

ExceptionResourceResult Constructor Glimpse API Documentation
Initializes a new instance of the ExceptionResourceResult class.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ExceptionResourceResult(
    Exception exception
)
public ExceptionResourceResult(
    Exception exception
)
Parameters
exception
Type:   Online System Exception
The exception.
See Also
ExceptionResourceResult Class
ExceptionResourceResult Members
Glimpse.Core.ResourceResult Namespace


ExceptionResourceResult Methods

ExceptionResourceResult Methods Glimpse API Documentation
The ExceptionResourceResult type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the resource result with the specified context. (Inherited from StatusCodeResourceResult.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ExceptionResourceResult Class
Glimpse.Core.ResourceResult Namespace


ExceptionResourceResult Properties

ExceptionResourceResult Properties Glimpse API Documentation
The ExceptionResourceResult type exposes the following members.
Properties
 | Name | Description
Public property | Message | Gets or sets the message to return to the client. (Inherited from StatusCodeResourceResult.)
Public property | StatusCode | Gets or sets the status code to return to the client. (Inherited from StatusCodeResourceResult.)
Back to Top
See Also
ExceptionResourceResult Class
Glimpse.Core.ResourceResult Namespace


FileResourceResult Class

FileResourceResult Class Glimpse API Documentation
The IResourceResult implementation responsible returning binary files to a client.
Inheritance Hierarchy
Online System Object
Glimpse.Core.ResourceResult FileResourceResult

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FileResourceResult : IResourceResult
public class FileResourceResult : IResourceResult
See Also
FileResourceResult Members
Glimpse.Core.ResourceResult Namespace


FileResourceResult Members

FileResourceResult Members Glimpse API Documentation

The FileResourceResult type exposes the following members.
Constructors
 | Name | Description
Public method | FileResourceResult | Initializes a new instance of the FileResourceResult class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the resource result with the specified context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Content | Gets or sets the content to send to the client.
Public property | ContentType | Gets or sets the content type of the Content.
Back to Top
See Also
FileResourceResult Class
Glimpse.Core.ResourceResult Namespace


FileResourceResult Constructor

FileResourceResult Constructor Glimpse API Documentation
Initializes a new instance of the FileResourceResult class.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileResourceResult(
    byte[] content,
    string contentType
)
public FileResourceResult(
    byte[] content,
    string contentType
)
Parameters
content
Type:    Online System Byte
The content.
contentType
Type:   Online System String
Type of the content.
Exceptions
Exception | Condition
Online System ArgumentNullException | Exception thrown if either content or contentType are null.
See Also
FileResourceResult Class
FileResourceResult Members
Glimpse.Core.ResourceResult Namespace


FileResourceResult Methods

FileResourceResult Methods Glimpse API Documentation
The FileResourceResult type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the resource result with the specified context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
FileResourceResult Class
Glimpse.Core.ResourceResult Namespace


Execute Method

FileResourceResult Execute Method Glimpse API Documentation
Executes the resource result with the specified context.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Execute(
    IResourceResultContext context
)
public void Execute(
    IResourceResultContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceResultContext
The context.
Implements
IResourceResult Execute(IResourceResultContext)
See Also
FileResourceResult Class
FileResourceResult Members
Glimpse.Core.ResourceResult Namespace


FileResourceResult Properties

FileResourceResult Properties Glimpse API Documentation
The FileResourceResult type exposes the following members.
Properties
 | Name | Description
Public property | Content | Gets or sets the content to send to the client.
Public property | ContentType | Gets or sets the content type of the Content.
Back to Top
See Also
FileResourceResult Class
Glimpse.Core.ResourceResult Namespace


Content Property

FileResourceResult Content Property Glimpse API Documentation
Gets or sets the content to send to the client.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] Content { get; set; }
public byte[] Content { get; set; }
Field Value

            The content.

See Also
FileResourceResult Class
FileResourceResult Members
Glimpse.Core.ResourceResult Namespace


ContentType Property

FileResourceResult ContentType Property Glimpse API Documentation
Gets or sets the content type of the Content.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ContentType { get; set; }
public string ContentType { get; set; }
Field Value

            The content type.

See Also
FileResourceResult Class
FileResourceResult Members
Glimpse.Core.ResourceResult Namespace


HtmlResourceResult Class

HtmlResourceResult Class Glimpse API Documentation
The IResourceResult implementation responsible returning Html files to a client.
Inheritance Hierarchy
Online System Object
Glimpse.Core.ResourceResult HtmlResourceResult

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class HtmlResourceResult : IResourceResult
public class HtmlResourceResult : IResourceResult
See Also
HtmlResourceResult Members
Glimpse.Core.ResourceResult Namespace


HtmlResourceResult Members

HtmlResourceResult Members Glimpse API Documentation

The HtmlResourceResult type exposes the following members.
Constructors
 | Name | Description
Public method | HtmlResourceResult | Initializes a new instance of the HtmlResourceResult class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the resource result with the specified context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Html | Gets or sets the Html to send to the client.
Back to Top
See Also
HtmlResourceResult Class
Glimpse.Core.ResourceResult Namespace


HtmlResourceResult Constructor

HtmlResourceResult Constructor Glimpse API Documentation
Initializes a new instance of the HtmlResourceResult class.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HtmlResourceResult(
    string html
)
public HtmlResourceResult(
    string html
)
Parameters
html
Type:   Online System String
The HTML.
See Also
HtmlResourceResult Class
HtmlResourceResult Members
Glimpse.Core.ResourceResult Namespace


HtmlResourceResult Methods

HtmlResourceResult Methods Glimpse API Documentation
The HtmlResourceResult type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the resource result with the specified context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
HtmlResourceResult Class
Glimpse.Core.ResourceResult Namespace


Execute Method

HtmlResourceResult Execute Method Glimpse API Documentation
Executes the resource result with the specified context.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Execute(
    IResourceResultContext context
)
public void Execute(
    IResourceResultContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceResultContext
The context.
Implements
IResourceResult Execute(IResourceResultContext)
See Also
HtmlResourceResult Class
HtmlResourceResult Members
Glimpse.Core.ResourceResult Namespace


HtmlResourceResult Properties

HtmlResourceResult Properties Glimpse API Documentation
The HtmlResourceResult type exposes the following members.
Properties
 | Name | Description
Public property | Html | Gets or sets the Html to send to the client.
Back to Top
See Also
HtmlResourceResult Class
Glimpse.Core.ResourceResult Namespace


Html Property

HtmlResourceResult Html Property Glimpse API Documentation
Gets or sets the Html to send to the client.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Html { get; set; }
public string Html { get; set; }
Field Value

            The Html.

See Also
HtmlResourceResult Class
HtmlResourceResult Members
Glimpse.Core.ResourceResult Namespace


JsonResourceResult Class

JsonResourceResult Class Glimpse API Documentation
The IResourceResult implementation responsible returning Json data to clients.
Inheritance Hierarchy
Online System Object
Glimpse.Core.ResourceResult JsonResourceResult

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class JsonResourceResult : IResourceResult
public class JsonResourceResult : IResourceResult
See Also
JsonResourceResult Members
Glimpse.Core.ResourceResult Namespace


JsonResourceResult Members

JsonResourceResult Members Glimpse API Documentation

The JsonResourceResult type exposes the following members.
Constructors
 | Name | Description
Public method | JsonResourceResult(Object) | Initializes a new instance of the JsonResourceResult class without a JsonP callback function.
Public method | JsonResourceResult(Object, String) | Initializes a new instance of the JsonResourceResult class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the resource result with the specified context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Callback | Gets or sets the JsonP callback function.
Public property | ContentType | Gets or sets the content type.
Public property | Data | Gets or sets the data to serialize into Json.
Back to Top
See Also
JsonResourceResult Class
Glimpse.Core.ResourceResult Namespace


JsonResourceResult Constructor

JsonResourceResult Constructor Glimpse API Documentation
Overload List
 | Name | Description
Public method | JsonResourceResult(Object) | Initializes a new instance of the JsonResourceResult class without a JsonP callback function.
Public method | JsonResourceResult(Object, String) | Initializes a new instance of the JsonResourceResult class.
Back to Top
See Also
JsonResourceResult Class
JsonResourceResult Members
Glimpse.Core.ResourceResult Namespace


JsonResourceResult Constructor (Object)

JsonResourceResult Constructor (Object) Glimpse API Documentation
Initializes a new instance of the JsonResourceResult class without a JsonP callback function.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JsonResourceResult(
    Object data
)
public JsonResourceResult(
    Object data
)
Parameters
data
Type:   Online System Object
The data.
See Also
JsonResourceResult Class
JsonResourceResult Members
JsonResourceResult Overload
Glimpse.Core.ResourceResult Namespace


JsonResourceResult Constructor (Object, String)

JsonResourceResult Constructor (Object, String) Glimpse API Documentation
Initializes a new instance of the JsonResourceResult class.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JsonResourceResult(
    Object data,
    string callback
)
public JsonResourceResult(
    Object data,
    string callback
)
Parameters
data
Type:   Online System Object
The data.
callback
Type:   Online System String
The callback.
Exceptions
Exception | Condition
Online System ArgumentNullException | An exception is thrown is data is null.
See Also
JsonResourceResult Class
JsonResourceResult Members
JsonResourceResult Overload
Glimpse.Core.ResourceResult Namespace


JsonResourceResult Methods

JsonResourceResult Methods Glimpse API Documentation
The JsonResourceResult type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the resource result with the specified context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
JsonResourceResult Class
Glimpse.Core.ResourceResult Namespace


Execute Method

JsonResourceResult Execute Method Glimpse API Documentation
Executes the resource result with the specified context.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Execute(
    IResourceResultContext context
)
public void Execute(
    IResourceResultContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceResultContext
The context.
Implements
IResourceResult Execute(IResourceResultContext)
See Also
JsonResourceResult Class
JsonResourceResult Members
Glimpse.Core.ResourceResult Namespace


JsonResourceResult Properties

JsonResourceResult Properties Glimpse API Documentation
The JsonResourceResult type exposes the following members.
Properties
 | Name | Description
Public property | Callback | Gets or sets the JsonP callback function.
Public property | ContentType | Gets or sets the content type.
Public property | Data | Gets or sets the data to serialize into Json.
Back to Top
See Also
JsonResourceResult Class
Glimpse.Core.ResourceResult Namespace


Callback Property

JsonResourceResult Callback Property Glimpse API Documentation
Gets or sets the JsonP callback function.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Callback { get; set; }
public string Callback { get; set; }
Field Value

            The JsonP callback function. Option.

See Also
JsonResourceResult Class
JsonResourceResult Members
Glimpse.Core.ResourceResult Namespace


ContentType Property

JsonResourceResult ContentType Property Glimpse API Documentation
Gets or sets the content type.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ContentType { get; set; }
public string ContentType { get; set; }
Field Value

            The content type.

See Also
JsonResourceResult Class
JsonResourceResult Members
Glimpse.Core.ResourceResult Namespace


Data Property

JsonResourceResult Data Property Glimpse API Documentation
Gets or sets the data to serialize into Json.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Data { get; set; }
public Object Data { get; set; }
Field Value

            The data to serialize.

See Also
JsonResourceResult Class
JsonResourceResult Members
Glimpse.Core.ResourceResult Namespace


RedirectResourceResult Class

RedirectResourceResult Class Glimpse API Documentation
The IResourceResult implementation responsible redirecting a client to a new Uri.
Inheritance Hierarchy
Online System Object
Glimpse.Core.ResourceResult RedirectResourceResult

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RedirectResourceResult : IResourceResult
public class RedirectResourceResult : IResourceResult
See Also
RedirectResourceResult Members
Glimpse.Core.ResourceResult Namespace


RedirectResourceResult Members

RedirectResourceResult Members Glimpse API Documentation

The RedirectResourceResult type exposes the following members.
Constructors
 | Name | Description
Public method | RedirectResourceResult(String) | Initializes a new instance of the RedirectResourceResult class without any parameter values in the Uri template.
Public method | RedirectResourceResult(String, IDictionary String, Object ) | Initializes a new instance of the RedirectResourceResult class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the resource result with the specified context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
RedirectResourceResult Class
Glimpse.Core.ResourceResult Namespace


RedirectResourceResult Constructor

RedirectResourceResult Constructor Glimpse API Documentation
Overload List
 | Name | Description
Public method | RedirectResourceResult(String) | Initializes a new instance of the RedirectResourceResult class without any parameter values in the Uri template.
Public method | RedirectResourceResult(String, IDictionary String, Object ) | Initializes a new instance of the RedirectResourceResult class.
Back to Top
See Also
RedirectResourceResult Class
RedirectResourceResult Members
Glimpse.Core.ResourceResult Namespace


RedirectResourceResult Constructor (String)

RedirectResourceResult Constructor (String) Glimpse API Documentation
Initializes a new instance of the RedirectResourceResult class without any parameter values in the Uri template.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RedirectResourceResult(
    string uriTemplate
)
public RedirectResourceResult(
    string uriTemplate
)
Parameters
uriTemplate
Type:   Online System String
The URI template.
See Also
RedirectResourceResult Class
RedirectResourceResult Members
RedirectResourceResult Overload
Glimpse.Core.ResourceResult Namespace


RedirectResourceResult Constructor (String, IDictionary(String, Object))

RedirectResourceResult Constructor (String, IDictionary String, Object ) Glimpse API Documentation
Initializes a new instance of the RedirectResourceResult class.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RedirectResourceResult(
    string uriTemplate,
    IDictionary<string, Object> data
)
public RedirectResourceResult(
    string uriTemplate,
    IDictionary<string, Object> data
)
Parameters
uriTemplate
Type:   Online System String
The Uri template. Uri templates should conform to   Online http://tools.ietf.org/html/rfc6570RFC 6570
data
Type:   Online System.Collections.Generic IDictionary    Online String,   Online Object
The Uri template parameter data.
Exceptions
Exception | Condition
Online System ArgumentNullException | Exception thrown if uriTemplate is null.
See Also
RedirectResourceResult Class
RedirectResourceResult Members
RedirectResourceResult Overload
Glimpse.Core.ResourceResult Namespace
  Online URI Template


RedirectResourceResult Methods

RedirectResourceResult Methods Glimpse API Documentation
The RedirectResourceResult type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the resource result with the specified context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
RedirectResourceResult Class
Glimpse.Core.ResourceResult Namespace


Execute Method

RedirectResourceResult Execute Method Glimpse API Documentation
Executes the resource result with the specified context.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Execute(
    IResourceResultContext context
)
public void Execute(
    IResourceResultContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceResultContext
The context.
Implements
IResourceResult Execute(IResourceResultContext)
See Also
RedirectResourceResult Class
RedirectResourceResult Members
Glimpse.Core.ResourceResult Namespace


StatusCodeResourceResult Class

StatusCodeResourceResult Class Glimpse API Documentation
The IResourceResult implementation responsible returning simple status code/message pairs to a client.
Inheritance Hierarchy
Online System Object
Glimpse.Core.ResourceResult StatusCodeResourceResult
Glimpse.Core.ResourceResult ExceptionResourceResult

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class StatusCodeResourceResult : IResourceResult
public class StatusCodeResourceResult : IResourceResult
Remarks
StatusCodeResourceResult is typically used to convey Http error conditions to client, as is typical of Rest style architectures.

See Also
StatusCodeResourceResult Members
Glimpse.Core.ResourceResult Namespace


StatusCodeResourceResult Members

StatusCodeResourceResult Members Glimpse API Documentation

The StatusCodeResourceResult type exposes the following members.
Constructors
 | Name | Description
Public method | StatusCodeResourceResult | Initializes a new instance of the StatusCodeResourceResult class.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the resource result with the specified context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Message | Gets or sets the message to return to the client.
Public property | StatusCode | Gets or sets the status code to return to the client.
Back to Top
See Also
StatusCodeResourceResult Class
Glimpse.Core.ResourceResult Namespace


StatusCodeResourceResult Constructor

StatusCodeResourceResult Constructor Glimpse API Documentation
Initializes a new instance of the StatusCodeResourceResult class.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StatusCodeResourceResult(
    int statusCode,
    string message
)
public StatusCodeResourceResult(
    int statusCode,
    string message
)
Parameters
statusCode
Type:   Online System Int32
The status code.
message
Type:   Online System String
The message.
See Also
StatusCodeResourceResult Class
StatusCodeResourceResult Members
Glimpse.Core.ResourceResult Namespace


StatusCodeResourceResult Methods

StatusCodeResourceResult Methods Glimpse API Documentation
The StatusCodeResourceResult type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Public method | Execute | Executes the resource result with the specified context.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
StatusCodeResourceResult Class
Glimpse.Core.ResourceResult Namespace


Execute Method

StatusCodeResourceResult Execute Method Glimpse API Documentation
Executes the resource result with the specified context.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Execute(
    IResourceResultContext context
)
public void Execute(
    IResourceResultContext context
)
Parameters
context
Type: Glimpse.Core.Extensibility IResourceResultContext
The context.
Implements
IResourceResult Execute(IResourceResultContext)
See Also
StatusCodeResourceResult Class
StatusCodeResourceResult Members
Glimpse.Core.ResourceResult Namespace


StatusCodeResourceResult Properties

StatusCodeResourceResult Properties Glimpse API Documentation
The StatusCodeResourceResult type exposes the following members.
Properties
 | Name | Description
Public property | Message | Gets or sets the message to return to the client.
Public property | StatusCode | Gets or sets the status code to return to the client.
Back to Top
See Also
StatusCodeResourceResult Class
Glimpse.Core.ResourceResult Namespace


Message Property

StatusCodeResourceResult Message Property Glimpse API Documentation
Gets or sets the message to return to the client.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Message { get; set; }
public string Message { get; set; }
Field Value

            The message the message to return to the client.

See Also
StatusCodeResourceResult Class
StatusCodeResourceResult Members
Glimpse.Core.ResourceResult Namespace


StatusCode Property

StatusCodeResourceResult StatusCode Property Glimpse API Documentation
Gets or sets the status code to return to the client.

Namespace: Glimpse.Core.ResourceResult
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int StatusCode { get; set; }
public int StatusCode { get; set; }
Field Value

            The status code to return to the client.

See Also
StatusCodeResourceResult Class
StatusCodeResourceResult Members
Glimpse.Core.ResourceResult Namespace


Glimpse.Core.SerializationConverter Namespace

Glimpse.Core.SerializationConverter Namespace Glimpse API Documentation
All implementations of [ISerialiationConverter], which transform objects into more suitable representations for serialization, are defined within this namespace.
Classes
 | Class | Description
Public class | CSharpTypeConverter | The ISerializationConverter implementation responsible converting Online Type representation's into more recognizable C# syntax.
Public class | DateTimeConverter | The ISerializationConverter implementation responsible converting Online DateTime representation's into culturally invariant strings.
Public class | GlimpseMetadataConverter | The ISerializationConverter implementation responsible converting GlimpseMetadata representation's into a format suitable for serialization.
Public class | GlimpseRequestConverter | The ISerializationConverter implementation responsible converting GlimpseRequest representation's into a format suitable for serialization.
Public class | GlimpseRequestHeadersConverter | The ISerializationConverter implementation responsible converting GlimpseRequestHeaders representation's into a format suitable for serialization.
Public class | ListOfTraceMessageConverter |
Public class | MethodInfoConverter | The ISerializationConverter implementation responsible converting Online MethodInfo representation's into a simpler format.
Public class | TabMetadataConverter | The ISerializationConverter implementation responsible converting TabMetadata representation's into a format suitable for serialization.
Public class | TabResultConverter | The ISerializationConverter implementation responsible converting TabResult representation's into a format suitable for serialization.
Public class | TimelineEventModelConverter | The ISerializationConverter implementation responsible converting TimelineEventModel representation's into a format suitable for serialization.
Public class | TimeSpanConverter | The ISerializationConverter implementation responsible converting Online TimeSpan representation's into rounded off millisecond counts.


CSharpTypeConverter Class

CSharpTypeConverter Class Glimpse API Documentation
The ISerializationConverter implementation responsible converting Online Type representation's into more recognizable C# syntax.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility SerializationConverter Online Type
Glimpse.Core.SerializationConverter CSharpTypeConverter

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CSharpTypeConverter : SerializationConverter<Type>
public class CSharpTypeConverter : SerializationConverter<Type>
Remarks

            Users of other languages could disable CSharpTypeConverter and create a SerializationConverter<Type> implementation for their language.

Examples

            With CSharpTypeConverter, System.Int32 is converted to int and System.Collections.Generic.IDictionary`2[System.Double, System.String[]] to IDictionary<double, string[]>.

See Also
CSharpTypeConverter Members
Glimpse.Core.SerializationConverter Namespace


CSharpTypeConverter Members

CSharpTypeConverter Members Glimpse API Documentation

The CSharpTypeConverter type exposes the following members.
Constructors
 | Name | Description
Public method | CSharpTypeConverter | Initializes a new instance of the CSharpTypeConverter class
Back to Top
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(Type) | Converts the specified type. (Overrides SerializationConverter T Convert(T).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for. (Inherited from SerializationConverter T .)
Back to Top
See Also
CSharpTypeConverter Class
Glimpse.Core.SerializationConverter Namespace


CSharpTypeConverter Constructor

CSharpTypeConverter Constructor Glimpse API Documentation
Initializes a new instance of the CSharpTypeConverter class

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CSharpTypeConverter()
public CSharpTypeConverter()
See Also
CSharpTypeConverter Class
CSharpTypeConverter Members
Glimpse.Core.SerializationConverter Namespace


CSharpTypeConverter Methods

CSharpTypeConverter Methods Glimpse API Documentation
The CSharpTypeConverter type exposes the following members.
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(Type) | Converts the specified type. (Overrides SerializationConverter T Convert(T).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
CSharpTypeConverter Class
Glimpse.Core.SerializationConverter Namespace


Convert Method

CSharpTypeConverter Convert Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(Type) | Converts the specified type. (Overrides SerializationConverter T Convert(T).)
Back to Top
See Also
CSharpTypeConverter Class
CSharpTypeConverter Members
Glimpse.Core.SerializationConverter Namespace


Convert Method (Type)

CSharpTypeConverter Convert Method (Type) Glimpse API Documentation
Converts the specified type.

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Convert(
    Type type
)
public override Object Convert(
    Type type
)
Parameters
type
Type:   Online System Type
The type.
Return Value
An string of the C# syntax which would be used to represent type.
See Also
CSharpTypeConverter Class
CSharpTypeConverter Members
Convert Overload
Glimpse.Core.SerializationConverter Namespace


CSharpTypeConverter Properties

CSharpTypeConverter Properties Glimpse API Documentation
The CSharpTypeConverter type exposes the following members.
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for. (Inherited from SerializationConverter T .)
Back to Top
See Also
CSharpTypeConverter Class
Glimpse.Core.SerializationConverter Namespace


DateTimeConverter Class

DateTimeConverter Class Glimpse API Documentation
The ISerializationConverter implementation responsible converting Online DateTime representation's into culturally invariant strings.
Inheritance Hierarchy
Online System Object
Glimpse.Core.SerializationConverter DateTimeConverter

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class DateTimeConverter : ISerializationConverter
public class DateTimeConverter : ISerializationConverter
See Also
DateTimeConverter Members
Glimpse.Core.SerializationConverter Namespace


DateTimeConverter Members

DateTimeConverter Members Glimpse API Documentation

The DateTimeConverter type exposes the following members.
Constructors
 | Name | Description
Public method | DateTimeConverter | Initializes a new instance of the DateTimeConverter class
Back to Top
Methods
 | Name | Description
Public method | Convert | Converts the specified date into a culturally invariant string.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for.
Back to Top
See Also
DateTimeConverter Class
Glimpse.Core.SerializationConverter Namespace


DateTimeConverter Constructor

DateTimeConverter Constructor Glimpse API Documentation
Initializes a new instance of the DateTimeConverter class

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTimeConverter()
public DateTimeConverter()
See Also
DateTimeConverter Class
DateTimeConverter Members
Glimpse.Core.SerializationConverter Namespace


DateTimeConverter Methods

DateTimeConverter Methods Glimpse API Documentation
The DateTimeConverter type exposes the following members.
Methods
 | Name | Description
Public method | Convert | Converts the specified date into a culturally invariant string.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
DateTimeConverter Class
Glimpse.Core.SerializationConverter Namespace


Convert Method

DateTimeConverter Convert Method Glimpse API Documentation
Converts the specified date into a culturally invariant string.

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Convert(
    Object date
)
public Object Convert(
    Object date
)
Parameters
date
Type:   Online System Object
The date.
Return Value
A culturally invariant date and time string
Implements
ISerializationConverter Convert(Object)
See Also
DateTimeConverter Class
DateTimeConverter Members
Glimpse.Core.SerializationConverter Namespace


DateTimeConverter Properties

DateTimeConverter Properties Glimpse API Documentation
The DateTimeConverter type exposes the following members.
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for.
Back to Top
See Also
DateTimeConverter Class
Glimpse.Core.SerializationConverter Namespace


SupportedTypes Property

DateTimeConverter SupportedTypes Property Glimpse API Documentation
Gets the supported types the converter will be invoked for.

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Type> SupportedTypes { get; }
public IEnumerable<Type> SupportedTypes { get; }
Field Value

            The supported types:   Online DateTime and   Online Nullable T , where T is a   Online DateTime.

Implements
ISerializationConverter SupportedTypes
See Also
DateTimeConverter Class
DateTimeConverter Members
Glimpse.Core.SerializationConverter Namespace


GlimpseMetadataConverter Class

GlimpseMetadataConverter Class Glimpse API Documentation
The ISerializationConverter implementation responsible converting GlimpseMetadata representation's into a format suitable for serialization.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility SerializationConverter GlimpseMetadata
Glimpse.Core.SerializationConverter GlimpseMetadataConverter

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlimpseMetadataConverter : SerializationConverter<GlimpseMetadata>
public class GlimpseMetadataConverter : SerializationConverter<GlimpseMetadata>
See Also
GlimpseMetadataConverter Members
Glimpse.Core.SerializationConverter Namespace


GlimpseMetadataConverter Members

GlimpseMetadataConverter Members Glimpse API Documentation

The GlimpseMetadataConverter type exposes the following members.
Constructors
 | Name | Description
Public method | GlimpseMetadataConverter | Initializes a new instance of the GlimpseMetadataConverter class
Back to Top
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(GlimpseMetadata) | Converts the specified metadata. (Overrides SerializationConverter T Convert(T).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for. (Inherited from SerializationConverter T .)
Back to Top
See Also
GlimpseMetadataConverter Class
Glimpse.Core.SerializationConverter Namespace


GlimpseMetadataConverter Constructor

GlimpseMetadataConverter Constructor Glimpse API Documentation
Initializes a new instance of the GlimpseMetadataConverter class

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlimpseMetadataConverter()
public GlimpseMetadataConverter()
See Also
GlimpseMetadataConverter Class
GlimpseMetadataConverter Members
Glimpse.Core.SerializationConverter Namespace


GlimpseMetadataConverter Methods

GlimpseMetadataConverter Methods Glimpse API Documentation
The GlimpseMetadataConverter type exposes the following members.
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(GlimpseMetadata) | Converts the specified metadata. (Overrides SerializationConverter T Convert(T).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
GlimpseMetadataConverter Class
Glimpse.Core.SerializationConverter Namespace


Convert Method

GlimpseMetadataConverter Convert Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(GlimpseMetadata) | Converts the specified metadata. (Overrides SerializationConverter T Convert(T).)
Back to Top
See Also
GlimpseMetadataConverter Class
GlimpseMetadataConverter Members
Glimpse.Core.SerializationConverter Namespace


Convert Method (GlimpseMetadata)

GlimpseMetadataConverter Convert Method (GlimpseMetadata) Glimpse API Documentation
Converts the specified metadata.

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Convert(
    GlimpseMetadata metadata
)
public override Object Convert(
    GlimpseMetadata metadata
)
Parameters
metadata
Type: Glimpse.Core.Framework GlimpseMetadata
The metadata.
Return Value
An object suitable for serialization.
See Also
GlimpseMetadataConverter Class
GlimpseMetadataConverter Members
Convert Overload
Glimpse.Core.SerializationConverter Namespace


GlimpseMetadataConverter Properties

GlimpseMetadataConverter Properties Glimpse API Documentation
The GlimpseMetadataConverter type exposes the following members.
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for. (Inherited from SerializationConverter T .)
Back to Top
See Also
GlimpseMetadataConverter Class
Glimpse.Core.SerializationConverter Namespace


GlimpseRequestConverter Class

GlimpseRequestConverter Class Glimpse API Documentation
The ISerializationConverter implementation responsible converting GlimpseRequest representation's into a format suitable for serialization.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility SerializationConverter GlimpseRequest
Glimpse.Core.SerializationConverter GlimpseRequestConverter

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlimpseRequestConverter : SerializationConverter<GlimpseRequest>
public class GlimpseRequestConverter : SerializationConverter<GlimpseRequest>
See Also
GlimpseRequestConverter Members
Glimpse.Core.SerializationConverter Namespace


GlimpseRequestConverter Members

GlimpseRequestConverter Members Glimpse API Documentation

The GlimpseRequestConverter type exposes the following members.
Constructors
 | Name | Description
Public method | GlimpseRequestConverter | Initializes a new instance of the GlimpseRequestConverter class
Back to Top
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(GlimpseRequest) | Converts the specified request. (Overrides SerializationConverter T Convert(T).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for. (Inherited from SerializationConverter T .)
Back to Top
See Also
GlimpseRequestConverter Class
Glimpse.Core.SerializationConverter Namespace


GlimpseRequestConverter Constructor

GlimpseRequestConverter Constructor Glimpse API Documentation
Initializes a new instance of the GlimpseRequestConverter class

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlimpseRequestConverter()
public GlimpseRequestConverter()
See Also
GlimpseRequestConverter Class
GlimpseRequestConverter Members
Glimpse.Core.SerializationConverter Namespace


GlimpseRequestConverter Methods

GlimpseRequestConverter Methods Glimpse API Documentation
The GlimpseRequestConverter type exposes the following members.
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(GlimpseRequest) | Converts the specified request. (Overrides SerializationConverter T Convert(T).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
GlimpseRequestConverter Class
Glimpse.Core.SerializationConverter Namespace


Convert Method

GlimpseRequestConverter Convert Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(GlimpseRequest) | Converts the specified request. (Overrides SerializationConverter T Convert(T).)
Back to Top
See Also
GlimpseRequestConverter Class
GlimpseRequestConverter Members
Glimpse.Core.SerializationConverter Namespace


Convert Method (GlimpseRequest)

GlimpseRequestConverter Convert Method (GlimpseRequest) Glimpse API Documentation
Converts the specified request.

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Convert(
    GlimpseRequest request
)
public override Object Convert(
    GlimpseRequest request
)
Parameters
request
Type: Glimpse.Core.Framework GlimpseRequest
The request.
Return Value
An object suitable for serialization.
See Also
GlimpseRequestConverter Class
GlimpseRequestConverter Members
Convert Overload
Glimpse.Core.SerializationConverter Namespace


GlimpseRequestConverter Properties

GlimpseRequestConverter Properties Glimpse API Documentation
The GlimpseRequestConverter type exposes the following members.
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for. (Inherited from SerializationConverter T .)
Back to Top
See Also
GlimpseRequestConverter Class
Glimpse.Core.SerializationConverter Namespace


GlimpseRequestHeadersConverter Class

GlimpseRequestHeadersConverter Class Glimpse API Documentation
The ISerializationConverter implementation responsible converting GlimpseRequestHeaders representation's into a format suitable for serialization.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility SerializationConverter GlimpseRequestHeaders
Glimpse.Core.SerializationConverter GlimpseRequestHeadersConverter

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlimpseRequestHeadersConverter : SerializationConverter<GlimpseRequestHeaders>
public class GlimpseRequestHeadersConverter : SerializationConverter<GlimpseRequestHeaders>
See Also
GlimpseRequestHeadersConverter Members
Glimpse.Core.SerializationConverter Namespace


GlimpseRequestHeadersConverter Members

GlimpseRequestHeadersConverter Members Glimpse API Documentation

The GlimpseRequestHeadersConverter type exposes the following members.
Constructors
 | Name | Description
Public method | GlimpseRequestHeadersConverter | Initializes a new instance of the GlimpseRequestHeadersConverter class
Back to Top
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(GlimpseRequestHeaders) | Converts the specified request. (Overrides SerializationConverter T Convert(T).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for. (Inherited from SerializationConverter T .)
Back to Top
See Also
GlimpseRequestHeadersConverter Class
Glimpse.Core.SerializationConverter Namespace


GlimpseRequestHeadersConverter Constructor

GlimpseRequestHeadersConverter Constructor Glimpse API Documentation
Initializes a new instance of the GlimpseRequestHeadersConverter class

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlimpseRequestHeadersConverter()
public GlimpseRequestHeadersConverter()
See Also
GlimpseRequestHeadersConverter Class
GlimpseRequestHeadersConverter Members
Glimpse.Core.SerializationConverter Namespace


GlimpseRequestHeadersConverter Methods

GlimpseRequestHeadersConverter Methods Glimpse API Documentation
The GlimpseRequestHeadersConverter type exposes the following members.
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(GlimpseRequestHeaders) | Converts the specified request. (Overrides SerializationConverter T Convert(T).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
GlimpseRequestHeadersConverter Class
Glimpse.Core.SerializationConverter Namespace


Convert Method

GlimpseRequestHeadersConverter Convert Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(GlimpseRequestHeaders) | Converts the specified request. (Overrides SerializationConverter T Convert(T).)
Back to Top
See Also
GlimpseRequestHeadersConverter Class
GlimpseRequestHeadersConverter Members
Glimpse.Core.SerializationConverter Namespace


Convert Method (GlimpseRequestHeaders)

GlimpseRequestHeadersConverter Convert Method (GlimpseRequestHeaders) Glimpse API Documentation
Converts the specified request.

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Convert(
    GlimpseRequestHeaders request
)
public override Object Convert(
    GlimpseRequestHeaders request
)
Parameters
request
Type: Glimpse.Core.Framework GlimpseRequestHeaders
The request.
Return Value
An object suitable for serialization.
See Also
GlimpseRequestHeadersConverter Class
GlimpseRequestHeadersConverter Members
Convert Overload
Glimpse.Core.SerializationConverter Namespace


GlimpseRequestHeadersConverter Properties

GlimpseRequestHeadersConverter Properties Glimpse API Documentation
The GlimpseRequestHeadersConverter type exposes the following members.
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for. (Inherited from SerializationConverter T .)
Back to Top
See Also
GlimpseRequestHeadersConverter Class
Glimpse.Core.SerializationConverter Namespace


ListOfTraceMessageConverter Class

ListOfTraceMessageConverter Class Glimpse API Documentation

[Missing <summary> documentation for "T:Glimpse.Core.SerializationConverter.ListOfTraceMessageConverter"]

Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility SerializationConverter Online IEnumerable ITraceMessage
Glimpse.Core.SerializationConverter ListOfTraceMessageConverter

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ListOfTraceMessageConverter : SerializationConverter<IEnumerable<ITraceMessage>>
public class ListOfTraceMessageConverter : SerializationConverter<IEnumerable<ITraceMessage>>
See Also
ListOfTraceMessageConverter Members
Glimpse.Core.SerializationConverter Namespace


ListOfTraceMessageConverter Members

ListOfTraceMessageConverter Members Glimpse API Documentation

The ListOfTraceMessageConverter type exposes the following members.
Constructors
 | Name | Description
Public method | ListOfTraceMessageConverter | Initializes a new instance of the ListOfTraceMessageConverter class
Back to Top
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(IEnumerable ITraceMessage ) | (Overrides SerializationConverter T Convert(T).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for. (Inherited from SerializationConverter T .)
Back to Top
See Also
ListOfTraceMessageConverter Class
Glimpse.Core.SerializationConverter Namespace


ListOfTraceMessageConverter Constructor

ListOfTraceMessageConverter Constructor Glimpse API Documentation
Initializes a new instance of the ListOfTraceMessageConverter class

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ListOfTraceMessageConverter()
public ListOfTraceMessageConverter()
See Also
ListOfTraceMessageConverter Class
ListOfTraceMessageConverter Members
Glimpse.Core.SerializationConverter Namespace


ListOfTraceMessageConverter Methods

ListOfTraceMessageConverter Methods Glimpse API Documentation
The ListOfTraceMessageConverter type exposes the following members.
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(IEnumerable ITraceMessage ) | (Overrides SerializationConverter T Convert(T).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
ListOfTraceMessageConverter Class
Glimpse.Core.SerializationConverter Namespace


Convert Method

ListOfTraceMessageConverter Convert Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(IEnumerable ITraceMessage ) | (Overrides SerializationConverter T Convert(T).)
Back to Top
See Also
ListOfTraceMessageConverter Class
ListOfTraceMessageConverter Members
Glimpse.Core.SerializationConverter Namespace


Convert Method (IEnumerable(ITraceMessage))

ListOfTraceMessageConverter Convert Method (IEnumerable ITraceMessage ) Glimpse API Documentation

[Missing <summary> documentation for "M:Glimpse.Core.SerializationConverter.ListOfTraceMessageConverter.Convert(System.Collections.Generic.IEnumerable{Glimpse.Core.Message.ITraceMessage})"]

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Convert(
    IEnumerable<ITraceMessage> obj
)
public override Object Convert(
    IEnumerable<ITraceMessage> obj
)
Parameters
obj
Type:   Online System.Collections.Generic IEnumerable  ITraceMessage
[Missing <param name="obj"/> documentation for "M:Glimpse.Core.SerializationConverter.ListOfTraceMessageConverter.Convert(System.Collections.Generic.IEnumerable{Glimpse.Core.Message.ITraceMessage})"]
Return Value
[Missing <returns> documentation for "M:Glimpse.Core.SerializationConverter.ListOfTraceMessageConverter.Convert(System.Collections.Generic.IEnumerable{Glimpse.Core.Message.ITraceMessage})"]
See Also
ListOfTraceMessageConverter Class
ListOfTraceMessageConverter Members
Convert Overload
Glimpse.Core.SerializationConverter Namespace


ListOfTraceMessageConverter Properties

ListOfTraceMessageConverter Properties Glimpse API Documentation
The ListOfTraceMessageConverter type exposes the following members.
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for. (Inherited from SerializationConverter T .)
Back to Top
See Also
ListOfTraceMessageConverter Class
Glimpse.Core.SerializationConverter Namespace


MethodInfoConverter Class

MethodInfoConverter Class Glimpse API Documentation
The ISerializationConverter implementation responsible converting Online MethodInfo representation's into a simpler format.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility SerializationConverter Online MethodInfo
Glimpse.Core.SerializationConverter MethodInfoConverter

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MethodInfoConverter : SerializationConverter<MethodInfo>
public class MethodInfoConverter : SerializationConverter<MethodInfo>
See Also
MethodInfoConverter Members
Glimpse.Core.SerializationConverter Namespace


MethodInfoConverter Members

MethodInfoConverter Members Glimpse API Documentation

The MethodInfoConverter type exposes the following members.
Constructors
 | Name | Description
Public method | MethodInfoConverter | Initializes a new instance of the MethodInfoConverter class
Back to Top
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(MethodInfo) | Converts the specified method info. (Overrides SerializationConverter T Convert(T).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for. (Inherited from SerializationConverter T .)
Back to Top
See Also
MethodInfoConverter Class
Glimpse.Core.SerializationConverter Namespace


MethodInfoConverter Constructor

MethodInfoConverter Constructor Glimpse API Documentation
Initializes a new instance of the MethodInfoConverter class

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MethodInfoConverter()
public MethodInfoConverter()
See Also
MethodInfoConverter Class
MethodInfoConverter Members
Glimpse.Core.SerializationConverter Namespace


MethodInfoConverter Methods

MethodInfoConverter Methods Glimpse API Documentation
The MethodInfoConverter type exposes the following members.
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(MethodInfo) | Converts the specified method info. (Overrides SerializationConverter T Convert(T).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
MethodInfoConverter Class
Glimpse.Core.SerializationConverter Namespace


Convert Method

MethodInfoConverter Convert Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(MethodInfo) | Converts the specified method info. (Overrides SerializationConverter T Convert(T).)
Back to Top
See Also
MethodInfoConverter Class
MethodInfoConverter Members
Glimpse.Core.SerializationConverter Namespace


Convert Method (MethodInfo)

MethodInfoConverter Convert Method (MethodInfo) Glimpse API Documentation
Converts the specified method info.

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Convert(
    MethodInfo methodInfo
)
public override Object Convert(
    MethodInfo methodInfo
)
Parameters
methodInfo
Type:   Online System.Reflection MethodInfo
The method info.
Return Value
The method name, without namespace identifiers, with trailing parenthesis.
See Also
MethodInfoConverter Class
MethodInfoConverter Members
Convert Overload
Glimpse.Core.SerializationConverter Namespace


MethodInfoConverter Properties

MethodInfoConverter Properties Glimpse API Documentation
The MethodInfoConverter type exposes the following members.
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for. (Inherited from SerializationConverter T .)
Back to Top
See Also
MethodInfoConverter Class
Glimpse.Core.SerializationConverter Namespace


TabMetadataConverter Class

TabMetadataConverter Class Glimpse API Documentation
The ISerializationConverter implementation responsible converting TabMetadata representation's into a format suitable for serialization.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility SerializationConverter TabMetadata
Glimpse.Core.SerializationConverter TabMetadataConverter

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TabMetadataConverter : SerializationConverter<TabMetadata>
public class TabMetadataConverter : SerializationConverter<TabMetadata>
See Also
TabMetadataConverter Members
Glimpse.Core.SerializationConverter Namespace


TabMetadataConverter Members

TabMetadataConverter Members Glimpse API Documentation

The TabMetadataConverter type exposes the following members.
Constructors
 | Name | Description
Public method | TabMetadataConverter | Initializes a new instance of the TabMetadataConverter class
Back to Top
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(TabMetadata) | Converts the specified metadata. (Overrides SerializationConverter T Convert(T).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for. (Inherited from SerializationConverter T .)
Back to Top
See Also
TabMetadataConverter Class
Glimpse.Core.SerializationConverter Namespace


TabMetadataConverter Constructor

TabMetadataConverter Constructor Glimpse API Documentation
Initializes a new instance of the TabMetadataConverter class

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TabMetadataConverter()
public TabMetadataConverter()
See Also
TabMetadataConverter Class
TabMetadataConverter Members
Glimpse.Core.SerializationConverter Namespace


TabMetadataConverter Methods

TabMetadataConverter Methods Glimpse API Documentation
The TabMetadataConverter type exposes the following members.
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(TabMetadata) | Converts the specified metadata. (Overrides SerializationConverter T Convert(T).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TabMetadataConverter Class
Glimpse.Core.SerializationConverter Namespace


Convert Method

TabMetadataConverter Convert Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(TabMetadata) | Converts the specified metadata. (Overrides SerializationConverter T Convert(T).)
Back to Top
See Also
TabMetadataConverter Class
TabMetadataConverter Members
Glimpse.Core.SerializationConverter Namespace


Convert Method (TabMetadata)

TabMetadataConverter Convert Method (TabMetadata) Glimpse API Documentation
Converts the specified metadata.

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Convert(
    TabMetadata metadata
)
public override Object Convert(
    TabMetadata metadata
)
Parameters
metadata
Type: Glimpse.Core.Framework TabMetadata
The metadata.
Return Value
An object suitable for serialization.
See Also
TabMetadataConverter Class
TabMetadataConverter Members
Convert Overload
Glimpse.Core.SerializationConverter Namespace


TabMetadataConverter Properties

TabMetadataConverter Properties Glimpse API Documentation
The TabMetadataConverter type exposes the following members.
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for. (Inherited from SerializationConverter T .)
Back to Top
See Also
TabMetadataConverter Class
Glimpse.Core.SerializationConverter Namespace


TabResultConverter Class

TabResultConverter Class Glimpse API Documentation
The ISerializationConverter implementation responsible converting TabResult representation's into a format suitable for serialization.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility SerializationConverter TabResult
Glimpse.Core.SerializationConverter TabResultConverter

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TabResultConverter : SerializationConverter<TabResult>
public class TabResultConverter : SerializationConverter<TabResult>
See Also
TabResultConverter Members
Glimpse.Core.SerializationConverter Namespace


TabResultConverter Members

TabResultConverter Members Glimpse API Documentation

The TabResultConverter type exposes the following members.
Constructors
 | Name | Description
Public method | TabResultConverter | Initializes a new instance of the TabResultConverter class
Back to Top
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(TabResult) | Converts the specified result. (Overrides SerializationConverter T Convert(T).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for. (Inherited from SerializationConverter T .)
Back to Top
See Also
TabResultConverter Class
Glimpse.Core.SerializationConverter Namespace


TabResultConverter Constructor

TabResultConverter Constructor Glimpse API Documentation
Initializes a new instance of the TabResultConverter class

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TabResultConverter()
public TabResultConverter()
See Also
TabResultConverter Class
TabResultConverter Members
Glimpse.Core.SerializationConverter Namespace


TabResultConverter Methods

TabResultConverter Methods Glimpse API Documentation
The TabResultConverter type exposes the following members.
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(TabResult) | Converts the specified result. (Overrides SerializationConverter T Convert(T).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TabResultConverter Class
Glimpse.Core.SerializationConverter Namespace


Convert Method

TabResultConverter Convert Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(TabResult) | Converts the specified result. (Overrides SerializationConverter T Convert(T).)
Back to Top
See Also
TabResultConverter Class
TabResultConverter Members
Glimpse.Core.SerializationConverter Namespace


Convert Method (TabResult)

TabResultConverter Convert Method (TabResult) Glimpse API Documentation
Converts the specified result.

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Convert(
    TabResult result
)
public override Object Convert(
    TabResult result
)
Parameters
result
Type: Glimpse.Core.Framework TabResult
The result.
Return Value
An object suitable for serialization.
See Also
TabResultConverter Class
TabResultConverter Members
Convert Overload
Glimpse.Core.SerializationConverter Namespace


TabResultConverter Properties

TabResultConverter Properties Glimpse API Documentation
The TabResultConverter type exposes the following members.
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for. (Inherited from SerializationConverter T .)
Back to Top
See Also
TabResultConverter Class
Glimpse.Core.SerializationConverter Namespace


TimelineEventModelConverter Class

TimelineEventModelConverter Class Glimpse API Documentation
The ISerializationConverter implementation responsible converting TimelineEventModel representation's into a format suitable for serialization.
Inheritance Hierarchy
Online System Object
Glimpse.Core.Extensibility SerializationConverter TimelineEventModel
Glimpse.Core.SerializationConverter TimelineEventModelConverter

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TimelineEventModelConverter : SerializationConverter<TimelineEventModel>
public class TimelineEventModelConverter : SerializationConverter<TimelineEventModel>
See Also
TimelineEventModelConverter Members
Glimpse.Core.SerializationConverter Namespace


TimelineEventModelConverter Members

TimelineEventModelConverter Members Glimpse API Documentation

The TimelineEventModelConverter type exposes the following members.
Constructors
 | Name | Description
Public method | TimelineEventModelConverter | Initializes a new instance of the TimelineEventModelConverter class
Back to Top
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(TimelineEventModel) | Converts the specified model. (Overrides SerializationConverter T Convert(T).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for. (Inherited from SerializationConverter T .)
Back to Top
See Also
TimelineEventModelConverter Class
Glimpse.Core.SerializationConverter Namespace


TimelineEventModelConverter Constructor

TimelineEventModelConverter Constructor Glimpse API Documentation
Initializes a new instance of the TimelineEventModelConverter class

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimelineEventModelConverter()
public TimelineEventModelConverter()
See Also
TimelineEventModelConverter Class
TimelineEventModelConverter Members
Glimpse.Core.SerializationConverter Namespace


TimelineEventModelConverter Methods

TimelineEventModelConverter Methods Glimpse API Documentation
The TimelineEventModelConverter type exposes the following members.
Methods
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(TimelineEventModel) | Converts the specified model. (Overrides SerializationConverter T Convert(T).)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TimelineEventModelConverter Class
Glimpse.Core.SerializationConverter Namespace


Convert Method

TimelineEventModelConverter Convert Method Glimpse API Documentation
Overload List
 | Name | Description
Public method | Convert(Object) | Converts the specified object. (Inherited from SerializationConverter T .)
Public method | Convert(TimelineEventModel) | Converts the specified model. (Overrides SerializationConverter T Convert(T).)
Back to Top
See Also
TimelineEventModelConverter Class
TimelineEventModelConverter Members
Glimpse.Core.SerializationConverter Namespace


Convert Method (TimelineEventModel)

TimelineEventModelConverter Convert Method (TimelineEventModel) Glimpse API Documentation
Converts the specified model.

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object Convert(
    TimelineEventModel model
)
public override Object Convert(
    TimelineEventModel model
)
Parameters
model
Type: Glimpse.Core.Model TimelineEventModel
The object to convert.
Return Value
An object suitable for serialization.
See Also
TimelineEventModelConverter Class
TimelineEventModelConverter Members
Convert Overload
Glimpse.Core.SerializationConverter Namespace


TimelineEventModelConverter Properties

TimelineEventModelConverter Properties Glimpse API Documentation
The TimelineEventModelConverter type exposes the following members.
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for. (Inherited from SerializationConverter T .)
Back to Top
See Also
TimelineEventModelConverter Class
Glimpse.Core.SerializationConverter Namespace


TimeSpanConverter Class

TimeSpanConverter Class Glimpse API Documentation
The ISerializationConverter implementation responsible converting Online TimeSpan representation's into rounded off millisecond counts.
Inheritance Hierarchy
Online System Object
Glimpse.Core.SerializationConverter TimeSpanConverter

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TimeSpanConverter : ISerializationConverter
public class TimeSpanConverter : ISerializationConverter
See Also
TimeSpanConverter Members
Glimpse.Core.SerializationConverter Namespace


TimeSpanConverter Members

TimeSpanConverter Members Glimpse API Documentation

The TimeSpanConverter type exposes the following members.
Constructors
 | Name | Description
Public method | TimeSpanConverter | Initializes a new instance of the TimeSpanConverter class
Back to Top
Methods
 | Name | Description
Public method | Convert | Converts the specified date.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for.
Back to Top
See Also
TimeSpanConverter Class
Glimpse.Core.SerializationConverter Namespace


TimeSpanConverter Constructor

TimeSpanConverter Constructor Glimpse API Documentation
Initializes a new instance of the TimeSpanConverter class

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpanConverter()
public TimeSpanConverter()
See Also
TimeSpanConverter Class
TimeSpanConverter Members
Glimpse.Core.SerializationConverter Namespace


TimeSpanConverter Methods

TimeSpanConverter Methods Glimpse API Documentation
The TimeSpanConverter type exposes the following members.
Methods
 | Name | Description
Public method | Convert | Converts the specified date.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | GetTypeOrNull | Returns the value of GetType if value is not null. (Defined by ObjectExtensions.)
Public Extension Method | ToStringOrDefault | Returns the value of ToString if value is not null. (Defined by ObjectExtensions.)
Back to Top
See Also
TimeSpanConverter Class
Glimpse.Core.SerializationConverter Namespace


Convert Method

TimeSpanConverter Convert Method Glimpse API Documentation
Converts the specified date.

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Convert(
    Object date
)
public Object Convert(
    Object date
)
Parameters
date
Type:   Online System Object
The date.
Return Value
A double of rounded off milliseconds of the length of the time span.
Implements
ISerializationConverter Convert(Object)
See Also
TimeSpanConverter Class
TimeSpanConverter Members
Glimpse.Core.SerializationConverter Namespace


TimeSpanConverter Properties

TimeSpanConverter Properties Glimpse API Documentation
The TimeSpanConverter type exposes the following members.
Properties
 | Name | Description
Public property | SupportedTypes | Gets the supported types the converter will be invoked for.
Back to Top
See Also
TimeSpanConverter Class
Glimpse.Core.SerializationConverter Namespace


SupportedTypes Property

TimeSpanConverter SupportedTypes Property Glimpse API Documentation
Gets the supported types the converter will be invoked for.

Namespace: Glimpse.Core.SerializationConverter
Assembly: Glimpse.Core (in Glimpse.Core.dll) Version: 1.0.1.0 (1.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Type> SupportedTypes { get; }
public IEnumerable<Type> SupportedTypes { get; }
Field Value

            The supported types.

Implements
ISerializationConverter SupportedTypes
See Also
TimeSpanConverter Class
TimeSpanConverter Members
Glimpse.Core.SerializationConverter Namespace